Câble haut débit : Systèmes de terminaison par modem câble (CMTS)

Configuration uBR7100 tout en un en mode Bridge

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour un système de terminaison par modem câble d'uBR7100 de Cisco (CMTS) ce agit en tant que protocole DHCP (DHCP), heure (ToD), et serveur TFTP. Il explique également comment a établi le fichier de configuration de Data-over-Cable Service Interface Specifications (DOCSIS) utilisant l'interface de ligne de commande (CLI) sur le CMTS. Cette configuration est connue en tant que « configuration tout-en-un pour Cisco CMTS » tandis que le CMTS est configuré en jetant un pont sur le mode. Actuellement la plate-forme d'uBR7100 est la seule plate-forme CMTS qui prend en charge la transition.

Conditions préalables

Conditions requises

Le lecteur de ce document doit avoir une compréhension de base de la transition, le DOCSIS, le DHCP, le ToD, et les protocoles TFTP.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Système de terminaison par modem câble d'uBR7100 de Cisco

  • Modems câble DOCSIS-conformes

  • Version de logiciel 12.1(7)EC ou ultérieures de ½ du ¿  de Cisco IOSïÂ

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Description

Un modem câble DOCSIS-conforme exige de l'accès à trois types de serveurs afin d'être livré avec succès en ligne.

La plupart des câblo-opérateurs utilisent le Cisco Network Registrar (le CNR) en tant que le DHCP, le Domain Name Server (DN), et serveurs TFTP. Le serveur de ToD n'est pas une partie du CNR. Le serveur de ToD qui est utilisé dépend de la plate-forme du système du câblo-opérateur. Le ToD devrait être RFC-868leavingcisco.com - conforme. Pour des systèmes Unix, Il est inclus dans Solaris ; il est seulement nécessaire de s'assurer que le fichier inetd.conf dans le répertoire de /etc contient ces lignes :

# Time service is used for clock synchronization.
#
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

Pour Windows, le logiciel le plus utilisé généralement est Greywareleavingcisco.com .

Cette table affiche les versions du logiciel Cisco IOS en lesquelles différentes capacités de serveur ont été ajoutées au CMTS :

Capacités de serveur Version du logiciel Cisco IOS
DHCP 12.0(1)T
ToD 12.0(4)XI
TFTP 11.0 (pour toutes les Plateformes)

Ce document explique chacune de ces caractéristiques. La configuration sur le CMTS qui contient toutes ces capacités s'appelle « la configuration tout-en-un pour le CMTS. » Avec cette configuration, vous n'avez besoin d'aucun serveur supplémentaire pour tester vos usines de câble et pour fournir l'accès d'Internet à grande vitesse.

Il est également possible de configurer un fichier de configuration DOCSIS résidant sur le CMTS au lieu du serveur TFTP. Selon les notes en version, vous avez besoin au moins de version du logiciel Cisco IOS 12.1(2)EC1 pour utiliser cette caractéristique.

Bien que cette « configuration tout-en-un » soit très commode pour des environnements de travaux pratiques, le test initial, de petits déploiements, et le dépannage, elle n'est pas extensible pour prendre en charge un très grand nombre de Modems câble. Ainsi on ne le recommande pas que vous utilisiez cette configuration aux usines opérationnelles de câble avec de grands déploiements des Modems câble.

Les ingénieurs de support technique de Cisco emploient souvent cette configuration pour éliminer des variables tout en dépannant des problèmes de câble.

Conduisant et exécution de transition

Les Routeurs de gamme Cisco uBR7100 prennent en charge ces modes de fonctionnement :

  • Conduisant le mode — L'acheminement de l'exécution est le mode par défaut typique pour des Routeurs de Cisco CMTS. Lui fournit un large spectre des caractéristiques de routage de logiciel de Cisco IOS, telles qu'un serveur DHCP et le contrôle au-dessus dont des paquets sont envoyés au-dessus de chaque interface.

  • Mode de Pontage transparent — L'exécution de transition entre l'interface de câble et les interfaces de carte de port n'est pas typiquement utilisée aux installations DOCSIS CMTS en raison des problèmes de performances et sécurité potentiels. La transition est très efficace, cependant, dans des environnements CMTS avec un nombre limité de périphériques de l'équipement client (CPE) — comme dans une unité multidwelling typique (MDU) ou l'environnement multitenant d'unité (MTU) — particulièrement si le CMTS remplace un réseau traversier existant.

Integrated Routing and Bridging (IRB)

L'exécution de Routage et mise en parallèle intégrés (IRB) permet la transition dans un segment spécifique des réseaux ou des hôtes, pourtant permet également à ces hôtes pour se connecter aux périphériques sur autre, des réseaux routés sans devoir utiliser un routeur distinct pour interconnecter les deux réseaux.

Remarque: Le Pontage transparent et l'exécution IRB sont pris en charge seulement à l'aide de la version du logiciel Cisco IOS 12.1(7)EC et plus tard. Pour les détails complets sur le Pontage transparent et l'exécution IRB, voyez les chapitres traversiers dans le Cisco IOS jetant un pont sur et guide de configuration de Mise en réseau IBM, version 12.1, disponibles sur Cisco.com et la CD-ROM de documentation.

Bridge Group Virtual Interface

ubr7100_config_bridge_1.gif

Puisque la transition fonctionne dans la couche liaison de données et l'acheminement fonctionne dans la couche réseau, ils suivent différents modèles de configuration de protocole. Prenant le modèle de base IP comme exemple, toutes les interfaces pontées appartiendraient au même réseau, alors que chaque interface conduite représente un réseau distinct.

Dans IRB, le Bridge Group Virtual Interface est introduit pour éviter de confondre le modèle de configuration de protocole quand un protocole spécifique est jeté un pont sur et conduit dans un groupe de passerelle.

Le Bridge Group Virtual Interface est une interface conduite par normale qui ne prend en charge pas la transition, mais représente son groupe correspondant de passerelle à l'interface conduite. Il a tous les attributs de couche réseau (tels qu'une adresse et des filtres de couche réseau) qui s'appliquent au groupe correspondant de passerelle. Le numéro d'interface attribué à cette interface virtuelle correspond au groupe de pontage que cette interface virtuelle représente. Ce numéro est la liaison entre l'interface virtuelle et le groupe de pontage.

Quand vous activez le routage pour un protocole donné relatif au Bridge Group Virtual Interface, des paquets provenant une interface conduite mais destinés pour un hôte dans un domaine ponté sont conduits au Bridge Group Virtual Interface et sont expédiés à l'interface pontée de correspondance. Tout le trafic conduit au Bridge Group Virtual Interface est expédié au groupe correspondant de passerelle comme trafic ponté. Tout le trafic routable reçu sur une interface pontée est conduit à d'autres interfaces conduites comme si il est livré directement du Bridge Group Virtual Interface.

Pour recevoir les paquets routable arrivant sur une interface pontée mais destinés pour une interface conduite ou recevoir des paquets routés, le Bridge Group Virtual Interface doit également avoir les adresses appropriées. Des adresses MAC et les adresses réseau sont assignées au Bridge Group Virtual Interface de cette manière :

  • Le Bridge Group Virtual Interface « emprunte » l'adresse MAC d'une des interfaces pontées dans le groupe associé de passerelle avec le Bridge Group Virtual Interface.

  • Pour conduire et jeter un pont sur un protocole donné dans le même groupe de passerelle, vous devez configurer les attributs de couche réseau du protocole relatif au Bridge Group Virtual Interface.

  • Aucun attribut de protocole ne devrait être configuré sur les interfaces pontées, et aucun attribut traversier ne peut être configuré sur le Bridge Group Virtual Interface.

Puisqu'il peut y avoir seulement un Bridge Group Virtual Interface représentant un groupe de passerelle — et le groupe de passerelle peut se composer des types de supports différents configurés pour plusieurs différentes méthodes d'encapsulation — vous pouvez devoir configurer le Bridge Group Virtual Interface avec les méthodes d'encapsulation particulières priées pour commuter des paquets correctement.

Le service de DHCP Cisco IOS sur un CMTS

Les Routeurs de Cisco exécutant ont le Logiciel Cisco IOS version 12.0(1)T ou plus tard la capacité d'agir en tant que serveurs DHCP. Ce service DHCP peut être configuré pour fournir des baux DHCP aux Modems câble et au CPE, tel que des PC et des postes de travail.

Il y a un ensemble minimum d'options DHCP des lesquelles les Modems câble exigent typiquement afin d'être livré en ligne :

  • Une adresse IP (le champ de yiaddr dans l'en-tête de paquet DHCP)

  • Un masque de sous-réseau (option DHCP 1)

  • Le décalage heure locale de l'heure de Greenwich (GMT) en quelques secondes (option DHCP 2)

  • Un routeur de par défaut (option DHCP 3)

  • L'adresse IP d'un serveur de ToD (option DHCP 4)

  • Le serveur de log (option DHCP 7)

  • L'adresse IP d'un serveur TFTP (le champ de siaddr dans l'en-tête de paquet DHCP)

  • Le nom d'un fichier de configuration DOCSIS (le gisement de fichier dans l'en-tête de paquet DHCP)

  • Une durée de bail DHCP en quelques secondes (option 51 DHCP)

Dans le routeur, ces options peuvent être configurées avec ces commandes :

!
ip dhcp pool cm-platinum
 network 10.1.4.0 255.255.255.0
 bootfile platinum.cm
 next-server 10.1.4.1
 default-router 10.1.4.1
 option 7 ip 10.1.4.1
 option 4 ip 10.1.4.1
 option 2 hex ffff.8f80
 lease 7 0 10
!

Ce sont des explications de chacune de ces commandes :

  • groupe DHCP — Définit le nom de la portée de modem câble (cm-platine).

  • réseau — Fournit l'adresse IP et le masque de sous-réseau (option DHCP 1).

  • bootfile — Fournit le nom du fichier de démarrage qui, dans ce cas, est platinum.cm.

  • next-server — Spécifie l'adresse IP pour serveur TFTP qui, dans ce cas, est l'adresse IP primaire dans l'interface c4/0.

  • default-router — Définit la passerelle par défaut qui, dans ce cas, est l'adresse IP primaire de l'interface c4/0 (option DHCP 3).

  • option 7 — Définit l'option DHCP de serveur de log.

  • option 4 — Fournit l'adresse IP du serveur de ToD (adresse IP primaire d'interface c4/0).

  • option 2 — Fournit l'option de décalage de temps pour le GMT ? 8 heures (? 8 heures d'égaux ? 28800 secondes, qui égale ffff.8f80 dans des nombres hexadécimaux).

    Remarque: Pour se renseigner plus sur la façon convertir une valeur décimale de temps excentré en hexadécimal, référez-vous à comment calculer la valeur hexadécimale pour l'Option 2 DHCP (décalage de temps).

  • bail — Place la durée de bail (7 jours, 0 heures, 10 minutes).

Pour des périphériques CPE, ces options sont le minimum exigé pour fonctionner avec succès :

  • Une adresse IP (le champ de yiaddr dans l'en-tête de paquet DHCP)

  • Un masque de sous-réseau (option DHCP 1)

  • Un routeur de par défaut (option DHCP 3)

  • L'adresse IP de l'un ou plusieurs DNSs (option DHCP 6)

  • Un nom de domaine (option 15 DHCP)

  • Une durée de bail DHCP en quelques secondes (option 51 DHCP)

Dans le routeur, ces options peuvent être configurées avec ces commandes :

! 
ip dhcp pool pcs-irb

!--- The scope for the hosts.

   network 172.16.29.0 255.255.255.224

!--- The IP address and mask for the hosts.

   next-server 172.16.29.1

!--- TFTP server; in this case, the secondary address is used.

   default-router 172.16.29.1
   dns-server 172.16.30.2

!--- DNS server (which is not configured on the CMTS).

   domain-name cisco.com
   lease 7 0 10
!

Davantage de fonctionnalité de serveur DHCP

Ce sont quelques autres caractéristiques qui peuvent être utilisées du serveur DHCP de logiciel de Cisco IOS :

  • ping DHCP d'IP — Cinglez avant la fonction de bail, qui s'assure que le serveur DHCP n'émet pas des baux pour les adresses IP qui sont déjà en service.

  • ip dhcp database — Une fonction qui enregistre des liaisons DHCP dans une base de données externe afin de mettre à jour des relations de MAC-adresse-à-IP-adresse pendant un arrêt et redémarrage CMTS.

  • DHCP de show ip — Une suite des commandes qui peuvent être utilisées pour surveiller le fonctionnement du serveur DHCP.

  • debug ip dhcp server — Une suite des commandes qui peuvent être utilisées pour dépanner le fonctionnement du serveur DHCP.

Toutes ces fonctions et caractéristiques supplémentaires sont décrites dans les notes de mise à jour en caractéristique de serveur DHCP de logiciel de Cisco IOS dans le document sur le serveur DHCP de Cisco IOS.

Le service TFTP de Cisco IOS

Après qu'un modem câble ait tenté de contacter un serveur de ToD, il poursuit pour contacter un serveur TFTP afin de télécharger un fichier de configuration DOCSIS. Si un fichier de configuration DOCSIS binaire peut être copié sur un périphérique flash sur Cisco CMTS puis le routeur peut agir en tant que serveur TFTP pour ce fichier.

C'est la procédure pour télécharger un fichier de configuration DOCSIS dans l'éclair :

  1. Émettez cette commande ping de s'assurer que le CMTS peut atteindre le serveur où le fichier de configuration DOCSIS se trouve.

    Ubr7111# ping 172.16.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
    
    !--- Output suppressed.
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  2. Copiez le fichier (dans ce cas, ce s'appelle silver.cm) dans l'éclair du CMTS.

    Ubr7111# copy tftp flash
    
    Address or name of remote host []? 172.16.30.2
    Source filename []? silver.cm
    Destination filename [silver.cm]?
    
    Accessing tftp://172.16.30.2/silver.cm...
    Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
    [OK - 76/4096 bytes]
    
    76 bytes copied in 0.152 secs
  3. Vérifiez l'éclair et le vérifiez que la taille du fichier est correcte, utilisant la commande de dir.

    Ubr7111# dir
    
    Directory of disk0:/
    
       1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
       2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
    
    47890432 bytes total (17936384 bytes free)
  4. Pour activer le service TFTP sur le CMTS, émettez cette commande en mode de configuration globale :

    tftp-server slot0:silver.cm alias silver.cm
    
  5. Confirmez l'étape 4 en vérifiant ces lignes dans la configuration :

    !
    tftp-server slot0:silver.cm alias silver.cm
    tftp-server server
    !

Pour plus d'informations sur la configuration d'un serveur TFTP dans un routeur, référez-vous au document supplémentaire de commandes de fonction de transfert de fichiers.

Le service de ToD de Cisco IOS

Après qu'un modem câble saisisse avec succès un bail DHCP, il puis des tentatives de contacter un serveur de ToD. Les Produits de Cisco CMTS exécutant peuvent le Logiciel Cisco IOS version 12.0(4)XI ou plus tard fournir un service RFCleavingcisco.com 868 ToD.

Une fausse idée commune est que le service de ToD que les Modems câble doivent employer pour être livré en ligne est identique que le service de Protocole NTP (Network Time Protocol) qui est généralement configuré sur des Routeurs de Cisco. Le service de NTP et le service de ToD sont incompatibles. Les Modems câble ne peuvent pas parler à un serveur de NTP. Tandis que les Modems câble doivent tenter de contacter un serveur de ToD comme partie du processus d'être livré en ligne, les Modems conformes avec les dernières révisions de la spécification de l'interférence de radio frequency de DOCSIS 1.0 (IFR) poursuivent toujours pour être livré en ligne même si un serveur de ToD ne peut pas être atteint.

Selon les la plupart des versions récentes de la spécification, si un modem câble ne peut pas contacter un serveur de ToD puis il peut continuer le processus d'être livré en ligne. Il devrait, cependant, périodiquement essayer de contacter le serveur de ToD jusqu'à ce qu'il soit réussi. Les versions antérieures de la spécification du DOCSIS 1.0 IFR les ont exigé que, si un modem câble ne pourrait pas contacter un serveur de ToD, alors le modem ne pourrait pas être livré en ligne. Il est important de se rendre compte que les Modems câble exécutant un micrologiciel plus ancien puissent être conformes à cette version plus ancienne de la spécification.

Remarque: Les Modems câble de quelques constructeurs n'interopèrent pas avec le service de ToD de logiciel de Cisco IOS. Si ces Modems sont conformes avec les versions les plus récentes de la spécification du DOCSIS 1.0 IFR puis ils devraient continuer à être livré en ligne sans se soucier. Ce problème d'interopérabilité est abordé par l'ID de bogue Cisco CSCdt24107 (clients enregistrés seulement).

Pour configurer ToD sur Cisco CMTS, émettez ces commandes globales :

service udp-small-servers max-servers no-limit
!
cable time-server
!

Le générateur interne de fichier de configuration DOCSIS

Des Produits de Cisco CMTS exécutant le Logiciel Cisco IOS version 12.1(2)EC ou plus tard (dans la série de versions EC) peuvent être configurés pour générer et enregistrer intérieurement des fichiers de configuration DOCSIS. Faire ainsi est utile parce qu'il emporte la condition requise d'avoir accès à un outil externe de création de fichier de configuration DOCSIS. Quand un fichier de configuration DOCSIS est créé utilisant l'outil de configuration interne, le fichier devient automatiquement TFTP traversant disponible. En outre, seulement les Modems câble sur les interfaces de câble directement connectées peuvent télécharger ces fichiers de configuration.

Ces exemples de configuration affichent la création de deux fichiers de configuration DOCSIS.

Le premier s'appelle disable.cm, qui permet à un modem câble pour être livré en ligne mais empêche les périphériques connectés CPE d'accéder au réseau du fournisseur de services. Dans ce cas, il y a une commande Access-refusée. Notez que les vitesses d'en aval et d'en amont sont dans ce cas le Kbps 1, et la taille de rafale maximale est de 1600 octets.

cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1600
   timestamp
!

Un câblo-opérateur utilise ce fichier de configuration DOCSIS de disable.cm pour refuser l'accès au CPE derrière le modem câble tout en permettant toujours au modem câble pour être livré en ligne. C'est plus de façon efficace de refuser un service CPE qu'utilisant l'option d'exclure au CNR, qui ne permet pas au modem câble pour être livré en ligne : de modem câble les essais à plusieurs reprises à être livré en ligne et bande passante de déchets.

Les Modems câble avec ce fichier de configuration DOCSIS affichent cette sortie, quand la commande de show cable modem est émise :

Cable1/0/U0 10  online(d)  2287  0.50  6  0  10.1.4.65  0010.7bed.9b45

Les conseils de vérification pour la section de configuration avancée de ce document fournit plus de détails au sujet de cette sortie. L'état en ligne (d) signifie que les Modems câble sont en ligne mais l'accès est refusé.

Dans le deuxième exemple, un fichier de configuration DOCSIS appelé platinum.cm est créé. Dans ce cas, la valeur en amont maximum est le Mbits/s 1, la valeur en amont garantie est de 100 Kbps, l'en aval maximum est 10 Mbits/s, et il permet jusqu'à 30 périphériques CPE à connecter.

cable config-file platinum.cm
   service-class 1 max-upstream 1000
   service-class 1 guaranteed-upstream 100
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 30
   timestamp
!

Notez que, le fichier de configuration DOCSIS de lors de la configuration de dans le CMTS, vous n'a pas besoin du serveur slot0:platinum.cm alias platinum.cm de tftp de déclaration parce qu'il n'y a aucun fichier stocké de .cm dans la mémoire ; il réside dans la configuration.

D'autres détails sur l'outil interne de fichier de configuration DOCSIS peuvent être trouvés dans les commandes de configuration de Cisco CMTS de document.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Une topologie typique d'installation de laboratoire est affichée dans cette image :

/image/gif/paws/29243/ubr7100_config_bridge_2.gif

Configurations

Ce document utilise les configurations suivantes :

Cette configuration est prise en charge seulement sur des Plateformes de l'uBR7100 CMTS.

La version du logiciel Cisco IOS qui prend en charge la configuration complète, y compris la configuration du fichier de configuration DOCSIS, est Logiciel Cisco IOS version 12.1(2)EC et la série ultérieure EC relâche. La série logicielle de Cisco IOS qui a été utilisée dans cette configuration est ubr7100-ik1s-mz.121-11b.EC.bin.

Configuration tout-en-un de base

Cette configuration récapitule toutes les parties expliquées jusqu'ici. Il a deux portées de DHCP : un pour les Modems câble et un autre pour les hôtes derrière les Modems câble.

Un fichier de configuration DOCSIS est créé, appelé platinum.cm. Ce fichier est appliqué au pool DHCP appelé le cm-platine. L'autre fichier de configuration DOCSIS, appelé disabled.cm, n'est pas appliqué à n'importe quoi à l'heure actuelle.

Les commentaires sont dans le bleu, après les commandes relatives. Les commandes de configuration tout-en-un sont en gras.

Configuration tout-en-un de base
ubr7100# show run
Building configuration...
 
Current configuration : 3511 bytes
!
! Last configuration change at 01:12:37 PST Mon Sep 3 2001
!
version 12.1
no service pad
service timestamps debug datetime msec localtime

!--- Provides useful timestamps on all log messages.

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

!--- Supports a large number of modems or hosts attaching quickly.

 
!
hostname ubr7111
!
boot system flash disk0:ubr7100-ik1s-mz.121-11b.EC.bin
!
cable spectrum-group 3 frequency 40800000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver

!---  Allows cable modems to obtain ToD from the uBR7100.

!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 8
 timestamp
!
clock timezone PST -9
clock calendar-valid
ip subnet-zero
no ip routing

!--- Disables routing on the CMTS.

no ip domain-lookup

!--- Prevents the CMTS from looking up domain names or attempting 
!--- to connect to machines (for example, when mistyping commands).

ip host ubr7111 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
 
ip dhcp excluded-address 10.45.50.1 10.45.50.5
!
ip dhcp pool cm-platinum

!--- Name of the DHCP pool. This scope is for the cable modems attached 
!--- to interface cable 4/0.

   network 10.1.4.0 255.255.255.0

!--- Pool of addresses for scope modems-c1/0.

   bootfile platinum.cm

!--- DOCSIS configuration file name associated with this pool.

   next-server 10.1.4.1

!--- IP address of the TFTP server which sends the boot file.

   default-router 10.1.4.1

!--- Default gateway for cable modems; necessary to get DOCSIS files.

   option 7 ip 10.1.4.1

!--- Log Server DHCP option.

   option 4 ip 10.1.4.1

!--- ToD server IP address.

   option 2 hex ffff.8f80

!--- Time offset for ToD, in seconds (HEX), from GMT.
!--- Pacific Standard Time offset from GMT = –28,000 seconds = ffff.8f80

   lease 7 0 10

!--- Lease 7 days 0 hours 10 minutes.

! 
ip dhcp pool pcs-irb

!--- Name of the DHCP pool. This scope is for the CPE attached to
!--- the cable modems that are connected to interface cable 1/0.

   network 172.16.29.0 255.255.255.0

!--- Pool of addresses for scope pcs-c4 (associated with the secondary address).

   next-server 172.16.29.1
   default-router 172.16.29.1
   dns-server 172.16.29.1
   domain-name cisco.com
   lease 7 0 10
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex half
 speed auto
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed 10
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Cable1/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable packet-cache
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable downstream frequency 525000000
 no cable downstream rf-shutdown
 cable downstream rf-power 55
 cable upstream 0 frequency 17808000
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 no cable upstream 0 shutdown
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.1.4.1 255.255.255.0
!
ip default-gateway 14.66.1.1
ip classless
no ip http server
!
no cdp run
bridge 1 protocol ieee
 bridge 1 route ip
alias exec scm show cable modem
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 15
 login
!
end

Conseils de vérification pour la configuration de base

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  1. Assurez-vous que les commandes sont prises en charge dans la version du logiciel Cisco IOS en émettant une commande de show version.

  2. Vérifiez que le fichier de configuration DOCSIS est dans l'éclair.

    Ubr7111# dir
    
    Directory of disk0:/
     
        1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
        2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
     
    47890432 bytes total (17936384 bytes free)

    Remarque: Le fichier silver.cm a été établi utilisant l'outil Configurator CPE DOCSIS. Pour le fichier de platinum.cm qui a été établi dans la configuration CMTS, vous n'avez pas besoin du serveur slot0:platinum.cm alias platinum.cm de tftp de déclaration parce qu'il n'y a aucun fichier de .cm ; il réside dans la configuration.

  3. Vérifiez que les Modems câble sont en ligne en émettant la commande de show cable modem.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Notez que tous les Modems câble sont en ligne. Ceux connectés au câble d'interface 1/0/U0 sont dans le réseau 10.1.4.0. Vous pouvez voir de la configuration que leurs adresses IP sont prises du pool DHCP appelé le cm-platine.

    Notez également que les Modems câble avec les adresses MAC 0010.7bed.9b23 et 0010.7bed.9b45 ont un CPE derrière elles. Ces Modems câble sont livré en ligne avec la configuration traversière par défaut. Ces PC sont configurés avec le DHCP de sorte qu'ils puissent obtenir leurs adresses IP du réseau.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Cette copie d'écran prouve que ces PC obtiennent une adresse IP des groupes appelés le pcs-c4.

    ubr7100_config_bridge_3.gif

    Vous pouvez également voir de ce PC que les configurations TCP/IP sont placées pour obtenir l'adresse IP automatiquement.

    ubr7100_config_bridge_4.gif

Configuration complète avancée

Cette section fournit un exemple plus sophistiqué de configuration qui implique la fonctionnalité de hiérarchie des pools DHCP. Les travaux de hiérarchie de pool DHCP de manière est que n'importe quel pool DHCP avec un network number qui est un sous-ensemble du network number d'un autre groupe hérite de toutes les caractéristiques de ce autre groupe. Ceci enregistre la répétition en configuration du serveur DHCP. Si, cependant, la même spécification est faite avec un paramètre différent, alors le paramètre est remplacé. Cet exemple affiche un pool général avec un fichier de démarrage appelé platinum.cm et un sous-ensemble de ce groupe avec un fichier de démarrage appelé disable.cm.

En plus des pools DHCP créés dans l'exemple de base, il y a des conditions requises spéciales pour deux Modems câble.

D'abord, le modem câble 0010.7bed.9b45 est refusé l'accès ; on lui accorde une adresse IP mais il n'est pas livré en ligne. Créez ce groupe :

ip dhcp pool cm-0010.7bed.9b45
   host 10.1.4.65 255.255.255.0
   client-identifier 0100.107b.ed9b.45
   bootfile disable.cm

La caractéristique la plus notable de cet exemple de configuration est la section où vous spécifiez les pools DHCP spéciaux qui correspondent aux adresses MAC de modem câble individuel. Une telle spécification permet au serveur DHCP pour envoyer de seules options DHCP à ces Modems. Pour spécifier un modem câble particulier, le paramètre de client-identifier est utilisé. Le client-identifier doit être placé à 01, suivi de l'adresse MAC du périphérique auquel l'entrée correspond. Les 01 correspond aux Ethernets pour le type de matériel DHCP.

Remarque: En changeant des fichiers de configuration pour un modem, vous devez faire ces étapes pour s'assurer que le modem câble obtient les paramètres manuellement configurés :

  1. Effacez la table de corrélation d'IP DHCP en émettant la commande d'IP address de clear ip dhcp binding.

  2. Remettez à l'état initial le modem câble en question en émettant la commande claire recherche de MAC address de modem câble.

En second lieu, le modem câble 0010.7bed.9b23 a également une condition requise spéciale : il obtient un différent Qualité de service (QoS). Par conséquent, un fichier différent de démarrage est associé à la portée, suivant les indications de cette configuration partielle :

ip dhcp pool cm-0010.7bed.9b23
   host 10.1.4.66 255.255.255.0
   client-identifier 0100.107b.ed9b.23
   bootfile silver.cm
!

En configurant des pools DHCP pour les Modems câble spécifiques, il est dans toujours une bonne pratique de donner un nom approprié. En outre, parce qu'une adresse IP spécifique est assignée au groupe utilisant la commande d'hôte, vous devez émettre le DHCP d'IP de commande globale excluez 10.1.4.60 10.1.4.70. Cette commande indique le DHCP ne pas utiliser des adresses dans cette plage.

Conseils de vérification pour la configuration avancée

La vérification de cette configuration se concentre sur les services que les Modems câble obtiennent, particulièrement 0010.7bed.9b45 et 0010.7bed.9b23. Vous devez être sûr qu'ils obtiennent les adresses avec lesquelles ils ont été manuellement configurés et le service.

La première chose à tester est que 0010.7bed.9b45 est livré en ligne, mais que le service est refusé. Émettez la commande de show cable modem.

7246VXR# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5

Notez ces faits :

  • Le modem câble 0010.7bed.9b23 a obtenu l'adresse IP 10.4.1.66, comme spécifié dans la portée cm-0010.7bed.9b23. Il y a un ordinateur relié à lui et il obtient son adresse IP du groupe pcs-c4.

  • Le modem câble 0010.7bed.9b23 a un QoS différent.

  • Le modem câble 0010.7bed.9b45 a obtenu l'adresse IP 10.1.4.65, comme spécifié dans la portée cm-0010.7bed.9b45. Il y a un ordinateur relié à lui ; la valeur CPE, cependant, est 0 parce que cela le service est refusé.

  • L'état en ligne de 0010.7bed.9b45 est en ligne (d), ainsi lui signifie que le modem câble est livré en ligne mais l'accès au réseau câblé est refusé.

    Considérez cette sortie de la commande émise bavarde de log de MAC de debug cable sur le modem câble :

    21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
    21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
    21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
    21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
    21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
    21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
    21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
    21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
    21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
    21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
    21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
    21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
    21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
    21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
    21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
    21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
    21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
    21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
    21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
    21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
    21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
    21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
    21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
    21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
    21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
    21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
    21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
    21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
    21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
    21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
    21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
    21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
    21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
    21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
    21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
    21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
    21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
    21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
    21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
    21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
    21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
    21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
    21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
    21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
    21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
    21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
    21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
    21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
    21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
    21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
    21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
    21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
    21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
    21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
    21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
    21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED
    21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
    21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
    21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
    21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
    21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

    La sortie de ceci mettent au point prouve que l'accès au réseau EST REFUSÉ.

Ubr7100# show cable modem detail

Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
Cable1/0/U0 7    0002.1685.b5db 10       yes            33.52
Cable1/0/U0 8    0002.fdfa.0a63 10       yes            33.24
Cable1/0/U0 9    0010.7bed.9b23 1        no             33.29
Cable1/0/U0 10   0010.7bed.9b45 1        no             33.23
Cable1/0/U0 11   0001.64ff.e47d 10       yes            33.20
Cable1/0/U0 12   0004.2752.ddd5 10       yes            33.44

Notez que le CPE maximum pour des Modems câble avec des portées spéciales est 1 et le repos sont 10. Si vous voyez la configuration de la portée platinum.cm, elle fait spécifier CPE 10 ; d'autre part, la portée disable.cm a seulement 1 CPE spécifié. Le fichier de configuration DOCSIS préconfiguré silver.cm a également seulement 1 CPE spécifié.

Ubr7111# show interface cable 1/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5

Pour vérifier que les Modems câble obtiennent le niveau correct du service, émettez la commande de show cable qos profile.

Ubr7111# show cable qos profile

ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
         upstream  upstream  downstream tx    mask value by      priv  rate
         bandwidth bandwidth bandwidth  burst                    enab  enab
1   0    0         0         0          0     0x0  0x0   cmts(r) no    no
2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no
3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no
4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no
5   4    64000     0         512000     0     0x0  0x0   cm      no    no
6   0    1000      0         1600000    0     0x0  0x0   cm      no    no
7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no
8   0    0         0         0          0     0x0  0x0   mgmt    no    no
10  0    0         0         0          0     0x0  0x0   mgmt    no    no
12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

Notez que l'ID 7 de QoS apparie la configuration sur platinum.cm :

cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp

Le même se produit avec la configuration DOCSIS de disable.cm :

Ubr7111# show ip dhcp binding

IP address       Hardware address        Lease expiration        Type
10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
10.1.4.66        0100.107b.ed9b.23       Infinite                Manual

Informations connexes


Document ID: 29243