Commutation multiprotocole par étiquette (MPLS) : MPLS

Exemple de configuration de prise en charge multicast pour les VPN MPLS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document propose un exemple de configuration et des directives générales pour configurer la prise en charge de la multidiffusion pour les VPN suivant la Commutation multiprotocole par étiquette (MPLS). Cette caractéristique a été introduite dans le ½ 12.2(13)T du ¿  d'andï de version de logiciel 12.0(23)S de½ du¿Â du Cisco IOSïÂ.

Conditions préalables

Conditions requises

Avant de tenter cette configuration, assurez-vous que vous répondez à ces exigences :

  • Les fournisseurs de services doivent avoir un noyau Multidiffusion-activé afin d'utiliser la caractéristique de VPN de multidiffusion de Cisco.

Composants utilisés

Les informations dans ce document sont basées sur le Logiciel Cisco IOS version 12.2(13)T

Remarque: Pour obtenir les informations mises à jour au sujet du soutien de plate-forme de cette caractéristique, utilisez le conseiller de logiciel (clients enregistrés seulement). Le conseiller de logiciel met à jour dynamiquement la liste de Plateformes prises en charge pendant que le nouveau support de plate-forme est ajouté pour la caractéristique.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

Pour l'information de fond, référez-vous à la nouvelle documentation sur les fonctionnalités de Logiciel Cisco IOS version 12.2(13)T pour le soutien de Protocole IP Multicast de MPLS VPNs.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/29220/config_mpls_vpn1.gif

Configurations

Le schéma de réseau représente le circuit principal d'un fournisseur de services. Ceci se compose des Routeurs R2, R3, et R4. Le circuit principal est configuré pour prendre en charge MPLS VPN. R2 et R4 sont des Routeurs de Provider Edge (PE) tandis que R3 est un routeur du fournisseur (p). R1 et R5 représentent les Routeurs de Customer Edge (CE) qui appartiennent au même exemple de routage et d'expédition VPN (VRF), jaunes.

Afin de fournir des services de Multidiffusion, le circuit principal doit être configuré pour exécuter le routage de Multidiffusion. Le protocole de Multidiffusion sélectionné à cet effet est le Protocol Independent Multicast (PIM), et R3 est configuré comme point de rendez-vous (RP). R2 et R4 sont également configurés pour exécuter le routage de Multidiffusion dans le jaune de VRF. Le mode clairsemé-dense PIM est configuré comme protocole de routage de Multidiffusion entre le siège potentiel d'explosion et le ces. R2 a été configuré pour être le RP pour le jaune de VRF.

Afin de tester la connectivité multicast, l'interface s0/0 de R5 est configurée pour joindre le groupe de multidiffusion 224.2.2.2. Des pings sont envoyés de l'adresse de bouclage R1 à 224.2.2.2. L'écho de Protocole ICMP (Internet Control Message Protocol) est un paquet de multidiffusion, alors que la réponse d'ICMP est un paquet monodiffusion puisque l'adresse de destination IP est l'adresse de bouclage R1.

Les configurations présentées dans ce document incluent ces derniers :

R1-(CE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip multicast-routing 

!--- Enable multicast routing.

!
!
interface Loopback0
 ip address 100.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.0.1 255.255.255.0
 ip pim sparse-dense-mode

!--- PIM sparce-dense mode is used between the PE and CE.
!--- PIM sparce-dense mode is the multicast routing protocol.

 
!
router rip
 version 2
 network 10.0.0.0
 network 100.0.0.0
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!         
end

R2-(PE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip vrf yellow
 rd 2:200
 route-target export 2:200
 route-target import 2:200
 mdt default 239.1.1.1

!--- Configure the default Multicast Distribution Tree (MDT) 
!--- for VRF yellow.

 mdt data 239.2.2.0 0.0.0.255 threshold 1

!--- Configure the range global addresses for 
!--- data MDTs and the threshold.

ip multicast-routing 

!--- Enable global multicast routing.

ip multicast-routing vrf yellow 

!--- Enable multicast routing in VRF yellow.

ip cef
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
!
!
interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip pim sparse-dense-mode


!--- Multicast needs to be enabled on loopback 
!--- interface. This is used as a source  
!--- for MPBGP sessions between PE routers that participate in MVPN.


!
interface Loopback100
 ip vrf forwarding yellow
 ip address 100.0.0.2 255.255.255.255
 ip pim sparse-dense-mode
!

!--- This router needs to be RP for 
!--- multicast in VRF yellow. Therefore, multicast
!--- needs to be enabled on the interface which is used as RP.


!
interface Serial1/0
 ip vrf forwarding yellow
 ip address 10.1.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Multicast is enabled on PE-CE interfaces in VRF.


!         
interface Serial2/0
 ip address 10.2.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Service provider core needs to run multicast
!--- to support MVPN services,
!--- so multicast is enabled on PE-P links.


 tag-switching ip        
!         
router ospf 1
 router-id 50.0.0.2
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.0.0.255 area 0
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf yellow
 version 2
 redistribute bgp 1
 network 10.0.0.0
 network 100.0.0.0
 default-metric 5
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute rip
 neighbor 50.0.0.4 remote-as 1
 neighbor 50.0.0.4 update-source Loopback0
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.6 remote-as 1
 neighbor 50.0.0.6 update-source Loopback0
 neighbor 50.0.0.6 activate
 no auto-summary
 !
 address-family ipv4 vrf yellow
 redistribute connected
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.4 send-community extended
 neighbor 50.0.0.6 activate
 neighbor 50.0.0.6 send-community extended
 no auto-summary
 exit-address-family
!         
ip classless
no ip http server
ip pim bidir-enable
ip pim vrf yellow send-rp-announce Loopback100 scope 100
ip pim vrf yellow send-rp-discovery Loopback100 scope 100

!--- Configure auto-RP. The R2's loopback 
!--- 100 is the RP in VRF yellow.

!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

R3-(P)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R3 
! 
! 
clock timezone CET 1 
ip subnet-zero 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.3 255.255.255.255 
 ip pim sparse-dense-mode 
! 
! 
interface Serial1/0 
 ip address 10.2.0.3 255.255.255.0 
 ip pim sparse-dense-mode

!--- Enable multicast on links to PE routers 
!--- which have MVPNs configured.

 
 tag-switching ip 
! 
interface Serial2/0 
 ip address 10.3.0.3 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
router ospf 1 
 router-id 50.0.0.3 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
ip pim send-rp-announce Loopback0 scope 100 
ip pim send-rp-discovery Loopback0 scope 100 

!--- R3 is configured to announce itself as 
!--- the RP through auto-RP.
 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login  
! 
end

R4-(PE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R4 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip vrf yellow 
 rd 2:200 
 route-target export 2:200 
 route-target import 2:200 
 mdt default 239.1.1.1 

!--- Configure the default MDT address.
 
 mdt data 238.2.2.0 0.0.0.255 threshold 1 

!--- Configure the data MDT range and threshold.
 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip multicast-routing vrf yellow  

!--- Enable multicast routing in VRF yellow.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Loopback100 
 ip vrf forwarding yellow 
 ip address 100.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Serial1/0 
 ip address 10.3.0.4 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
interface Serial2/0 
 ip vrf forwarding yellow 
 ip address 10.4.0.4 255.255.255.0 
 ip pim sparse-dense-mode 

!--- Enable the PIM toward the CE.
 
! 
router ospf 1 
 router-id 50.0.0.4 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
router rip 
 version 2 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 version 2 
 redistribute bgp 1 
 network 10.0.0.0 
 network 100.0.0.0 
 default-metric 5 
 no auto-summary 
 exit-address-family 
! 
router bgp 1 
 no synchronization 
 no bgp default ipv4-unicast 
 bgp log-neighbor-changes 
 redistribute rip 
 neighbor 50.0.0.2 remote-as 1 
 neighbor 50.0.0.2 update-source Loopback0 
 neighbor 50.0.0.2 activate 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 redistribute connected 
 redistribute rip 
 no auto-summary 
 no synchronization 
 exit-address-family 
 ! 
 address-family vpnv4 
 neighbor 50.0.0.2 activate 
 neighbor 50.0.0.2 send-community extended 
 no auto-summary 
 exit-address-family 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
! 
end

R5-(CE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R5 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip multicast-routing  

!--- Enable global multicast routing in the CE.
 
! 
! 
interface Loopback0 
 ip address 100.0.0.5 255.255.255.255 
! 
interface Serial0/0 
 ip address 10.4.0.5 255.255.255.0 
 ip pim sparse-dense-mode 
 ip igmp join-group 224.2.2.2 
! 
router rip 
 version 2 
 network 10.0.0.0 
 network 100.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
!          
end

Conseils de conception

  • La Multidiffusion pour MPLS VPN (MVPN) est configurée sur la configuration du VPN. Le réseau VPN MPLS doit être soigneusement conçu, pour observer toutes les recommandations pour des réseaux VPN MPLS d'abord.

  • Le noyau de fournisseur de services doit être configuré pour le service indigène de Multidiffusion. Le noyau doit être configuré pour la Multidiffusion spécifique de mode intermédiaire PIM (PIM-SM), de source (PIM-SSM), ou le PIM bidirectionnel (PIM-BIDIR). Le PIM en mode dense (PIM-DM) n'est pas pris en charge en tant que principal protocole dans des configurations MVPN. Il est possible de configurer un mélange de protocoles pris en charge dans le noyau du fournisseur. Ceci peut être fait quand quelques groupes de multidiffusion sont manipulés par un mode PIM et quelques autres groupes sont manipulés par un autre mode pris en charge PIM.

  • Tous les protocoles de Multidiffusion sont pris en charge dans le VRF de Multidiffusion. C'est-à-dire, dans le VRF de Multidiffusion vous pouvez utiliser le MSDP et le PIM-DM en plus du PIM-SM, du PIM-SSM et du PIM-BIDIR

  • Le service MVPN peut être ajouté séparément sur une base de Vrf-par-VRF. C'est-à-dire, un routeur PE peut faire configurer des vrf Multidiffusion-activés et des vrf réservés unicast.

  • Non tous les sites d'un VRF simple d'unicast doivent être configurés pour la Multidiffusion. Il est possible d'avoir quelques sites (et même interfaces de routeur PE MVPN) où la Multidiffusion n'est pas activée. Vous devez s'assurer que des artères ne sont jamais calculées pour indiquer les interfaces activées parMultidiffusion. Autrement, la Fonction Multicast Forwarding sera cassée.

  • Plus d'un VRF peut appartenir au même domaine de Multidiffusion MVPN. L'adressage IP doit être seul dans un domaine de Multidiffusion. La fuite des artères et/ou des paquets entre les domaines de Multidiffusion ou dans une table de routage globale de Multidiffusion n'est actuellement pas possible.

  • Il est obligatoire pour que MVPN fonctionne une configuration de mdt default. Configurer les données MDT est facultatif. Il est fortement recommandé pour placer le seuil pour les données MDT si vous choisissez de configurer un.

  • L'adresse IP du par défaut MDT détermine à quel VRF de domaine de Multidiffusion appartient. Par conséquent, il est possible d'avoir la même adresse du par défaut MDT pour plus d'un VRF. Cependant, ils partageront des paquets de multidiffusion entre eux et doivent observer d'autres exigences sur des domaines de Multidiffusion (tels que le seul schéma d'adressage IP).

  • Les données MDT pourraient ou ne pourraient pas être configurées avec la même plage des adresses IP sur différents Routeurs de PE. Ceci dépend de quel mode PIM est utilisé dans le noyau d'un fournisseur. Si le noyau de fournisseur de services utilise le mode clairsemé PIM, alors chaque routeur PE doit utiliser une seule plage des adresses IP pour des groupes des données MDT. Si le noyau de fournisseur de services utilise la Multidiffusion de Source-particularité, alors tous les Routeurs de PE pourraient être configurés avec la même plage des adresses IP pour les données MDT de chaque domaine de Multidiffusion.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip igmp groups — Affiche les groupes de multidiffusion avec les récepteurs qui sont directement connectés au routeur et qui ont été appris par le Protocole IGMP (Internet Group Management Protocol).

  • show ip pim mdt bgp — Les affichages ont détaillé la publicité de Protocole BGP (Border Gateway Protocol) du moteur de distinction de route (RD) pour le groupe de mdt default.

  • le mdt de <vrf-name> de show ip pim vrf envoient — Affiche les annonces des données MDT que le routeur a faites dans le VRF spécifié.

  • le mdt de <vrf-name> de show ip pim vrf reçoivent — Affiche les annonces des données MDT reçues par le routeur dans le VRF spécifié.

  • show ip mroute — Affiche le contenu de la table de routage de Protocole IP Multicast dans le noyau du fournisseur.

  • <vrf-name> de vrf de show ip mroute — Affiche la table de routage de Multidiffusion dans le VRF du client.

Terminez-vous ces étapes pour vérifier que votre configuration fonctionne correctement.

  1. Vérifiez que le siège potentiel d'explosion ont joint le groupe IGMP pour le tunnel du par défaut MDT.

    S'il est configuré après que la commande de par défaut-mdt soit émise sous la configuration de VRF, le PE pourrait pour joindre le groupe du par défaut MDT. Une fois que le bouclage est configuré, retirez la commande de mdt du VRF et mettez-la de nouveau à résolvent le problème.

    • Pour PE-R2, émettez la commande de show ip igmp groups.

      IGMP Connected Group Membership
      Group Address  Interface   Uptime     Expires   Last Reporter
      224.0.1.40     Serial2/0   02:21:23   stopped   10.2.0.2
      239.1.1.1      Loopback0   02:36:59   stopped   0.0.0.0
    • Pour PE-R4, émettez la commande de show ip igmp groups.

      IGMP Connected Group Membership 
      Group Address  Interface    Uptime    Expires   Last Reporter
      224.0.1.40     Loopback0    02:51:48  00:02:39  50.0.0.4
      239.1.1.2      Loopback0    02:51:45  stopped   0.0.0.0
      239.1.1.1      Loopback0    02:51:45  stopped   0.0.0.0
      239.2.2.0      Loopback0    01:40:03  stopped   0.0.0.0 
  2. Vérifiez la publicité BGP reçue pour chaque PE.

    Remarque: Pour cet exemple, vérifiez le MDTs originaire du siège potentiel d'explosion PE-R2 et PE-R4 de pair.

    • Pour PE-R2, émettez la commande de show ip pim mdt bgp.

      MDT-default group 239.1.1.1 
      rid: 50.0.0.4 next_hop: 50.0.0.4 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0
    • Pour la question PE-R4 la commande de show ip pim mdt bgp

      MDT-default group 239.1.1.1 
      rid: 50.0.0.2 next_hop: 50.0.0.2 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0 
      MDT-data   : 239.2.2.0  Tunnel0     source-interface: Loopback0 
  3. Vérifiez les données MDTs.

    Remarque: Pour cet exemple, vérifiez les données MDT originaires ou jointes par PE-R2 et PE-R4.

    • Pour PE-R2, émettez le mdt de jaune de show ip pim vrf envoient la commande.

      MDT-data send list for VRF: yellow 
        (source, group)                     MDT-data group      ref_count 
        (100.0.0.1, 224.2.2.2)              239.2.2.0           1 
    • Pour PE-R2, émettez le mdt de jaune de show ip pim vrf reçoivent la commande.

      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group
      Joined MDT-data groups for VRF: yellow 
        group: 239.2.2.0 source: 0.0.0.0 ref_count: 1 
    • Vérifiez la table de routage globale de Multidiffusion pour le par défaut MDT.

      Remarque: Notez ces informations :

      1. La liste d'interfaces en sortie est jaune MVRF sur le siège potentiel d'explosion.

      2. Le routeur P voit le groupe en tant que groupe de multidiffusion régulier.

      3. Chaque PE est une source pour le par défaut MDT, et est seulement dans les Routeurs de PE.

      4. Un nouvel indicateur, Z, indique que c'est un tunnel de Multidiffusion.

    • Pour PE-R2, émettez la commande de 239.1.1.1 de show ip mroute.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:37:16/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28 
      
      (50.0.0.2, 239.1.1.1), 02:37:12/00:03:29, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:36:09/00:02:33 
      (
      50.0.0.4, 239.1.1.1), 02:36:02/00:02:59, flags: JTZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28
    • Pour P-R3, émettez la commande de 239.1.1.1 de show ip mroute.

       
      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:50:24/stopped, RP 50.0.0.3, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.2, 239.1.1.1), 02:49:56/00:03:23, flags: T 
        Incoming interface: Serial1/0, RPF nbr 10.2.0.2 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.4, 239.1.1.1), 02:49:47/00:03:23, flags: T 
        Incoming interface: Serial2/0, RPF nbr 10.3.0.4 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
    • Pour PE-R4, émettez la commande de 239.1.1.1 de show ip mroute.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:51:06/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:51:06/00:00:48 
      
      (50.0.0.2, 239.1.1.1), 02:50:06/00:02:58, flags: JTZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:50:06/00:00:48 
      
      (50.0.0.4, 239.1.1.1), 02:51:00/00:03:10, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:35:24/00:03:00 
  4. Vérifiez la table de routage globale de Multidiffusion pour des données MDTs.

    Remarque: Pour PE-R2, notez que l'interface sortante est tunnel0.

    • Pour PE-R2, où la source se trouve (côté de VRF), émettez la commande de 224.2.2.2 de jaune de vrf de show ip mroute.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 224.2.2.2), 2d01h/stopped, RP 100.0.0.2, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 2d01h/00:02:34 
      
      (100.0.0.1, 224.2.2.2), 00:05:32/00:03:26, flags: Ty 
        Incoming interface: Serial1/0, RPF nbr 10.1.0.1 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 00:05:37/00:02:34
    • Pour PE-R2, où la source se trouve (route multicast globale), émettez la commande de 239.2.2.0 de show ip mroute.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.2.2.0), 02:13:27/stopped, RP 50.0.0.3, flags: SJPFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: Null 
      
      (50.0.0.2, 239.2.2.0), 02:13:27/00:03:22, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:13:27/00:03:26

    Remarque: Seulement le routeur PE avec a la source multicast reliée à elle apparaît comme source pour le trafic de multidiffusion de l'adresse de groupe des données MDT.

Dépannez

  • Émettez la commande neighbor de show ip pim vrf de vérifier que les Routeurs de PE ont établi des relations voisines PIM par l'interface de tunnel dynamique. S'ils faisaient, alors MDT par défaut fonctionne correctement.

  • Si MDT par défaut ne fonctionne pas, émettez la commande de show ip pim mdt bgp de vérifier que des bouclages des Routeurs distants de PE participant à MVPN sont connus par le routeur local. S'ils ne sont pas, vérifiez que PIM est activé sur des interfaces de bouclage utilisées comme source des sessions BGP de député britannique

  • Vérifiez que le noyau de fournisseur de services est correctement configuré pour fournir la Multidiffusion entre les Routeurs de PE. Pour le test vous pourriez configurer l'ip igmp join-group sur l'interface de bouclage d'un routeur PE et faire le ping de Multidiffusion originaire du bouclage d'un autre routeur PE.


Informations connexes


Document ID: 29220