Câble haut débit : Systèmes de terminaison par modem câble (CMTS)

Configuration des services DHCP, ToD, TFTP sur le système de terminaison par modem câble (CMTS) Cisco : configuration tout en un

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document illustre une configuration du Système de terminaison par modem-câble (CMTS) de Cisco qui agit en tant que serveur DHCP, ToD et TFTP. Il explique également comment établir le fichier de configuration DOCSIS à partir de l'interface de ligne de commande du système CMTS. Cette configuration est connue en tant que « configuration tout-en-un pour le système CMTS de Cisco ».

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Le lecteur devrait avoir une compréhension de base du protocole DOCSIS et de la ligne de commande Cisco IOS sur les routeurs de la gamme d'ubr.

Composants utilisés

L'utilisation de matériel dans ce document étaient de l'uBR7200 de Cisco, de l'uBR7100 ou de l'uBR10k CMTS et des Modems câble conformes DOCSIS.

Description

Un modem câble conforme DOCSIS exige de l'accès à trois types de serveurs afin d'être livré avec succès en ligne.

  • Le premier est un serveur DHCP, qui fournit au modem câble une adresse IP, un masque de sous-réseau et d'autres paramètres associés par IP.

  • Le deuxième est un serveur conforme de l'heure RFC868 (ToD) qui fait le modem savoir ce qu'est le temps en cours. Un modem câble doit connaître le temps afin de pouvoir ajouter correctement les horodateurs précis à son journal d'événements.

  • Le tiers est un serveur de Protocole TFTP (Trivial File Transfer Protocol) dont un modem câble peut télécharger un fichier de configuration DOCSIS contenant des paramètres opérationnels spécifiques de modem câble.

La plupart de câblo-opérateurs utilisent le Cisco Network Registrar (le CNR) en tant que serveurs DHCP, de DN, et TFTP. Le serveur de ToD n'est pas une partie du CNR. Le serveur de ToD qui est utilisé dépend de la plate-forme de leur système. Le ToD devrait être RFC868 conforme. Pour des systèmes Unix, Il est inclus dans Solaris, il est seulement nécessaire de s'assurer le fichier « inetd.conf » que les vies dans le répertoire « /etc » contient les lignes suivantes :

# Time service is used for clock synchronization.
#
timeÝÝÝ streamÝ tcpÝÝÝÝ nowaitÝ rootÝÝÝ internal
timeÝÝÝ dgramÝÝ udpÝÝÝÝ waitÝÝÝ rootÝÝÝ internal

Pour Windows, le logiciel le plus commun qui est utilisé est Greywareleavingcisco.com .

Le tableau suivant affiche les versions de logiciel de Cisco IOSÝ dans lesquelles différentes capacités de serveur ont été ajoutées au CMTS.

Capacités de serveur Version du logiciel Cisco IOS
DHCP 12.0(1)T
ToD 12.0(4)XIÝ
TFTP 11.0 (pour toutes les Plateformes)

Ce document expliquera chacune de ces caractéristiques. Est la configuration sur le CMTS qui contient toutes ces capacités ce que nous appelons « configuration tout-en-un pour les cmts ». Avec cette configuration vous n'avez besoin d'aucun serveur supplémentaire pour tester vos usines de câble pour fournir l'accès d'Internet à grande vitesse.

Il est également possible de configurer un fichier de configuration DOCSIS résidant sur le CMTS au lieu du serveur TFTP. Selon les notes en version, vous avez besoin au moins de version du logiciel Cisco IOS 12.1(2)EC1 pour utiliser cette caractéristique.

Bien que cette « configuration tout-en-un » soit très commode pour l'environnement de travaux pratiques, le test initial, les petits déploiements, et le dépannage, elle n'est pas extensible pour prendre en charge un très grand nombre de Modems câble. Ainsi il n'est pas recommandé pour utiliser cette configuration aux usines opérationnelles de câble avec de grands déploiements des Modems câble.

Les ingénieurs TAC emploient cette configuration très souvent pour pouvoir éliminer des variables tout en dépannant des problèmes de câble.

Le service du protocole DHCP de Cisco IOS (DHCP) sur un CMTS

Les Routeurs de Cisco exécutant une version du logiciel Cisco IOS de 12.0(1)T ou plus grands ont la capacité d'agir en tant que serveurs DHCP. Ce service DHCP peut être configuré pour fournir des baux DHCP aux Modems câble et à l'équipement client (CPE) comme des PC et des postes de travail.

Il y a un ensemble minimum d'options DHCP des lesquelles les Modems câble exigent typiquement afin d'être livré sur la ligne. Ceux-ci sont :

  • Une adresse IP (le champ de yiaddr dans l'en-tête de paquet DHCP)

  • Un masque de sous-réseau (option DHCP 1)

  • Le décalage heure locale du GMT en quelques secondes (option DHCP 2)

  • Un routeur de par défaut (option DHCP 3)

  • L'adresse IP d'un serveur de ToD (option DHCP 4)

  • Le serveur de log (option DHCP 7)

  • L'adresse IP d'un serveur TFTP (le champ de siaddr dans l'en-tête de paquet DHCP)

  • Le nom d'un fichier de configuration DOCSIS (le gisement de fichier dans l'en-tête de paquet DHCP)

  • Une durée de bail DHCP en quelques secondes (option 51 DHCP)

Dans le routeur ceci peut être configuré comme suit :

!
ip dhcp pool cm-platinum
ÝÝ network 10.1.4.0 255.255.255.0
ÝÝ bootfile platinum.cm
ÝÝ next-server 10.1.4.1Ý
ÝÝ default-router 10.1.4.1Ý
ÝÝ option 7 ip 10.1.4.1Ý
ÝÝ option 4 ip 10.1.4.1Ý
ÝÝ option 2 hex ffff.8f80
ÝÝ lease 7 0 10
!

L'explication de chaque commande est comme suit :

  • L'ordre de groupe DHCP définit le nom de la portée (le cm-platine qui signifie le service de platine pour des Modems câble).

  • Le réseau fournit l'adresse IP et le masque de sous-réseau (option DHCP 1).

  • La bootfile fournit le nom du fichier de démarrage qui est dans ce cas platinum.cm.

  • La commande de next-server spécifie l'adresse IP pour serveur TFTP (est dans ce cas l'IP address primaire dans l'interface c4/0).

  • Le default-router est la passerelle par défaut, qui est dans ce cas l'adresse IP primaire de l'interface c4/0 (option3).

  • L'option 7 est l'option DHCP de serveur de log.

  • L'option 4 est l'IP address de serveur de ToD (IP address primaire d'interface c4/0).

  • L'Option 2 est l'option de décalage de temps pour le GMT - 8 heures (-8 heure = sec -28800 = ffff.8f80 dans l'hexa).

  • La durée de bail est de 7 jours pendant 0 heures 10 minutes.

Remarque: Pour se renseigner plus sur la façon convertir une valeur décimale de temps excentré en hexadécimal, lisez le conseil de tech comment calculer la valeur hexadécimale pour l'Option 2 DHCP (décalage de temps).

Pour des périphériques CPE les options suivantes sont les minimum afin de pouvoir utiliser avec succès.

  • Une adresse IP (le champ de yiaddr dans l'en-tête de paquet DHCP)

  • Un masque de sous-réseau (option DHCP 1)

  • Un routeur de par défaut (option DHCP 3)

  • L'adresse IP d'un ou plusieurs Domain Name Server (option DHCP 6)

  • Un nom de domaine (option 15 DHCP)

  • Une durée de bail DHCP en quelques secondes (option 51 DHCP)

!
ip dhcp pool pcs-c4Ý

! -- the scope for the hosts

    network 172.16.29.0 255.255.255.224

! -- the ip address and mask for the hosts

ÝÝÝ next-server 172.16.29.1

! -- tftp server, in this case we put the secondary add.

ÝÝÝ default-router 172.16.29.1
ÝÝÝ dns-server 172.16.30.2

! -- dns server (which is not configured on the cmts)

ÝÝÝ domain-name cisco.com
ÝÝÝ lease 7 0 10
!

En configurant les groupes DHCP, il est important d'inclure le cable dhcp-giaddr policy de commande dans la configuration d'interface de câble. Cette commande a l'effet de diriger le serveur DHCP assigner des baux aux Modems câble correspondant au numéro du réseau principal sur l'interface de câble et loue au CPE correspondant au network number secondaire sur l'interface de câble. Si cette commande manque alors tous les baux DHCP proviendront le groupe correspondant au numéro du réseau principal sur l'interface de câble. En outre, car nous verrons dans la configuration partielle de l'interface ci-dessous, le cm-platine de portée est associé avec l'adresse principale définie sur le câble d'interface 4/0 et la portée pcs-c4 est dans le réseau de l'adresse secondaire.

!
interface Cable4/0
ÝÝ ip address 172.16.29.1 255.255.255.224 secondary

! -- CPE network

ÝÝ ip address 10.1.4.1 255.255.255.0

! -- Cable Modem Network

ÝÝ cable dhcp-giaddr policy
!

Notez qu'il n'y a aucune commande de cable helper-address ou de helper-address d'IP sous l'interface de câble. C'est parce que des requêtes DHCP n'ont pas besoin d'être expédiées à un serveur externe quand le serveur DHCP interne IOS est utilisé. Si cette commande est ajoutée sous l'interface, et il y a un serveur DHCP externe configuré, les Modems câble s'inscriront à la configuration du DHCP externe.

Davantage de fonctionnalité de serveur DHCP

D'autres caractéristiques qui peuvent être utilisées utilisant le serveur DHCP de Cisco IOS incluent :

  • ping DHCP d'IP : Cinglez avant que la fonction de bail qui s'assure que le serveur DHCP n'émet pas des baux pour les adresses IP qui sont déjà en service.

  • ip dhcp database : Mémoire des liaisons DHCP dans une base de données externe afin de mettre à jour l'adresse MAC aux relations d'adresse IP au-dessus d'un arrêt et redémarrage CMTS.

  • DHCP de show ip : Une suite des commandes qui peuvent être utilisées pour surveiller le fonctionnement du serveur DHCP.

  • debug ip dhcp server : Une suite des commandes qui peuvent être utilisées pour dépanner le fonctionnement du serveur DHCP.

Toutes ces fonctions et caractéristiques supplémentaires sont décrites dans les notes de mise à jour en caractéristique de serveur DHCP de Cisco IOS situées au document sur le serveur DHCP de Cisco IOS.

Le service de heure du jour (TOD) de Cisco IOS (ToD)

Après qu'un modem câble saisisse avec succès un bail DHCP il poursuit alors à la tentative de contacter un serveur de ToD. Les Produits de Cisco CMTS exécutant peuvent le Logiciel Cisco IOS version 12.0(4)XI ou plus tard fournir un service RFC868 ToD.

Une fausse idée commune est que le service de ToD que les Modems câble doivent utiliser car une partie d'être livré en ligne est identique que le service de Protocole NTP (Network Time Protocol) qui est généralement configuré sur des Routeurs de Cisco. Le service de NTP et le service de ToD sont incompatibles. Les Modems câble ne peuvent pas parler à un serveur de NTP. Tandis que les Modems câble doivent tenter d'entrer en contact avec un serveur Heure (TOD) comme partie du processus d'être livré en ligne, les Modems conformes avec les dernières révisions de la spécification du DOCSIS 1.0 IFR poursuivront toujours pour être livré en ligne même si un serveur de ToD ne peut pas être atteint.

Selon les la plupart des versions récentes de la spécification, si un modem câble ne peut pas contacter un serveur de ToD puis il peut continuer le processus d'être livré en ligne. Cependant il devrait périodiquement continuer à essayer de contacter le serveur de ToD jusqu'à ce qu'il soit réussi. Des versions plus anciennes de la spécification du DOCSIS 1.0 IFR les ont exigé que si un modem câble ne pourrait pas contacter un serveur de ToD puis le modem ne pourrait pas être livré en ligne. Il est important de se rendre compte que les Modems câble exécutant un micrologiciel plus ancien puissent être conformes à cette version plus ancienne de la spécification.

Remarque: Les Modems câble d'un certain constructeur n'interopèrent pas avec le service de heure du jour (TOD) de Cisco IOS. Si ces Modems sont conformes avec les versions les plus récentes de la spécification du DOCSIS 1.0 IFR puis ils devraient continuer à être livré en ligne sans se soucier. Ce problème d'interopérabilité est abordé par l'ID de bogue Cisco CSCdt24107.

Remarque: Pour configurer ToD sur commandes globales CMTS de Cisco seulement deux soyez nécessaire :

service udp-small-servers max-servers no-limit
!
cable time-server
!

Le service de Protocole TFTP (Trivial File Transfer Protocol) de Cisco IOS

Après qu'un modem câble ait tenté de contacter un serveur de ToD, il poursuit pour contacter un serveur TFTP afin de télécharger un fichier de configuration DOCSIS. Si un fichier de configuration DOCSIS binaire peut être copié sur un périphérique flash sur Cisco CMTS puis le routeur peut agir en tant que serveur TFTP pour ce fichier.

La procédure pour télécharger un fichier de configuration DOCSIS dans l'éclair est la suivante :

D'abord, assurez-vous que le CMTS peut atteindre le serveur où le fichier de configuration DOCSIS vit :

7246VXR#ping 172.16.30.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Ensuite, copiez le fichier, dans ce cas il s'appelle silver.cm dans l'éclair du CMTS.

7246VXR#copy tftp flash
Address or name of remote host []? 172.16.30.2
Source filename []? silver.cm
Destination filename [silver.cm]?Ý

Accessing tftp://172.16.30.2/silver.cm...
Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
[OK - 76/4096 bytes]

76 bytes copied in 0.152 secs

En conclusion, c'est toujours une bonne idée de vérifier l'éclair et de le vérifier que la taille du fichier est correcte. Pour ceci faites le show flash.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1ÝÝ .. unknownÝ 2D6C7818ÝÝ 200CCÝÝÝ 9ÝÝÝÝÝÝ 74 Feb 28 2001 7:39:09 silver.cm
2ÝÝ .. unknownÝ 1CB785DCÝÝ 20258ÝÝÝ 7ÝÝÝÝÝÝ 62 Feb 20 2001 15:44:11 test.cm
3ÝÝ .. imageÝÝÝ 4350A04FÝ 7A0CC8ÝÝ 24Ý 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4ÝÝ .. unknownÝ 36E5D6D3Ý 7A0D94ÝÝÝ 7ÝÝÝÝÝÝ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Pour activer le service TFTP sur le CMTS là que nous devons seulement inclure la commande suivante dans le mode de configuration globale.

tftp-server slot0:silver.cm alias silver.cm

Une fois que cette commande est sélectionnée, ce qui suit affichera ensuite dans la configuration :

!
tftp-server slot0:silver.cm alias silver.cm
tftp-server serverÝÝ
!

Pour plus d'informations sur la configuration du serveur de tftp dans un routeur voyez les commandes supplémentaires de transfert de fichiers de document.

Le générateur interne de fichier de configuration DOCSIS

Des Produits de Cisco CMTS exécutant le Logiciel Cisco IOS version 12.1(2)EC ou plus tard (dans la série de versions EC) peuvent être configurés pour générer et enregistrer intérieurement des fichiers de configuration DOCSIS. C'est utile parce qu'il emporte la condition requise d'avoir accès à un outil externe de création de fichier de configuration DOCSIS. Quand un fichier de configuration DOCSIS est créé utilisant l'outil de configuration interne, le fichier devient automatiquement disponible par l'intermédiaire du TFTP. En outre seulement les Modems câble sur les interfaces de câble directement connectées peuvent télécharger ces fichiers de configuration.

L'exemple de configuration suivant affiche la création de deux fichiers de configuration DOCSIS.

Le premier s'appelle disable.cm qui permet à un modem câble pour être livré en ligne mais les périphériques CPE connectés par arrêts d'accéder au fournisseur de services. Dans ce cas nous voyons la commande « Access-refusée ». Notez que les vitesses d'en aval et d'en amont sont dans ce cas 1Kbps, la taille de rafale maximale est de 1600 octets.

cable config-file disable.cm
Ýaccess-denied
Ýservice-class 1 max-upstream 1
Ýservice-class 1 max-downstream 1600
Ýtimestamp
!

La raison qu'un câblo-opérateur aurait ce fichier de configuration DOCSIS « disable.cm » est parce qu'il veut refuser l'accès au CPE derrière les Modems câble tout en permettant le modem câble d'être livré en ligne. C'est plus de façon efficace de refuser le service de CPEs qu'utilisant « excluez » l'option au CNR qui ne permettra pas au modem câble pour être livré en ligne et donc le modem câble essayera d'obtenir en ligne à plusieurs reprises qui gaspillera la bande passante.

Les Modems câble obtenant ce fichier de configuration DOCSIS ressembleront à sous le show cable modem de commande :

Cable4/0/U0 10ÝÝ online(d)Ý 2287ÝÝÝ 0.50Ý 6ÝÝ 0ÝÝ 10.1.4.65ÝÝÝÝÝÝ 0010.7bed.9b45

(|| ajoutez le lien si disponible) fournit ci-dessous plus de détails sur cette sortie. L'état « en ligne (d) » signifie que les Modems câble sont seulement mais l'accès est refusé.

Dans le deuxième exemple, un nom du fichier de configuration DOCSIS est « platinum.cm » appelé créé. Dans ce cas la valeur ascendante maximum est 1Mbps, l'en amont garanti est 100Kpbs, l'en aval maximum est 10Mbps et il permet jusqu'à 30 périphériques CPE à connecter à ceci.

cable config-file platinum.cm
Ýservice-class 1 max-upstream 1000
Ýservice-class 1 guaranteed-upstream 100
Ýservice-class 1 max-downstream 10000
Ýservice-class 1 max-burst 1600
Ýcpe max 30
Ýtimestamp
!

Notez que ce fichier de configuration DOCSIS de lors de la configuration de dans le CMTS que nous n'avons pas besoin de la déclaration le « serveur slot0:platinum.cm alias platinum.cm de tftp » parce qu'il n'y a aucun fichier stocké de « .cm » sur la mémoire, il réside dans la configuration. D'autres détails sur l'outil interne de fichier de configuration DOCSIS peuvent être trouvés dans les commandes de système de terminaison par modem câble de document.

Exemple de diagramme

Une topologie typique d'installation de laboratoire est décrite dans l'image.

/image/gif/paws/28990/all_in_one_config1.gif

Configurations

Cette configuration est prise en charge dans des toutes les Plateformes CMTS de Cisco. Ceci inclut l'uBR7200, l'uBR7246 VXR, l'uBR7100, et l'uBR10000.

La version du logiciel Cisco IOS qui prend en charge tous dans une configuration, y compris la configuration du fichier de configuration DOCSIS, est Logiciel Cisco IOS version 12.1(2)EC et la série ultérieure EC relâche.

Les configurations suivantes ont été faites dans un uBR7246 VXR utilisant la version du logiciel Cisco IOS 12.1(4)EC et avoir un NPE300. D'abord une configuration de base est présentée et alors plus de configuration avancée sera affichée.

Configuration tout-en-un de base

La configuration ci-dessous récapitule toutes les parties que nous avons expliquées dedans sur le document. Il a deux portées DHCP, une pour les Modems câble et des autres pour les hôtes derrière les Modems câble.

Un fichier de configuration DOCSIS a été créé a appelé platinum.cm. Ce fichier est appliqué au pool DHCP appelé le cm-platine. L'autre fichier de configuration DOCSIS appelé disabled.cm n'est pas appliqué à n'importe quoi à l'heure actuelle.

Il y a deux pools DHCP configurés dans cet exemple, un pour les Modems câble et un autre pour les PC derrière les Modems câble.

Remarque:  Les commandes de configuration tout-en-un sont en gras.

« Configuration complète » de base 7246VXR
7246VXR#show run

version 12.1
no service pad
service timestamps debug datetime msec localtime

! -- provides nice timestamps on all log messages

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

! -- supports a large number of modems / hosts attaching quickly

!
hostname 7246VXR
!
logging buffered 1000000 debugging
enable password cable
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server

! --Ý permits cable modems to obtain Time of Day (ToD) from uBR7246VXR

!
cable config-file disable.cm
Ýaccess-denied
Ýservice-class 1 max-upstream 1
Ýservice-class 1 max-downstream 1600
Ýcpe max 1
Ýtimestamp
!
cable config-file platinum.cm
Ýservice-class 1 max-upstream 128
Ýservice-class 1 guaranteed-upstream 10
Ýservice-class 1 max-downstream 10000
Ýservice-class 1 max-burst 1600
Ýcpe max 10
Ýtimestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
ip cef

! -- Turn on cef switching / routing, anything but processÝ switching (no ip route-cache)

ip cef accounting per-prefixÝ
no ip finger
ip tcp synwait-time 5
no ip domain-lookup

! -- Prevents cmts from looking up domain names / attemptingÝ
! -- to connect to machines when mistyping commands

ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
!
!
!ÝÝ
ip dhcp pool cm-platinum

! -- name of the dhcp pool. This scope is for the cable modems attachedÝ
! -- to interface cable 4/0

ÝÝ network 10.1.4.0 255.255.255.0

! -- pool of addresses for scope modems-c4/0

ÝÝ bootfile platinum.cm

! -- DOCSIS config file name associated with this pool

ÝÝ next-server 10.1.4.1

! -- IP address of TFTP server which sends bootfile

ÝÝ default-router 10.1.4.1

! -- default gateway for cable modems, necessary to get DOCSIS files

ÝÝ option 7 ip 10.1.4.1

! -- Log Server DHCP option

ÝÝ option 4 ip 10.1.4.1

! -- ToD server IP address

ÝÝ option 2 hex ffff.8f80

! -- Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

ÝÝ lease 7 0 10

! -- lease 7 days 0 hours 10 minutes
ip dhcp pool pcs-c4

! -- name of the dhcp pool. This scope is for the CPEsÝ attachedÝ
! -- the cable modems that are connected to interface cable 4/0

ÝÝ network 172.16.29.0 255.255.255.224

! -- pool of addresses for scope pcs-c4 (associated with the secondary address)

ÝÝ next-server 172.16.29.1Ý
ÝÝ default-router 172.16.29.1
ÝÝ dns-server 172.16.30.2Ý
ÝÝ domain-name cisco.comÝ
ÝÝ lease 7 0 10ÝÝÝÝÝÝ
!
!
interface Ethernet2/0
Ýip address 172.16.30.4 255.255.255.192
Ýno ip mroute-cache
Ýhalf-duplex
!
interface Cable4/0
Ýip address 172.16.29.1 255.255.255.224 secondary

! -- used for the scope pcs-c4 so that PC's get an ip address on this network

Ýip address 10.1.4.1 255.255.255.0

! -- used for the scope modems-c4/0 so that cable modems get an ip address from this network

Ýno ip route-cache cef
Ýno keepalive
Ýcable downstream rate-limit token-bucket shaping
Ýcable downstream annex B
Ýcable downstream modulation 64qam
Ýcable downstream interleave-depth 32
Ýcable downstream frequency 555000000
Ýcable upstream 0 frequency 40000000
Ýcable upstream 0 power-level 0
Ýno cable upstream 0 shutdown
Ýcable upstream 1 shutdown
Ýcable upstream 2 shutdown
Ýcable upstream 3 shutdown
Ýcable upstream 4 shutdown
Ýcable upstream 5 shutdown
Ýcable dhcp-giaddr policy

! -- Used toÝ modify the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets with a
! -- Relay IP address before they are forwarded to the DHCP server

!ÝÝÝÝÝÝÝÝÝ
!ÝÝÝÝÝÝÝÝÝ
router eigrp 202
Ýredistribute connected
Ýredistribute static
Ýnetwork 10.0.0.0
Ýnetwork 172.16.0.0
Ýno auto-summary
Ýno eigrp log-neighbor-changes
!ÝÝÝÝÝÝÝÝÝ
router rip
Ýversion 2
Ýredistribute connected
Ýredistribute static
Ýnetwork 10.0.0.0
Ýnetwork 172.16.0.0
Ýno auto-summary
!ÝÝÝÝÝÝÝÝÝ
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!ÝÝÝÝÝÝÝÝÝ
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server server

! -- enable the cmts to act as a tftp server

tftp-server slot0:silver.cm alias silver.cm

! -- get the DOCSIS config file called silver.cm that is pre-downloaded to flash.
! -- this DOCSIS config file is built using DOCSIS CPE Configurator.ÝÝ

!ÝÝÝÝÝÝÝÝÝ
line con 0
Ýexec-timeout 0 0
Ýtransport input none
line aux 0
Ýspeed 19200
line vty 0 4
Ýsession-timeout 60Ý
Ýlogin
!
ntp clock-period 17179977
ntp server 172.16.135.51
end

Conseils de vérification pour la configuration de base

D'abord nous devons nous assurer que la commande sont prises en charge dans la version du logiciel Cisco IOS. Pour ceci nous pouvons faire le show version.

7246VXR#show version
Cisco Internetwork Operating System SoftwareÝ
IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(4)EC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Fri 08-Dec-00 17:35 by ninahung
Image text-base: 0x60008950, data-base: 0x612AA000

ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT SOFTWARE
BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(7)T,Ý RELEASE SOFTWARE (fc2)

7246VXR uptime is 9 minutes
System returned to ROM by reload at 09:47:00 PDT Tue Feb 27 2001
System restarted at 09:48:26 PDT Tue Feb 27 2001
System image file is "slot0:ubr7200-ik1s-mz.121-4.EC"

cisco uBR7246VXR (NPE300) processor (revision C) with 253952K/40960K bytes of memory.
Processor board ID SAB03500058
R7000 CPU at 262Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
6 slot VXR midplane, Version 2.0

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
4 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
5 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.

16384K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

Nous devons vérifier que le fichier de configuration DOCSIS est dans l'éclair.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1ÝÝ .. unknownÝ 2D6C7818ÝÝ 200CCÝÝÝ 9ÝÝÝÝÝÝ 74 Feb 28 2001 7:39:09 silver.cm
2ÝÝ .. unknownÝ 1CB785DCÝÝ 20258ÝÝÝ 7ÝÝÝÝÝÝ 62 Feb 20 2001 15:44:11 test.cm
3ÝÝ .. imageÝÝÝ 4350A04FÝ 7A0CC8ÝÝ 24Ý 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4ÝÝ .. unknownÝ 36E5D6D3Ý 7A0D94ÝÝÝ 7ÝÝÝÝÝÝ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Notez que le fichier « silver.cm » a été établi utilisant l'outil Configurator DOCSISCPE. Pour le fichier de platunum.cm qui a été établi dans la configuration CMTS que vous n'avez pas besoin de la déclaration le « serveur slot0:platinum.cm alias platinum.cm de tftp » parce qu'il n'y a aucun fichier « cm », il réside dans la configuration.

L'étape suivante est de vérifier que les Modems câble sont en ligne. Nous pouvons réaliser ceci avec le show cable modem de commande.

7246VXR#show cable modem
InterfaceÝÝ Prim OnlineÝÝÝÝ Timing RecÝÝÝ QoS CPE IP addressÝÝÝÝÝ MAC address
ÝÝÝÝÝÝÝÝÝÝÝ SidÝ StateÝÝÝÝÝ Offset Power
Cable4/0/U0 75ÝÝ onlineÝÝÝÝ 2290ÝÝÝ 0.00Ý 5ÝÝ 1ÝÝ 10.1.4.2ÝÝÝÝÝÝÝ 0010.7bed.9b23
Cable4/0/U0 76ÝÝ onlineÝÝÝÝ 2809ÝÝÝ 0.00Ý 5ÝÝ 0ÝÝ 10.1.4.3ÝÝÝÝÝÝÝ 0002.fdfa.0a63
Cable4/0/U0 77ÝÝ onlineÝÝÝÝ 2288ÝÝÝ 0.25Ý 5ÝÝ 1ÝÝ 10.1.4.5ÝÝÝÝÝÝÝ 0010.7bed.9b45
Cable4/0/U0 78ÝÝ onlineÝÝÝÝ 2810ÝÝÝ 0.50Ý 5ÝÝ 0ÝÝ 10.1.4.4ÝÝÝÝÝÝÝ 0004.2752.ddd5
Cable4/0/U0 79ÝÝ onlineÝÝÝÝ 2813ÝÝÝ 0.25Ý 5ÝÝ 0ÝÝ 10.1.4.6ÝÝÝÝÝÝÝ 0002.1685.b5db
Cable4/0/U0 80ÝÝ onlineÝÝÝÝ 2812ÝÝ -0.50Ý 5ÝÝ 0ÝÝ 10.1.4.7ÝÝÝÝÝÝÝ 0001.64ff.e47d


Notez que tous les Modems câble sont en ligne. Ceux connectés au câble d'interface 4/0/U0 sont dans le réseau 10.1.4.0. Nous pouvons voir de la configuration que leurs IP address sont pris du groupe DHCP appelé le « cm-platine ».

Notez également que les Modems câble avec le MAC adressent 0010.7bed.9b23, et 0010.7bed.9b45 respectivement, ont un CPE derrière. Ces Modems câble sont livré en ligne avec la configuration traversière par défaut. Ces PC sont configurés avec le DHCP de sorte qu'ils puissent obtenir leur adresse IP du réseau.

7246VXR#show interface cable 4/0 modem 0
SIDÝÝ Priv bitsÝ TypeÝÝÝÝÝ StateÝÝÝÝ IP addressÝÝÝ methodÝÝÝ MAC address
75ÝÝÝ 00ÝÝÝÝÝÝÝÝ hostÝÝÝÝÝ unknownÝÝ 172.16.29.2ÝÝ staticÝÝÝ 00c0.4f97.61c5
75ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.2ÝÝÝÝÝ dhcpÝÝÝÝÝ 0010.7bed.9b23
76ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.3ÝÝÝÝÝ dhcpÝÝÝÝÝ 0002.fdfa.0a63
77ÝÝÝ 00ÝÝÝÝÝÝÝÝ hostÝÝÝÝÝ unknownÝÝ 172.16.29.3ÝÝ dhcpÝÝÝÝÝ 00a0.243c.eff5
77ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.5ÝÝÝÝÝ dhcpÝÝÝÝÝ 0010.7bed.9b45
78ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.4ÝÝÝÝÝ dhcpÝÝÝÝÝ 0004.2752.ddd5
79ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.6ÝÝÝÝÝ dhcpÝÝÝÝÝ 0002.1685.b5db
80ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.7ÝÝÝÝÝ dhcpÝÝÝÝÝ 0001.64ff.e47d

Les images suivantes prouvent que ces PC obtiennent une adresse IP des groupes appelés "pcs-c4."

all_in_one_config2.gif

Nous pouvons également voir de ce PC que les configurations TCP/IP sont d'obtenir l'IP address automatiquement.

all_in_one_config3.gif

Configuration complète avancée

Cette section fournit un exemple plus sophistiqué de configuration qui implique la fonctionnalité de hiérarchie des groupes DHCP. Les travaux de hiérarchie de pool DHCP de manière est que n'importe quel pool DHCP avec un network number qui est un sous-ensemble du network number d'un autre groupe hérite de toutes les caractéristiques de ce autre groupe. Ceci enregistre la répétition en configuration du serveur DHCP. Cependant, si la même spécification est faite avec un paramètre différent puis le paramètre sera remplacé. Cet exemple affichera qu'un pool général avec une bootfile appelée platinum.cm et un sous-ensemble de ce groupe aura une bootfile appelée disable.cm.

En plus des pools DHCP créés dans l'exemple de base, nous avons des conditions requises spéciales pour deux Modems câble.

Le modem câble 0010.7bed.9b45 sera refusé l'accès. Ceci signifie que le modem câble sera accordé une adresse IP mais il ne sera pas livré en ligne. Pour ceci nous créerons le groupe suivant :

ip dhcp pool cm-0010.7bed.9b45
ÝÝ host 10.1.4.65 255.255.255.0
ÝÝ client-identifier 0100.107b.ed9b.45
ÝÝ bootfile disable.cm

La caractéristique la plus notable de cet exemple de configuration est la section où des pools DHCP spéciaux correspondant aux adresses MAC de modem câble individuel sont spécifiés. C'est de sorte que le serveur DHCP puisse envoyer de seules options DHCP à ces Modems. Afin de spécifier un modem câble particulier le paramètre de « client-identifier » est utilisé. Le « client-identifier » doit être placé à 01 suivis de l'adresse MAC du périphérique que l'entrée correspond à. Les 01 correspond au type de matériel d'Ethernets pour le DHCP.

Remarque: Quand changer le config classe pour un modem qu'il est nécessaire de faire le suivant de sorte que le modem câble obtienne les paramètres manuellement configurés :

  • Effacez la table de corrélation DHCP d'IP utilisant le <ip address> de clear ip dhcp binding de commande. »

  • Remettez à l'état initial le modem câble en question utilisant la recherche de < MAC address > de modem câble d'espace libre de commande.

Le modem câble 0010.7bed.9b23 a également une condition requise spéciale. Ceci obtiendra une qualité de service différente. Par conséquent une bootfile différente est associée à la portée. Voyez la configuration partielle ci-dessous :

ip dhcp pool cm-0010.7bed.9b23
ÝÝ host 10.1.4.66 255.255.255.0
ÝÝ client-identifier 0100.107b.ed9b.23
ÝÝ bootfile silver.cm

!

En configurant des pools DHCP pour les Modems câble spécifiques qu'il est dans toujours une bonne pratique de donner un approprié nommez. En outre, puisqu'un IP address spécifique est assigné au groupe utilisant la commande d'hôte, nous devons ajouter le DHCP d'IP de commande globale excluons 10.1.4.60 10.1.4.70. Cette commande indique le DHCP ne distribuent pas des adresses appartenant à cette plage.

« Configuration complète » avancée 7246VXR
7246VXR# show run

version 12.1
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit
!
hostname 7246VXR
!
logging buffered 1000000 debugging
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file disable.cm
Ýaccess-denied
Ýservice-class 1 max-upstream 1
Ýservice-class 1 max-downstream 1600
Ýcpe max 1
Ýtimestamp
!
cable config-file platinum.cm
Ýservice-class 1 max-upstream 128
Ýservice-class 1 guaranteed-upstream 10
Ýservice-class 1 max-downstream 10000
Ýservice-class 1 max-burst 1600
Ýcpe max 10
Ýtimestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
no ip finger
no ip domain-lookup
ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
ip dhcp excluded-address 10.1.4.60 10.1.4.70
!
ip dhcp pool cm-platinum
ÝÝ network 10.1.4.0 255.255.255.0
ÝÝ bootfile platinum.cm
ÝÝ next-server 10.1.4.1Ý
ÝÝ default-router 10.1.4.1Ý
ÝÝ option 7 ip 10.1.4.1Ý
ÝÝ option 4 ip 10.1.4.1Ý
ÝÝ option 2 hex ffff.8f80
ÝÝ lease 7 0 10
!
ip dhcp pool pcs-c4
ÝÝ network 172.16.29.0 255.255.255.224
ÝÝ next-server 172.16.29.1Ý
ÝÝ default-router 172.16.29.1Ý
ÝÝ dns-server 172.16.30.2Ý
ÝÝ domain-name cisco.com
ÝÝ lease 7 0 10
!
ip dhcp pool cm-0010.7bed.9b45
ÝÝ host 10.1.4.65 255.255.255.0
ÝÝ client-identifier 0100.107b.ed9b.45
ÝÝ bootfile disable.cm
!
ip dhcp pool cm-0010.7bed.9b23
ÝÝ host 10.1.4.66 255.255.255.0
ÝÝ client-identifier 0100.107b.ed9b.23
ÝÝ bootfile silver.cm
!
!
interface Ethernet2/0
Ýip address 172.16.30.4 255.255.255.192
Ýno ip mroute-cache
Ýhalf-duplex
!
interface Cable4/0
Ýip address 172.16.29.1 255.255.255.224 secondary
Ýip address 10.1.4.1 255.255.255.0
Ýno keepalive
Ýcable downstream rate-limit token-bucket shaping
Ýcable downstream annex B
Ýcable downstream modulation 64qam
Ýcable downstream interleave-depth 32
Ýcable downstream frequency 555000000
Ýcable upstream 0 frequency 40000000
Ýcable upstream 0 power-level 0
Ýno cable upstream 0 shutdown
Ýcable upstream 1 shutdown
Ýcable upstream 2 shutdown
Ýcable upstream 3 shutdown
Ýcable upstream 4 shutdown
Ýcable upstream 5 shutdown
Ýcable dhcp-giaddr policy
!
router eigrp 202
Ýredistribute connected
Ýredistribute static
Ýnetwork 10.0.0.0
Ýnetwork 172.16.0.0
Ýno auto-summary
Ýno eigrp log-neighbor-changes
!
router rip
Ýversion 2
Ýredistribute connected
Ýredistribute static
Ýnetwork 10.0.0.0
Ýnetwork 172.16.0.0
Ýno auto-summary
!
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!
access-list 188 permit tcp any any eq www log
access-list 188 permit ip any any
route-map docsis permit 10
!
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server slot0:silver.cm alias silver.cm
tftp-server server

line con 0
Ýexec-timeout 0 0
Ýtransport input none
line aux 0
Ýspeed 19200
line vty 0 4
Ýsession-timeout 60Ý
Ýexec-timeout 0 0
Ýlogin
!
ntp clock-period 17179973
end

Conseils de vérification pour la configuration avancée

La vérification de cette configuration se concentre sur les services que les Modems câble obtiennent, particulièrement 0010.7bed.9b45 et 0010.7bed.9b23. Nous devons être sûrs qu'ils obtiennent les adresses avec lesquelles ont été manuellement configurés et le service.

La première chose à tester est que 0010.7bed.9b45 sera livré en ligne mais le service sera refusé. Pour ceci nous nous avons permis de prendre à un regarder la commande de show cable modem :

7246VXR#show cable modem
InterfaceÝÝ Prim OnlineÝÝÝÝ Timing RecÝÝÝ QoS CPE IP addressÝÝÝÝÝ MAC address
ÝÝÝÝÝÝÝÝÝÝÝ SidÝ StateÝÝÝÝÝ Offset Power
Cable4/0/U0 7ÝÝÝ onlineÝÝÝÝ 2813ÝÝÝ 0.00Ý 7ÝÝ 0ÝÝ 10.1.4.7ÝÝÝÝÝÝÝ 0002.1685.b5db
Cable4/0/U0 8ÝÝÝ onlineÝÝÝÝ 2809ÝÝÝ 0.25Ý 7ÝÝ 0ÝÝ 10.1.4.10ÝÝÝÝÝÝ 0002.fdfa.0a63
Cable4/0/U0 9ÝÝÝ onlineÝÝÝÝ 2288ÝÝ -0.25Ý 5ÝÝ 1ÝÝ 10.1.4.66ÝÝÝÝÝÝ 0010.7bed.9b23
Cable4/0/U0 10ÝÝ online(d)Ý 2287ÝÝÝ 0.50Ý 6ÝÝ 0ÝÝ 10.1.4.65ÝÝÝÝÝÝ 0010.7bed.9b45
Cable4/0/U0 11ÝÝ onlineÝÝÝÝ 2809ÝÝ -0.50Ý 7ÝÝ 0ÝÝ 10.1.4.6ÝÝÝÝÝÝÝ 0001.64ff.e47d
Cable4/0/U0 12ÝÝ onlineÝÝÝÝ 2812ÝÝ -0.50Ý 7ÝÝ 0ÝÝ 10.1.4.9ÝÝÝÝÝÝÝ 0004.2752.ddd5

Il y a plusieurs points à noter ici :

  • Le modem câble 0010.7bed.9b23 a obtenu l'adresse IP 10.4.1.66 comme spécifié dans la portée cm-0010.7bed.9b23. Il y a un ordinateur relié à lui et il obtient son IP address du groupe pcs-c4.

  • Le modem câble 0010.7bed.9b23 a un QoS différent.

  • Le modem câble 0010.7bed.9b45 a obtenu l'adresse IP 10.1.4.65 comme spécifié dans la portée cm-0010.7bed.9b45. Il y a un ordinateur relié à lui, toutefois la valeur CPE est 0. La raison est que le service est refusé.

  • L'état en ligne de 0010.7bed.9b45 est en ligne (d) qui signifie que le modem câble est livré en ligne mais l'accès au réseau câblé est refusé. Voyez la sortie du log de MAC de debug cable bavard du modem câble.

21:52:16:Ý 78736.550 CMAC_LOG_RESET_RANGING_ABORTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:16:Ý 78736.554 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ reset_interface_state
21:52:16:Ý 78736.558 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ reset_hardware_state
21:52:17:Ý 78737.024 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ wait_for_link_up_state
21:52:17:Ý 78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESETÝÝÝÝÝÝÝÝÝÝÝÝÝ 0x082B9CA8
21:52:17:Ý 78737.032 CMAC_LOG_LINK_DOWNÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:17:Ý 78737.034 CMAC_LOG_LINK_UPÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:17:Ý 78737.040 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ds_channel_scanning_state
21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
21:52:18:Ý 78738.386 CMAC_LOG_UCD_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 1
21:52:19:Ý 78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIREDÝÝÝÝÝÝÝÝÝÝÝÝ 747000000
21:52:19:Ý 78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETEDÝÝÝÝÝÝÝÝÝÝ
21:52:19:Ý 78739.704 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ wait_ucd_state
21:52:20:Ý 78740.368 CMAC_LOG_UCD_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 1
21:52:22:Ý 78742.396 CMAC_LOG_UCD_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 1
21:52:22:Ý 78742.398 CMAC_LOG_ALL_UCDS_FOUNDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:22:Ý 78742.402 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ wait_map_state
21:52:22:Ý 78742.406 CMAC_LOG_FOUND_US_CHANNELÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 1
21:52:24:Ý 78744.412 CMAC_LOG_UCD_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 1
21:52:24:Ý 78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCYÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 39984000
21:52:24:Ý 78744.420 CMAC_LOG_SLOT_SIZE_CHANGEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 8
21:52:24:Ý 78744.500 CMAC_LOG_UCD_UPDATEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:24:Ý 78744.560 CMAC_LOG_MAP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:24:Ý 78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTSÝÝÝÝÝÝÝÝÝ 41
21:52:24:Ý 78744.566 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ranging_1_state
21:52:24:Ý 78744.570 CMAC_LOG_RANGING_OFFSET_SET_TOÝÝÝÝÝÝÝÝÝÝÝÝÝ 9610
21:52:24:Ý 78744.574 CMAC_LOG_POWER_LEVEL_ISÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 55.0Ý dBmV (commanded)
21:52:24:Ý 78744.578 CMAC_LOG_STARTING_RANGINGÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:24:Ý 78744.580 CMAC_LOG_RANGING_BACKOFF_SETÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 0
21:52:24:Ý 78744.586 CMAC_LOG_RNG_REQ_QUEUEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 0
21:52:24:Ý 78744.622 CMAC_LOG_RNG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:24:Ý 78744.626 CMAC_LOG_RNG_RSP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:24:Ý 78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 10
21:52:24:Ý 78744.632 CMAC_LOG_ADJUST_RANGING_OFFSETÝÝÝÝÝÝÝÝÝÝÝÝÝ 2286
21:52:24:Ý 78744.636 CMAC_LOG_RANGING_OFFSET_SET_TOÝÝÝÝÝÝÝÝÝÝÝÝÝ 11896
21:52:24:Ý 78744.638 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ranging_2_state
21:52:24:Ý 78744.644 CMAC_LOG_RNG_REQ_QUEUEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 10
21:52:25:Ý 78745.654 CMAC_LOG_RNG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:25:Ý 78745.658 CMAC_LOG_RNG_RSP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:25:Ý 78745.660 CMAC_LOG_RANGING_SUCCESSÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:25:Ý 78745.680 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ dhcp_state
21:52:25:Ý 78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESSÝÝÝÝÝÝÝÝÝÝ 10.1.4.65
21:52:25:Ý 78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESSÝÝÝÝÝÝÝÝÝÝ 10.1.4.1
21:52:25:Ý 78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESSÝÝÝÝÝÝÝÝÝÝÝ 10.1.4.1
21:52:25:Ý 78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESSÝÝÝÝÝÝÝÝÝÝÝ
21:52:25:Ý 78745.834 CMAC_LOG_DHCP_TZ_OFFSETÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ -28800
21:52:25:Ý 78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAMEÝÝÝÝÝÝÝÝÝÝÝÝÝ disable.cm
21:52:25:Ý 78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDRÝÝ
21:52:25:Ý 78745.846 CMAC_LOG_DHCP_COMPLETEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:25:Ý 78745.968 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ establish_tod_state
21:52:25:Ý 78745.978 CMAC_LOG_TOD_REQUEST_SENTÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:26:Ý 78746.010 CMAC_LOG_TOD_REPLY_RECEIVEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 3192525217
21:52:26:Ý 78746.018 CMAC_LOG_TOD_COMPLETEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:26:Ý 78746.020 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ security_association_state
21:52:26:Ý 78746.024 CMAC_LOG_SECURITY_BYPASSEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:26:Ý 78746.028 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ configuration_file_state
21:52:26:Ý 78746.030 CMAC_LOG_LOADING_CONFIG_FILEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ disable.cm
21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
21:52:27:Ý 78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETEÝÝÝÝÝÝÝ
21:52:27:Ý 78747.066 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ registration_state
21:52:27:Ý 78747.070 CMAC_LOG_REG_REQ_MSG_QUEUEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:27:Ý 78747.076 CMAC_LOG_REG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:27:Ý 78747.080 CMAC_LOG_REG_RSP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:27:Ý 78747.082 CMAC_LOG_COS_ASSIGNED_SIDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 1/10
21:52:27:Ý 78747.088 CMAC_LOG_RNG_REQ_QUEUEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 10
21:52:27:Ý 78747.090 CMAC_LOG_NETWORK_ACCESS_DENIEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:27:Ý 78747.094 CMAC_LOG_REGISTRATION_OKÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:27:Ý 78747.096 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ establish_privacy_state
21:52:27:Ý 78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGUREDÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:27:Ý 78747.102 CMAC_LOG_STATE_CHANGEÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ maintenance_state
21:52:31:Ý 78751.122 CMAC_LOG_RNG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:31:Ý 78751.124 CMAC_LOG_RNG_RSP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:37:Ý 78757.164 CMAC_LOG_RNG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:37:Ý 78757.168 CMAC_LOG_RNG_RSP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:43:Ý 78763.206 CMAC_LOG_RNG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:43:Ý 78763.210 CMAC_LOG_RNG_RSP_MSG_RCVDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:49:Ý 78769.250 CMAC_LOG_RNG_REQ_TRANSMITTEDÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ
21:52:49:Ý 78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

La sortie de ceci mettent au point prouve que l'accès au réseau est refusé.

7246VXR#show cable modem detail
InterfaceÝÝ SIDÝ MAC addressÝÝÝ Max CPEÝ ConcatenationÝ Rx SNR
Cable4/0/U0 7ÝÝÝ 0002.1685.b5db 10ÝÝÝÝÝÝ yesÝÝÝÝÝÝÝÝÝÝÝ 33.52
Cable4/0/U0 8ÝÝÝ 0002.fdfa.0a63 10ÝÝÝÝÝÝ yesÝÝÝÝÝÝÝÝÝÝÝ 33.24
Cable4/0/U0 9ÝÝÝ 0010.7bed.9b23 1ÝÝÝÝÝÝÝ noÝÝÝÝÝÝÝÝÝÝÝÝ 33.29
Cable4/0/U0 10ÝÝ 0010.7bed.9b45 1ÝÝÝÝÝÝÝ noÝÝÝÝÝÝÝÝÝÝÝÝ 33.23
Cable4/0/U0 11ÝÝ 0001.64ff.e47d 10ÝÝÝÝÝÝ yesÝÝÝÝÝÝÝÝÝÝÝ 33.20
Cable4/0/U0 12ÝÝ 0004.2752.ddd5 10ÝÝÝÝÝÝ yesÝÝÝÝÝÝÝÝÝÝÝ 33.44

Notez que le CPE maximum pour des Modems câble avec des portées spéciales est 1 et le repos sont 10. Si vous voyez la configuration de la portée platinum.cm, elle a 10 CPEs spécifié, d'autre part, la portée disable.cm a seulement 1 CPE. Le fichier de configuration DOCSIS préconfiguré silver.cm a également seulement un CPE spécifié.

7246VXR#show interface cable 4/0 modem 0
SIDÝÝ Priv bitsÝ TypeÝÝÝÝÝ StateÝÝÝÝ IP addressÝÝÝ methodÝÝÝ MAC address
7ÝÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.7ÝÝÝÝÝ dhcpÝÝÝÝÝ 0002.1685.b5db
8ÝÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.10ÝÝÝÝ dhcpÝÝÝÝÝ 0002.fdfa.0a63
9ÝÝÝÝ 00ÝÝÝÝÝÝÝÝ hostÝÝÝÝÝ unknownÝÝ 172.16.29.2ÝÝ staticÝÝÝ 00c0.4f97.61c5
9ÝÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.66ÝÝÝÝ dhcpÝÝÝÝÝ 0010.7bed.9b23
10ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.65ÝÝÝÝ dhcpÝÝÝÝÝ 0010.7bed.9b45
11ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.6ÝÝÝÝÝ dhcpÝÝÝÝÝ 0001.64ff.e47d
12ÝÝÝ 00ÝÝÝÝÝÝÝÝ modemÝÝÝÝ upÝÝÝÝÝÝÝ 10.1.4.9ÝÝÝÝÝ dhcpÝÝÝÝÝ 0004.2752.ddd5

Pour vérifier que les Modems câble obtiennent le niveau correct du service, nous voyons la sortie du show cable qos profile de commande.

7246VXR#show cable qos profile
IDÝ Prio MaxÝÝÝÝÝÝ Guarantee MaxÝÝÝÝÝÝÝ MaxÝÝ TOSÝ TOSÝÝ CreateÝ BÝÝÝÝ IP prec.
ÝÝÝÝÝÝÝÝ upstreamÝ upstreamÝ downstream txÝÝÝ mask value byÝÝÝÝÝ privÝ rate
ÝÝÝÝÝÝÝÝ bandwidth bandwidth bandwidthÝ burstÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ enabÝ enab
1ÝÝ 0ÝÝÝ 0ÝÝÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ cmts(r) noÝÝÝ noÝÝÝÝÝÝ
2ÝÝ 0ÝÝÝ 64000ÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 1000000ÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ cmts(r) noÝÝÝ noÝÝÝÝÝÝ
3ÝÝ 7ÝÝÝ 31200ÝÝÝÝ 31200ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ cmtsÝÝÝ yesÝÝ noÝÝÝÝÝÝ
4ÝÝ 7ÝÝÝ 87200ÝÝÝÝ 87200ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ cmtsÝÝÝ yesÝÝ noÝÝÝÝÝÝ
5ÝÝ 4ÝÝÝ 64000ÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 512000ÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ cmÝÝÝÝÝ noÝÝÝ noÝÝÝÝÝÝ
6ÝÝ 0ÝÝÝ 1000ÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 1600000ÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ cmÝÝÝÝÝ noÝÝÝ noÝÝÝÝÝÝ
7ÝÝ 0ÝÝÝ 128000ÝÝÝ 10000ÝÝÝÝ 10000000ÝÝ 1600Ý 0x0Ý 0x0ÝÝ cmÝÝÝÝÝ noÝÝÝ noÝÝÝÝÝÝ
8ÝÝ 0ÝÝÝ 0ÝÝÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ mgmtÝÝÝ noÝÝÝ noÝÝÝÝÝÝ
10Ý 0ÝÝÝ 0ÝÝÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ mgmtÝÝÝ noÝÝÝ noÝÝÝÝÝÝ
12Ý 0ÝÝÝ 0ÝÝÝÝÝÝÝÝ 100000000 0ÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 0x0Ý 0x0ÝÝ mgmtÝÝÝ noÝÝÝ no

Notez cet ID de qos 7 correspondances avec la configuration sur platinum.cm :

cable config-file platinum.cm
Ýservice-class 1 max-upstream 128
Ýservice-class 1 guaranteed-upstream 10
Ýservice-class 1 max-downstream 10000
Ýservice-class 1 max-burst 1600
Ýcpe max 10
Ýtimestamp

Le même se produit avec la configuration DOCSIS de disable.cm.

7246VXR#show ip dhcp binding
IP addressÝÝÝÝÝÝ Hardware addressÝÝÝÝÝÝÝ Lease expirationÝÝÝÝÝÝÝ Type
10.1.4.6ÝÝÝÝÝÝÝÝ 0100.0164.ffe4.7dÝÝÝÝÝÝ Mar 08 2001 07:58 AMÝÝÝ Automatic
10.1.4.7ÝÝÝÝÝÝÝÝ 0100.0216.85b5.dbÝÝÝÝÝÝ Mar 08 2001 07:58 AMÝÝÝ Automatic
10.1.4.9ÝÝÝÝÝÝÝÝ 0100.0427.52dd.d5ÝÝÝÝÝÝ Mar 08 2001 07:58 AMÝÝÝ Automatic
10.1.4.10ÝÝÝÝÝÝÝ 0100.02fd.fa0a.63ÝÝÝÝÝÝ Mar 08 2001 08:36 AMÝÝÝ Automatic
10.1.4.65ÝÝÝÝÝÝÝ 0100.107b.ed9b.45ÝÝÝÝÝÝ InfiniteÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Manual
10.1.4.66ÝÝÝÝÝÝÝ 0100.107b.ed9b.23ÝÝÝÝÝÝ InfiniteÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Manual

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 28990