Services de mise en réseau d'applications : Logiciel Cisco Application and Content Networking System (ACNS)

Comment configurer Cache Engine pour la mise en cache de proxy inverse à l'aide de WCCP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires



Contenu


Introduction

Ce document décrit comment configurer le moteur de cache de Cisco pour la mise en cache de proxy inverse à l'aide de la coordination Protocol (WCCP) de cache de Web.

Version matérielle et logicielle

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel ci-dessous.

  • Version 4.0 courante de Logiciel Cisco Cache version 2.3 et ACNS du moteur de cache 560 de Cisco et ACNS 5.0 dans un environnement de travaux pratiques avec des configurations effacées.

  • Version de logiciel 12.1(2) courante de Cisco IOS® de routeur de Cisco 2600.
Les informations présentées dans ce document ont été créées utilisant le matériel dans un environnement de travaux pratiques. Les périphériques démarrés avec une configuration (par défaut) effacée. Si vous fonctionnez dans un réseau vivant, assurez-vous que vous comprenez l'impact potentiel d'une commande avant de l'utiliser.

Diagramme du réseau


Configurations

Moteur de cache 560 (version de logiciel 2.3 de cache ou version de logiciel 4.0 ou 5.0 ACNS)
Current configuration:
!
!
user add admin uid 0 
password 1 "eeSdy9dcy" 
capability admin-access
!
!
!
hostname ce
!
interface ethernet 0
 ip address 10.0.0.2 255.255.255.0
!--- Important: If you configure the Cache Engine
!--- with a private address, it must get translated
!--- to a public address.
 ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! ip default-gateway 10.0.0.1 ip name-server 171.70.168.183 ip domain-name cisco.com ip route 0.0.0.0 0.0.0.0 10.0.0.1 cron file /local/etc/crontab ! wccp router-list 1 10.0.0.1 wccp reverse-proxy router-list-num 1 wccp version 2 ! authentication login local enable authentication configuration local enable rule no-cache url-regex .*cgi-bin.* rule no-cache url-regex .*aw-cgi.* ! !

Routeur de Cisco 2600 (version du logiciel Cisco IOS 12.1[2])
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2611-5
!
enable secret 5 $1$9VQ.$BTPbq8xlE2dsKwKPDDmpL/
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 description Interface to the Internet 
 ip address 172.17.63.194 255.255.255.192
 no ip redirects
!
interface Serial0/0
 no ip address
 no ip mroute-cache
 shutdown
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp 99 redirect out
!
interface Ethernet1/1
 no ip address
 shutdown
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Commandes debug et show

Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

Le moteur de cache mettent au point et des commandes show :

  • affichez le cache de wccp - Affichez les informations de la CE WCCP
  • affichez les écoulements de wccp - Affichez les écoulements de paquet WCCP
  • affichez les Routeurs de wccp - Affichez la liste de routeur WCCP
  • affichez les services de wccp - Affichez les services WCCP configurés
  • affichez la slowstart de wccp - Affichez à WCCP le début lent
  • affichez l'état de wccp - Affichez à WCCP l'état courant
  • affichez l'épargne de HTTP de statistiques - Statistiques de l'épargne de HTTP d'affichages
  • mettez au point le wccp entièrement WCCP activent toute l'élimination des imperfections
  • mettez au point les événements de wccp - Événements WCCP
  • mettez au point les paquets de wccp - Les informations paquet paquet WCCP
Le routeur mettent au point et des commandes show :
  • détail du show ip wccp 99 - Cette commande affiche des statistiques de moteur de cache et de routeur WCCP pour un groupe de service.
  • vue du show ip wccp 99 - Les informations de vue de groupe de service
  • debug ip wccp events - Événements WCCP
  • mettez au point les paquets d'ip wccp - Les informations paquet paquet WCCP

Vérification

Vérifiez que la mise en cache de proxy inverse fonctionne avec ces commandes.

Émettez cette commande de vérifier l'état de cache WCCP/engine de contenu :

 
router#sh ip wccp 99 detail 
WCCP Cache-Engine information: 
       IP Address:            10.0.0.2 
       Protocol Version:      2.0 
       State:                 Usable                              
	   !--- This cache is active.
       Initial Hash Info:     00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Hash Allotment:        256 (100.00%) 
       Packets Redirected:    93 
       Connect Time:          00:15:27

Émettez cette commande de vérifier la redirection inverse transparente WCCP sur le routeur :

 
router#sh ip wccp 99 
Global WCCP information: 
    Router information: 
        Router Identifier:                   172.17.63.194 
        Protocol Version:                    2.0 
    Service Identifier: 99 
        Number of Cache Engines:             1 
        Number of routers:                   1 
        Total Packets Redirected:            93                   
		!--- The router is redirecting.
        Redirect access-list:                -none- 
        Total Packets Denied Redirect:       0 
        Total Packets Unassigned:            0 
        Group access-list:                   -none- 
        Total Messages Denied to Group:      0 
        Total Authentication failures:       0


Émettez cette commande de vérifier des statistiques de HTTP sur le cache/engine de contenu :

 
cache#sh statistic http request 
                              Statistics - Requests 
                                                Total             % of Requests 
                            --------------------------------------------------- 
     Total Received Requests:                      23                         - 
              Forced Reloads:                       2                       8.7 
               Client Errors:                       0                       0.0 
               Server Errors:                       0                       0.0 
         URL Blocked (Reset):                       0                       0.0 
                 URL Blocked:                       0                       0.0 
      Sent to Outgoing Proxy:                       0                       0.0 
Failures from Outgoing Proxy:                       0                       0.0 
Excluded from Outgoing Proxy:                       0                       0.0 
             ICP Client Hits:                       0                       0.0 
             ICP Server Hits:                       0                       0.0 
               If-Range Hits:                       0                       0.0 
           HTTP 0.9 Requests:                       0                       0.0 
           HTTP 1.0 Requests:                       0                       0.0 
           HTTP 1.1 Requests:                      23                     100.0 
       HTTP Unknown Requests:                       0                       0.0 
           Non HTTP Requests:                       0                       0.0 
          Non HTTP Responses:                       0                       0.0 
      Chunked HTTP Responses:                       0                       0.0 
        Http Miss Due To DNS:                       0                       0.0 
     Http Deletes Due To DNS:                       0                       0.0 
  Objects cached for min ttl:                       4                      17.4

Émettez cette commande de vérifier la mise en cache des demandes :

 
cache#sh stat http sav 
                         Statistics - Savings 
                        Requests                          Bytes 
         ----------------------------------------------------------- 
  Total:                      23                          16481 
   Hits:                       6                           2205 
   Miss:                      17                          14276 
Savings:                    25.0 %                         13.4 %

Résumé des commandes

Ces commandes de moteur de cache ont été utilisées dans cette configuration.
  • version de wccp {1 | 2}
  • IP address de nombre de routeur-liste de wccp
  • nombre routeur-liste-numérique de wccp
Ces commandes de routeur ont été utilisées dans cette configuration.
  • ip wccp {Web-cache | service-nombre}
  • ip wccp {Web-cache | le service-nombre} réorientent
  • version 2 d'ip wccp


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes



Document ID: 28832