Technologies IBM : Data-Link Switching (DLSw) et Data-Link Switching Plus (DLSw+)

Configuration DLSw+ sur QLLC

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans cette configuration, deux ressources différentes en X.25 (nous avons utilisé le dspu-hôte pour simuler les périphériques d'extrémité dans cette installation). Pour plus d'informations sur l'Équipement de connexion de base (DSPU), référez-vous à ces documents :

Ces périphériques de deux extrémités communiquent avec différents adaptateurs dans le site de mainframe au-dessus du X.25. Les ressources distantes en X.25 ont été configurées pour différentes adresses de destination (dans différentes longueurs et différentes adresses). N'importe quel appel entrant dont l'adresse de destination X.121 apparie le « subaddress du qllc dlsw » du routeur est acheminé au Data-Link Switching Plus (DLSw+) (avec un ID.STN Ind). Quand DLSw+ reçoit « pouvez vous atteindre » la demande au sujet d'une adresse MAC virtuelle dans le groupe, les tentatives de code de Procédure QLLC (Qualified Logical Link Control) d'installer un circuit virtuel (circuit virtuel) à l'adresse X.121 qui trace à l'adresse MAC virtuelle spécifiée. Si un appel entrant est reçu, QLLC envoie un ID.STN.IND avec une adresse MAC virtuelle du groupe à DLSw+.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations de ce document sont basées sur les versions de logiciel et matériel suivantes :

  • La version de logiciel 12.2(6a) de½ du¿Â du Cisco IOSï a été utilisée dans le pathétique (Cisco 2612)

  • Le Logiciel Cisco IOS version 12.0(20) a été utilisé à Namur et Goode (Cisco 2500, Cisco 4000)

  • Le Logiciel Cisco IOS version 12.1(7) a été utilisé dans Nesle (Cisco 4500)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Diagramme de topologie

/image/gif/paws/28401/Topo.gif

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Configurations

Les adresses MAC du mainframe sont comme suit :

  • 4000.7507.0000

  • 4000.7507.ffff

Ce document utilise les configurations affichées ici :

Cisco 7507 (Meatfeast)
source-bridge ring-group 100 
dlsw local-peer peer-id 10.48.64.75 promiscuous 
! 
interface Channel4/2 
 ip address 10.48.64.225 255.255.255.240 
 no keepalive 
 lan TokenRing 0 
  source-bridge 88 1 100 
  adapter 0 4000.7507.0000 
  adapter 1 4000.7507.ffff 

Cisco 2612 (pathétique)
! 
source-bridge ring-group 200 
dlsw local-peer peer-id 10.48.64.40 
dlsw remote-peer 0 tcp 10.48.64.75 
! 
interface Ethernet0/0 
 ip address 10.48.64.40 255.255.255.0 
 half-duplex 
! 
interface Serial0/0 
 no ip address 
! 
interface TokenRing0/0 
 no ip address 
 ring-speed 16 
! 
interface Serial0/1 
 no ip address 
 encapsulation x25 
 x25 alias .*  

!--- It is used against the destination 
!--- address of a received call.

 x25 htc 10 
 x25 win 7 
 x25 wout 7 
 qllc accept-all-calls 
 qllc dlsw subaddress 123456789012345 vmacaddr 4000.3333.0000 2 partner 4000.7507.0000 
 qllc dlsw subaddress 2224 vmacaddr 4000.2222.0000 2 partner 4000.7507.ffff 
! 
ip default-gateway 10.48.64.1 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
dial-peer cor custom 
!  

Cisco 4500 (Nesle)
! 
x25 routing 
! 
! 
! 
interface Ethernet0 
 ip address 10.48.64.34 255.255.255.0 
 media-type 10BaseT 
! 
interface Ethernet1 
 no ip address 
 shutdown 
 media-type 10BaseT 
! 
interface Ethernet2 
 no ip address 
 media-type 10BaseT 
! 
interface Serial0 
 no ip address 
 encapsulation x25 dce 
 clockrate 250000 
! 
interface Serial1 
 no ip address 
! 
interface Serial2 
 no ip address 
 encapsulation x25 dce 
 no ip mroute-cache 
 clockrate 250000 
! 
interface Serial3 
 no ip address 
 encapsulation x25 dce 
 clockrate 250000 
 ! 
interface TokenRing0 
 no ip address 
 ring-speed 16 
! 
ip default-gateway 10.48.64.1 
ip classless 
no ip http server 
x25 route input-interface Serial2 interface Serial0 
x25 route input-interface Serial3 interface Serial0 
x25 route 555 interface Serial2 
x25 route 666 interface Serial3 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
 exec-timeout 0 0 
line vty 0 4 
 exec-timeout 0 0 
 password 7 071836 
 login 
! 
ntp clock-period 17179258 
ntp server 10.48.64.100 
end 

Cisco 2500 (Namur)
hostname namur 
! 
logging buffered 150000 debugging 
enable password 7 120E12 
! 
dspu host OZDEN xid-snd 00000000 x25 2224 qllc 12 interface Serial1 
! 
interface Ethernet0 
 no ip address
 no ip directed-broadcast 
 shutdown 
! 
interface Serial0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 
interface Serial1 
 no ip address 
 no ip directed-broadcast 
 encapsulation x25 
 no ip mroute-cache 
 x25 address 555 
 x25 htc 10 
 x25 win 7 
 x25 wout 7 
 dspu enable-host qllc 12 
 dspu start OZDEN 
! 
interface TokenRing0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 

Cisco 4000 (Goode)
dspu host GOODE xid-snd 11132323 x25 123456789012345 qllc 20 interface Serial1 
! 
interface Ethernet0 
 ip address 10.48.64.17 255.255.255.0 
 no ip directed-broadcast 
 media-type 10BaseT 
! 
interface Serial0 
 no ip address 
 no ip directed-broadcast 
 shutdown 
! 
interface Serial1 
 no ip address 
 no ip directed-broadcast 
 encapsulation x25 
 no ip mroute-cache 
 x25 address 666 
 x25 htc 10 
 x25 win 7 
 x25 wout 7 
 dspu enable-host qllc 20 
 dspu start GOODE 
! 

Vérifiez

Cette section fournit des informations que vous pouvez employer pour confirmer votre configuration est en activité.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show llc2 — Affiche les connexions LLC2 actives dans le routeur.

  • show version — Affiche les informations de version de logiciel.

  • affichez le pair de dlsw — Affiche les informations de connexion homologue de dlsw.

  • affichez le détail de circuit de dlsw — Affiche les détails du circuit DLSW.

  • interface série 0/1 de show qllc — Affiche des informations sur l'interface série 0/1 QLLC.

  • interface série 0/1 de show x25 interface — Affiche le statut de la ligne et du protocole relatif à l'interface série 0/1 de X.25.

  • show x25 route — Affiche la table de routage de X.25.

  • interface série 0 de show x25 interface — Affiche le statut de la ligne et du protocole relatif à l'interface série 0 de X.25.

  • show dspu — Affiche le statut de la caractéristique DSPU.

  • interface série 1 de show x25 interface — Affiche le statut de la ligne et du protocole relatif à l'interface série 1. de X.25.

Meatfeast
#show llc2 
.... 
Channel4/2 DTE: 4000.7507.ffff 4000.2222.0000 04 04 state NORMAL 
   V(S)=1, V??)=1, Last N??)=1, Local window=7, Remote Window=127 
   akmax=3, n2=8, 
   xid-retry timer      0/0       ack timer       0/1000 
   p timer              0/1000    idle timer   5430/10000 
   rej timer            0/3200    busy timer      0/9600 
   adm timer            0/60000   llc1 timer      0/1000 
   akdelay timer        0/100     txQ count       0/200 
   RIF: 06B0.0581.0640 
Channel4/2 DTE: 4000.7507.0000 4000.3333.0000 04 04 state NORMAL 
   V(S)=6, V??)=6, Last N??)=6, Local window=7, Remote Window=127 
   akmax=3, n2=8, 
   xid-retry timer      0/0       ack timer       0/1000 
   p timer              0/1000    idle timer   5630/10000 
   rej timer            0/3200    busy timer      0/9600 
   adm timer            0/60000   llc1 timer      0/1000 
   akdelay timer        0/100     txQ count       0/200 
   RIF: 06B0.0581.0640 

Pathétique
pathos#show version 
Cisco Internetwork Operating System Software 
IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(6a), RELEASE SOFTWARE (fc1) 
Copyright ??) 1986-2001 by cisco Systems, Inc. 
Compiled Sat 01-Dec-01 22:30 by pwade 
Image text-base: 0x80008088, data-base: 0x810616B4 
pathos#show dlsw peer 
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime 
 TCP 10.48.64.75     CONNECT        118        91  conf      0    2   0 00:32:12 
Total number of connected peers: 1 
Total number of connections:     1 
pathos#show dlsw circuit detail
Index           local addr(lsap)    remote addr(dsap)  state          uptime 
234881048       4000.2222.0000(04)  4000.7507.ffff(04) CONNECTED      00:29:50 
        PCEP: 81C25730   UCEP: 81D88528 
        Port:Se0/1          peer 10.48.64.75(2065) 
        Flow-Control-Tx  CW:20, Permitted:19; Rx CW:20, Granted:39; Op: Repeat 
        Congestion: Low(02), Flow Op: Half: 0/0 Reset 0/0 
        RIF = --no rif-- 
        Bytes:             429/453        Info-frames:           1/1 
        XID-frames:          5/4          UInfo-frames:          0/0 
        HPR saps: local 0x0, remote 0x4 
1426063385      4000.3333.0000(04)  4000.7507.0000(04) CONNECTED      00:29:49 
        PCEP: 81D081B4   UCEP: 81D108B0 
        Port:Se0/1          peer 10.48.64.75(2065) 
        Flow-Control-Tx  CW:20, Permitted:34; Rx CW:20, Granted:34; Op: Repeat 
        Congestion: Low(02), Flow Op: Half: 0/0 Reset 0/0 
        RIF = --no rif-- 
        Bytes:             554/513        Info-frames:           6/6 
        XID-frames:          5/4          UInfo-frames:          0/0 
        HPR saps: local 0x0, remote 0x4 
Total number of circuits connected: 2 
pathos#show qllc serial 0/1
Interface Serial0/1 
 vc 2 66620 
   Circuit State P4/D1, Logical Link State QLOpened 4000.3333.0000(04)->4000.7507.0000(04) 
   0 packets held 
 vc 1 55512 
   Circuit State P4/D1, Logical Link State QLOpened 4000.2222.0000(04)->4000.7507.ffff(04) 
   0 packets held 
pathos# 
pathos#show x25 interface  serial 0/1
SVC 1,  State: D1,  Interface: Serial0/1 
  Started 00:30:51, last input 00:30:50, output 00:30:50 
  Connects 55512 <--> 
   qllc 4000.2222.0000 
  Window size input: 7, output: 7 
  Packet size input: 128, output: 128 
  PS: 0  PR: 7  ACK: 6  Remote PR: 0  RCNT: 1  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 463/441 packets 8/7 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
SVC 2,  State: D1,  Interface: Serial0/1 
  Started 00:30:51, last input 00:30:50, output 00:30:50 
  Connects 66620 <--> 
   qllc 4000.3333.0000 
  Window size input: 7, output: 7 
  Packet size input: 128, output: 128 
  PS: 5  PR: 4  ACK: 2  Remote PR: 5  RCNT: 2  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 523/566 packets 13/12 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
pathos# 

Nesle
nesle#show x25 route 
  #  Match                         Substitute          Route to 
  1  input-int Serial2                                 Serial0 
  2  input-int Serial3                                 Serial0 
  3  dest 555                                          Serial2 
  4  dest 666                                          Serial3 

nesle#show x25 interface serial 0
SVC 1,  State: D1,  Interface: Serial0 
  Started 00:32:47, last input 00:32:46, output 00:32:46 
  Connects 55512 <--> 2224 from Serial2 SVC 10 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 7  PR: 0  ACK: 0  Remote PR: 6  RCNT: 0  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 441/463 packets 7/8 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
SVC 2,  State: D1,  Interface: Serial0 
  Started 00:32:47, last input 00:32:46, output 00:32:46 
  Connects 66620 <--> 123456789012345 from Serial3 SVC 1024 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 4  PR: 5  ACK: 5  Remote PR: 2  RCNT: 0  RNR: no 
  Window is closed 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 566/523 packets 12/13 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
nesle#show x25 interface serial 2 
SVC 10,  State: D1,  Interface: Serial2 
  Started 00:32:51, last input 00:32:50, output 00:32:50 
  Connects 55512 <--> 2224 to Serial0 SVC 1 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 0  PR: 7  ACK: 6  Remote PR: 0  RCNT: 1  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 463/441 packets 8/7 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
nesle#show x25 interface serial 3 
SVC 1024,  State: D1,  Interface: Serial3 
  Started 00:32:53, last input 00:32:52, output 00:32:52 
  Connects 66620 <--> 123456789012345 to Serial0 SVC 2 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 5  PR: 4  ACK: 2  Remote PR: 5  RCNT: 2  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 523/566 packets 13/12 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0

Namur
namur#show dspu 
dspu host OZDEN Serial1 (QLLC) PU STATUS Active 
     FRAMES RECEIVED 8 FRAMES SENT 8 
     LUs USED BY DSPU 0 LUs ACTIVE 0 
     LUs USED BY API 0 LUs ACTIVE 0 
     LUs ACTIVATED BY HOST BUT NOT USED 0 

namur#show x25 interface serial 1 
SVC 10,  State: D1,  Interface: Serial1 
  Started 00:34:55, last input 00:34:54, output 00:34:54 
  Connects 2224 <--> 
   qllc 
  Window size input: 7, output: 7 
  Packet size input: 128, output: 128 
  PS: 7  PR: 0  ACK: 0  Remote PR: 6  RCNT: 0  RNR: no 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 441/463 packets 7/8 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
namur# 

Goode
goode#show dspu 
dspu host GOODE Serial1 (QLLC) PU STATUS Active 
     FRAMES RECEIVED 18 FRAMES SENT 18 
     LUs USED BY DSPU 0 LUs ACTIVE 0 
     LUs USED BY API 0 LUs ACTIVE 0 
     LUs ACTIVATED BY HOST BUT NOT USED 5 

goode#show x25 interface serial 1 
SVC 1024,  State: D1,  Interface: Serial1 
  Started 00:41:25, last input 00:41:25, output 00:41:25 
  Connects 123456789012345 <--> 
   qllc 
  Window size input: 2, output: 2 
  Packet size input: 128, output: 128 
  PS: 4  PR: 5  ACK: 5  Remote PR: 2  RCNT: 0  RNR: no 
  Window is closed 
  P/D state timeouts: 0  timer (secs): 0 
  data bytes 566/523 packets 12/13 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
goode# 

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 28401