Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Utilisation d'un adaptateur de terminal ADTRAN avec les routeurs Cisco

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Les adaptateurs terminaux RNIS ADTRAN (TAS) peuvent être utilisés pour fournir la Connectivité d'accès de base (BRI) aux Routeurs sans interfaces BRI. Les VENTRES (connectés au port série) termine l'appel BRI et communique les données au routeur comme un flux de données synchrones.

Contours de ce document comment au TAS ADTRAN ISU? fonctionner avec des Routeurs de Cisco. Nous recommandons que vous vous référiez à la documentation du produit sur le site Webleavingcisco.com ADTRAN avant la démarche.

Conditions préalables

Conditions requises

Vérifiez que le circuit BRI fonctionne correctement. Vous pouvez souhaiter utiliser le circuit sur un routeur avec un port BRI pour tester le circuit avant de le déployer dans cette configuration. Également vérifiez et testez le périphérique de pair pour s'assurer qu'il fonctionne correctement.

Pour quelques applications, l'ADTRAN ISU doit prendre en charge le PPP à liaisons multiples synchrone (MPPP). L'ISUs qui prennent en charge la député britannique synchrone incluent l'ISU exprès (numéros de pièce 1200.081L5, 1200.081L6, et 1202.081 L6), ISU 2x64 (1200.051L1 et 1200.051L2), et la seconde génération ISU 128 (1202.029L2 et 1202.029L3.)

Pour utiliser MPPP sur un routeur de Cisco, la révision de logiciel de l'ISU doit être à jour. Une liste de révisions de logiciel minimum est présentée le sous-produit dans la table ci-dessous :

Unité Numéro de référence Révision de logiciel
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00 ou G.00
ISU expriment L6 1200.081L6 K.28
ISU expriment L6 1202.081L6 D.43

Remarque: Puisque les conditions requises peuvent changer, vérifiez les conditions requises de micrologiciel avec utiliser ADTRAN ISUs avec des Routeurs de Ciscoleavingcisco.com .

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Un routeur avec une interface série synchrone. L'interface série peut être intégrée ou sur un module WIC/Network.

  • Il n'y a aucune restriction de logiciel de Cisco IOSÝ pour cette configuration.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Méthode de composition

Il y a trois méthodes qui peuvent être utilisées pour initier un cadran par les VENTRES :

  • Composition V.25 ou V.25bis

  • Composition prête de terminal de données (DTR)

  • Composition de pavé numérique

Composition V.25 ou V.25bis

Suivre cette méthode, le routeur envoie un numéro de téléphone aux VENTRES. Cette méthode permet au routeur pour placer et recevoir des appels RNIS. Pour lancer V.25/V,.25bis composant, vous devez configurer l'ordre de dialer in-band sur l'interface de routeur. Exemple :

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

Vous devriez configurer l'ISU pour la composition V.25bis et le MPPP.

Quand le routeur reçoit le trafic intéressant, il soulève DTR et Request To Send (RTS), qui fait initier les VENTRES un cadran sur le premier canal B. Cependant, le routeur ne demande pas aux VENTRES pour initier la deuxième connexion de canal B. Dans ce cas, l'ADTRAN doit être programmé pour composer le deuxième canal B ou pour avoir le deuxième nombre passé dans la même chaîne de numéroteur. L'interface série de routeur est une interface point par point et n'a aucune idée du nombre de canaux B configurés sur l'ADTRAN.

Ne configurez pas le ppp multilink de commande sur le routeur, puisque les VENTRES manipule réellement la connexion multiliaison, tandis que le processus du besoin de routeur seulement le flot synchrone des VENTRES.

Remarque: Utilisant de plusieurs Cartes de composeur (car nous sur des interfaces BRI) n'aide pas pour cette question de multilink.

Composition DTR

Suivre cette méthode, le routeur peut seulement placer des appels à un numéro de téléphone particulier, il ne peut pas recevoir des appels entrant. Avec cette méthode, les numéros de téléphone du site distant doivent être enregistrés dans la mémoire des VENTRES. Quand les VENTRES voit le DTR passer à 1, il compose le numéro qui est enregistré dans les VENTRES. Ceci exige la commande de dialer dtr sous l'interface série. Exemple :

Exemple :

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

L'ADTRAN doit être configuré pour la composition, le PPP à liaisons multiples DTR, et ainsi de suite, et a le numéro de téléphone de destination programmé.

Les deux canaux B sont composés par l'ADTRAN.

Composition de pavé numérique

Un certain TAS ont des pavés numériques sur eux à tenir compte de la composition interactive directement des VENTRES. Avec cette méthode, l'utilisateur doit entrer le nombre pour se connecter le pavé numérique de VENTRES chaque fois qu'une connexion doit être faite. Cette méthode est principalement utilisée afin de tester pour vérifier la Connectivité. La configuration de routeur exigée est affichée ci-dessous :

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

Câblage

Pour connecter le port série du routeur aux VENTRES utilisez un câble du V.35 DTE (avec port série DB-60 ou interface série intelligente d'un côté). Le diagramme suivant affiche un câble témoin :

adtran_ta1.gif

Si les VENTRES a seulement un port de RS-232, alors vous avez besoin également d'un V.35 au câble du RS-232 (DB-25) en plus du câble affiché ci-dessus. Alternativement, vous pouvez utiliser juste un câble du RS-232 DB-60-to-DB-25.

Référez-vous aux sections de catalogue des produits sur des câbles série pour plus d'informations sur le câblage.

Exemple de configuration utilisant V.25bis

Cette section affiche un exemple de configuration utilisant V.25bis.

/image/gif/paws/28080/adtran_ta2.gif

Configuration ADTRAN ISU

Cette section inclut quelques conseils sur configurer l'ADTRAN ISU. Cependant, consultez s'il vous plaît le site Web ADTRANleavingcisco.com avant de configurer les VENTRES, comme fonctionnalité, des caractéristiques et les paramètres de configuration ont pu avoir changé.

  1. Connectez l'ADTRAN MERCI à un PC. Cette étape est nécessaire de sorte que vous puissiez accéder aux VENTRES et configurer les divers paramètres avant de l'accrocher jusqu'au routeur.

    Reliez un « terminal » RJ-45-to-DB-9 marqué par adaptateur au port des transmissions (COM) du PC. De l'extrémité de RJ-45 de l'adaptateur, connectez un câble de RJ-45 RJ-45-- roulé parsatin (numéro de pièce CAB-500RJ=), qui est donné en chaque routeur de Cisco pour des connexions de console. Vous avez besoin également d'un RJ-45 au « MODEM » DB-25 marqué par adaptateur (numéro de pièce CAB-25AS-MMOD) pour connecter le câble enroulé au RS-232 du port intitulé DB-25 au dos de l'ADTRAN.

  2. Entrez À ! V (ou si connecté au port RS366/Maintenance, utilisation ! V) pour obtenir le menu principal. Puis presse Ctrl+C pour écrire le menu de configuration.

    Vous devriez voir le menu semblable à celui ci-dessous (ceci peut varier selon le modèle de VENTRES) :

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. Utilisez les numéros correspondants pour écrire le mode de configuration pour les divers attributs.

    Les attributs suivants (à un minimum) devraient être configurés :

    • Commutateur Protocol : Le type de commutateur spécifié par la compagnie de téléphone.

    • Type d'appel : Spécifiez 64 données k ou 56K (selon le type de circuit).

    • SPID1, SPID2, LDN1, LDN2 : Si c'est approprié, assignez les SPID et les LDN fournis par la compagnie de téléphone.

    • Options de cadran : V.25.

    • V.25 : V.25 HDLC (si utilisant l'interface série de sync) ou V.25 ASYNC (si utilisant l'interface série async).

    • Options DTE : Synchrone (si utilisant l'interface série de sync) ou asynchrone (si utilisant l'interface série async).

    • Débit binaire : 128000 (ou 112000 pour appels 56K).

    • Protocol : Asyn-sync de PPP.

    • Méthode : Multilien.

    Nous recommandons que vous vous référiez à la fiche technique/à manuels ISU sur le site Web ADTRANleavingcisco.com pour les choix possibles pour chaque paramètre. L'exemple présenté ci-dessus devrait fonctionner pour la plupart des situations.

Configuration de routeur et test

Employez la procédure suivante pour configurer et examiner le routeur.

  1. Connectez un V.35 ou un câble du RS-232 DTE au port série de routeur. Référez-vous au câblage de section pour plus d'informations sur les types de câble que vous devriez utiliser.

  2. Utilisez le show controller x séquentiel (qui indique que le type de câble le routeur est connecté à) pour vérifier que le câble du côté routeur est DTE. Exemple :

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    Vous devriez également vérifier que la configuration de type de connecteur sur l'ADTRAN (option 16 dans l'exemple ci-dessus) apparie le câblage utilisé.

  3. Configurez le routeur comme suit :

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    Remarque: Pour que les VENTRES évoquent les deux canaux, vous devez enregistrer le deuxième nombre dans l'ADTRAN, ou utilisez [phonenumber1]&[phonenumber2] dans le (recommandé) d'instruction de mappage de numéroteur de Cisco. L'interface série est juste une interface point par point, ainsi avoir de plusieurs Cartes de composeur n'affecte pas des connexions multiliaison.

    L'ADTRAN compose le premier numéro, négocie et authentifie, et puis compose immédiatement le deuxième. Notez que le ppp multilink de commande n'est pas configuré sur le routeur, puisque les VENTRES manipule le multilink

    Remarque: Si vous souhaitez utiliser l'interface série dans le mode asynchrone, utilisez la couche physique de commande async sous la configuration de l'interface série. Cependant, du matériel d'interface série ne prennent en charge pas la transmission async. Pour connecter un modem à cette interface, référez-vous à configurer Dialout utilisant un modem sur le port auxiliaire. Ce document utilise le port auxiliaire. Cependant, les configurations sont très semblables.

  4. Initiez un ping au routeur distant. Le routeur envoie les chaînes de numéroteur aux VENTRES, qui initie alors la liaison RNIS. Une fois que la liaison RNIS est en hausse, les Routeurs négocient le PPP et et l'authentification se produit. Vous devriez pouvoir passer le trafic à ce moment.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • mettez au point le numéroteur - Pour afficher les informations de débogage au sujet des paquets reçus sur une interface capable de numéroteur. Quand le Routage à établissement de connexion à la demande (DDR) est activé sur l'interface, les informations au sujet de la cause de n'importe quel appel (appelé la cause d'appel) sont également affichées. Le pour en savoir plus, voient les informations de numéroteur de débogage dans la documentation de commandes de debug.

  • interface série de debug interface - Utilisez la commande EXEC d'interface série de débogage d'afficher les informations sur une panne de connexion série. Le pour en savoir plus, voient les informations séquentielles de debug interface dans la documentation de commandes de debug.

  • debug ppp negotiation - Affiche des informations sur le trafic PPP et des échanges tout en négociant les composants de PPP comprenant le Link Control Protocol (LCP), l'authentification, et le protocole de contrôle de réseau (NCP). Une négociation PPP réussie d'abord ouvrira l'état LCP, puis authentifie, et négocie finalement le NCP. Pour plus d'informations sur le debug ppp negotiation de lecture sorti s'il vous plaît référez-vous derrière la sortie de debug ppp negotiation de document compréhension.

  • debug ppp authentication - Affiche les messages du protocole d'authentification de PPP, y compris des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP). Référez-vous au pour en savoir plus de document suivant : Dépannage de l'authentification de PPP (CHAP ou PAP).

Sortie de débogage

Activate mettent au point le numéroteur et le debug ppp negotiation, puis initient un ping au pair. Le routeur devrait tenter de composer. Une fois que la connexion RNIS est établie la négociation PPP devrait commencer. La sortie de débogage suivante affiche un appel réussi.

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

Remarque: Pour plus d'informations sur la sortie de debug ppp negotiation de lecture, référez-vous s'il vous plaît derrière la sortie de debug ppp negotiation de document compréhension.

Procédure de dépannage

Cette section inclut quelques procédures de dépannage communes. Si vous rencontrez des questions à n'importe quelle étape pour se référer au pour en savoir plus technique de documentation ADTRAN :

  1. Vérifiez que l'affichage sur l'avant de l'ADTRAN lit comme suit :

    Adtran ISU 128
    [Switch-type] Ready

    Ceci s'assure que la configuration RNIS, telle que les switchtypes, les identifiants de service profile (SPID) et le numéro dans le répertoire local (LDN) ont été correctement configurés et reçus par la compagnie de téléphone.

  2. Initiez une connexion de test au pair à l'aide du pavé numérique sur l'ADTRAN. Ceci peut aider à s'assurer que le circuit RNIS, et la configuration associée par RNIS sur les VENTRES est correct.

  3. Initiez un ping au pair. Vous devriez voir le suivant sur l'affichage de panneau avant de l'ADTRAN : « APPELANT [PHONENUMBER ». Ceci indique qu'au moins V.25bis fonctionne correctement. Si vous ne voyez pas le message, essayez les câbles d'échange et même le TAS. Ceci peut aider à isoler de mauvais câbles et interfaces de V.35 sur les VENTRES.

  4. Activate mettent au point le numéroteur. Initiez un ping. Vérifiez que vous voyez le suivant dans la sortie de débogage :

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    Si vous ne voyez pas le message, alors la question est liée à la DDR. Vérifiez que la configuration de routeur est comme affichée ci-dessus. Assurez-vous que le routage et la définition du trafic intéressant est aussi bien configuré.

  5. Activate mettent au point l'interface série, initient un ping et le vérifient que les VENTRES soulève le poste de données prêt (DSR).

    Seulement quand le routeur détecte une haute DSR, la tentative de routeur de négocier le PPP. Si DSR ne monte pas, alors nous devons dépanner une couche inférieure telle que le RNIS, le matériel et le câblage.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 28080