IP : Protocole OSPF (Open Shortest Path First)

Routage sous-optimal lors de la redistribution entre processus OSPF

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit les problèmes de routage sous-optimal liés à la redistribution entre les processus Open Shortest Path First (OSPF) et y fournit des solutions.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Problème

En redistribuant entre différents processus OSPF à de plusieurs points sur le réseau, il est possible d'entrer dans des situations du routage subobtimal ou même plus mauvais, une boucle de routage.

Dans la topologie ci-dessous nous avons l'OSPF 1 de processus et le routeur 1 (R1) OSPF 2. et le routeur 2 (R2) redistribuent d'OSPF 1 dans OSPF 2.

/image/gif/paws/28025/2ospf-redis-1.jpg

Les configurations pour les Routeurs R1 et R2 sont affichées ci-dessous.

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0
 network 10.255.255.1 0.0.0.0 area 0 
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal
 
!--- Redistributing OSPF 1 into OSPF 2.
 
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
!  
ip classless  
!  
end

R2
hostname r2  
!  
ip subnet-zero  
!  
 
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0 
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal

!--- Redistributing OSPF 1 into OSPF 2. 

 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
!  
ip classless  
 
end

Dans la topologie ci-dessus, R4 E1/0 est dans la zone 1 et E0/0 est dans la zone 0. Par conséquent, R4 est un routeur de cadre de zone (ABR) annonçant le réseau 10.0.1.0/24 car l'artère de l'inter-zone (IA) à R1 et à R2. R1 et R2 redistribuent ces informations dans OSPF 2. Les commandes de configuration de redistribuer sont mises en valeur dans les configurations ci-dessus de R1 et de R2. Par conséquent, R1 et R2 vont apprendre environ 10.0.1.0/24 comme IA par l'intermédiaire d'OSPF 1 et en tant que type-2 externe (E2) par l'intermédiaire d'OSPF 2 parce que les annonces externes d'état de lien (LSAs) sont propagées dans tout le domaine OSPF 2.

Puisque des artères IA sont toujours préférées au-dessus de l'E1 ou des artères E2, l'attente est de voir, dans la table de routage de R1 et de R2, que 10.0.1.0/24 est une artère IA avec le prochain-saut R4. Cependant, en visualisant leurs tables de routage, quelque chose différente est vue - sur R1, 10.0.1.0/24 est une artère IA avec le prochain-saut R4 mais sur R2, 10.0.1.0/24 est une artère E2 avec le prochain-saut R1.

C'est la sortie de commande de la commande de show ip route pour R1.

r1#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.
 
 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O E2    10.255.255.2/32 [110/1] via 192.168.0.2, 00:24:21, Ethernet1/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:23:49, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O IA    10.255.255.4/32 [110/11] via 10.0.0.4, 00:23:49, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:09, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:26:09, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:09, Ethernet1/0 

C'est la sortie de commande de la commande de show ip route pour R2.

r2#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O E2    10.0.1.0/24 [110/20] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.1/32 [110/1] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.4/32 [110/11] via 192.168.0.1, 00:25:34, Ethernet1/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:45, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:26:45, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:45, Ethernet1/0 

Pourquoi ce problème se pose-t-il ?

En activant de plusieurs processus OSPF sur un routeur, du point de vue de logiciel, les processus sont indépendants. Le protocole OSPF, à l'intérieur d'un OSPF de processus, préfère toujours la route interne au-dessus de l'artère externe. Cependant, l'OSPF ne fait aucune sélection de routes OSPF entre les processus (par exemple, des mesures OSPF et les types d'artère ne sont pas pris en considération, en décidant l'artère dont le processus devrait être installé dans la table de routage).

Il n'y a aucune interaction entre différents processus OSPF, et le lien-briseur est la distance administrative. Ainsi, puisque les deux processus OSPF ont une distance administrative par défaut de 110, premier essayer de processus à installer que l'artère le transforme en table de routage. Par conséquent, la distance administrative pour des artères de différents processus OSPF doit être configurée, de sorte que des artères de certains processus OSPF soient préférées au-dessus des artères d'un autre processus par intention humaine, et pas comme question d'occasion.

Pour plus d'informations sur la distance administrative, référez-vous à ce qui est distance administrative. Pour plus d'informations sur la façon dont un routeur de Cisco sélectionne qui conduit pour placer dans la table de routage, référez-vous à la sélection de routes dans des Routeurs de Cisco.

Solutions

Solution 1

Puisque nous connaissons cela dans le cas ci-dessus, les Routeurs sélectionnent la meilleure route basée sur la distance administrative, la façon logique d'empêcher ce comportement doivent augmenter la distance administrative des artères externes dans OSPF 2. De cette façon, des artères apprises par l'intermédiaire d'OSPF 1 sera toujours préférée au-dessus des artères externes redistribuées d'OSPF 1 dans OSPF 2. Ceci est fait utilisant le <value> externe de distance ospf de commande de configuration de sous-titre-routeur suivant les indications des configurations ci-dessous.

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.1 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of external 
!--- routes to 115. 

!  
ip classless  
!  
end 

R2
hostname r2  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of 
!--- external routes to 115. 

!  
ip classless  
!  
end 

La table de routage en résultant quand changer la distance administrative des artères externes dans OSPF 2 est affiché ci-dessous.

C'est la sortie de commande de la commande de show ip route pour R1.

r1#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O       10.255.255.2/32 [110/11] via 10.0.0.2, 00:00:35, Ethernet0/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:00:35, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:00:35, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:00:35, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:00:35, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:00:35, Ethernet1/0 

C'est la sortie de commande de la commande de show ip route pour R2.

r2#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O       10.255.255.1/32 [110/11] via 10.0.0.1, 00:01:28, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:01:28, Ethernet0/0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:01:28, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:01:28, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:01:28, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:01:28, Ethernet1/0 

Il est important de noter le ce dans certains cas, quand il y a également de redistribution d'OSPF 2 dans OSPF 1 et il y a d'autres protocoles de routage étant redistribués dans OSPF 2 (Protocole d'Information de Routage [RIP], statique de Protocole EIGPR (Enhanced Interior Gateway Routing Protocol), et ainsi de suite), ceci peut mener au routage subobtimal dans OSPF 2 pour ces artères externes.

Solution 2

Si la raison finale de mettre en application deux processus différents OSPF est de filtrer certaines artères, il y a une nouvelle caractéristique dans le Fonction OSPF ABR type 3 LSA filtering appelé par version de logiciel 12.2(4)T de Cisco IOSÝ qui te permet pour faire l'artère filtrant dans l'ABR.

Au lieu de configurer un deuxième processus OSPF, les liens qui font partie d'OSPF 2, dans l'exemple ci-dessus, pourraient être configurés en tant qu'autre zone à l'intérieur d'OSPF 1. Puis, vous pouvez implémenter l'artère priée filtrant dans R1 et R2 avec cette nouvelle configuration. Pour plus d'informations sur cette caractéristique, référez-vous au Fonction OSPF ABR type 3 LSA filtering.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 28025