IP : Routage IP

Spécification de l'adresse IP du relais suivant pour les routages statiques

30 juillet 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (30 octobre 2006) | Commentaires


Contenu


Introduction

Ce document introduit des concepts de base à propos des routes statiques. Ce document utilise un scénario de problème pour expliquer les circonstances dans lesquelles il est souhaitable de spécifier l'interface par laquelle l'adresse IP de saut suivant est accessible lorsque vous configurez une route statique.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Théorie générale

La capacité de configurer une artère statique a été introduite dans la version de logiciel 10.0 de Cisco IOS®. Les routes statiques sont utilisées pour un grand nombre de raisons et sont souvent utilisées lorsqu'il n'existe aucune route dynamique vers la destination, ou lorsque vous ne pouvez pas exécuter un protocole de routage dynamique.

Par défaut, les routes statiques ont une distance administrative égale à un, qui leur donne la priorité sur les routes des protocoles de routage dynamique. Lorsque vous augmentez la distance administrative à une valeur supérieure à celle d'un protocole de routage dynamique, la route statique peut être un filet de sécurité en cas d'échec du routage dynamique. Par exemple, les routes dérivées du protocole IGP (Interior Gateway Routing Protocol) ont une distance administrative par défaut de 100. Afin de configurer une route statique qui est remplacée par une route IGRP, spécifiez une distance administrative supérieure à 100 pour la route statique.

Ce genre de route statique est qualifiée de « flottante ». Elle est installée dans la table de routage seulement quand la route préférée disparaît. Par exemple, ip route 172.31.10.0 255.255.255.0 10.10.10.2 101.

Remarque: Une distance administrative de 255 est considérée comme inaccessible et les routes statiques avec une distance administrative de 255 ne sont jamais entrées dans la table de routage.

Si vous indiquez une route statique à une interface de diffusion, la route est insérée dans la table de routage seulement quand l'interface de diffusion est active. Cette configuration n'est pas recommandée car lorsque le saut suivant d'une route statique indique une interface, le routeur considère chacun des hôtes à portée de la route comme étant directement connecté par cette interface. Par exemple, ip route 0.0.0.0 0.0.0.0 Ethernet0.

Avec ce type de configuration, un routeur exécute le Protocole de résolution d'adresse (ARP) sur Ethernet pour chaque destination que le routeur trouve via la route par défaut car le routeur considère toutes ces destinations comme étant directement connectées à Ethernet 0.

Ce genre de route par défaut, particulièrement s'il est utilisé par de nombreux paquets pour nombre de différents sous-réseaux de destination, peut entraîner un taux d'utilisation du processeur élevé et un cache ARP très grand (avec les défaillances d'allocation mémoire propres).

La spécification d'un saut suivant numérique sur une interface directement connectée empêche le routeur d'exécuter le protocole ARP ou chaque adresse de destination. Cependant, si l'interface avec le saut suivant se désactive et que le saut suivant numérique est accessible par une route récursive, vous devriez spécifier l'adresse IP du saut suivant et l'interface via lesquelles le saut suivant est accessible. Par exemple, ip route 0.0.0.0 0.0.0.0 Serial 3/3 192.168.20.1.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Problème

Dans ce schéma de réseau, deux routes statiques ont la même destination (172.31.10.0/24). L'une des routes est une route statique flottante, qui est le chemin redondant ou « de secours » au réseau de destination sur le réseau LAN. Le problème dans le scénario est que la route statique flottante n'est jamais installée dans la table de routage quand la liaison principale est désactivée.

R1 a une route par défaut qui pointe vers le routeur du fournisseur de services Internet (ISP) pour accéder à Internet. R1 a deux liaisons à R2. Le T1 est la liaison principale et 56 K est la liaison de secours. R1 a une route statique pour 172.31.10.0/24 qui indique l'adresse IP R2 Serial 0 (10.10.10.2) comme saut suivant. R1 a également une route statique flottante pour 172.131.10.0/24 qui indique l'adresse IP R2 Serial 1 (192.168.20.2), la distance administrative pour la route statique flottante est 250. L'idée est que les paquets passent sur la ligne 56 K dans les deux directions uniquement si la liaison principale échoue.

/image/gif/paws/27082/ip_static_routes_01.gif

Cet exemple montre la configuration R1 :

R1
hostname R1

!
ip subnet-zero
no ip domain-lookup
!
controller E1 2/0
!
controller E1 2/1
!
interface Serial3/0
 description ISP Link
 ip address 192.168.10.1 255.255.255.252
 clockrate 64000
!
interface Serial3/1
 no ip address
 shutdown
!
interface Serial3/2
 description Primary Link to R2
 ip address 10.10.10.1 255.255.255.252
!
interface Serial3/3
 description Backup Link to R2
 ip address  192.168.20.1 255.255.255.252
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0

!---This is the default route to ISP router.

ip route 172.31.10.0 255.255.255.0 10.10.10.2

!---This is the preferred route to the LAN.

ip route 172.31.10.0 255.255.255.0 192.168.20.2 250

!---This is the floating route to the LAN.

Cet exemple montre la table de routage R1 :

Table de routage R1
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

!--- The preferred static route to the LAN through the T1.

S*   0.0.0.0/0 is directly connected, Serial3/0

!--- The static default route to the Internet.

Cet exemple montre la configuration R2 :

R2
hostname R2
!
enable password ww
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Local LAN
 ip address 172.31.10.2 255.255.255.0
!
interface Serial0
 description Primary Link to R1
 ip address 10.10.10.2 255.255.255.252
 clockrate 56000
!
interface Serial1
 description Backup Link to R1
 ip address 192.168.20.2 255.255.255.252
!
interface TokenRing0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1

!--- This is the primary default route.

ip route 0.0.0.0 0.0.0.0 192.168.20.1 250

!--- The floating default route to be used if the T1 fails.

no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

La route par défaut est installée pour R2 via 10.10.10.1 et quand vous utilisez la commande traceroute de R2 au routeur de l'ISP, les paquets utilisent la liaison T1. R2 peut envoyer des commandes ping à l'hôte Internet 192.168.30.1 originaire de 172.31.10.2. La route vers 192.168.30.1 passe par la route par défaut 0.0.0.0 0.0.0.0.

Table de routage R2
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0
S*   0.0.0.0/0 [1/0] via 10.10.10.1

!--- This is the primary default route.

R2#traceroute 192.168.10.2

Type escape sequence to abort.
Tracing the route to 192.168.10.2

  1 10.10.10.1 16 msec 20 msec 16 msec
  2 192.168.10.2 32 msec *  32 msec

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Si vous arrêtez Serial 3/2 sur R1 pour tester le basculement, vous devriez vous attendre à ce que R1 installe la route statique flottante sur le réseau LAN local 172.31.10.0 et que R2 installe la route statique flottante vers 0.0.0.0 via 192.168.20.1. Le trafic devrait passer sur la liaison 56K.

R1
R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s3/2
R1(config-if)#shut
R1(config-if)#end
2d21h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
2d21h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up&                   up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

!--- The static route through the T1 remains in the routing table.
!--- This is not what was expected to happen when Serial 3/2 was shut.

S*   0.0.0.0/0 is directly connected, Serial3/0

!--- The static default route to the Internet.

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.20.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
S*   0.0.0.0/0 [250/0] via 192.168.20.1

!--- It is no longer possible to ping the Internet host 192.168.20.1 if the ping 
!--- is sourced from the LAN on R2 because R1 tries to send the replies
!--- via the Serial 3/2, which is down.

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

La route statique flottante n'a pas été installée sur R1 et la route statique principale est toujours dans la table de routage de R1 bien que la liaison Serial 3/2 soit arrêtée. La raison pour laquelle cela se produit est que les routes statiques sont intrinsèquement récursives. Maintenez toujours la route statique dans la table de routage tant que vous disposez d'une route au saut suivant. Dans ce cas, R1 pense qu'il peut accéder à 10.10.10.2 par 192.168.10.2 parce que 192.168.10.2 est le saut suivant pour 0.0.0.0 0.0.0.0.

La route vers le saut suivant peut être une route plus spécifique, moins spécifique ou par défaut. Dans ce scénario de problème, vous pouvez penser que puisque la liaison est désactivée, vous ne devriez pas avoir de route vers 10.10.10.2, mais si vous observez la table de routage sur R1, vous voyez qu'elle contient une route statique par défaut qui pointe vers le routeur de l'ISP. R1 croit donc qu'il peut accéder au saut suivant (10.10.10.2) pour 172.31.10.0/24 via cette route par défaut, et la route statique vers 172.31.10.0/24 par 10.10.10.2 est conservée dans la table de routage et la route statique flottante n'est jamais installée.

Les routes statiques peuvent être configurées d'une meilleure façon afin d'éviter ce problème. Si vous spécifiez l'interface par laquelle le saut suivant est accessible, vous installez la route statique flottante uniquement si l'adresse IP du saut suivant est accessible via l'interface spécifiée. Avant que la solution à ce problème soit présentée, vous devez réactiver l'interface Serial 3/2 sur R1.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#no shut
R1(config-if)#end
R1#
2d22h: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
2d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
2d22h: %SYS-5-CONFIG_I: Configured from console by console


R1#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0&             192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Solution

La solution consiste à supprimer les anciennes routes statiques vers le réseau LAN (172.31.10.0) et à configurer de nouvelles routes statiques en spécifiant l'interface par laquelle le saut suivant est accessible. La route statique flottante est ainsi installée sur R1 lorsque l'interface Serial 3/2 est arrêtée.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#no ip route 172.31.10.0 255.255.255.0 10.10.10.2
R1(config)#no ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/2 10.10.10.2
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/3 192.168.20.2 250
R1(config)#end
R1#
2d22h: %SYS-5-CONFIG_I: Configured from console by console

La route statique vers 172.31.10.0 par 10.10.10.2 est installée dans la table de routage de R1 si 10.10.10.2 est accessible via Serial 3/2. Si cette condition n'est pas satisfaite, la route statique via 10.10.10.2 est supprimée de la table de routage et la route statique flottante à 172.31.10.0 via Serial 3/3 avec le saut suivant 192.168.20.2 est installée.

Pour tester cette configuration et désactiver la liaison T1, arrêtez Serial 3/2 et observez si la route statique flottante est installée dans la table de routage.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#shut
R1(config-if)#end
R1#
3d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
3d00h: %SYS-5-CONFIG_I: Configured from console by console
3d00h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [250/0] via 192.168.20.2, Serial3/3
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

À présent, R1 peut envoyer une commande ping à l'hôte Internet 192.168.20.1 avec des paquets originaires du réseau LAN.

R2
R2#ping
Protocol [ip]:
Target IP address: 192.168.20.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

La route statique flottante est installée comme prévue.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 27082