IP : Technologie Cisco Express Forwarding (CEF)

Dépannage des boucles de routage Cisco Express Forwarding

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document aide à dépanner des boucles de routage de Technologie Cisco Express Forwarding (CEF) et le routage suboptimal provoqués par une contiguïté cachée valide de Cisco Express Forwarding qui précise l'interface incorrecte. Une contiguïté avec une interface incorrecte est créée pour ces raisons :

Conditions préalables

Conditions requises

Employez ces ressources afin de comprendre mieux certains des concepts des utilisations de ce document :

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Diagramme du réseau

Le routeur R1 se connecte à R3 par l'intermédiaire de l'interface série 8/0, et le routeur R2 se connecte à R4 par l'intermédiaire de l'interface série 8/0. R1 et R2 sont connectés par l'intermédiaire des Ethernets 0/0, car cette figure affiche.

/image/gif/paws/26083/trouble_cef_01.gif

  • R2 reçoit des mises à jour de préfixe d'External Border Gateway Protocol (eBGP) pour 10.10.34.0/24 de R4. R2 propage ce préfixe à R1 par l'intermédiaire de BGP interne (iBGP).

  • R2 a une route statique par défaut (0.0.0.0/0) ces points à l'adresse IP 10.10.24.4 de l'interface série 8/0 R4.

  • R2 a également une route flottante par défaut de copie de sauvegarde (artère IP 0.0.0.0 0.0.0.0 Ethernet0/0 10) ces points pour relier Ethernets 0/0 pour conduire des paquets si la connexion série entre R2 et R4 échoue.

  • R1 a un default route ces points à l'interface série 8/0 R3 avec l'adresse IP 10.10.13.3.

Problème

Le trafic IP destiné pour 10.10.34.0/24 obtient fait une boucle entre R1 et R2. Observez la commande traceroute sortie sur R1.

R1#traceroute 10.10.34.4 
 
Type escape sequence to abort. 
Tracing the route to 10.10.34.4 
 
  1 192.168.12.2 20 msec 20 msec 20 msec 
  2 192.168.12.1 8 msec 12 msec 8 msec 
  3 192.168.12.2 8 msec 8 msec 12 msec 
  4 192.168.12.1 12 msec ...

Notez que le trafic destiné pour 10.10.34.4 saute à cloche-pied entre les Ethernets 0/0 (adresse IP 192.168.12.1) R1 et les Ethernets 0/0 (adresse IP 192.168.12.2) R2. Dans le meilleur des cas, le trafic de R1 destiné pour que les 10.10.34.0/24 besoins aillent à R2 en raison de l'iBGP a appris le préfixe 10.10.34.0/24. Puis, de R2, le trafic devrait conduire à R4. Cependant, la sortie de commande traceroute confirme une boucle de routage entre R1 et R2.

R1
hostname R1 
! 
ip subnet-zero 
! 
ip cef 
! 
interface Ethernet0/0 
 ip address 192.168.12.1 255.255.255.0 
! 
interface Serial8/0 
 ip address 10.10.13.1 255.255.255.0 
! 
router bgp 11 
 no synchronization 
 bgp log-neighbor-changes 
 neighbor 10.10.13.3 remote-as 12
 neighbor 192.168.12.2 remote-as 11 
 no auto-summary 
!  
ip route 0.0.0.0 0.0.0.0 10.10.13.3

R2
hostname  R2 
! 
ip cef 
! 
interface Ethernet0/0 
  ip address 192.168.12.2 255.255.255.0 
! 
interface Serial8/0 
 ip address 10.10.24.2 255.255.255.0 
! 
router bgp 11 
 no synchronization 
bgp log-neighbor-changes 
 network 192.168.12.0 
 neighbor 10.10.24.4 remote-as 10 
 neighbor 192.168.12.1 remote-as 11 
 neighbor 192.168.12.1 next-hop-self 
 no auto-summary 
! 
ip route 0.0.0.0 0.0.0.0 10.10.24.4 
ip route 0.0.0.0 0.0.0.0 Ethernet0/0 10 
!

Dépannez

Puisque les paquets destinés pour 10.10.34.4 obtiennent fait une boucle entre R1 et R2, commencez à dépanner. Vérifiez d'abord le Routage IP sur R1. La sortie de commande de 10.10.34.0 de show ip route confirme le prochain saut de 192.168.12.2 pour des paquets destinés à 10.10.34.0/24. Ceci s'assortit avec la commande traceroute sautent à cloche-pied d'abord, où des paquets sont envoyés au prochain saut 192.168.12.2, qui confirme que des paquets sont commutés correctement sur R1.

R1#show ip route 10.10.34.0 
Routing entry for 10.10.34.0/24
  Known via "bgp 11", distance 200, metric 0
  Tag 10, type internal
  Last update from 192.168.12.2 00:22:59 ago
  Routing Descriptor Blocks:
  * 192.168.12.2, from 192.168.12.2, 00:22:59 ago
      Route metric is 0, traffic share count is 1
      AS Hops 1

L'étape suivante est de vérifier la table de Routage IP de R2. Pendant que cette sortie de commande de 10.10.34.0 de show ip route affiche, des paquets destinés à 10.10.34.0 devraient être conduits au prochain saut 10.10.24.4 sur l'interface série 8/0. Cependant, la commande traceroute affiche des paquets commutés de nouveau à R1 à l'adresse IP 192.168.12.1. Les recherches plus approfondies sont nécessaires dans pourquoi les paquets destinés à 10.10.34.0 sont R2 en fonction au prochain saut 192.168.12.1 (comme dans la sortie de la commande traceroute) au lieu de à 10.10.24.4.

R2#show ip route 10.10.34.0
Routing entry for 10.10.34.0/24
  Known via "bgp 11", distance 20, metric 0
  Tag 10, type external
  Last update from 10.10.24.4 00:42:32 ago
  Routing Descriptor Blocks:
  * 10.10.24.4, from 10.10.24.4, 00:42:32 ago
      Route metric is 0, traffic share count is 1
      AS Hops 1

En ce moment il est important de comprendre que dans un réseau Expédition-commuté exprès de Cisco, une décision de transfert de paquets se compose :

  • Une consultation de table de routage pour la correspondance de préfixe la plus longue.

  • Une consultation de Forwarding Information Base (FIB).

Puisque la table de routage est vérifiée, regardez le FIB de Cisco Express Forwarding. Dans les résultats de la commande de détail de 10.10.34.4 de show ip cef, notez cet Ethernet 0/0 de 10.10.34.4 de Commutateurs de Cisco Express Forwarding au lieu de la prochaine interface série 8/0 de 10.10.24.4 de saut (suivant les indications de la sortie de commande de 10.10.34.0 de show ip route). Cette anomalie crée des boucles dans le réseau.

R2#show ip cef 10.10.34.4 detail
10.10.34.4/32, version 19, cached adjacency 10.10.34.4
0 packets, 0 bytes
  via 10.10.34.4, Ethernet0/0, 0 dependencies
    next hop 10.10.34.4, Ethernet0/0
    valid cached adjacency

L'étape suivante est de regarder la table de juxtaposition de Cisco Express Forwarding et de voir comment Cisco Express Forwarding apprend commuter les Ethernets 0/0 de paquets. Notez que la contiguïté est établie en raison de l'ARP.

R2#show adjacency ethernet 0/0 detail | begin  10.10.34.4 
IP       Ethernet0/0               10.10.34.4(5)
                                   50 packets, 2100 bytes
                                   AABBCC006500AABBCC0066000800
                                   ARP        03:02:00

Cette sortie de commande de show ip arp est confirmation.

R2#show ip arp 10.10.34.4
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.10.34.4             60   aabb.cc00.6500  ARPA   Ethernet0/0

Ensuite, découvrez pourquoi cette entrée d'ARP a été créée quand il y a une artère IP dans la table de routage. Regardez la table de routage de nouveau.

R2#show run | include ip route 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.10.24.4
ip route 0.0.0.0 0.0.0.0 Ethernet0/0 10

Si la connexion série échoue entre R2 et R4, tout le trafic est conduit avec l'utilisation d'un Ethernet 0/0 de Route statique flottante parce que R2 a une Route statique flottante qui indique les Ethernets à plusieurs accès 0/0 d'interface, et pas à l'adresse IP 192.168.12.1 d'Ethernets de R1. Par conséquent, pour toutes les destinations inconnues, le routeur R2 envoie une demande d'ARP par l'interface Ethernet0/0. Dans ce cas, R2 a perdu plus d'artère spécifique au réseau de 10.10.34.0. Par conséquent, quand le paquet de données arrive pour les hôtes sur ce réseau, il génère une demande d'ARP par l'intermédiaire de l'interface Ethernet. Puisque le proxy ARP est activé par défaut sur l'interface Ethernet R1 et il a un default route qui indique R3, il répond de retour avec une réponse de proxy ARP avec sa propre adresse MAC. Par conséquent, R2 envoie tout le trafic à R1, et R1 en avant tout le trafic avec l'utilisation de son default route (0.0.0.0/0) à EN TANT QUE 12, et par conséquent à 10.10.34.4 par l'intermédiaire de l'Internet.

Quand R2 reçoit la réponse de proxy ARP de R1, il crée une contiguïté valide de /32 Cisco Express Forwarding qui précise les Ethernets 0/0 d'interface. Cette entrée de Cisco Express Forwarding ne vieillit pas jusqu'à ce que le routeur R1 de proxy ARP soit présent sur le segment d'Ethernets. Ainsi, l'entrée de /32 Cisco Express Forwarding continue à être utilisée au l'Expédition-commutateur exprès de Cisco les paquets, même après la connexion série entre R2 et R4 est sauvegardent et le default route de table de routage précise l'interface série 8/0 vers EN TANT QUE 10. Le résultat est une boucle de routage.

En conclusion, regardez les logs et voyez si la liaison série (s8/0) s'agitait. Ceci cause une Route statique flottante d'être installée dans la table de routage qui mène alors au proxy ARP et aux résultats à l'installation d'une entrée de Cisco Express Forwarding de 10.10.34.4/32 dans le FIB de Cisco Express Forwarding.

R2#show log | beg Ethernet0/0
[..]
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0, changed state to down
%BGP-5-ADJCHANGE: neighbor 10.10.24.4 Down Interface flap
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0, changed state to up
%BGP-5-ADJCHANGE: neighbor 10.10.24.4 Up

Les logs confirment la cause. En résumé, ces étapes affichent la séquence d'opérations :

  1. L'interface série 8/0 sur R2 descend.

  2. R2 a un paquet destiné à 10.10.34.4.

  3. R2 suit le default route de sauvegarde indiqué directement les Ethernets 0/0.

  4. R2 envoie une demande d'ARP de 10.10.34.4.

  5. R1 (proxy) répond à la demande d'ARP avec sa propre adresse MAC à R2.

  6. R2 a maintenant une entrée d'ARP pour 10.10.34.4 avec l'adresse MAC de R1.

  7. R2 crée une contiguïté de Cisco Express Forwarding pour 10.10.34.4, et une entrée 10.10.34.4/32 est installée dans la table de Cisco Express Forwarding (FIB) pour cette destination par l'intermédiaire des Ethernets 0/0. Cette entrée de Cisco Express Forwarding est mise à jour pour tant que l'entrée d'ARP est valide ou jusqu'à ce que R1 est présent sur le segment d'Ethernets.

  8. L'interface série 8/0 sur R2 est soulevée.

  9. R2 apprend l'artère 10.10.34.0/24 d'eBGP de R4 avec le prochain saut 10.10.24.4 et installe l'artère dans la table de Routage IP.

  10. R1 apprend le préfixe 10.10.34.0/24 par l'intermédiaire de l'iBGP de R2 et l'installe dans la table de Routage IP.

  11. R1 a un paquet destiné pour 10.10.34.4.

  12. R1 regarde dans sa table de routage, artères de préfixe d'iBGP de correspondances à R2, et artères à R2.

  13. R2 reçoit un paquet destiné pour 10.10.34.4. Puisqu'il a déjà une entrée de Cisco Express Forwarding pour 10.10.34.4/32 qui indique les Ethernets 0/0 dans sa table FIB avec l'adresse MAC de R1, elle envoie le paquet de nouveau à R1 sans regarder la table de routage. Ceci crée une boucle.

Solution

Remplacez la Route statique flottante ces points directement aux Ethernets 0/0 par un ces points à une adresse du prochain saut.

R2(config)#no ip route 0.0.0.0 0.0.0.0 ethernet 0/0 10
R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.12.1 10

Quand vous avez une artère statique qui indique la prochaine adresse IP de saut au lieu d'un Ethernet à plusieurs accès 0/0 d'interface, il arrête R2 d'envoyer des demandes d'ARP de toutes les destinations. Les paquets sont conduits et commutés basé sur le prochain saut 192.168.12.1. Par conséquent, toutes les entrées de Cisco Express Forwarding d'ARP et boucles sont évitées.

Observez l'entrée de Cisco Express Forwarding sur R2 ces points à l'interface série 8/0 d'interface appropriée.

R2#show ip cef 10.10.34.4
10.10.34.0/24, version 32, cached adjacency to Serial8/0
0 packets, 0 bytes
  via 10.10.24.4, 0 dependencies, recursive
    next hop 10.10.24.4, Serial8/0 via 10.10.24.0/24
    valid cached adjacency

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 26083