Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : DSL haut débit symétrique (G.SHDSL)

Configuration CPE dos à dos via les ports G.SHDSL

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour la configuration de deux Routeurs dos à dos par les ports ultra-rapides symétriques de la ligne d'abonné numérique de mutivitesse (G.SHDSL). Il décrit comment un routeur G.SHDSL CiscoÝ peut être configuré pour fonctionner le périphérique du bureau central d'asÝa (Co) DSL qui termine une connexion d'un autre périphérique CPE du distant G.SHDSL.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Matériel de 828 sites du client (CPE) exécutant la version de logiciel 12.2(8)T1 de Cisco IOSÝ

  • 2612 Logiciel Cisco IOS version 2.2(8)T courants de routeur

  • routeur 2612 utilisant une carte d'interface WAN (WIC)-1SHDSL

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/25900/dsl_cpe_config1.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Dans cette configuration le 828A est configuré avec le type d'équipement « Co, » qui simule la signalisation de la Cie. Tandis que les 2612 avec le G.SHDSL WIC est configurés avec le type d'équipement « CPE. »

CPE DSL5-828A(Cisco 828 agissant en tant que Co)
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A (routeur de Cisco 2612 agissant en tant que CPE)
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Référence des commandes

Cette section documente des commandes modifiées. Toutes autres commandes utilisées avec cette configuration sont documentées dans les publications de référence de commandes de Logiciel Cisco IOS version 12.2.

Commandes modifiées

  • dsl equipment-type

  • dsl linerate

  • dsl operating-mode (g.shdsl)

dsl equipment-type

Émettez la commande de dsl equipment-type en mode d'interface ATM de configurer l'interface ATM DSL pour fonctionner comme matériel Co ou CPE. Utilisez le forme no de cette commande de restaurer le type d'équipement par défaut.

  • dsl equipment-type {Co | cpe}

  • aucun dsl equipment-type

Les descriptions de syntaxe pour ces commandes sont :

  • Co — Configure l'interface ATM DSL pour fonctionner comme matériel Co.

  • cpe — Configure l'interface ATM DSL pour fonctionner comme CPE.

Par défaut

Les fonctions d'interface ATM DSL comme CPE.

Mode de commande d'interface

L'interface ATM pour le G.SHDSL WIC a été intégrée dans ces versions logicielles de Cisco IOS :

  • 12.2(4)XL — sur les Routeurs de gamme Cisco 2600

  • 12.2(8)T — sur les Routeurs de gamme Cisco 2600 et de gamme Cisco 3600

Directives d'utilisation

Cette commande de configuration s'applique à une interface ATM spécifique. Vous devez spécifier l'interface ATM avant que vous émettiez cette commande. L'interface ATM doit également être dans l'état d'arrêt avant que vous émettiez cette commande. Cet exemple affiche comment configurer l'interface ATM 1/1 DSL pour fonctionner comme matériel Co.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

Commandes associées

  • dsl linerate — Spécifie une ligne débit pour l'interface ATM DSL.

  • dsl operating-mode (g.shdsl) — Spécifie un mode de fonctionnement de l'interface ATM DSL.

dsl linerate

Émettez la commande de dsl linerate en mode d'interface ATM de spécifier une ligne débit pour l'interface ATM DSL. Utilisez le forme no de cette commande de restaurer la ligne par défaut débit.

  • dsl linerate {Kbps | automatique}

  • aucun dsl linerate

Les descriptions de syntaxe pour ces commandes sont :

  • Kbps — Spécifie une ligne débit dans les kilobits par seconde pour l'interface ATM DSL. Les entrées permises sont 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, et 2312.

  • automatique — Configure l'interface ATM DSL pour s'exercer automatiquement pour une ligne optimale débit en étant en pourparlers avec le multiplicateur d'accès DSL d'éloigné (DSLAM) ou le WIC.

Par défaut

L'interface ATM DSL synchronise automatiquement sa ligne débit avec l'éloigné DSLAM ou WIC.

Mode de commande d'interface

L'interface ATM pour le G.SHDSL WIC a été intégrée dans ces versions logicielles de Cisco IOS :

  • 12.2(4)XL — sur les Routeurs de gamme Cisco 2600

  • 12.2(8)T — sur les Routeurs de gamme Cisco 2600 et de gamme Cisco 3600

Directives d'utilisation

Cette commande de configuration s'applique à une interface ATM spécifique. Vous devez spécifier l'interface ATM avant que vous émettiez cette commande. L'interface ATM doit également être dans l'état d'arrêt avant que vous émettiez cette commande. Cet exemple affiche comment configurer l'interface ATM 0/1 DSL pour fonctionner à une fréquence de ligne de 1040 Kbps :

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

Commandes associées

  • dsl equipment-type — Configure l'interface ATM DSL pour fonctionner comme matériel Co ou CPE.

  • dsl operating-mode (g.shdsl) — Spécifie un mode de fonctionnement de l'interface ATM DSL. Utilisez le noform de cette commande de restaurer le mode de fonctionnement par défaut.

dsl operating-mode (g.shdsl)

Émettez la commande d'interface ATM de dsl operating-mode de spécifier un mode de fonctionnement du DSL pour une interface ATM. Utilisez le forme no de cette commande de restaurer le mode de fonctionnement par défaut.

  • annexe symétrique de dsl operating-mode gshdsl {A | B}

  • aucun dsl operating-mode

Les descriptions de syntaxe pour ces commandes sont :

  • gshdsl — Configure l'interface ATM DSL pour fonctionner en mode ultra-rapide de mutivitesse par ITU G.991.2.

  • symétrique — Configure l'interface ATM DSL pour fonctionner en mode symétrique par ITU G.991.2.

  • annexe {A | B} — spécifie les paramètres d'emploi régionaux. Écrivez A pour l'Amérique du Nord et B pour l'Europe. Le par défaut est R.

Par défaut

Le mode de fonctionnement par défaut est annexe A symétrique G.SHDSL.

Mode de commande d'interface

L'interface ATM pour le G.SHDSL WIC a été introduite dans la version du logiciel Cisco IOS 12.1(3)X, et intégrée dans ce Cisco IOS des versions logicielles.

  • 12.2(2)T — sur les Routeurs de gamme Cisco 1700

  • 12.2(4)XL — sur les Routeurs de gamme Cisco 2600

  • 12.2(8)T — sur les Routeurs de gamme Cisco 2600 et de gamme Cisco 3600

Directives d'utilisation

Cette commande de configuration s'applique à une interface ATM spécifique. Vous devez spécifier l'interface ATM avant que vous émettiez cette commande. L'interface ATM doit également être dans l'état d'arrêt avant que vous sélectionniez cette commande. Cet exemple affiche comment configurer l'interface ATM 0/0 DSL pour fonctionner en mode G.SHDSL.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

Commandes associées

  • dsl equipment-type — Configure l'interface ATM DSL pour fonctionner comme matériel Co ou CPE.

  • dsl linerate — Spécifie une ligne débit pour l'interface ATM DSL.

Vérifiez

Vous devriez voir cette sortie allant à travers la session de console. Émettez la commande de lundi de terme, si vous êtes Telnetted dans les Routeurs, de visualiser les messages console.

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • show running-config — Vérifie la configuration en cours, et visualise l'état pour tous les contrôleurs.

  • emplacement/port de show controllers atm — Statistiques de contrôleur atmosphère de vues.

  • show atm vc — Vérifie l'état du circuit virtuel permanent (PVC).

  • show dsl interface atm — Visualise l'état du modem G.SHDSL

  • interface atm d'exposition — Visualise le statut de l'interface ATM.

C'est exemple de sortie de la commande de show atm vc. Assurez-vous que le PVCs actif sont.

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

C'est exemple de sortie de la commande de show dsl interface atm. Si la ligne est en baisse, la ligne n'est pas en activité. Certaines des valeurs peuvent ne pas être précises. la déclaration apparaît. Vous pouvez également vérifier si la configuration de type d'équipement et de mode de fonctionnement sont correcte pour votre application.

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

Si vous ne pouvez pas cingler à travers le circuit atmosphère, vérifiez que l'interface ATM est UP/UP en émettant la commande d'interface d'exposition pour l'interface ATM sur les deux Routeurs. Émettez la commande d'interface atm d'exposition de visualiser le statut de l'interface ATM. Assurez-vous que l'emplacement atmosphère, port, et la ligne protocole sont, comme indiqué dans cet exemple.

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

Dépannage

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • debug atm events — Identifie des événements associés atmosphère pendant qu'ils sont générés.

  • mettez au point les erreurs atmosphère — Indique quelles interfaces ont le problème.

C'est échantillon mettent au point les informations d'une interface ATM, s'exécuter met au point énuméré cette section, et en étant livré en ligne (maintenez dans l'esprit qu'il pourrait falloir à 30 secondes ou à plus pour que le circuit soit soulevé).

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 25900