IP : Protocole OSPF (Open Shortest Path First)

Conséquences de l'adresse de transfert sur la sélection de chemins LSA Type 5

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document vise à montrer le processus de sélection d'un chemin du protocole Open Shortest Path First (OSPF) lorsqu'un routeur reçoit deux annonces d'état de lien (LSA) de type 5 pour un réseau externe donné. Dans cet exemple, l'adresse de transfert d'un LSA est réglée à zéro (0.0.0.0) et l'adresse de transfert de l'autre LSA est différente de zéro.

Conditions préalables

Conditions requises

Les lecteurs de ce document doivent avoir une bonne connaissance de ce qui suit :

  • Routage IP général

  • Concepts et termes de protocole de routage OSPF

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Routeur Cisco 2503

  • Exécution de version de logiciel 12.2(24a) de½ du¿Â du Cisco IOSï sur tous les Routeurs

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Comment les adresses de transfert LSA du type 5 peuvent affecter la sélection de chemin

Adresses de transfert non réglées pour des les deux LSAs

La topologie représentée ci-dessous est utilisée pour expliquer comment l'adresse de transfert dans un LSA du type 5 OSPF peut affecter la sélection de chemin du LSA du type 5.

/image/gif/paws/25493/type5_lsa_01.gif

Dans le diagramme ci-dessus, tous les Routeurs, autre que le routeur 8, exécutent l'OSPF dans la zone 0. pour ce document, les configurations de routeur 3 et le routeur 4 soient les plus importants parce qu'ils sont le routeur de borne d'Autonomous System (ASBR) générant le type 5 LSAs. Comme affiché ci-dessous, Routeur3 et le routeur 4 ont une artère statique au réseau 200.200.200.0 255.255.255.0, qui est redistribué dans l'OSPF.

Routeur 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Routeur 4
interface Ethernet0
 ip address 172.16.3.4 255.255.255.0
!
interface Serial0
 ip address 172.16.7.4 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.7.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Remarque: Routeur3 et le routeur 4 n'incluez pas le réseau 172.16.3.0 255.255.255.0 dans le processus OSPF ; donc, le type 5 LSAs généré par les deux Routeurs ont les adresses de transfert réglées à 0.0.0.0

Dans cet exemple, le routeur 5 peut être utilisé pour visualiser le LSAs externe. Pour visualiser le LSAs externe, émettez la commande externe de show ip ospf database sur le routeur 5. La sortie de cette commande est affichée ci-dessous.

Routeur 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 1514
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000030
  Checksum: 0x93C0
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 1922
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000027
  Checksum: 0x83D4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

Ce que vous pouvez voir en haut est que les adresses de transfert pour le type 5 LSAs généré par chacun des deux Routeur3 et routeur 4 sont placées à 0.0.0.0. Dans ce cas, le LSA à installer dans la table de routage du routeur 5 est déterminé en comparant les mesures aux ASBR générant le LSAs. En émettant la commande de show ip ospf border-routers sur le routeur 5, vous pouvez voir les mesures que le routeur 5 prend pour les ASBR. La sortie de cette commande est affichée ci-dessous.

Routeur 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14
router-5#

Comme affiché ci-dessus, 64 est la mesure du routeur 5 pour atteindre ASBR 172.16.3.3, alors que la mesure pour atteindre ASBR 172.16.7.4 est 74 ; donc, le routeur 5 choisit le LSA généré par ASBR 172.16.3.3 pour placer dans sa table de routage (affichée ci-dessous).

Routeur 5
router-5# 
show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0
C       172.16.2.0 is directly connected, Serial0
router-5#

Adresse de transfert réglée pour un LSA mais pas pour l'autre

La même topologie comme ci-dessus est utilisé pour cette partie du document. La configuration du routeur 4 demeure également sans changement, mais la configuration pour Routeur3 a changé pour inclure le réseau 172.16.3.0 255.255.255.0 dans la zone 0 du processus OSPF. Routeur3 la configuration est affichée ci-dessous avec le changement mis en valeur de gras.

Routeur 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Le résultat de la modification de configuration ci-dessus est que le LSA du type 5 généré par fait Routeur3 maintenant placer l'adresse de transfert à l'adresse IP du routeur 8, suivant les indications de la base de données sortie pris du routeur 5 ci-dessous.

Routeur 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 270
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000033
  Checksum: 0x5138
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.16.3.8
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 258
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000029
  Checksum: 0x7FD6
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

Vous pouvez voir en haut que le LSA du type 5 généré par fait Routeur3 maintenant placer l'adresse de transfert à 172.16.3.8, alors que le LSA du type 5 généré par le routeur 4 a toujours une adresse de transfert de 0.0.0.0.

Dans ce cas, le LSA à installer dans la table de routage du routeur 5 est déterminé en comparant la mesure du routeur 5 à l'ASBR (le routeur 4) qui a généré le LSA avec une adresse de transfert de 0.0.0.0 à la mesure du routeur 5 pour atteindre l'adresse de transfert de 172.16.3.8, qui a été placée pour le LSA a généré par l'ASBR (routeur 3).

Pour voir les mesures aux ASBR, émettez la commande de cadre de show ip ospf dans le routeur 5. La sortie est affichée ci-dessous.

Routeur 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15
router-5#

Dans la sortie ci-dessus, la mesure au routeur 4 est 74. Ceci est comparé à la mesure du routeur 5 pour atteindre l'adresse de transfert de 172.16.3.8, qui peut être vue utilisant la commande de 172.16.3.8 de show ip route. La sortie de cette commande est ci-dessous.

Routeur 5
router-5# show ip route 172.16.3.8
Routing entry for 172.16.3.0/24
  Known via "ospf 7", distance 110, metric 79, type intra area
  Last update from 172.16.2.3 on Serial0, 00:30:49 ago
  Routing Descriptor Blocks:
  * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0
      Route metric is 79, traffic share count is 1

router-5#

Ainsi, la mesure pour atteindre le routeur 4 ASBR, qui a 74 ans, est comparée à la mesure pour atteindre l'adresse de transfert de 172.16.3.8 (généré par le routeur 3), qui est 79. Par conséquent, le LSA installé dans la table de routage est le LSA généré par le routeur 4, suivant les indications de la sortie du routeur 5 du show ip route ci-dessous.

Routeur 5
router-5# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0
C       172.16.2.0 is directly connected, Serial0
O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0
router-5#

Quand la mesure de l'artère redistribuée du multiple ASBR sont égal comme illustrée dans le document, l'adresse de transfert change le comportement de la sélection de chemin LSA du type 5. Quand un routeur reçoit deux le type 5 LSAs à la même destination avec les adresses de transfert réglées sur des les deux LSAs, le routeur fait une comparaison basée sur la mesure aux adresses de transfert. Le LSA avec une adresse de transfert qui offre la mesure plus petite est placé dans la table de routage.

Si la mesure des artères redistribuées sont différente, les Routeurs préfèrent l'artère avec la plus basse mesure et pas la plus basse mesure à l'adresse de transfert.


Informations connexes


Document ID: 25493