IP : Protocole BGP (Border Gateway Protocol)

Configuration de la fonction BGP Maximum-Prefix

15 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit la configuration et l'information de dépannage sur la caractéristique de maximum-prefix de Protocole BGP (Border Gateway Protocol).

La caractéristique de BGP Maximum-Prefix te permet pour contrôler combien de préfixes peuvent être reçus d'un voisin. Par défaut, cette caractéristique permet à un routeur pour réduire un pair quand le nombre de préfixes reçus de ce pair dépasse la limite configurée de maximum-prefix. Cette caractéristique est utilisée généralement pour des pairs de BGP externe, mais peut être appliquée aux pairs internes BGP également.

La caractéristique de maximum-prefix est utile quand, à une modification de la politique sortante au site scrutant distant, les débuts d'un routeur pour recevoir plus des artères que la mémoire de routeur peuvent prendre. Si ce même routeur scrute avec le BGP et exécute également le routage essentiel fonctionne dans un réseau, ce temps système pourrait s'avérer le mauvais. Un problème BGP a pu perturber la Connectivité de réseau interne. Avec la commande de neighbor maximum-prefix, il est possible de protéger un routeur contre cette situation.

Quand vous prévoyez d'utiliser cette caractéristique, considérez ces points clé :

  • Connaissez combien d'artères le routeur d'appairage BGP de distant envoie normalement.

  • Placez un supérieur à de seuil un peu le nombre de préfixes BGP prévus pour être reçu pendant les fonctionnement normal.

  • Sachez que l'action de rentrer la caisse le pair BGP de distant envoie plus de préfixes que ceux ont prévu. Les actions disponibles pourraient l'un ou l'autre être de réduire la session et de réduire les relations voisines BGP jusqu'à ce que vous utilisiez la commande du clear ip bgp x.x.x.x ou, alternativement, pour se connecter seulement un message d'avertissement.

Remarque: Une amélioration à cette caractéristique est introduite dans des versions de logiciel 12.0(22)S et 12.2(15)T de Ý de Cisco IOS. L'amélioration permet à l'utilisateur pour rétablir automatiquement une session scrutante qui a été réduite parce que la limite configurée de maximum-prefix est dépassée. Aucune intervention de l'opérateur réseau n'est exigée quand cette caractéristique est activée. Pour de plus amples informations, référez-vous à la session de reprise BGP après la limite de maximum-prefix.

Conditions préalables

Conditions requises

Cisco recommande des lecteurs de ce document ont la compréhension de base de ces informations :

Section d'implémentation BGP de guide de configuration IP de Cisco IOS, version 12.2

Section de configuration BGP de configurer le BGP

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

Routeurs de la gamme Cisco 2500 sur des versions de logiciel 12.2(27) de Cisco IOSÝ

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Accédez au navigateur de caractéristique de Cisco (clients enregistrés seulement) afin de déterminer quelles versions de logiciel de Cisco IOS vous pouvez utiliser avec cette configuration.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

La syntaxe de commande utilisée afin de configurer la caractéristique de BGP Maximum-Prefix est :

neighbor {ip-address | peer-group-name} maximum-prefix 
maximum [threshold] [restart restart-interval] [warning-only]

Où :

  • maximum — Représente le nombre maximal de préfixes permis du voisin.

  • seuil — Une valeur entière facultative qui spécifie à quelle valeur maximale de pourcentage est configurée. Les débuts de routeur pour générer un message d'avertissement. La plage est de 1 à 100 pour cent, et le par défaut est de 75 pour cent.

    Par exemple, si la valeur maximale configurée est 20 et le seuil 60, le routeur génère les messages d'avertissement quand le nombre de routes apprises BGP du voisin dépasse 60 pour cent de 20 (12) artères.

    reprise-intervalle — Un intervalle de temps facultatif (en quelques minutes) qu'une session scrutante est rétabli. La plage est de 1 à 65535 minutes.

    réservé à l'avertissement — (facultatif) permet au routeur pour générer un message de log quand la limite de maximum-prefix est dépassée, au lieu de terminer la session scrutante.

Afin d'illustrer mieux l'utilisation, considérez cet exemple :

neighbor 10.1.1.1 maximum-prefix 3000

!--- Drops the peering to 10.1.1.1 when 
!--- more than 3000 prefixes are received.


neighbor 10.1.1.1 maximum-prefix 3000 warning-only

!--- Logs a warning message when the peer sends 
!--- more than 3000 prefixes.


neighbor 10.1.1.1 maximum-prefix 3000 50

!--- Logs a warning message at 1500 and drops the 
!--- peering  when over 3000 prefixes are sent.


neighbor 10.1.1.1 maximum-prefix 3000 50 warning-only

!--- Initially warns at 1500 and re-warns 
!--- (different message) at 3000 prefixes received.
!---  However, the BGP Peer is not disconnected.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande IOS (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/25160/bgp-maximum-prefix-01.gif

Configurations

Ce document utilise les configurations suivantes :

Maximum-prefix configuré pour le message réservé à l'avertissement quand le seuil dépasse le positionnement de seuil

Dans la configuration réservée à l'avertissement de maximum-prefix, Router_B est configuré pour se connecter seulement un message d'avertissement quand le nombre de préfixes reçus de Router_A dépasse le positionnement de seuil. La configuration des deux Routeurs est suivant les indications de cette table. Notez la présence du mot clé réservé à l'avertissement configuré avec la commande neighbor.

Router_A Router_B
hostname Router_A
! 
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0 
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1
 ip unnumbered Loopback0 
! 
router bgp 200
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 192.168.1.2 local-as 100
 neighbor 10.0.0.2 remote-as 300
 neighbor 10.0.0.2 ebgp-multihop 2
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 version 4
 no auto-summary
!
ip route 10.0.0.2 255.255.255.252 Serial1
hostname Router_B 
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.252
!
interface Ethernet0 
 ip address 10.0.1.1 255.255.255.0 
!
interface Serial0
 ip unnumbered Loopback0
! 
router bgp 300
 no synchronization
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 200
 neighbor 10.0.0.1 ebgp-multihop 2
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 version 4
 neighbor 10.0.0.1 maximum-prefix 10 80 warning-only

!--- Enables warning message logging when the number 
!--- of BGP routes learned from neighbor 
!--- 10.0.0.1 exceeds eight. 

 no auto-summary
!
ip route 10.0.0.1 255.255.255.252 Serial0

L'exposition et mettent au point des sorties de commande dans le vérifier et dépannent la section de cet état de document ce qui se produit vraiment sur Router_B toutes les fois que le nombre de préfixes reçus de Router_A dépasse le positionnement de seuil.

Maximum-prefix configuré pour réduire des relations voisines quand le seuil dépasse le positionnement de seuil

Dans le maximum-prefix configuré pour réduire la configuration voisine de relations, Router_B est configuré pour générer les messages d'avertissement quand le nombre de préfixes reçus de Router_A dépasse le positionnement de seuil. Router_B est également configuré pour réduire le voisin BGP quand la limite maximum de préfixe est dépassée. La configuration des deux Routeurs est suivant les indications de la table. Notez l'absence du mot clé réservé à l'avertissement réglé avec la commande neighbor.

Router_A Router_B
hostname Router_A
! 
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0 
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1
 ip unnumbered Loopback0 
! 
router bgp 200
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 192.168.1.2 local-as 100
 neighbor 10.0.0.2 remote-as 300
 neighbor 10.0.0.2 ebgp-multihop 2
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 version 4
 no auto-summary
!
ip route 10.0.0.2 255.255.255.252 Serial1
hostname Router_B 
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.252
!
interface Ethernet0 
 ip address 10.0.1.1 255.255.255.0 
!
interface Serial0
 ip unnumbered Loopback0
! 
router bgp 300
 no synchronization
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 200
 neighbor 10.0.0.1 ebgp-multihop 2
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 version 4
 neighbor 10.0.0.1 maximum-prefix 10 80

!--- This forces the neighbor session to tear down  
!--- when the BGP learned routes from 
!--- the neighbor exceeds 10.

 no auto-summary
!
ip route 10.0.0.1 255.255.255.252 Serial0

L'exposition et mettent au point des sorties de commande dans le vérifier et dépannent l'état de section ce qui se produit vraiment sur Router_B toutes les fois que le nombre de préfixes qu'il reçoit de Router_A dépasse le positionnement de seuil.

Vérifiez et dépannez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

La syntaxe de commande et les par défaut de la caractéristique utilisée dans ce document sont disponibles à la page de commande BGP.

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Maximum-prefix réservé à l'avertissement

Attention de paiement à ces nombres :

  • Préfixes maximum convenus : 10

  • Seuil d'avertissement : 80 pour cent (huit)

Tant que le nombre de préfixes reçus n'obtient pas le supérieur au positionnement de seuil, huit, aucun messages sont enregistré. Dès que le nombre de routes BGP apprises du voisin 10.0.0.1 dépassera la limite de seuil de huit, Router_B se connecte ce message. Cette situation est simulée quand neuf préfixes sont envoyés :

%BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0) reaches 9, max 10

Si la situation obtient plus mauvais, et dépasse l'ensemble de nombre de maximum-prefix de 10, puis les journaux du routeur ce message. Cette situation est simulée quand 12 préfixes sont envoyés :

%BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1 (afi 0): 11 exceed limit 10 

Quand vous lancez le debug ip bgp updates dedans, vous pouvez obtenir un oeil plus attentif à ce qui se produit. Cependant, n'utilisez pas cette commande dans un environnement vivant avec des plusieurs milliers de préfixes. La situation représentée est que Router_B a déjà scruter établi. Six préfixes ont été annoncés au routeur B par Router_A. Maintenant trois préfixes supplémentaires sont annoncés par le pair Router_A.

Router_B# debug ip bgp updates in
*Mar 12 07:31:18.944: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, or
igin i, metric 0, path 200
*Mar 12 07:31:18.948: BGP(0): 10.0.0.1 rcvd 10.0.1.0/24...duplicate ignored
*Mar 12 07:31:18.952: BGP(0): 10.0.0.1 rcvd 10.0.2.0/24...duplicate ignored
*Mar 12 07:31:18.960: BGP(0): 10.0.0.1 rcvd 10.0.3.0/24...duplicate ignored
*Mar 12 07:32:20.224: BGP(0): 10.0.0.1 rcvd 10.0.4.0/24...duplicate ignored
*Mar 12 07:32:20.228: BGP(0): 10.0.0.1 rcvd 10.0.5.0/24...duplicate ignored
*Mar 12 07:32:20.232: BGP(0): 10.0.0.1 rcvd 10.0.6.0/24...duplicate ignored
*Mar 12 07:34:19.768: BGP(0): 10.0.0.1 rcvd 10.0.7.0/24
*Mar 12 07:34:19.772: BGP(0): 10.0.0.1 rcvd 10.0.8.0/24
*Mar 12 07:34:19.780: BGP(0): 10.0.0.1 rcvd 10.0.9.0/24
*Mar 12 07:34:19.780: 
%BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0
) reaches 9, max 10

*Mar 12 07:34:19.792: BGP(0): Revise route installing 1 of 1 route for 10.0.7.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 07:34:19.796: BGP(0): Revise route installing 1 of 1 route for 10.0.8.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 07:34:19.804: BGP(0): Revise route installing 1 of 1 route for 10.0.9.0/
24 -> 10.0.0.1 to main IP table

Router_B#show ip bgp neighbor 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.0.0.1
  BGP state = Established, up for 00:13:22
  Last read 00:00:21, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    IPv4 MPLS Label capability:
  Received 930 messages, 0 notifications, 0 in queue
  Sent 919 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 30, neighbor version 30
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  9 accepted prefixes consume 432 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0, maximum limit 10 (warning-only
)
  Threshold for warning message 80%

  Connections established 2; dropped 1
  Last reset 00:29:13, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    003C0200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A000A 180A000B 180A000C
  External BGP neighbor can be up to 2 hops away.
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 10.0.0.2, Local port: 15668
Foreign host: 10.0.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x3A46EB54):
Timer          Starts    Wakeups            Next
Retrans            18          0             0x0
TimeWait            0          0             0x0
AckHold            22          9             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 2047376434  snduna: 2047376784  sndnxt: 2047376784     sndwnd:  16035
irs:  821061364  rcvnxt:  821062116  rcvwnd:      16188  delrcvwnd:    196

SRTT: 279 ms, RTTO: 500 ms, RTV: 221 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 384 ms, ACK hold: 200 ms
Flags: higher precedence, nagle

Datagrams (max data segment is 536 bytes):
Rcvd: 33 (out of order: 0), with data: 22, total data bytes: 751
Sent: 29 (retransmit: 0, fastretransmit: 0), with data: 17, total data bytes: 349



Router_B#show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 30, main routing table version 30
9 network entries and 9 paths using 1341 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 36/101 prefixes, 36/27 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     932     921       30    0    0 00:15:08        9

Supposez que la situation obtient plus mauvais et que Router_A envoie trois préfixes supplémentaires, qui augmente le nombre total jusqu'à 12.


Router_B# debug ip bgp updates in
*Mar 12 07:39:21.192: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, origin i, metric 0, path 200
*Mar 12 07:39:21.196: BGP(0): 10.0.0.1 rcvd 10.0.10.0/24
*Mar 12 07:39:21.200: %BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0) reaches 10, max 10
*Mar 12 07:39:21.208: BGP(0): 10.0.0.1 rcvd 10.0.11.0/24
*Mar 12 07:39:21.212: %BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1 (afi 0): 11 exceed limit 10
*Mar 12 07:39:21.216: BGP(0): 10.0.0.1 rcvd 10.0.12.0/24
*Mar 12 07:39:21.228: BGP(0): Revise route installing 1 of 1 route for 10.0.10.0/24 -> 10.0.0.1 to main IP table
*Mar 12 07:39:21.236: BGP(0): Revise route installing 1 of 1 route for 10.0.11.0/24 -> 10.0.0.1 to main IP table
*Mar 12 07:39:21.240: BGP(0): Revise route installing 1 of 1 route for 10.0.12.0/24 -> 10.0.0.1 to main IP table

Router_B# show ip bgp neighbors 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.0.0.1
  BGP state = Established, up for 00:19:56
  Last read 00:00:56, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    IPv4 MPLS Label capability:
  Received 937 messages, 0 notifications, 0 in queue
  Sent 925 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 33, neighbor version 33
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  12 accepted prefixes consume 576 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0, maximum limit 10 (warning-only)
  Threshold for warning message 80%

  Connections established 2; dropped 1
  Last reset 00:35:47, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    003C0200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A000A 180A000B 180A000C
  External BGP neighbor can be up to 2 hops away.
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 10.0.0.2, Local port: 15668
Foreign host: 10.0.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x3A4CEA98):
Timer          Starts    Wakeups            Next
Retrans            24          0             0x0
TimeWait            0          0             0x0
AckHold            29         16             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 2047376434  snduna: 2047376898  sndnxt: 2047376898     sndwnd:  15921
irs:  821061364  rcvnxt:  821062290  rcvwnd:      16014  delrcvwnd:    370

SRTT: 290 ms, RTTO: 376 ms, RTV: 86 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 384 ms, ACK hold: 200 ms
Flags: higher precedence, nagle

Datagrams (max data segment is 536 bytes):
Rcvd: 40 (out of order: 0), with data: 29, total data bytes: 925
Sent: 42 (retransmit: 0, fastretransmit: 0), with data: 23, total data bytes: 463
Router_B#show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 33, main routing table version 33
12 network entries and 12 paths using 1788 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 39/101 prefixes, 39/27 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     939     927       33    0    0 00:21:28       12

Comme vous pouvez voir de l'exemple présenté, les relations voisines BGP sont mises à jour même si le routeur voisin envoie plus de préfixes que la stratégie laisse. Le résultat est que seulement un message d'avertissement obtient loggé par Router_B. Aucune autre mesure n'est prise par Router_B.

Maximum-prefix configuré pour réduire la session quand le seuil dépasse le positionnement de seuil

Les conditions initiales exigées pour ce cas sont d'avoir l'en service voisin BGP et avec six préfixes envoyés par Router_A à Router_B. Comme vu dans l'exemple, quand Router_A annonce plus de préfixes (par exemple, 9), la sortie des commandes reflète exactement ce qui a été déjà vu pour le cas où Router_B est configuré pour se connecter juste un message d'avertissement. Si vous soulevez le nombre de préfixes envoyés et faites Router_A annoncer 12, Router_B clôture les relations voisines avec Router_A.


Router_B# debug ip bgp updates in
*Mar 12 08:03:27.864: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, or
igin i, metric 0, path 200
*Mar 12 08:03:27.868: BGP(0): 10.0.0.1 rcvd 10.0.1.0/24...duplicate ignored
*Mar 12 08:03:27.876: BGP(0): 10.0.0.1 rcvd 10.0.2.0/24...duplicate ignored
*Mar 12 08:03:27.880: BGP(0): 10.0.0.1 rcvd 10.0.3.0/24...duplicate ignored
*Mar 12 08:03:27.884: BGP(0): 10.0.0.1 rcvd 10.0.4.0/24...duplicate ignored
*Mar 12 08:03:27.892: BGP(0): 10.0.0.1 rcvd 10.0.5.0/24...duplicate ignored
*Mar 12 08:03:27.896: BGP(0): 10.0.0.1 rcvd 10.0.6.0/24...duplicate ignored
*Mar 12 08:03:27.900: BGP(0): 10.0.0.1 rcvd 10.0.7.0/24
*Mar 12 08:03:27.908: BGP(0): 10.0.0.1 rcvd 10.0.8.0/24
*Mar 12 08:03:27.912: BGP(0): 10.0.0.1 rcvd 10.0.9.0/24
*Mar 12 08:03:27.916: %BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0
) reaches 9, max 10
*Mar 12 08:03:27.924: BGP(0): 10.0.0.1 rcvd 10.0.10.0/24
*Mar 12 08:03:27.932: BGP(0): 10.0.0.1 rcvd 10.0.11.0/24
*Mar 12 08:03:27.932: %BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1
(afi 0): 11 exceed limit 10
*Mar 12 08:03:27.940: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Down BGP Notification
sent
*Mar 12 08:03:27.940: %BGP-3-NOTIFICATION: sent to neighbor 10.0.0.1 3/1 (update
 malformed) 0 bytes  FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0060 0200 0000 1940
 0101 0040 0204 0201 00C8 4003 040A 0000 0180 0404 0000 0000 180A 0001 180A 0002
 180A 0003 180A 0004 180A 0005 180A 0006 180A 0007 180A 0008 180A 0009 180A 000A
 180A 000B 180A 000C
*Mar 12 08:03:28.024: BGP(0): Revise route installing 1 of 1 route for 10.0.7.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.032: BGP(0): Revise route installing 1 of 1 route for 10.0.8.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.036: BGP(0): Revise route installing 1 of 1 route for 10.0.9.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.044: BGP(0): Revise route installing 1 of 1 route for 10.0.10.0
/24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.148: BGP(0): no valid path for 10.0.1.0/24
*Mar 12 08:03:28.152: BGP(0): no valid path for 10.0.2.0/24
*Mar 12 08:03:28.156: BGP(0): no valid path for 10.0.3.0/24
*Mar 12 08:03:28.156: BGP(0): no valid path for 10.0.4.0/24
*Mar 12 08:03:28.160: BGP(0): no valid path for 10.0.5.0/24
*Mar 12 08:03:28.164: BGP(0): no valid path for 10.0.6.0/24
*Mar 12 08:03:28.168: BGP(0): no valid path for 10.0.7.0/24
*Mar 12 08:03:28.168: BGP(0): no valid path for 10.0.8.0/24
*Mar 12 08:03:28.172: BGP(0): no valid path for 10.0.9.0/24
*Mar 12 08:03:28.176: BGP(0): no valid path for 10.0.10.0/24
*Mar 12 08:03:28.184: BGP(0): nettable_walker 10.0.1.0/24 no best path
*Mar 12 08:03:28.188: BGP(0): nettable_walker 10.0.2.0/24 no best path
*Mar 12 08:03:28.192: BGP(0): nettable_walker 10.0.3.0/24 no best path
*Mar 12 08:03:28.196: BGP(0): nettable_walker 10.0.4.0/24 no best path
*Mar 12 08:03:28.200: BGP(0): nettable_walker 10.0.5.0/24 no best path
*Mar 12 08:03:28.204: BGP(0): nettable_walker 10.0.6.0/24 no best path
*Mar 12 08:03:28.208: BGP(0): nettable_walker 10.0.7.0/24 no best path
*Mar 12 08:03:28.212: BGP(0): nettable_walker 10.0.8.0/24 no best path
*Mar 12 08:03:28.212: BGP(0): nettable_walker 10.0.9.0/24 no best path
*Mar 12 08:03:28.216: BGP(0): nettable_walker 10.0.10.0/24 no best path



Router_B# show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 87, main routing table version 87

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     965     948        0    0    0 00:02:24 Idle (PfxCt)

Router_B# show ip bgp neighbors 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Last read 00:02:43, hold time is 180, keepalive interval is 60 seconds
  Received 965 messages, 0 notifications, 0 in queue
  Sent 948 messages, 2 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 87, neighbor version 0
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0, maximum limit 10
  Threshold for warning message 80%

  Connections established 2; dropped 2
  Last reset 00:02:43, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    00600200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A0001 180A0002 180A0003 180A0004
    180A0005 180A0006 180A0007 180A0008
    180A0009 180A000A 180A000B 180A000C

  Peer had exceeded the max. no. of prefixes configured.
  Reduce the no. of prefix and clear ip bgp 10.0.0.1 to restore peering
  External BGP neighbor can be up to 2 hops away.
  No active TCP connection

Remarque: Employez cette commande afin de restaurer la capacité de pair :

Router_B# clear ip bgp 10.0.0.1

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 25160