IP : IP version 6

Tunnel IPv6 via un réseau IPv4

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour effectuer une transmission tunnel d'un protocole d'informations de routage (RIP) IPv6 et d'un réseau et du trafic du protocole BGP (Border Gateway Protocol) IPv6 par le biais d'un réseau IPv4 préexistant. Cette technique vous permet de connecter des sites IPv6 sur la dorsale principale IPv4 qui existe.

La transmission tunnel de recouvrement encapsule les paquets IPv6 en paquets IPv4 pour la livraison à travers une infrastructure IPv4. Ceci est semblable à la façon dont vous créez un tunnel d'encapsulation de routage générique (GRE) pour transporter le trafic Internetwork Packet Exchange (IPX) par le biais d'un réseau IP. À la tête du tunnel, un paquet IPv6 est encapsulé en paquet IPv4 et envoyé à la destination du tunnel distant. C'est à cet endroit que l'en-tête de paquet IPv4 est éliminé et que le paquet IPv6 d'origine est transféré dans un nuage IPv6.

Il existe cinq méthodes de transmission tunnel du trafic IPv6 :

  • Tunnels IPv6 manuels

  • Tunnels compatibles IPv4 automatiques

  • GRE

  • Tunnels 6to4 automatiques

  • Tunnels ISATAP (Intra-Site Automatic Tunnel Addressing Protocol)

La différence principale dans ces techniques de transmission tunnel est la méthode selon laquelle la source et la destination du tunnel sont déterminées. Dans ce document, les types de tunnel compatibles IPv4 manuels et automatiques sont décrits. Reportez-vous à Implémentation de la transmission tunnel pour IPv6 pour obtenir des informations sur les autres techniques de transmission tunnel et leurs caractéristiques.

Remarque: Les tunnels de recouvrement réduisent la valeur MTU (Maximum Transmission Unit) d'une interface de 20 octets. Ceci suppose que l'en-tête de paquet IPv4 de base ne contient pas de champs facultatifs. Il est difficile de dépanner un réseau qui utilise des tunnels de recouvrement. Par conséquent, les tunnels de recouvrement qui connectent des réseaux IPv6 isolés ne doivent pas être considérés comme une architecture réseau IPv6 finale. L'utilisation de tunnels de recouvrement doit être considérée comme une technique de transition vers un réseau qui prend en charge les piles de protocoles IPv4 et IPv6, ou juste la pile de protocoles IPv6.

Conditions préalables

Conditions requises

Cisco recommande que vous ayez connaissance du protocole IPv6 avant d'essayer cette configuration. Reportez-vous à Implémentation de l'adressage IPv6 et connectivité de base pour obtenir des informations sur IPv6.

Composants utilisés

Les informations dans ce document sont basées sur les Routeurs de gamme Cisco 36xx qui exécutent la version de logiciel 12.3(13) de Ý de Cisco IOS.

Remarque: Toute plate-forme matérielle qui prend en charge le logiciel Cisco IOS Version 12.2(2)T ou 12.0(21)ST et versions ultérieures prend également en charge IPv6.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/25156/ipv6tunnel.gif

Configurations (mode IPv6 manuel)

La configuration des tunnels configurés manuellement pour IPv6 est explicite. Elle requiert la spécification précise de la source IPv4 du tunnel et de la destination IPv4 du tunnel. Le seul inconvénient de cette technique, c'est que le travail d'administration augmente parallèlement au nombre de tunnels.

Ce document utilise les configurations suivantes pour le mode IPv6 :

R1-IPv6 (routeur Cisco 3640)
R1-ipv6#show run
Building configuration...
 
Current configuration : 916 bytes
!
version 12.3
hostname R1-ipv6
!
boot system flash 
logging buffered 4096 debugging
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 ipv6 address 2000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone 
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
!
end

R2-IPv6-IPv4 (routeur Cisco 3640)
R2-ipv6-ipv4#show run
Building configuration...
 
Current configuration : 1079 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
ip subnet-zero
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::1/112
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel destination 192.34.1.4
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!--- In some cases, user would require a Data License  
!--- in order to issue "tunnel mode ipv6ip"


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R3-IPv4 (routeur Cisco 2621)
R3-ipv4#show run
Building configuration...
 
Current configuration : 865 bytes
!
version 12.3
!
hostname R3-ipv4
!
!
memory-size iomem 15
ip subnet-zero
!
!
interface Serial0/0
 ip address 192.23.1.3 255.255.255.0
!
interface Serial0/1
 ip address 192.34.1.3 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4-IPv4-IPv6 (routeur Cisco 3640)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1413 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::2/112
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel destination 192.23.1.2
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!         
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5-IPv6 (routeur Cisco 7500)
R5-ipv6#show run
Building configuration...
 
Current configuration : 1001 bytes
!
version 12.3
!
hostname R5-ipv6
!
ip subnet-zero
ip cef distributed
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Ethernet1/2
 no ip address
 ipv6 address 4000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Configurations (mode compatible IPv4 automatique)

Les configurations pour R1, R3 et R5 sont identiques aux exemples du mode IPv6 manuel. Seules les configurations R2 et R4 sont modifiées. Lorsque vous configurez le tunnel compatible IPv4, ne spécifiez pas explicitement l'adresse IPv4 de destination du tunnel. La destination du tunnel est automatiquement calculée à partir de l'adresse du prochain saut IPv6 de la route IPv6. Afin de fournir la route sur un tel tunnel, un protocole de routage avec une définition d'adresse de voisin explicite, par exemple BGP ou statique, est requis. Dans ce cas, vous devez utiliser une adresse IPv6 compatible IPv4 comme adresse IPv6 de voisin BGP ou adresse de prochain saut de route statique.

Ces exemples utilisent l'interface série sur le R2 et R4 comme adresse IPv6 compatible IPv4. La même interface série est la source du tunnel. Par exemple, l'adresse IPv4 192.23.1.2 sur R2 S0/0 est convertie en : 192.23.1.2 dans la notation IPv6. Cette adresse est utilisée comme adresse IPv6 d'homologue BGP et prochain saut BGP. Après tout, les routes BGP IPv6 sont redistribuées dans le RIP IPv6 de sorte que les extrémités distantes du réseau reçoivent les informations.

Cette technique de transmission tunnel est à présent obsolète. Cisco vous recommande d'utiliser la technique de transmission tunnel ISATAP IPv6. Reportez-vous à Tunnels ISATAP pour plus d'informations sur cette technique.

Remarque: Il n'est pas nécessaire de configurer une destination de tunnel avec le mode IPv6 automatique.

R2-IPv6-IPv4 (routeur Cisco 3640)
R2-ipv6-ipv4#show run
Building configuration...
Current configuration : 1394 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
!
ip subnet-zero
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.34.1.4 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.34.1.4 activate
 neighbor ::192.34.1.4 next-hop-self
 network 2000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!         
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R4-IPv4-IPv6 (routeur Cisco 3640)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1697 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.23.1.2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.23.1.2 activate
 neighbor ::192.23.1.2 next-hop-self
 network 4000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • ping — Détermine si un hôte distant est actif ou inactif, et le délai aller-retour de la communication avec l'hôte.

  • show ipv6 route — Vérifie si une route existe sur IPv6.

  • show bgp ipv6 — Vérifie si BGP est en cours d'exécution.

  • show bgp ipv6 summary — Affiche des informations résumées sur le BGP en cours d'exécution sur IPv6.

  • affichez le tunnel 0 de l'IPv6 international — Vérifie que le tunnel est sur l'IPv6, et vérifie le MTU configuré sur l'interface.

Sortie de commande de vérification pour le mode IPv6 manuel

À partir de R1, exécutez une commande ping sur l'adresse IPv6 sur R5 pour vérifier si le tunnel transporte IPv6 par le biais du réseau IPv4.

R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#

À partir de R5, exécutez une commande ping sur l'adresse IPv6 sur R1.

R5-ipv6#ping  2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#

Sortie de commande de vérification pour le mode IPv6 automatique

Exécutez une commande ping sur le réseau IPv6 distant pour vérifier la connectivité par le biais du tunnel.

R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms 
R1-ipv6# 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms 
R5-ipv6#

Si la commande ping échoue, consultez la table de routage IPv6 pour vérifier si la route existe. Consultez aussi la table de routage de l'autre côté. La route au niveau du routeur de fin, tel que R5 ou R1, doit être apprise sous forme d'une route RIP. Cette route est redistribuée à partir de BGP dans le RIP au niveau de R2 et de R4. C'est au niveau de R2 et de R4 que le tunnel se termine et que l'appairage BGP est configuré.

R5-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
R   ::/96 [120/2] 
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
R   2000:1:1:1:1:1:1:0/112 [120/3]
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
L   4000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet1/2
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet1/2
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R5-ipv6#

Si le réseau IPv6 distant ne figure pas sur le routeur de fin, vérifiez le routeur où le tunnel se termine.

R4-ipv4-ipv6#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   ::192.34.1.4/128 [0/0] 
     via ::, Tunnel0
C   ::/96 [0/0] 
     via ::, Tunnel0
B   2000:1:1:1:1:1:1:0/112 [200/0]
     via ::192.23.1.2, Null
L   4000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, Ethernet3/0
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet3/0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R4-ipv4-ipv6#

Comme vous utilisez BGP IPv6 pour partager des informations entre les deux réseaux IPv6 différents, vérifiez que BGP est opérationnel.

R4-ipv4-ipv6#show bgp ipv6 
BGP table version is 3, local router ID is 192.34.1.4 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure 
Origin codes: i - IGP, e - EGP, ? - incomplete 
   Network          Next Hop            Metric LocPrf Weight Path 
*>i2000:1:1:1:1:1:1:0/112 
                    ::192.23.1.2                  100      0 i 
*> 4000:1:1:1:1:1:1:0/112 
                    ::                                 32768 i 
R4-ipv4-ipv6#show bgp ipv6 summary 
BGP router identifier 192.34.1.4, local AS number 100 
BGP table version is 3, main routing table version 3 
2 network entries and 2 paths using 394 bytes of memory 
2 BGP path attribute entries using 120 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
::192.23.1.2    4   100      24      24        3    0    0 00:19:00        1 
R4-ipv4-ipv6# 
R4-ipv4-ipv6#show ipv6 int tunnel 0 
Tunnel0 is up, line protocol is up 
  IPv6 is enabled, link-local address is FE80::C022:104 
  Global unicast address(es): 
    ::192.34.1.4, subnet is ::/96 
  Joined group address(es): 
    FF02::1 
    FF02::2 
    FF02::9 
    FF02::1:FF22:104 
  MTU is 1480 bytes 
  ICMP error messages limited to one every 100 milliseconds 
  ICMP redirects are enabled 
  ND DAD is not supported 
  ND reachable time is 30000 milliseconds 
  Hosts use stateless autoconfig for addresses. 
R4-ipv4-ipv6#

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • show ipv6 route — Vérifie si une route existe sur IPv6.

  • show ip ospf neighbor — Affiche l'ID du routeur, la priorité et l'état du routeur voisin. En outre, cette commande affiche la durée restante pendant laquelle le routeur doit attendre de recevoir un paquet hello Open Shortest Path First (OSPF) du voisin avant de déclarer le voisin comme étant inactif. Elle affiche également l'adresse IP de l'interface à laquelle ce voisin est directement connecté et l'interface sur laquelle le voisin OSPF forme la contiguïté.

  • show ipv6 interface brief — Vérifie que l'interface du tunnel est active.

  • show interfaces tunnel 0 — Vérifie que la destination du tunnel configurée est connue dans la table de routage.

  • show ipv6 rip — Affiche informations du RIP IPv6.

  • show ipv6 protocols — Affiche l'état du protocole de routage IPv6.

En cas d'échec de la commande ping au réseau IPv6 distant, vérifiez que les routes IPv6 sont apprises par l'intermédiaire du RIP IPv6.

R1-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet0/1
R   3000::/112 [120/2]
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
R   4000:1:1:1:1:1:1:0/112 [120/3] 
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R1-ipv6#

Sur R2, vérifiez que les routes RIP IPv6 sont apprises à partir de l'interface Tunnel0.

R2-ipv6-ipv4#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, FastEthernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, FastEthernet0/1
L   3000::1/128 [0/0] 
     via ::, Tunnel0
C   3000::/112 [0/0] 
     via ::, Tunnel0
R   4000:1:1:1:1:1:1:0/112 [120/2]
     via FE80::230:80FF:FEF3:4701, Tunnel0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R2-ipv6-ipv4#

Si des problèmes de connectivité se produisent, vérifiez d'abord que le réseau IPv4 est intact. Vérifiez également les contiguïtés du voisin OSPF et que des routes existent vers l'adresse IPv4, qui est la source de tunnel de l'interface du tunnel distant. Vérifiez ensuite que vous pouvez exécuter une commande ping entre les sources de tunnel avec IPv4 ping.

R2-ipv6-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:36    192.23.1.3      Serial0/0 
R2-ipv6-ipv4# 
R3-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
1.1.1.1           1   FULL/  -        00:00:30    192.34.1.4      Serial0/1 
192.23.1.2        1   FULL/  -        00:00:35    192.23.1.2      Serial0/0 
R3-ipv4# 
R4-ipv4-ipv6#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:35    192.34.1.3      Serial1/5 
R4-ipv4-ipv6#

Sur R2, vérifiez que l'interface du tunnel IPv6 est active et que vous pouvez exécuter une commande ping IPv6 sur le tunnel source distant avec l'adresse IPv6 compatible IPv4. Si l'interface du tunnel est inactive, vérifiez que la destination du tunnel configurée est connue dans la table de routage. Il s'agit d'un problème dans la partie IPv4 du réseau, car la destination du tunnel n'est pas dans la table de routage.

R2-ipv6-ipv4#show ipv6 interface brief 
FastEthernet0/0            [up/up] 
    unassigned 
Serial0/0                  [up/up] 
    unassigned 
FastEthernet0/1            [up/up] 
    2000:1:1:1:1:1:1:1111 
Tunnel0                    [up/up] 
    3000::1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show interfaces tunnel 0 
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel 
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation TUNNEL, loopback not set 
  Keepalive not set 
  Tunnel source 192.23.1.2 (Serial0/0), destination 192.34.1.4 
  Tunnel protocol/transport IPv6/IP, key disabled, sequencing disabled 
  Tunnel TTL 255 
  Checksumming of packets disabled 
  Last input 00:00:09, output 00:00:19, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/0 (size/max) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     3119 packets input, 361832 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     3117 packets output, 361560 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
R2-ipv6-ipv4#

S'il reste des problèmes avec les routes IPv6 et que vous avez vérifié le réseau IPv4, vous devez vérifier la configuration du RIP IPv6.

R2-ipv6-ipv4#show ipv6 rip 
RIP process "6bone", port 521, multicast-group FF02::9, pid 111 
     Administrative distance is 120.  Routing table is 0 
     Updates every 30 seconds, expire after 180 
     Holddown lasts 180 seconds, garbage collect after 120 
     Split horizon is on; poison reverse is off 
     Default routes are not generated 
     Periodic updates 176, trigger updates 1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show ipv6 protocols 
IPv6 Routing Protocol is "connected" 
IPv6 Routing Protocol is "static" 
IPv6 Routing Protocol is "rip 6bone" 
  Interfaces: 
    FastEthernet0/1 
    Tunnel0 
  Redistribution: 
    Redistributing protocol rip 6bone

Vérifiez que les minuteurs sont identiques si les paramètres par défaut ne sont pas utilisés. Dans cet exemple, la valeur par défaut est utilisée sur tous les routeurs RIP IPv6. Vérifiez la configuration pour vous assurer que toutes les interfaces activées par RIP sont configurées correctement. Vérifiez aussi que le nom du processus RIP est cohérent dans tout le réseau. Si nécessaire, vous pouvez consulter la sortie de debug ipv6 rip. Comme avec tous les débogages, faites preuve de prudence pour ne pas surcharger la mémoire tampon de journalisation du CPU et de la console.

Résumé

Ce document explique comment des tunnels peuvent être utilisés pour faire coexister IPv6 et IPv4 sur le même réseau. Ceci peut être nécessaire dans les phases de transition. Concernant les configurations IPv6, souvenez-vous que les instructions réseau ne sont pas utilisées avec le RIP IPv6. Le RIP IPv6 est activé globalement et chaque interface participe au RIP et prend en charge le RIP IPv6. Dans l'exemple BGP IPv6, la section Tunnel automatique requiert l'utilisation du jeu de commandes address-family ipv6 pour écrire les instructions BGP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 25156