Voix : H.323

Configuration et dépannage du service Cisco ITS (IOS Telephony Service)

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (12 novembre 2015) | Commentaires


Contenu


Introduction

Le service téléphonique de Cisco IOS (SON), autrefois connu sous le nom d'IP Keyswitch, est une solution de Traitement des appels de Téléphonie sur IP intégrée dans le logiciel de½ du¿Â du Cisco IOSï qui s'adapte en architecture Cisco pour la Voix, le vidéo, et les données intégrées (AVVID). Le concept de base est de fournir une fonctionnalité minimale PBX/key-switch à un nombre restreint de téléphones IP directement reliés à la passerelle vocale. Le service Cisco ITS peut être déployé dans les cas où une filiale n’a pas de réseau WAN ou que sa connectivité WAN passe par des liaisons satellites.

Cisco SON semble raisonnable dans les situations où un client voudrait ajouter un service téléphonique à un tel site sans exiger nécessairement toutes les caractéristiques de téléphonie trouvées dans le Cisco CallManager. Ce document décrit un déploiement d'échantillon de la SA caractéristique dans un réseau témoin.

Remarque: Cisco SON n'est pas identiques, ni sont les caractéristiques les mêmes, car la caractéristique de Survivable Remote Site Telephony (SRST) qui est utilisée en même temps que le Cisco CallManager.

Conditions préalables

Conditions requises

Avant d'essayer cette configuration, veuillez vous assurer que vous remplissez les conditions préalables suivantes :

  • Connaissance de version 2.01 de service téléphonique de Cisco IOS.

  • Une compréhension de base des principes fondamentaux TCP/IP, tels que l'adressage IP, le DHCP, le Protocole NTP (Network Time Protocol), le TFTP, et le HTTP

  • Une compréhension de base des principes fondamentaux de logiciel de Cisco IOS, tels que la configuration de l'interface de ligne de commande (CLI)

  • Une compréhension de base des principes fondamentaux de la voix sur ip (VoIP), tels que configurer des cadran-pairs, des ports vocaux, et le Qualité de service (QoS)

Composants utilisés

Les informations dans ce document sont basées sur le logiciel et les versions de matériel suivants :

  • Logiciel Cisco IOS version 2.2(8)T ou plus tard, avec un minimum de positionnement de caractéristique de l'IP Plus (plus IP/VOX sur la gamme 1700). Ce document suppose Cisco SON support 2.0 en logiciel de Cisco IOS.

  • La passerelle de Cisco 3660 avec la version de logiciel d'IOS Software 12.2(11)T avec le positionnement de caractéristique d'IP PLUS est utilisée dans l'exemple de configuration, bien que la plupart de 2600, 3600, IAD 2400, 1700, et des Routeurs de gamme 3700 appliquiez-vous actuellement. Veuillez vérifier les notes en version logicielle de Cisco IOS pour la version en cours et les informations de support logiciel.

  • Cisco SON 2.0.3 lots de logiciels a été utilisé dans cet exemple. Vous pouvez télécharger ce paquet de téléchargement logiciel : Cisco CallManager Express/ITS et SRST (clients enregistrés seulement).

  • Pour prendre en charge Cisco SON, il est recommandé que vous avez la quantité maximale de mémoire pour chaque plate-forme, particulièrement si le nombre maximal de téléphones et les noms uniques (dn) pour la plate-forme doivent être configurés.

  • Dans cet exemple, un commutateur de la gamme Catalyst 3500 XL est utilisé comme commutateur de succursale. Configurez les VLAN distincts pour la Voix et les données pour la qualité et les raisons de sécurité.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/25100/config_troubleshoot_its1.gif

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

La table ci-dessous spécifie les informations sur la Voix et le transfert des données par les VLAN distincts. Il spécifie également le réseau et les adresses et les ports d'interface.

But VLAN Réseau Interface Adresse d'interface
Données 50 10.1.50.0/24 Fa0/0.50 10.1.50.1/24
Voix 150 10.1.150.0/24 Fa0/0.150 10.1.150.1/24

Cisco SON routeur est des 3660 Logiciel Cisco IOS version 12.2(11)T courants avec le positionnement de caractéristique d'IP Plus. Cisco SES fichiers devrait être téléchargé dans .tar ou le format .zip du téléchargement logiciel : Cisco CallManager Express/ITS et SRST (clients enregistrés seulement).

Une fois qu'extrait, chaque fichier doit être transféré vers l'éclair du routeur par le TFTP. N'effacez pas l'éclair chaque fois que un fichier individuel est copié. Ce qui suit est une liste des fichiers trouvés à Cisco SES 2.0.3 (pas tous ces fichiers sont nécessaires).

Nom de fichier Description
P003G302.bin Le chargement de téléphone être utilisé avec Cisco SON pour le téléphone IP de Cisco 7910. Le chargement de téléphone a une note de mise à jour distincte incluse qui explique certaines des difficultés des versions préalables. (Requis)
P004G302.bin Le chargement de téléphone être utilisé avec Cisco SON pour le téléphone IP de Cisco 7960. Le chargement de téléphone a une note de mise à jour distincte incluse qui explique certaines des difficultés des versions préalables. (Requis)
admin_user.html La page Web d'administrateur pour configurer le système
ephone_admin.html La page Web de gestion de téléphone.
normal_user.html La page Web d'utilisateur (non-administrateur) pour gérer des téléphones pour caractéristiques de transmission et autres.
telephony_service.html La page Web supérieure que chaque utilisateur visite pour configurer des téléphones ou pour configurer le système en tant qu'administrateur. (Facultatif)
logohome.gif
en_dest_busy.au Une demande d'audio témoin pour une extension occupée. Utilisé par le script its_Cisco.2.0.0.tcl.
en_dest_unreachable.au Une demande d'audio témoin pour une extension inaccessible. Utilisé par le script its_Cisco.2.0.0.tcl.
en_disconnect.au Une demande d'audio témoin pour une extension déconnectée ou non inscrite. Utilisé par le script its_Cisco.2.0.0.tcl.
en_enter_dest.au Une demande d'audio témoin pour que l'utilisateur entre dans une destination. Utilisé par le script its_Cisco.2.0.0.tcl.
en_reenter_dest.au Une demande d'audio témoin pour que l'utilisateur ressaisisse la destination. Utilisé par le script its_Cisco.2.0.0.tcl.
en_welcome.au Une demande d'audio témoin pour le message d'accueil d'utilisateur. Utilisé par le script its_Cisco.2.0.0.tcl.
its_Cisco.2.0.0.tcl Le script TCL pour un échantillon a automatisé le préposé qui peut conduire des appels à une extension. Utilise les fichiers témoin .au pour saluer l'utilisateur, pour inciter pour un nombre, et pour conduire l'appel à la destination désirée.
music-on-hold.au Un fichier audio témoin utilisé pour la musique d'attente.

Le fichier suivant est également une partie du fichier de Cisco ITS-2.0.3.zip, mais n'a pas besoin d'être placé dans l'éclair du SON routeur.

Nom de fichier Description
CiscoIOSTSP.zip Ce fournisseur de services de l'interface de programmation de téléphonie (TAPI) (TSP) a été développé pour Cisco SON et agit en tant qu'interface entre TAPI (une partie du système d'exploitation Windows 2000) et le SON. Le TSP permet des applications basées sur TAPI telles que le numéroteur téléphonique et l'ACTE ! logiciel pour fournir le Contrôle d'appel aux Téléphones IP sur Cisco SON. L'implémentation TAPI sur Cisco SON n'est pas une pleine pile TAPI, mais une implémentation « TAPI Lite ». Il prend en charge les caractéristiques suivantes :
  • Plusieurs adresses sur une ligne simple.
  • Le placement appelle utilisant le carnet d'adresses composant de l'application.
  • Répondant ou rejetant à des appels de l'application.
  • Tenir des appels à l'aide des bruits d'écran.
  • Rendant les informations d'identification de l'appelant disponibles à l'application.
  • Le placement invite l'attente et le changement entre les faire appel à différentes adresses de la même ligne.
Le TSP fournit une interface cet à télécommande linéaire d'enables d'un téléphone IP. Bien que plusieurs TSPs peut fonctionner sur le même ordinateur, seulement un téléphone IP peut être associé avec chaque TSP. Puisque le fournisseur de service de médias (FSG) n'est pas pris en charge par ce TSP, des applications telles que le téléphone IP de Cisco ne sont pas prises en charge.

Remarque: Le TSP qui se transporte avec le Cisco CallManager n'est pas pris en charge avec le SON.

Configurations

Configuration VLAN sur le Catalyst 3500XL

Cisco que SES passages sur le RÉSEAU LOCAL où des Téléphones IP et les Cisco CallManagers sont connectés aux Passerelles voix par le Catalyst commute. Il est très important de configurer ces périphériques correctement en ce qui concerne les VLAN qui portent les données vocales. Cette section fournit un aperçu de configuration du Catalyst 3500XL et de la connexion au réseau local correspondante sur le routeur de la passerelle 3660 de Voix.

  1. La Voix et les données VLAN devraient être installées avec un commutateur unconfigured, suivant les indications de l'exemple suivant :

    Cat3500BranchSwitch# vlan database
    Cat3500BranchSwitch(vlan)# vlan 50 name corporate-data-vlan
    VLAN 50 added:
    Name: corporate-data-vlan
    Cat3500BranchSwitch(vlan)# vlan 150 name corporate-voice-vlan
    VLAN 150 added:
    Name: corporate-voice-vlan
    Cat3500BranchSwitch(vlan)#
    Cat3500BranchSwitch(vlan)# exit
    APPLY completed.
    Exiting....
    Cat3500BranchSwitch#
  2. L'exemple suivant est une configuration d'échantillon de l'interface entre le Catalyst 3500XL et le routeur 3660 :

    interface FastEthernet0/1
     description Port to 3660 (supports Dot1q)
     duplex full
     speed 100
     switchport trunk native 50
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,50,150,1002-1005
     switchport mode trunk
    !
    
  3. L'exemple suivant est un port à utiliser pour une connexion téléphonique :

    interface FastEthernet0/2
     description DOT1Q port to IP Phone
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 50
     switchport mode trunk
     switchport voice vlan 150
     spanning-tree portfast
    !
    

Pour de plus amples informations, référez-vous à la gamme Catalyst 2900 XL et aux Commutateurs de la gamme Catalyst 3500 XL.

Configuration VLAN sur Cisco SON routeur

Suivez les étapes ci-dessous pour configurer des VLAN sur Cisco SON routeur.

  1. La première étape est de configurer des paramètres de QoS et des VLAN sur l'interface 3660, comme affiché ci-dessous.

    ! 
    class-map match-all L3-to-L2_VoIP-Cntrl
     match ip dscp af31 
    class-map match-all L3-to-L2_VoIP-RTP
     match ip dscp ef 
    !
    !
    policy-map output-L3-to-L2
     class L3-to-L2_VoIP-RTP
      set cos 5
     class L3-to-L2_VoIP-Cntrl
      set COs 3
    !
    
  2. Maintenant appliquez-vous ces stratégies à l'interface et créez les VLAN.

    interface FastEthernet0/0
     description Catalyst 3500 Branch Office Switch
     no ip address
     no ip mroute-cache
     load-interval 30
     speed 100
     full-duplex
    !
    interface FastEthernet0/0.50
     encapsulation dot1Q 50
     ip address 10.1.50.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    interface FastEthernet0/0.150
     description native subnet 10.1.150.0 voice
     encapsulation dot1Q 150
     ip address 10.1.150.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    

Pour de plus amples informations, référez-vous à la gamme Catalyst 2900 XL et aux Commutateurs de la gamme Catalyst 3500 XL.

Configuration du serveur DHCP sur Cisco SON routeur

L'étape suivante est nécessaire pour configurer un serveur DHCP sur le routeur 3660. Vous avez besoin de cette étape seulement si vous avez un serveur DHCP externe, pas si vos adresses IP sont statiquement configurées. L'exemple ci-dessous affiche une portée de DHCP pour les Téléphones IP et pour d'autres périphériques sur l'autre VLAN.

ip dhcp excluded-address 10.1.50.1 10.1.50.10
ip dhcp excluded-address 10.1.150.1 10.1.150.10
!
ip dhcp pool ip-phones
 network 10.1.150.0 255.255.255.0  

!--- This defines the range of IP addresses to be assigned.

 default-router 10.1.150.1
 option 150 ip 10.1.150.1   

!--- This must be the IP address of the ITS router.  

!
ip dhcp pool Data-clients
 network 10.1.50.0 255.255.255.128
 default-router 10.1.50.1 
 domain-name cisco.com
 dns-server 10.1.50.100 
 netbios-name-server 10.1.50.100 
!

Remarque: Si vous voulez activer le DHCP seulement pour des appareils spécifiques, vous pouvez créer une portée de DHCP avec la commande d'hôte (au lieu d'une commande réseau, comme affiché ci-dessus). Vous devez également configurer un client-identifier et une adresse de matériel pour le téléphone IP que vous souhaitez donner une adresse IP à. Pour le client-identifier, vous devez spécifier 01 + adresse MAC de téléphone, et l'adresse de matériel doit contenir l'adresse MAC du téléphone comme paramètre.

Pour de plus amples informations, référez-vous au serveur DHCP de Cisco IOS.

Configuration de temps sur Cisco SON routeur

Puisque les Téléphones IP reçoivent leurs configurations de date/heure de Cisco SON routeur, il est important de s'assurer que l'horloge est réglée correctement sur le routeur. On le recommande fortement que vous configuriez le NTP, si possible. Spécifiez le fuseau horaire et, s'il y a lieu, l'heure d'été, et configurez le serveur de NTP. Un exemple est affiché ci-dessous.

its-router(config)# clock time EST -5
its-router(config)# clock summer-time EST recurring 
its-router(config)# ntp server 172.18.106.15

Pour plus d'informations sur le NTP, référez-vous à exécuter la gestion du système de base.

Cisco SA configuration sur les 3660

Configuration de base

La configuration suivante devrait être écrite pour configurer Cisco SON en fonction les 3660 :

telephony-service
 load 7910 P004G302       

!--- This is the load file minus the .bin extension. 
!--- Only the 7910, 7940/7960, and 7935 IP Phones are supported.


 load 7960-7940 P003G302  

!--- This is the load file minus the .bin extension.

 ip source-address 10.1.150.1 port 2000  

!--- This is the ip address of the Cisco ITS router on the voice subnet.

 max-ephones 48  

!--- This is the total number of phones that will be allowed to register.
!--- The maximum varies by platform and sometimes by software level.


 max-dn 192      

!--- This is the maximum number of directory numbers that can be configured 
!--- on this gateway (maximum varies by platform and sometimes by software level).

 voicemail 52222 

!--- This is the number that will be dialed when the "Messages" 
!--- button is pressed on the phone (optional).

!

La plupart des commandes restantes sont facultatives. Le seul obligatoire est les déclarations de « chargement » (pas qui sont nécessaires pour tous les téléphones), qui sont les commandes de source-address, maximum-ephones, et de maximum-dn d'IP.

Remarque: Cisco SON routeur est conçu pour fonctionner avec des fichiers de chargement des versions de Cisco CallManager plus tôt que 3.1 ; par exemple, fichiers de chargement qui obtiennent leur configuration à partir du fichier SEPDEFAULT.cnf, plutôt qu'à partir d'un fichier XML. Assurez-vous que cette commande est dans la configuration :

tftp-server 
  flash:XMLDefault.cnf.xml

D'autres options de service téléphonique sont affichées dans l'exemple suivant :

Its-router(config-telephony)# telephony-service
its-router(config-telephony)# ? 
  Cisco IOS Telephony Service configuration commands:
  admin-password      define password for admin user
  admin-username      define username for admin user
  date-format         Set date format for IP Phone display 
  default             Set a command to its defaults
  dialplan-pattern    Define E.164 telephone number prefix
  directory           Define directory naming order
  dn-webedit          enable Edit DN through Web
  exit                Exit from telephony-service configuration mode
  ip                  Define IP address and port for Telephony-Service/Fallback
  keepalive           Define keepalive timeout period to unregister IP phones
  load                Select the IP phone firmware load file
  max-conferences     Define max number of 3 party G.711 conferences
  max-dn              Maximum directory numbers supported 
  max-ephones         Define max number of IP phones
  moh                 Define music-on-hold filename
  mwi                 Define IP address and port for MWI Server
  no                  Negate a command or set its defaults
  reset               reset ethernet phone
  time-format         Set time format for IP Phone display 
  time-webedit        enable Edit Time through Web
  timeouts            Define timeout value for IP phone
  transfer-pattern    Define valid call transfer destinations
  url                 Define Ephone URL's
  voicemail           Set the voicemail access number called when the MESSAGES IP
                      phone button is pressed

its-router(config-telephony)#

attention Attention : Plusieurs des modifications au service téléphonique, tel que changer la date ou le format horaire, exigent des téléphones de remettre à l'état initial. Quelques options, telles que changer les configurations maximum-ephones ou de maximum-dn, exigent un plein routeur rechargé. Pour remettre à l'état initial tous les téléphones, entrez dans ce qui suit :

its-router(config-telephony)# telephony-service
its-router(config-telephony)# reset all

Certaines de ces options seront discutées dans les sections suivantes ; d'autres peuvent être trouvés en se rapportant à la version 2.01 de service téléphonique de Cisco IOS.

Configuration TFTP sur le SON routeur

Suivez les étapes ci-dessous pour configurer le TFTP sur le SON routeur.

  1. Assurez-vous que tous les fichiers ont été correctement transférés vers l'éclair du routeur. Au moins, les fichiers P003G302.bin de chargement et P004G302.bin doivent être chargés. Une fois que chargé, l'éclair devrait ressembler à l'exemple suivant :

    Its-router# show flash
    System flash directory:
    File Length    Name/status
    1    16084816  c3660-is-mz.122-11.T 
    2    229542    admin_user.html 
    3    42484     en_dest_busy.au 
    4    26376     en_dest_unreachable.au 
    5    14352     en_disconnect.au 
    6    19512     en_enter_dest.au 
    7    17167     en_reenter_dest.au 
    8    17486     en_welcome.au 
    9    4152      ephone_admin.html 
    10   5968      its_Cisco.2.0.0.0.tcl 
    11   29092     logohome.gif 
    12   496521    music-on-hold.au 
    13   35138     normal_user.html 
    14   268008    P003G302.bin 
    15   258360    P004G302.bin 
    16   522       telephony_service.html 
    17   54        SEPDEFAULT.cnf     
    
    !--- This file will not show up until telephony-service is configured.
    
    18   249       XMLDefault.cnf.xml 
    
    !--- This file will not show up until telephony-service is configured.
    
    [17551227 bytes used, 49033349 available, 66584576 total]
    65536K bytes of processor board System flash (Read/Write)
    
    its-router#
    
  2. Dans la configuration, vous devez permettre aux Téléphones IP pour télécharger les fichiers de chargement par TFTP de Cisco SON routeur. Notez que ces noms de fichier distinguent les majuscules et minuscules.

    tftp-server flash:P003G302.bin
    tftp-server flash:P004G302.bin
    tftp-server flash:SEPDEFAULT.cnf
    tftp-server flash:XMLDefault.cnf.xml
    
  3. Les fichiers SEPDEFAULT.cnf et XMLDefault.cnf.xml sont créés automatiquement une fois que le commandsare de service téléphonique et de source-address d'IP émettait.

  4. Le fichier XMLDefault.cnf.xml contient l'adresse IP d'un des ports Ethernet du routeur auquel l'adaptateur ATA devrait s'enregistrer. Ces fichiers sont spécifiques au routeur et ne peuvent pas être partagés par des plusieurs routeurs.

Configuration de téléphone IP sur le SON routeur

Suivez les étapes ci-dessous pour configurer des Téléphones IP sur le SON routeur.

  1. En ce moment, si les Téléphones IP sont branchés et ont reçu une adresse DHCP, ils peuvent enregistrer avec Cisco SON routeur. Ils n'auront aucune ligne configurée. Vous pouvez vérifier que les téléphones sont enregistrés en émettant la commande d'ephone d'exposition et en regardant la sortie, qui devrait ressembler à ce qui suit :

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.10 50568 Telecaster 7960 keepalive 889 max_line 6
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 52397 Telecaster 7960 keepalive 872 max_line 6
    
    
    ephone-3 Mac:0006.D74B.107C TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.12 51116 Telecaster 7960 keepalive 871 max_line 6
    
    
    ephone-4 Mac:0008.E31B.7A8A TCP socket:[5] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.13 50321 Telecaster 7960 keepalive 867 max_line 6
    
    its-router#
  2. Vous pouvez maintenant configurer ces téléphones par le CLI ou par l'administration web. (Référez-vous à l'administration par le Web configurante de Cisco SA section Routeur de ce document.) Quelques informations de configuration spéciale sont disponibles pour le téléphone IP de Cisco 7910 à Cisco SA configuration pour les 7910 sections de téléphone IP.

    !
    ephone-dn 1
     number 1000
     name George P Burdell
     call-forward noan 52222 timeout 10
     no huntstop
    !
    ! 
    ephone-dn 2
     number 1000
     name George P Burdell
     preference 1
     call-forward busy 52222
     call-forward noan 52222 timeout 10
    !
    !
    ephone-dn 10
     number 1111
     name Helpdesk
     no huntstop
    !
    !
    ephone-dn 11
     number 1111
     name Helpdesk
     preference 1
    !
    !
    ephone-dn 12
     number 1111
     name Helpdesk
     preference 2
    !
    !
    ephone-dn 13
     number 1111
     name Helpdesk
     preference 3
    !
    
  3. Chaque ephone-dn représente une ligne. Vous pouvez assigner les lignes à de plusieurs téléphones, si désiré. Dans cet exemple, un utilisateur a été configuré qui a l'extension 1000 sur deux lignes. Une ligne de help desk, qui est un groupe de recherche de quatre lignes, a été aussi bien ajoutée. Configurez maintenant les ephones, qui assignent les lignes aux appareils téléphoniques réels.

    !
    ephone 1
     username "gpburdell" password letmein
     mac-address 0006.D74B.0F46
     button 1:10 2:11 3:12 4:13 5:1 6:2
    !
    !
    !
    ephone 2
     Mac-address 0006.D74B.1361
     button 1:15 2:10 3:11 4:12 5:13
     speed-dial 1 1000
    !
    
  4. Les balises de bouton renvoient aux balises d'ephone-dn. La sortie de commande d'ephone d'exposition devrait ressembler à la sortie ci-dessous.

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.14 52311 Telecaster 7960 keepalive 6 max_line 6
    button 1: dn 10 number 1111 IDLE 
    button 2: dn 11 number 1111 IDLE 
    button 3: dn 12 number 1111 IDLE 
    button 4: dn 13 number 1111 IDLE 
    button 5: dn 1 number 1000 IDLE 
    button 6: dn 2 number 1000 IDLE 
    Username: gpburdell Password: letmein 
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 50512 Telecaster 7960 keepalive 7 max_line 6
    button 1: dn 15 number 1001 IDLE 
    button 2: dn 10 number 1111 IDLE 
    button 3: dn 11 number 1111 IDLE 
    button 4: dn 12 number 1111 IDLE 
    button 5: dn 13 number 1111 IDLE 
    speed dial 1:1000
    
    its-router#
    Ephone 1 Ephone 2
    Ligne 1 1111 Ligne 1 1001
    Ligne 2 1111 Ligne 2 1111
    Ligne 3 1111 Ligne 3 1111
    Ligne 4 1111 Ligne 4 1111
    Ligne 5 1000 Ligne 5 1111
    Ligne 6 1000 Ligne 6 George P Burdell

  5. Quand un appel entre à 1111, il sonne jusqu'à ce que quelqu'un le prenne (aucun transfert d'appels configuré). Si ephone-dn 10 (la ligne 1 sur l'ephone 1 ou la ligne 2 sur l'ephone 2) est en service, alors le prochain appel à 1111 va automatiquement à l'ephone-dn 10, parce qu'aucun huntstop n'est configuré et la préférence est plus élevée (la préférence par défaut est 0). Si les préférences étaient identiques, alors les deux lignes sonneraient.

  6. Si un appel est placé à 1000 et personne ne reprend, il roulera à la messagerie vocale (extension 5222 dans ce transfert d'appel installé). Si l'ephone-dn 1 est en service, le prochain appel obtient conduit à l'ephone-dn 2. C'est en raison du routage régulier de cadran-pair et du fait qu'aucun huntstop n'est configuré. Il n'est pas nécessaire d'avoir un établissement en avant-occupé dans ce cas, à moins que vous ayez voulu que l'appel expédiât à un DN différent totalement si occupé (par exemple, si 1000 est occupé, expédiez alors à 1001). Sur l'ephone-dn 2, vous devez configurer le transfert d'appel pour occupé et pas de réponse, parce qu'il n'y a aucune autre extension 1000 avec une préférence plus élevée à conduire à (même s'il y avait, vous faites configurer implicitement le huntstop, ainsi l'appel finirait là).

Pour plus d'informations sur le routage normal de cadran-pair, référez-vous à l'assistance technique concernant la technologie de voix.

Ephone 1 a également un nom d'utilisateur et mot de passe pour le « gpburdell. » Ceci permettra à l'utilisateur pour accéder à et à la procédure de connexion à la même page Web de telephony_service.html et pour changer son expédition (occupé, pas de réponse, tous) et cadrans de vitesse, aussi bien qu'exécute des recherches de répertoire local.

Ephone 2 a un cadran de vitesse sur la ligne 6. Si ce bouton est appuyé sur, 1001 composent 1000. La commande de numérotation abrégée elle-même ne spécifie pas l'emplacement de bouton. Il indique, dans ce cas, que la première ligne libre sera un cadran de vitesse pour numéro 1000. Le fait qu'il s'avère justement être la ligne 6 n'est pas directement configuré. Si un autre cadran de vitesse étaient configurés (la « vitesse composent 2 1004," par exemple), il ne génèrerait pas une erreur, mais il n'afficherait pas, non plus.

Quelques autres commandes de configuration pour des ephone-dn les ont répertorié ci-dessous.

its-router(config-ephone-dn)# ?
Ephone DN configuration commands:
  application   The selected application
  call-forward  Define E.164 telephone number for call forwarding
  caller-id     Configure port caller id parameters
  cor           Class of Restriction on dial-peer for this dn
  default       Set a command to its defaults
  description   dn desc, for DN Qualified Display Name
  exit          Exit from ephone-dn configuration mode
  hold-alert    Set Call On-Hold timeout alert parameters
  huntstop      Stop hunting on Dial-Peers
  intercom      Define intercom/auto-call extension number
  loopback-dn   Define dn-tag to create loopback dn pair with this ephone-dn
  mwi           set message waiting indicator options (mwi)
  name          Define dn user name
  no            Negate a command or set its defaults
  number        Define E.164 telephone number 
  paging        set audio paging mode
  preference    Preference for the attached dial-peer for the primary dn number
  translate     Translation rule

its-router(config-ephone-dn)#

Affichées ci-dessous sont d'autres commandes de configuration pour des ephones.

Its-router(config-ephone-dn)# ephone 1
its-router(config-ephone)# ?
Ethernet phone configuration commands:
  button        define button to dn map
  default       Set a command to its defaults
  exit          Exit from ephone configuration mode
  Mac-address   define ethernet phone MAC address
  no            Negate a command or set its defaults
  paging-dn     set audio paging dn group for phone
  reset         reset ethernet phone
  speed-dial    Define ip-phone speed-dial number
  username      define username to access ethernet phone from Web
  vm-device-id  define voice-mail id string

its-router(config-ephone)#

attention Attention : Après n'importe quelle modification à l'ephone ou à l'ephone-dn, les téléphones auxquels les modifications s'appliquent doit être remis à l'état initial. Ceci peut être fait sous l'ephone lui-même avec la commande de remise, ou globalement sous le menu de configuration de service téléphonique comme décrit plus tôt.

Cisco SA configuration pour les 7910 téléphones IP

À la différence des 7960 téléphones IP, les 7910 a seulement un bouton de ligne. Pour prendre en charge la mise en attente et le transfert à ce téléphone, deux lignes sont exigées. Ainsi pour ce téléphone, vous pouvez configurer deux lignes avec le même DN comme suit :

ephone-dn  20
 number 1020
 no huntstop
!
!
ephone-dn 21
 number 1020
 preference 1
!
...
ephone 10
 button 1:20 2:21
!

Quoique ce soient deux la ligne apparences, il n'est pas possible de placer chacun des deux lignes sur l'attente en même temps. Quand la ligne principale est sur l'attente, appuyer sur le bouton de ligne sélectionne la deuxième ligne et un deuxième appel peut être placé (ou répondu). Une fois que le deuxième appel est connecté, appuyer sur le bouton de mise en attente placera le deuxième invitent l'attente et rebranchent la ligne principale. Appuyant sur le bouton de mise en attente de nouveau alternera les lignes primaires et secondaires. Appuyant sur le bouton de ligne de nouveau déconnectera l'interlocuteur actuellement connecté.

Configurant l'administration par le Web de Cisco SON routeur

Pour gérer correctement Cisco SON serveur par le Web, aussi bien que permettre à des utilisateurs finaux pour gérer leurs téléphones par le Web, les fichiers suivants doit être présent dans l'éclair :

  • admin_user.html

  • ephone_admin.html

  • logohome.gif

  • normal_user.html

  • telephony_service.html

Pour permettre la gestion des pages Web par le Web, les commandes suivantes de configuration globale doivent être sélectionnées :

ip http server
  ip http path flash

D'autres commandes doivent être sélectionnées sous la section de configuration de service téléphonique.

telephony-service
 admin-username administrator 

 !--- This sets up the administrator account used to access the web page.

 admin-password cisco  

 !--- This sets up the password for the admin account.

 dn-webedit    

 !--- (optional) This permits the editing of DNs through the web interface.

 time-webedit  

 !--- (optional) This permits editing of the system time through the web interface.

!

Pour accéder à Cisco SON routeur par le Web, indiquent votre navigateur l'URL suivant :

http://ITSrouter_ipaddr/telephony_service.html

L'URL est identique pour chacun. D'autres fichiers de .html sont considérés les fichiers internes appelés par la page Web de telephony-service.html. Appeler d'autres fichiers directement peut mener aux erreurs de Javascript. Des utilisateurs qui doivent utiliser la page Web doivent être configurés d'abord sur l'ephone, comme affiché ci-dessous.

ephone 1
 username "gpburdell" password letmein

L'utilisateur (dans ces exemple, « gpburdell ») peut ouvrir une session et changer leurs informations d'expédition, exécute des recherches dans le répertoire, et configure même leurs propres configurations de cadran de vitesse. Il y a d'aide en ligne disponible, aussi bien.

Les administrateurs peuvent exécuter le téléphone ou le DN ajoute, supprime, et des modifications, aussi bien que quelques évolutions des systèmes. Notez qu'il peut y avoir des problèmes si vous configurez par le Web aussi bien que par la ligne de commande, parce que la page Web ne vote pas la configuration du logiciel de Cisco IOS périodiquement, ni fait le bouton de régénération sur la mise à jour de navigateur ces informations. En fait, en essayant de régénérer de cette façon, vous êtes enregistré hors de la page GUI et voyez qu'on ne permet pas la « modification de configuration a manqué, modification de configuration » la case de message d'erreur. Seulement le bouton de mise à jour sur le menu principal récupère les dernières modifications de Cisco SON routeur.

De la page Web, le bouton de configuration système d'inscription cause des modifications d'être écrites immédiatement à NVRAM. Cependant, pour les utilisateurs réguliers, les modifications sont écrites toutes les 10 minutes tant que il n'y a aucune session active sur vty, console, et lignes aux.

Remarque: Pour que la mise à jour fonctionne, satisfaire assurez-vous qu'au moins quatre lignes vty libres sont disponibles à Cisco SON, quoiqu'une ligne vty libre soit suffisante pour les modifications de configuration normales.

Les informations de historique d'appel sont également à la disposition des administrateurs. D'abord il doit être activé en configurant comme suit :

call-history-mib retain-timer 500
call-history-mib max-size 500

Tout au plus, 500 entrées et 500 minutes d'historique d'appel sont retenues dans la table MIB.

Vous pouvez visualiser les enregistrements d'appel en choisissant la configuration système de vue du GUI après avoir ouvert une session, et puis en choisissant les informations de historique d'appel de vue.

Configurant la connexion PSTN sur Cisco SON routeur

Supposant que le SON routeur a des cartes d'interface vocale, vous voudrez maintenant configurer cartes de sorte que des appels puissent être placés à et des Téléphones IP. Ce n'est pas sensiblement différent que d'autres connexions vocales sur un routeur. Vous pouvez penser aux ephones avec les nombres qui ont été assignés à chaque ephone-dn comme ports du Foreign Exchange Station (FXS) sur les Routeurs.

Configurer d'autres SES caractéristiques

Configuration de fonction de mise en attente

Une fonctionnalité supplémentaire pour les appelants extérieurs est la musique d'attente (MoH) /Tone sur l'attente (ToH). ToH est toujours en fonction par défaut et ne peut pas être désactivé. Le MoH peut être fourni au réseau téléphonique public commuté (PSTN) ou aux appels G.711 sur le réseau qui sont placés sur l'attente. Appelle du téléphone IP au téléphone IP sur le même SON routeur qui sont placés sur l'attente entendent toujours seulement le bip de ToH. Pour le MoH, après vérification que le fichier audio existe dans l'éclair, configurez comme suit :

telephony-service
 moh music-on-hold.au

Le fichier .au ou .wav lu pour le MoH doit être dans G.711 le format d'u-law ou d'a-law. Afin de distinguer la mise en attente du ToH, la tonalité d'attente est entendue en tant que bips périodiques, avec un intervalle de 10 secondes entre les bips. S'il y a des plusieurs lignes de mise en attente, seulement une tonalité est envoyée toutes les 10 secondes. Le ToH, cependant, est entendu à intervalles périodiques de toutes les 8 secondes et se compose de trois bips (une tonalité simple répétée trois fois). ToH a la priorité plus élevée que la tonalité d'attente. Si les deux tonalités sont jouées exactement au même temps, un utilisateur d'abord, puis entendra le ToH dans des 8 secondes, un ToH différent, et finalement en deux secondes supplémentaires, une tonalité d'attente.

Une fois des appels sont placés sur l'attente, là sont plusieurs options, affichées ci-dessous, pour envoyer des notifications audibles aux utilisateurs qu'un appel est toujours en fonction attente.

Its-router(config-ephone-dn)# hold-alert 15 ?
  idle        alert on-hold originator only if idle
  originator  alert on-hold originator always
  shared      alert all phones that share the line

Une un-deuxième alerte de sonnerie à l'intervalle configuré (toutes les 15 à 300 secondes) peut être configurée pour être envoyée toujours à l'interlocuteur qui a placé l'appel sur l'attente, ou pour être envoyée seulement si cet interlocuteur est de veille. Une autre option est de configurer l'alerte à envoyer à tous les téléphones qui partagent la même ligne. La valeur par défaut est pour pas vigilant, n'importe comment long un appel a été sur l'attente.

Configuration de Conférences

Des Conférences à trois voies sont prises en charge tant que tous les interlocuteurs sont G.711 des utilisateurs et des ressources en conférence sont disponible. Des ressources en conférence sont configurées comme suit :

telephony-service
 max-conferences 10

Si un des interlocuteurs dans une conférence appuie sur l'attente, les deux autres interlocuteurs entendront le MoH ou le ToH. Cependant, ils pourront également parler entre eux, avec la musique ou la tonalité jouant à l'arrière-plan.

Configuration de transfert

La capacité de transférer des appels d'arrivée exige souvent la configuration supplémentaire. Par défaut, Cisco Son-a enregistré des Téléphones IP peut transférer vers d'autres Téléphones IP enregistrés au même SON routeur. D'autres transferts, aux destinations PSTN ou VoIP, sont refusés. Pour activer ces types de transferts, des transfert-modèles doivent être configurés sous le service téléphonique comme suit :

Telephony-service
 transfer-pattern 9.......

Maintenant, supposant qu'il y a un cadran-pair de pots pour conduire les appels au PSTN, un téléphone IP peut maintenant transférer des appels vers tout nombre de sept-chiffre en composant 9 premiers. Il n'y a aucune option pour la tonalité secondaire avec le SON.

attention Attention : Soyez particulièrement prudent quand les transferts d'appels qui sont entrés par un port du Foreign Exchange Office (FXO) sur le SON routeur et sont sortis par un autre port FXO, parce que ceci peut faire rester les deux ports en service même après que les deux interlocuteurs ont raccroché. Référez-vous compréhension derrière le problème de débranchement FXO. Si votre fournisseur ne peut pas prendre en charge une forme de supervision de débranchement avec FXO, alors ne permettez pas les transferts de nouveau au PSTN.

Pour transférer/appels en avant qui arrivent d'une autre destination VoIP (telle qu'un autre SON routeur), un bouclage-dn est exigé. C'est un sujet avancé hors de portée de ce document.

Configuration d'intercom

La fonction intercom permet une caractéristique d'appel entre deux Téléphones IP. Il n'est pas pris en charge sur les lignes partagées, signifiant qu'un ephone-dn qui est configuré pour l'exécution d'intercom doit seulement être associé avec un téléphone IP.

!
ephone-dn 30
number A1234
name "Intercom"
intercom A4321 label "Office A"
!
!
ephone-dn 31
number A4321
name "Intercom"
intercom A1234 label "Office B"
!
...
!
ephone 3
Mac-address 0006.D74B.107C
button 1:16 6:30
!
!
!
ephone 4
Mac-address 0008.E31B.7A8A
button 1:17 6:31
!

Maintenant, quand l'ephone 4 appuie sur la ligne 6, un appel est placé pour rayer 6 d'ephone 3 (par exemple, il appelle A1234 automatiquement). Par défaut, si le téléphone de destination est avec combiné raccroché, puis il disparaît le hors fonction-crochet, va au mode haut-parleur, et met en sommeil son microphone. D'autres options dans la commande d'intercom sont insertion-dans et NO--automatique-réponse. Insertion-dans l'option permet à l'appel intercom d'arrivée pour forcer un appel existant dans l'état en attente. Le téléphone répond alors à l'appel intercom immédiatement. L'option de NO--automatique-réponse fait sonner simplement l'appel intercom, au lieu d'être automatiquement pris.

Avec tous les appels intercom, l'étiquette configurée avec la déclaration d'intercom apparaît du côté droit de l'affichage, tout comme un cadran de vitesse. Sans option d'étiquette, le nom (si configuré sur l'ephone-dn) apparaît du côté gauche de la ligne affichage, alors que le nombre d'intercom est affiché du côté droit.

Remarque: Cisco ne recommande pas l'utilisation de Cisco 7910 pour la fonctionnalité d'intercom, parce que le téléphone n'a pas un microphone et le haut-parleur ne peut pas être désactivé sourdine, ainsi le combiné téléphonique doit être sélectionné jusqu'à la réponse.

Pagination de la configuration

La caractéristique de pagination fonctionne tout comme la fonction intercom précédemment décrite, sauf qu'elle fournit seulement un flux voix à sens unique sans l'option de presse-à-réponse. Seulement des téléphones de veille sont atteints par la pagination ; les téléphones en service ne recevront pas la page. La pagination prend en charge la distribution sonore utilisant l'unicast, la Multidiffusion (jusqu'à dix périphériques), ou chacun des deux (de sorte que l'audio puisse atteindre les téléphones qui ne peuvent pas être accédés par la Multidiffusion). La pagination de Multidiffusion est recommandée. Chaque extension de pagination exige une seule adresse de Protocole IP Multicast.

Par exemple, dites que trois groupes de pagination sont créés : « Personnes fraîches, » « personnes sophistiquées, » et « toutes les personnes, » qui sont simplement la somme des deux premiers groupes. La Multidiffusion est la méthode sonore de la livraison, ainsi vous configureriez ce qui suit :

!
ephone-dn 40
 number 4001
 name "Cool People"
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn 41
 number 4002
 name "Uncool People"
 paging ip 239.0.1.21 port 2000
! 
!
ephone-dn 42
 number 4000
 name "All People"
 paging ip 239.0.1.22 port 2000
 paging group 40,41
!

Remarque: Les Téléphones IP ne prennent en charge pas la Multidiffusion aux adresses 224.x.x.x.

Maintenant configurez et assignez chaque ephone à un DN de pagination comme affiché ci-dessous (configuration supplémentaire sur chaque ephone omis). Souvenez-vous que chaque téléphone IP peut appartenir à seulement un groupe de pagination. En outre, l'ephone-dn configuré pour paginer ne doit pas être assigné à une touche du téléphone.

!
ephone 1
 paging-dn 40
!
ephone 2
 paging-dn 40
!
ephone 3
 paging-dn 41
!
ephone 4
 paging-dn 41
!
ephone 5
 paging-dn 42
!

Avec cette configuration, vous avez assigné le numéro de page 4001 (« personnes fraîches ») aux ephones 1 et 2, le numéro de page 4002 (« personnes sophistiquées ») aux ephones 3 et 4, et le numéro de page 4000 (« toutes les personnes ») aux ephones 1 5.

N'importe quel appel à 4001 se connecte aux ephones 1 et 2 (s'ils ne sont pas occupés) par exemple.

Remarque: La pagination est prise en charge un maximum d'un saut de routeur à partir du SON routeur.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Les ordres de service téléphonique d'exposition répertoriés ci-dessous (particulièrement tous) te donneront un instantané de la configuration.

its-router# show telephony-service ?
  admin        Show telephony-service admin username and password
  all          Show telephony-service details
  dial-peer    Show telephony-service dialpeers 
  ephone       Show ephone configuration
  ephone-dn    Show ephone-dn configuration
  voice-port   Show telephony-service voice ports
  |            Output modifiers
<cr>

Les commandes d'ephone d'exposition les ont répertorié te donnent ci-dessous l'état actuel des Téléphones IP. Le plus souvent, l'ephone d'exposition est par lui-même tout ce qui est nécessaire.

Its-router# show ephone ?
  7910              7910 phone status
  7940              7940 phone status
  7960              7960 phone status
  H.H.H             mac address
  dn                Dn with tag assigned
  offhook           Offhook phone status
  registered        Registered ephone status
  remote            non-local phones (with no arp entry)
  ringing           Ringing phone status
  summary           Summary of all ephone
  tapiclients       Ephone status of tapi client
  telephone-number  Telephone number assigned
  unregistered      Unregistered ephone status
  |                 Output modifiers
  <cr>

La sortie de commande d'ephone-dn d'exposition regardera très semblable à la sortie de commande de show voice port. Pour la plupart des problèmes courants, cette commande n'est pas aussi utile que certains des autres outils.

Its-router# show ephone-dn ? 
  <1-960>   dn tag
  loopback  Show ephone-dn in loopback mode
  summary   Summary of all ephone-dn
  |         Output modifiers
  <cr>

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

Cisco SON a quelques commandes de dépannage supplémentaires et les met au point qui peuvent faciliter collectant les informations beaucoup.

Il y a quelques uns met au point qui peut être des problèmes utiles de pour le dépannage. La commande d'ephone de débogage est la seule commande de Son-particularité de Cisco à cet égard.

Its-router# debug ephone ?
  alarm       Enable ephone alarm message debugging
  detail      Enable ephone detail debugging
  error       Enable ephone error debugging
  keepalive   Enable ephone keepalive debugging
  loopback    Enable ephone loopback debugging
  moh         Enable ephone music-on-hold debugging
  mwi         Enable ephone mwi debugging
  pak         Enable ephone packet debugging
  raw         Enable ephone raw protocol debugging
  register    Enable ephone registration debugging
  state       Enable ephone state debugging
  statistics  Enable ephone statistics debugging

Pour la plupart des situations, pour le dépannage un problème entre un ou deux téléphones, il est utile d'émettre le debug ephone error et les ordres de debug ephone state, à moins que le problème implique spécifiquement l'enregistrement, l'indicateur de message en attente (MWI), ou le MoH. S'il y a beaucoup de téléphones, alors c'est une bonne idée de limiter la sortie seulement aux adresses MAC appropriées. Exemple :

its-router# debug ephone state Mac-address 0009.433C.E5EC
EPHONE state debugging is enabled for phone 0009.433C.E5EC

Les problèmes tels qu'appeler les destinations distantes VoIP peuvent exiger les commandes de débogage supplémentaires qui sont plus générales au VoIP sur des Routeurs de Cisco, tels que le debug voip ccapi inout et les commandes debug vtsp all. Des particularités pour dépanner la signalisation PSTN et d'autres éléments d'implémentation-particularité ne sont pas couverts dans ce document. Pour plus d'informations, référez-vous aux documents suivants :

Voici une sortie de commande de debug ephone state témoin pour un appel à partir de 1004 à 1002. La partie appropriée de la sortie de commande d'ephone d'exposition est affichée ci-dessous.

ephone-3 Mac:0006.D74B.107C TCP socket:[5] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.12 51718 Telecaster 7960 keepalive 92 max_line 6
button 1: dn 16 number 1002 IDLE 


ephone-4 Mac:0008.E31B.7A8A TCP socket:[2] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.13 50396 Telecaster 7960 keepalive 96 max_line 6
button 1: dn 17 number 1004 IDLE

Maintenant vous pouvez examiner le débogage. Le message OFFHOOK est vu, l'appel est placé (vous ne voyez pas différents chiffres capturés dans ce suivi), et on lui répond. Les messages de canal d'OpenReceive sont envoyés à chaque téléphone et plus tard sont reconnus ; un message de StartMedia indique à chaque téléphone à quels adresse IP et port pour envoyer l'audio. En fin de compte, le message ONHOOK est vu.

Its-router# debug ephone state
EPHONE state debugging is enabled
its-router#
Sep 26 18:39:40.837: ephone-4[2]:OFFHOOK
Sep 26 18:39:40.837: ephone-4[2]:SIEZE on activeline 0
Sep 26 18:39:40.837: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOffHook
Sep 26 18:39:40.837: DN 17 Voice_Mode
Sep 26 18:39:40.837: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:42.349: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:42.853: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.105: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-4[2]:Skinny-to-Skinny call DN 17 to DN 16 instance 1
Sep 26 18:39:43.609: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsRingOut
Sep 26 18:39:43.609: ephone-4[2]:Call Info DN 17 line 1 ref 52 called 1002 calling 1004 
origcalled calltype 2
Sep 26 18:39:43.609: ephone-4[2]: John Doe calling 
Sep 26 18:39:43.609: ephone-4[2]: Jane Doe
Sep 26 18:39:43.609: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsRingIn
Sep 26 18:39:43.613: ephone-3[5]:Call Info DN 16 line 1 ref 53 called 1002 calling 1004 
origcalled calltype 1
Sep 26 18:39:43.613: ephone-3[5]: John Doe calling 
Sep 26 18:39:43.613: ephone-3[5]: Jane Doe
Sep 26 18:39:43.613: ephone-3[5]:Ringer Inside Ring On
Sep 26 18:39:43.613: dn_tone_control DN=17 tonetype=36:DtAlertingTone onoff=1 pid=113
Sep 26 18:39:51.926: ephone-3[5]:OFFHOOK
Sep 26 18:39:51.926: ephone-3[5]:Ringer Off
Sep 26 18:39:51.926: ephone-3[5]:ANSWER call
Sep 26 18:39:51.926: ephone-3[5]:Answer Incoming call from ephone-(4) DN 17
Sep 26 18:39:51.926: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:OpenReceive DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: ephone-3[5]:OpenReceive DN 16 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:51.930: DN 17 End Voice_Mode
Sep 26 18:39:51.930: DN 17 Voice_Mode
Sep 26 18:39:51.930: DN 16 Voice_Mode
Sep 26 18:39:51.930: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:52.182: ephone-4[2]:OpenReceiveChannelAck:IP 10.1.150.13, port=23094, 
dn_index=17, dn=17
Sep 26 18:39:52.182: ephone-3[5]:StartMedia 10.1.150.13 port=23094
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:52.182: ephone-3[5]:OpenReceiveChannelAck:IP 10.1.150.12, port=22778, 
dn_index=16, dn=16
Sep 26 18:39:52.182: ephone-4[2]:StartMedia 10.1.150.12 port=22778
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:40:01.254: ephone-3[5]:ONHOOK
Sep 26 18:40:01.254: ephone-4[2]:CloseReceive
Sep 26 18:40:01.254: ephone-4[2]:StopMedia
Sep 26 18:40:01.254: ephone-3[5]:call clean up this DN 16 was called by other DN 17
Sep 26 18:40:01.254: this ephone-3 other ephone-(4) other DN state CONNECTED
Sep 26 18:40:01.254: ephone-3[5]:CloseReceive
Sep 26 18:40:01.254: ephone-3[5]:StopMedia
Sep 26 18:40:01.254: DN 16 End Voice_Mode
Sep 26 18:40:01.254: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsOnHook
Sep 26 18:40:01.254: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.254: DN 17 End Voice_Mode
Sep 26 18:40:01.254: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOnHook
Sep 26 18:40:01.254: ephone-4[2]:SpeakerPhoneOnHook
Sep 26 18:40:01.258: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.354: DN 16 Voice_Mode
Sep 26 18:40:01.354: DN 16 End Voice_Mode
Sep 26 18:40:01.354: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:40:01.366: SkinnyReportDnState DN 17 ONHOOK
Sep 26 18:40:01.366: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113

Informations connexes


Document ID: 25100