Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette sur ATM (MPLS sur ATM)

MPLS sur Cisco Catalyst 8540 MSR Enhanced ARM (ARM 2) à l'aide de PVP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour la commutation multiprotocole de couche (MPLS) sur le module routeur ATM amélioré par Catalyst 8540 (BRAS). La fonction principale du module de BRAS est d'augmenter la capacité en connectant deux mondes différents - paquet/commutation (qui est trame en fonction) et atmosphère (qui est cellulaire). Cette fonctionnalité a pu être aussi bien étendue au MPLS. Le Catalyst 8540 MSR avec un ARMÝ amélioré peut être installé à la périphérie d'un paquet et au réseau cellulaire avec les deux modes MPLS activés dans le même châssis. Le BRAS amélioré (ARM2) sur le Catalyst 8540 MSR est exigé pour la fonctionnalité du routage de périphérie d'étiquette (LER) sur des interfaces ATM - il agit en tant qu'interface de proxy pour chaque interface ATM entrante et sortante dans le chemin de commutateur d'étiquette (LSP) pour faire le traitement de paquets MPLS. Le Catalyst 8540 approprié idéalement au cellule-mode à l'intégration du mode trame MPLS (accomplie en déployant le module routeur ATM amélioré). Jusqu'à deux cartes ARM2 peuvent être utilisées dans un châssis unique.

Ce document fournit des exemples de deux configurations différentes qui expliquent l'utilisation du BRAS 2.

  • Utilisant l'ARMÝ amélioré pour le mode de cellules (terminant mode MPLS de cellules sur le BRAS 2)
  • Utilisant l'ARMÝ amélioré pour le mode trame MPLS au-dessus de l'atmosphère au-dessus du tunnel vp atmosphère.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document. L'OSPF a été utilisé comme protocole de routage interne.

Diagramme du réseau

Ce document utilise la configuration réseau affichée dans le diagramme ci-dessous :

Le diagramme ci-dessus est utilisé pour les scénarios suivants :

  • Utilisant l'ARMÝ amélioré pour le mode de cellules (terminant mode MPLS de cellules sur le BRAS 2)
  • Utilisant l'ARMÝ amélioré pour le mode trame MPLS au-dessus de l'atmosphère au-dessus du tunnel vp atmosphère.
Notez que la configuration pour le mode de cellules utilise le chemin C8540MSR-2 à C8510MSR-3 à C8540MSR-1, alors que les configurations décrites dans ce document pour le mode trame emploie le tunnel vp pour connecter C8540MSR-2 et C8540MSR-1.

Composants utilisés

Les configurations décrites dans ce document ont été développées et testées utilisant le logiciel et les versions de matériel ci-dessous.
  • Deux Cisco C8540 MSR, version 12.1(10)EY de Cisco IOS® (256 DRACHMES de Mo)
  • Cisco C8510 MSR, version 12.1(7a)EY1 de version IOS (64 DRACHMES de Mo)
  • C8540-ARM2 (module routeur ATM amélioré)
  • WAI-OC3-4MM (4 linecard de port OC-3)
  • C85MS-4F-OC12MM (linecard d'OC-12 de 4 ports)
Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Utilisant l'ARMÝ amélioré pour le mode MPLS de cellules

Sur le cellule-mode du Catalyst 8540 MSR LE MPLS est pris en charge sur tous les travaux d'andÝ d'interfaces ATM parallèlement à la Signalisation ATM (telle que l'ILMI) et au routage atmosphère (PNNI). Le cellule-mode MPLS est activé en ajoutant le MPLS que l'andÝ de commande d'interface d'IP (ou IP de balise-commutation dans des versions IOS plus anciennes) exige l'établissement d'un circuit virtuel unidirectionnel d'étiquette (LVC), ou un circuit virtuel de balise (TVC) pour chaque classe d'équivalence de transfert (FEC) ou une destination IP. Des circuits virtuels d'étiquette sont connus comme tête de réseau LVC au créateur LER, la fin LVC à la destination LER, et le transit LVC au LSR.Ý au cas où un Cat8540 MSR agirait en tant qu'atmosphère pure LSR (routeur MPLS P), la CPU n'établit pas la tête de réseau LVC pour les artères apprises dans le noyau atmosphère. Le trafic qui provient de la CPU et est destiné à un distant LSR est envoyé au-dessus du circuit virtuel de contrôle MPLS. Une interface ATM pourrait être liée à un port ARM2 et le LVC se terminera sur le port ARM2 si c'est le cas. En fait, en liant une interface ATM à un port ARM2, l'ARM2 agit en tant qu'atmosphère LER (routeur PE MPLS) et initiera la tête de réseau LVC (terminant LVC) pour les artères apprises dans le noyau atmosphère.

Des interfaces ATM, l'atmosphère VP et les tunnels hiérarchiques VP peuvent être configurés pour se terminer sur le port ARM2 (disponible sur la plate-forme de 8540 MSR seulement). Pour l'Équilibrage de charge, des interfaces ATM peuvent être liées à l'un ou l'autre des deux ports d'un BRAS amélioré. Pour terminer le mode MPLS de cellules sur un port ARM2, utilisez la commande de configuration d'interface de l'interface ATMx/y/z de MPLS-expédition, où ATMx/y/z est le port amélioré de BRAS). Cette commande s'applique à l'interface principale seulement.

Configurations

C8540MSR-2 (Catalyst 8540MSR)
C8540MSR-2#show hardware
C8540 named c8540MSR-2, Date: 04:46:41 UTC Mon Feb 10 2003

Slot Ctrlr-TypeÝÝÝ Part No.Ý RevÝ Ser NoÝ Mfg DateÝÝ RMA No. Hw VrsÝ Tst EEP
---- ------------Ý ---------- -- -------- --------- -------- ------- --- ---
Ý0/* Super CamÝÝÝÝ 73-2739-03 B0 03170SXG Apr 27 99 0ÝÝÝÝÝÝÝÝÝ 3.0ÝÝÝÝÝ
Ý0/1 155MM PAMÝÝÝÝ 73-1496-03 A0 09006167 Aug 01 95 00-00-00ÝÝ 3.1ÝÝÝÝ 0ÝÝ 2
Ý2/* OCM BoardÝÝÝÝ 73-2833-06 A0 03210XWB May 26 99 0ÝÝÝÝÝÝÝÝÝ 6.0
Ý2/0 QUAD 622 GenÝ 73-2852-05 A0 03210YN8 May 26 99 0ÝÝÝÝÝÝÝÝÝ 5.0
Ý9/* ETHERNET PAMÝ 73-3754-05 A0 03374A9K Mar 17 99 0ÝÝÝÝÝÝÝÝÝ 4.1
12/* CMPM CardÝÝÝÝ 73-3944-05 A0 04209EX0 Aug 29 00 0ÝÝÝÝÝÝÝÝÝ 5.0ÝÝÝÝÝ
12/0 ARM2 PAMÝÝÝÝÝ 73-5533-01 A0 0424A160 Aug 29 00 0ÝÝÝÝÝÝÝÝÝ 5.1
12/1 ARM2 PAMÝÝÝÝÝ 73-5533-01 A0 0424A183 Aug 29 00 0ÝÝÝÝÝÝÝÝÝ 5.1ÝÝÝÝ
C8540MSR-2#conf t
Enter configuration commands, one per line.Ý End with CNTL/Z.
C8540MSR-2(config)#int atm 0/1/2Ý 
C8540MSR-2(config-if)#mpls ipÝ 
! Cell mode MPLS enabled 
C8540MSR-2(config-if)#ip add 10.254.14.237 255.255.255.252 
C8540MSR-2(config-if)#mpls label protocol ldp 
! LDP enabled on the interface 
C8540MSR-2(config-if)#end       
C8540MSR-2#show atm vc int atm 0/1/2 
         InterfaceÝÝÝÝÝÝÝÝ VPIÝ VCIÝÝ TypeÝÝ X-InterfaceÝÝÝÝÝ X-VPI X-VCI EncapÝ StatusÝ 
ATM0/1/2ÝÝÝÝÝÝÝÝÝ 0ÝÝÝ 5ÝÝÝÝ PVCÝÝÝ ATM0ÝÝÝÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 57ÝÝÝ QSAALÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝÝÝ 0ÝÝÝ 16ÝÝÝ PVCÝÝÝ ATM0ÝÝÝÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 37ÝÝÝ ILMIÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝÝÝ 0ÝÝÝ 18ÝÝÝ PVCÝÝÝ ATM0ÝÝÝÝÝÝÝÝÝÝÝÝ 0ÝÝÝÝ 202ÝÝ PNNIÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝÝÝ 0ÝÝÝ 32ÝÝÝ PVCÝÝÝ ATM0ÝÝÝ     ÝÝÝÝ 0Ý ÝÝ 256ÝÝÝSNAPÝÝ UP  
C8540MSR-2#show mpls int atm 0/1/2
InterfaceÝÝÝÝÝÝÝÝÝÝÝÝÝ IPÝÝÝÝÝÝÝÝÝÝÝ TunnelÝÝ Operational
ATM0/1/2ÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝ (ATM labels)
C8540MSR-2#show mpls int atm 0/1/2 det
Interface ATM0/1/2:Ý 
       IP labeling enabled (ldp) 
       LSP Tunnel labeling not enabledÝ 
       MPLS operationalÝÝÝÝÝÝÝÝ MTU = 4470Ý 
       ATM tagging: Label VPI = 1Ý 
       Label VCI range = 33 - 65535Ý 
       Control VC = 0/32        
C8540MSR-2#conf t
Enter configuration commands, one per line.Ý End with CNTL/Z.
C8540MSR-2(config)#int atm 0/1/2Ý 
C8540MSR-2(config-if)#mpls-forwarding int atm 12/0/1Ý 
! Terminate Cell mode MPLS on ARM2 
C8540MSR-2(config-if)#endÝ        
C8540MSR-2#show atm vc int atm 0/1/2Ý 

InterfaceÝÝÝÝÝÝ VPIÝ VCIÝÝ TypeÝÝ X-InterfaceÝÝÝX-VPI X-VCI EncapÝ StatusÝ 
ATM0/1/2ÝÝÝÝÝÝÝ 0ÝÝÝ 5ÝÝÝÝ PVCÝÝÝÝATM0ÝÝÝÝÝÝÝÝÝÝÝ0ÝÝÝ 57ÝÝÝQSAALÝ UPÝ 
ATM0/1/2ÝÝÝÝÝÝÝ 0ÝÝÝ 16ÝÝÝ PVCÝÝÝÝATM0ÝÝÝÝÝÝÝÝÝÝÝ0ÝÝÝ 37ÝÝÝILMIÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝ 0ÝÝÝ 18ÝÝÝ PVCÝÝÝÝATM0ÝÝÝÝÝÝÝÝÝÝÝ0ÝÝ 202ÝÝ PNNIÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝ 0ÝÝÝ 32ÝÝÝ PVCÝÝÝÝATM12/0/1Ý  ÝÝ 2ÝÝ 120ÝÝ SNAPÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝ 1ÝÝÝ 35ÝÝÝ TVC(O) ATM12/0/1ÝÝÝÝÝ 2ÝÝ 121ÝÝ MUXÝÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝ 1ÝÝÝ 36ÝÝÝ TVC(O) ATM12/0/1ÝÝÝÝÝ 2ÝÝ 122ÝÝ MUXÝÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝ 1ÝÝÝ 37ÝÝÝ TVC(O) ATM12/0/1ÝÝÝÝÝ 2ÝÝ 123ÝÝ MUXÝÝÝ UP 
ATM0/1/2ÝÝÝÝÝÝÝ 1ÝÝÝ 41ÝÝÝ TVC(O) ATM12/0/1ÝÝÝÝÝ 2ÝÝ 124ÝÝ MUXÝÝÝ UP        
C8540MSR-2#show mpls int
InterfaceÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ IPÝÝÝÝÝÝÝÝÝÝÝ TunnelÝÝ OperationalÝ 
FastEthernet9/0/0ÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝ 
ATM0/1/2ÝÝÝÝÝÝÝÝÝÝÝÝYes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝÝÝ (ATM labels) 
! Note: ATM labels -> Cell mode 
ATM12/0/0.60ÝÝÝÝ ÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝ

Remarque: La même procédure de configuration affichée ci-dessus devrait être utilisée sur les 8540 deuxièmes MSR (la configuration C8540MSR-1).This n'est pas affichée ici parce que les mêmes étapes sont exigées pour obtenir le MPLS en service.

C8510MSR-3 (Catalyst 8510MSR)
C8510MSR-1#show running-configÝ
Building configuration...
!ÝÝÝÝÝÝÝÝÝ
interface Loopback0
Ýip address 10.254.231.1 255.255.255.255
!
interface ATM0/0/2
Ýip address 10.254.14.245 255.255.255.252
Ýlogging event subif-link-status
Ýno atm ilmi-keepalive
 mpls label protocol ldp
Ýtag-switching ip
!
interface ATM0/0/3
Ýip address 10.254.14.238 255.255.255.252
Ýlogging event subif-link-status
Ýload-interval 30
Ýno atm ilmi-keepalive
Ýmpls label protocol ldp
Ýtag-switching ip
!ÝÝÝÝÝÝÝÝ
router ospf 1
Ýlog-adjacency-changes
Ýnetwork 10.0.0.0 0.255.255.255 area 0.0.0.0

Utilisant le mode trame amélioré MPLS d'ARMÝfor au-dessus du tunnel vp atmosphère

Le Catalyst 8540 MSR avec un linecard amélioré de BRAS peut également exécuter le mode trame MPLS au-dessus de l'atmosphère. Afin d'illustrer l'utilisation du BRAS amélioré dans le mode trame MPLS, visualisez « utilisant le BRAS amélioré pour le mode trame MPLS au-dessus de l'atmosphère perce un tunnel » l'exemple de configuration situé dans ce document. Des tunnels atmosphère VP sont parfois utilisés pour connecter deux sites. Au lieu de configurer VCs individuel, le grand tunnel vp de « canal » peut être utilisé. Afin d'illustrer cette option, qui est normalement utilisée par les sociétés qui ont besoin d'un grand nombre de VCs entre les sites distants, le tunnel vp a été créé entre C8540MSR-1 et C8540MSR-2. Deux 8540MSR's sont directement connectés par l'ATM2/0/0 (l'OC-12, un tunnel vp hiérarchique ATM2/0/0.60 a été utilisé). Chacun des deux ont amélioré le mode trame MPLS de passage de modules de BRAS sur une sous-interface atmosphère. Pour cette raison, des données PVC/aal5snap ont été configurées.

La table ci-dessous affiche les étapes exécutées dans C8540MSR-1 pour configurer le mode trame amélioré MPLS d'ARMÝfor au-dessus du tunnel vp atmosphère.

C8540MSR-1 (Catalyst 8540MSR)
C8540MSR-1#show hardware
C8540 named c8540-r6-1, Date: 04:46:41 UTC Mon Feb 10 2003

Slot Ctrlr-TypeÝÝÝ Part No.Ý RevÝ Ser NoÝ Mfg DateÝÝ RMA No. Hw VrsÝ Tst EEP
---- ------------Ý ---------- -- -------- --------- -------- ------- --- ---
Ý0/* Super CamÝÝÝÝ 73-2739-03 B0 03170SUQ Apr 27 99 0ÝÝÝÝÝÝÝÝÝ 3.0ÝÝÝÝÝÝÝÝÝÝ
Ý0/1 155MM PAMÝÝÝÝ 73-1496-03 A6 03199939 Aug 01 95 00-00-00ÝÝ 3.1ÝÝÝÝ 0ÝÝ 2
Ý2/* OCM BoardÝÝÝÝ 73-2833-06 A0 03210XWB May 26 99 0ÝÝÝÝÝÝÝÝÝ 6.0ÝÝÝÝÝÝÝÝÝÝ
Ý2/0 QUAD 622 GenÝ 73-2852-05 A0 03210YN8 May 26 99 0ÝÝÝÝÝÝÝÝÝ 5.0ÝÝÝÝÝÝÝÝÝÝ
Ý9/* ETHERNET PAMÝ 73-3754-05 A0 031111EO Mar 17 99 0ÝÝÝÝÝÝÝÝÝ 4.1ÝÝÝÝÝÝÝÝÝÝ
11/* CMPM CardÝÝÝÝ 73-3944-05 A0 04209F5E Aug 29 00 0ÝÝÝÝÝÝÝÝÝ 5.0ÝÝÝÝÝÝÝÝÝÝ
11/0 ARM2 PAMÝÝÝÝÝ 73-5533-01 A0 0424A162 Aug 29 00 0ÝÝÝÝÝÝÝÝÝ 5.1ÝÝÝÝÝÝÝÝÝÝ
11/1 ARM2 PAMÝÝÝÝÝ 73-5533-01 A0 0424A17C Aug 29 00 0ÝÝÝÝÝÝÝÝÝ 5.1ÝÝÝÝÝÝÝÝÝÝ
C8540MSR-1#conf t
Enter configuration commands, one per line.Ý End with CNTL/Z.
C8540MSR-1(config)#atm hierarchical-tunnelÝ
C8540MSR-1(config)#atm connection-traffic-table-row index 60 cbr pbr 120000
C8540MSR-1(config)#int atm 2/0/0
C8540MSR-1(config-if)#atm pvp 6 hierarchical rx-cttr 60 tx-cttr 60
C8540MSR-1(config-if)#int atm 2/0/0.60
C8540MSR-1(config-subif)#exit
C8540MSR-1(config)#int atm 11/0/0.60 point-to-pointÝ
C8540MSR-1(config-subif)#ip address 10.254.14.10 255.255.255.252
C8540MSR-1(conf-sif)#atm pvc 2 60 pd on encap aal5snap int atm 2/0/0.60 60 60ÝÝÝÝÝÝ
C8540MSR-1(config-subif)#mpls label protocol ldp
C8540MSR-1(config-subif)#mpls ip
C8540MSR-1(config-subif)#end
C8540MSR-1#show atm vc int atm 11/0/0.60 | include ATM2/
ATM11/0/0ÝÝÝÝÝÝÝÝ 2ÝÝÝ 60ÝÝÝ PVCÝÝÝ ATM2/0/0.60ÝÝÝÝÝ 60ÝÝÝ 60ÝÝÝ SNAPÝÝ UP
C8540MSR-1#show mpls int
InterfaceÝÝÝÝÝÝÝÝÝÝÝÝÝ IPÝÝÝÝÝÝÝÝÝÝÝ TunnelÝÝ Operational
ATM0/0/1ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝ (ATM labels)
ATM0/0/2ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝÝÝ NoÝÝÝÝÝÝ NoÝÝÝÝÝÝÝÝÝ (ATM labels)
FastEthernet9/0/4ÝÝÝÝÝ YesÝÝÝÝÝÝÝÝÝÝ NoÝÝÝÝÝÝ NoÝÝÝÝÝÝÝÝÝÝ
ATM0/1/0ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ NoÝÝÝÝÝÝÝÝÝ (ATM labels)
ATM11/0/1ÝÝÝÝÝÝÝÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝÝÝ NoÝÝÝÝÝÝ NoÝÝÝÝÝÝÝÝÝÝ
ATM11/0/0.5ÝÝÝÝÝÝÝÝÝÝÝ Yes (tdp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝÝ
ATM11/0/0.60ÝÝÝÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝ
! Note: no ATM labels -> Frame mode
C8540MSR-1#show mpls int atm 11/0/0.60 det
Interface ATM11/0/0.60:
ÝÝÝÝÝÝÝ IP labeling enabled (ldp)
ÝÝÝÝÝÝÝ LSP Tunnel labeling not enabled
ÝÝÝÝÝÝÝ MPLS operational
ÝÝÝÝÝÝÝ MTU = 4470

C8540MSR-1#show atm vp
InterfaceÝÝÝÝÝÝÝÝ VPIÝ TypeÝ X-InterfaceÝÝÝÝÝÝÝÝ X-VPIÝÝÝÝ Status
ATM2/0/0ÝÝÝÝÝÝÝÝÝ 60ÝÝ PVPÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ HIE. TUNNEL

Configurations

Les configurations de l'ofÝthe le MSR d'éléments pertinents du schéma de réseau sont affichées ci-dessous :
C8540MSR-2 (Catalyst 8540MSR)
C8540MSR-2#show running-configÝ
Building configuration...
!
mpls label protocol ldp
atm hierarchical-tunnelÝ
atm connection-traffic-table-row index 60 cbr pcr 120000

!
interface Loopback0
Ýip address 10.254.225.1 255.255.255.255
!
interface ATM0/1/2
Ýdescription IP subnet 10.254.14.236
Ýip address 10.254.14.237 255.255.255.252
Ýip ospf cost 4
Ýno atm ilmi-keepalive
Ýmpls label protocol ldp
Ýtag-switching ip
Ýmpls-forwarding interface ATM12/0/1
! terminates cell mode MPLS on the ARM moduleÝÝÝÝÝÝÝÝÝ
interface ATM2/0/0
Ýno ip address
Ýno atm ilmi-keepalive
Ýatm pvp 60 hierarchical rx-cttr 60 tx-cttr 60Ý
!
interface ATM2/0/0.60 point-to-point
Ýdescription Hierarchical VP Tunnel for frame mode MPLS over ATM
!ÝÝÝÝÝÝÝÝÝ
interface FastEthernet9/0/0
Ýip address 10.64.0.2 255.255.255.252
Ýload-interval 30
Ýduplex full
Ýspeed 100
Ýtag-switching ip
Ýmpls-forwarding interface ATM12/0/0
! EPIF based FE line cards do not support MPLS natively
! link to ARM2 (ATM 12/0/0) enables MPLS on those cardsÝ
interface ATM12/0/0

Ýdescription Enhanced ARM - ARM2Ý
no ip address

!

interface ATM12/0/0.60 point-to-point

Ýdescription ARM2 subinterface used for Frame mode MPLS over HVPT 60
Ýip address 10.254.14.9 255.255.255.252
Ýatm pvc 2 60 pd onÝ encap aal5snap interfaceÝ ATM2/0/0.60 60 60Ý
Ýmpls label protocol ldp
Ýtag-switching ip
! une sous-interface ARM2 point par point (Point à point) Ýsupported en date de l'onlyÝ de la release 12.1(10)EY IOS
!ÝÝÝ
router ospf 1
Ýrouter-id 10.254.225.1
Ýlog-adjacency-changes
Ýnetwork 10.0.0.0 0.255.255.255 area 0.0.0.0
!ÝÝÝ

Ý
C8540MSR-1 (Catalyst 8540MSR)
C8540MSR-1#show running-configÝ
Building configuration...
sdm sram Label 32768Ý
sdm sram Tag-Cos 32768
!
tag-switching tdp router-id Loopback0
!ÝÝÝÝÝÝÝÝÝ
atm hierarchical-tunnelÝ
atm connection-traffic-table-row index 60 cbr pcr 120000Ý
!ÝÝÝÝÝÝÝÝÝ
interface Loopback0
Ýip address 10.254.232.1 255.255.255.255
!ÝÝÝÝÝÝÝÝÝ
interface ATM0/1/0
Ýip address 10.254.14.246 255.255.255.252
Ýip ospf cost 100
Ýlogging event subif-link-status
Ýno atm ilmi-keepalive
Ýmpls label protocol ldp
Ýtag-switching ip
Ýmpls-forwarding interface ATM11/0/0
!ÝÝÝÝ
interface ATM2/0/0
Ýno ip address
Ýno atm ilmi-keepalive
Ýatm pvp 60 hierarchical rx-cttr 60 tx-cttr 60
!
interface ATM2/0/0.60 point-to-point
Ýno atm ilmi-keepalive
!
interface FastEthernet9/0/4
Ýip address 10.177.1.1 255.255.255.252
Ýtag-switching ip
Ýmpls-forwarding interface ATM11/0/0
!
interface ATM11/0/0
Ýno ip address
!
interface ATM11/0/0.60 point-to-point
Ýip address 10.254.14.10 255.255.255.252
Ýatm pvc 2 60 pd onÝ encap aal5snap interfaceÝ ATM2/0/0.60 60 60Ý
Ýmpls label protocol ldp
Ýtag-switching ip
!
router ospf 1
Ýrouter-id 10.254.232.1
Ýlog-adjacency-changesÝ
Ýnetwork 10.177.1.0 0.0.0.3 area 0.0.0.0
Ýnetwork 10.254.0.0 0.0.255.255 area 0.0.0.0
!ÝÝ
end

Vérifiez

Utilisez les commandes suivantes au verifyÝif que le MPLS est haut et fonctionnant correctement :
  • show mpls interfaces [détail] - Vérifie si un protocole de distribution d'étiquette s'exécute sur l'interface demandée
  • show mpls ldp neighbor - Affiche le statut de sessions LDP/de connexions voisines
  • show mpls ldp discovery - Détermine le statut d'identifiant LDP et d'échange LDP bonjour des interfaces
  • show mpls forwarding-table - Vérifie la table de Forwarding Information Base MPLS (FIB)
  • show mpls ip binding - Vérifie la table de base d'informations d'étiquette IP MPLS (BIBLIOTHÈQUE)
C8540MSR-1#show mpls interfaces 
 InterfaceÝÝÝÝÝÝÝÝÝÝÝÝÝ IPÝÝÝÝÝÝÝÝÝÝÝ TunnelÝÝ Operational 
 ATM0/0/1ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝ (ATM labels)  
 ATM0/1/0ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ YesÝÝÝÝÝÝÝÝ (ATM labels)  
 ATM11/0/0.60ÝÝÝÝÝÝÝÝÝÝ Yes (ldp)ÝÝÝÝ NoÝÝÝÝÝÝ Yes  
C8540MSR-1#show mpls interfaces atm 0/1/0 detail    
   Interface ATM0/1/0: 
ÝÝÝÝÝÝÝ IP labeling enabled (ldp) 
ÝÝÝÝÝÝÝ LSP Tunnel labeling not enabled 
ÝÝÝÝÝÝÝ MPLS operational 
ÝÝÝÝÝÝÝ MTU = 4470 
ÝÝÝÝÝÝÝ ATM tagging: Label VPI = 1 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Label VCI range = 33 - 65535 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ Control VC = 0/32 
C8540MSR-1#show mpls ldp neighbor 
   Peer LDP Ident: 10.254.225.1:0; Local LDP Ident 10.254.232.1:0 
ÝÝÝÝÝÝÝ TCP connection: 10.254.225.1.646 - 10.254.232.1.11016 
ÝÝÝÝÝÝÝ State: Oper; Msgs sent/rcvd: 106/93; Downstream 
ÝÝÝÝÝÝÝ Up time: 00:56:36 
ÝÝÝÝÝÝÝ LDP discovery sources: 
ÝÝÝÝÝÝÝÝÝ ATM11/0/0.60, Src IP addr: 10.254.14.9 
ÝÝÝÝÝÝÝ Addresses bound to peer LDP Ident: 
ÝÝÝÝÝÝÝÝÝ 2.2.2.1ÝÝÝÝÝÝÝÝ 10.64.4.190ÝÝÝÝ 10.254.225.1ÝÝÝ 1.254.8.1 
ÝÝÝÝÝÝÝÝÝ 10.254.14.221ÝÝ 10.254.14.225ÝÝ 10.254.14.237ÝÝ 10.254.14.9    
   Peer LDP Ident: 10.254.231.1:4; Local LDP Ident 10.254.232.1:2 
ÝÝÝÝÝÝÝ TCP connection: 10.254.14.245.646 - 10.254.14.246.11017 
ÝÝÝÝÝÝÝ State: Oper; Msgs sent/rcvd: 45/45; Downstream on demand 
ÝÝÝÝÝÝÝ Up time: 00:38:27 
ÝÝÝÝÝÝÝ LDP discovery sources: 
ÝÝÝÝÝÝÝÝÝ ATM0/1/0, Src IP addr: 10.254.14.245 
C8540MSR-1#show mpls ldp discovery 
   Local LDP Identifier:ÝÝÝÝ 10.254.232.1:0 
   Discovery Sources: 
ÝÝ Interfaces: 
Ý 
ÝÝÝÝÝÝÝ ATM0/1/0 (ldp): xmit/recvÝÝÝÝÝÝÝÝÝÝ LDP Id: 10.254.231.1:4; IP addr:    10.254.14.245 
ÝÝÝÝÝÝÝ ATM11/0/0.60 (ldp): xmit/recvÝÝÝÝÝÝ LDP Id: 10.254.225.1:0 
C8540MSR-1#show mpls forwarding-table 
   LocalÝ OutgoingÝÝÝ PrefixÝÝÝÝÝÝÝÝÝÝÝÝÝ Bytes tagÝ OutgoingÝÝ Next Hop    
   tagÝÝÝ tag or VCÝÝ or Tunnel IdÝÝÝÝÝÝÝ switchedÝÝ interface 
   16ÝÝÝÝ UntaggedÝÝÝ 10.254.14.220/30ÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   17ÝÝÝÝ 27ÝÝÝÝÝÝÝÝÝ 10.254.247.1/32ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   20ÝÝÝÝ 22ÝÝÝÝÝÝÝÝÝ 10.254.14.240/30ÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   21ÝÝÝÝ 26ÝÝÝÝÝÝÝÝÝ 10.254.231.1/32ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   24ÝÝÝÝ UntaggedÝÝÝ 10.254.14.224/30ÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   25ÝÝÝÝ 24ÝÝÝÝÝÝÝÝÝ 10.254.227.1/32ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   26ÝÝÝÝ Pop tagÝÝÝÝ 10.254.14.236/30ÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   33ÝÝÝÝ UntaggedÝÝÝ 10.254.221.1/32ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point    
   45ÝÝÝÝ 18ÝÝÝÝÝÝÝÝÝ 10.254.14.12/30ÝÝÝÝ 0ÝÝÝÝÝÝÝÝÝ AT11/0/0.60 point2point  
SORBRCV0(c8540-r6-1)#show mpls ip bind 
Ý... 
Ý 10.254.221.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 33 
Ý 10.254.222.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 36 
ÝÝÝÝÝÝÝ out vc label: 1/53ÝÝÝÝÝ lsr: 10.254.233.1:2ÝÝ ATM0/0/1 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ActiveÝÝÝ ingress 4 hops (vcd 49) 
Ý 10.254.223.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 34 
ÝÝÝÝÝÝÝ out vc label: 1/54ÝÝÝÝÝ lsr: 10.254.233.1:2ÝÝ ATM0/0/1 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ActiveÝÝÝ ingress 3 hops (vcd 43) 
Ý 10.254.225.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 28 
ÝÝÝÝÝÝÝ out label:ÝÝÝ imp-nullÝ lsr: 10.254.225.1:0 
ÝÝÝ 10.254.227.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 25 
ÝÝÝÝÝÝÝ out label:ÝÝÝ 24ÝÝÝÝÝÝÝ lsr: 10.254.225.1:0 
ÝÝ 10.254.232.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ imp-null 
ÝÝÝÝÝÝÝ in vc label:Ý 1/34ÝÝÝÝÝ lsr: 10.254.233.1:2ÝÝ ATM0/0/1 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ActiveÝÝÝ egress (vcd 59) 
ÝÝÝÝÝÝÝ out label:ÝÝÝ 33ÝÝÝÝÝÝÝ lsr: 10.254.225.1:0 
Ý 10.254.233.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 29 
ÝÝÝÝÝÝÝ out label:ÝÝÝ 34ÝÝÝÝÝÝÝ lsr: 10.254.225.1:0 
ÝÝÝÝÝÝÝ out vc label: 1/60ÝÝÝÝÝ lsr: 10.254.233.1:2ÝÝ ATM0/0/1 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ActiveÝÝÝ ingress 2 hops (vcd 38) 
Ý 10.254.242.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 19 
ÝÝÝÝÝÝÝ out vc label: 1/61ÝÝÝÝÝ lsr: 10.254.233.1:2ÝÝ ATM0/0/1 
ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ ActiveÝÝÝ ingress 5 hops (vcd 50) 
Ý 10.254.247.1/32 
ÝÝÝÝÝÝÝ in label:ÝÝÝÝ 17 
ÝÝÝÝÝÝÝ out label:ÝÝÝ 27ÝÝÝÝÝÝÝ lsr: 10.254.225.1:0 

Dépannez

Pour des informations supplémentaires sur le dépannage MPLS, référez-vous au document général de dépannage de dépannage MPLS qui explique le MPLS dépannant en détail.


Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes



Document ID: 24853