Distribution de vidéo et de contenu : Routeurs haut débit universels de la gamme Cisco uBR7100

Configuration UBR 7100 en mode pont

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document détaille la configuration de l'uBR7100 et du Cisco Network Registrar pour le réseau traversier. À la différence de l'uBR7200, l'uBR7100 peut être utilisé comme passerelle. La configuration traversière se compose désactiver le Routage IP, mettre toutes les interfaces dans un groupe de passerelle, et configurer l'interface de câble. Dans cette configuration, conduisant des fonctions sont faits sur la passerelle/routeur uBR7100. Puisque les fonctions de routage ne sont pas faites sur l'uBR7100 la configuration est rationalisée. La configuration traversière met le serveur du Cisco Network Registrar (le CNR) sur le même réseau que le CMTS et les Modems câble. Le CNR peut résider derrière la passerelle/routeur, dans ce cas la passerelle est configurée avec une adresse auxiliaire IP pour conduire des émissions entre les Modems câble et le CNR.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Le lecteur devrait avoir une compréhension de base du protocole DOCSIS et de la ligne de commande de Cisco IOSÝ sur les routeurs de la gamme d'ubr.

Composants utilisés

Cette configuration a été développée et testée utilisant ce qui suit :

  • Routeurs haut débit universels de la gamme Cisco uBR7100 exécutant la version 12.10EC1 de Cisco IOS

  • Cisco Network Registrar (le CNR) exécutant V 5.5

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Fondements DOCSIS

Du client DOCSIS éventuel est « plug and play, » signifiant que le modem câble est automatiquement configuré du réseau. Quand le câble est branché pour la première fois il balayera l'en aval pour un transporteur DOCSIS. Le modem verrouillera en fonction au premier transporteur DOCSIS qu'il le détecte. Le descripteur du canal ascendant (UCD), que le modem câble indique du transporteur en aval, indique au modem comment transmettre. L'UCD a des paramètres, la fréquence ascendante, le type de modulation, et le débit symbole de la correction d'erreurs de transfert (FEC). Une fois le modem câble et les CMTS conviennent sur l'approprié transmettent de niveau le modem initieront le processus du protocole DHCP (DHCP). Le serveur CNR devrait entendre les Modems le découvrir. Le modem et le serveur CNR permuteront une gamme de messages qui ont comme conséquence le modem ayant la connectivité IP au reste du réseau. Une fois que le modem a la connectivité IP il peut demander l'heure (ToD) et télécharger son fichier de configuration de modem câble. Une fois que le modem est configuré il enverra une demande d'enregistrement au CMTS. Si le Ý de la sécurisation de base (BPI) n'est pas activé, le modem s'inscrira au CMTS. Si le BPI est activé, le modem permutera des clés de chiffrement avec le CMTS avant d'être entièrement enregistrée.

Transition du concept de mode

En mode de passerelle toutes les interfaces sur le CMTS sont configurées dans un groupe de passerelle. Toutes les interfaces associées avec le groupe de passerelle sont considérées une partie du domaine d'émission. Ceci signifie que chaque périphérique associé avec une de ces interfaces entendra des émissions de tous les périphériques dans le groupe de passerelle. C'est commode, puisque nous pouvons mettre le serveur CNR, le CMTS et les Modems câble sur le même réseau. Quand un modem câble annonce un DHCP découvrez l'interface de câble sur le CMTS l'expédiera aux autres interfaces dans le groupe de passerelle. Puisque le serveur CNR est dans le même groupe de passerelle il entendra le DHCP le découvrir, et répondra avec une offre DHCP. Ultérieurement, le modem obtiendra ToD (d'un serveur externe dans le groupe de passerelle ou du CMTS configuré pour être le serveur de ToD) et son fichier de configuration par l'intermédiaire du Protocole TFTP (Trivial File Transfer Protocol), et s'inscrit au CMTS.

Configurez

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

http://www.cisco.com/c/dam/en/us/support/docs/video/ubr7100-series-universal-broadband-routers/24544-ubr7100-bridging-24544-1.gif

Figure 1

Configurations

Ce document utilise les configurations présentées ci-dessous.

La configuration est divisée en deux parts : Configuration de serveur CNR, et la configuration CMTS. Le CNR est utilisé pour assigner l'adresse IP par l'intermédiaire du DHCP et pour fournir aux Modems les informations de connexion réseau qu'ils ont besoin des éléments de raccourci du réseau. Dans la section de configuration CMTS, l'uBR7100 est configuré pour enregistrer les Modems câble, et le trafic en avant de modem câble au reste du RÉSEAU LOCAL.

Configuration CNR

En configurant le CNR composez-vous configurer des stratégies et des places pour les Modems câble et les hôtes. Les stratégies sont une liste d'options DHCP qui obtiennent associé à une portée. Les portées sont les plages d'adresses IP qui doivent être assignées à un réseau.

Créez une stratégie pour les Modems câble

  1. Lancez le programme et la procédure de connexion CNR. ÝClick sur le serveur DHCP.

    ubr7100_bridging_24544_2.gif

    Figure 2

  2. Cliquez sur le bouton Properties d'EXPOSITION sur le gestionnaire du serveur bar.Ý

  3. Cliquez sur en fonction l'onglet de STRATÉGIES. La stratégie dans cet exemple est nommée bb-ubr7114-1a.Ý

  4. Sélectionnez NOUVEAU pour créer une nouvelle stratégie.

  5. Sous éditez les options ajoutent les options suivantes DHCP :

    1. DHCP-bail-temps ? C'est la durée de bail en quelques secondes. Dans cet exemple, la durée de bail est 604800 (qui est le nombre de secondes dans une période de sept jours). Notez que dans cet exemple nous avons choisi de rendre ces baux permanents en vérifiant le bail sommes box.Ý permanents

    2. Routeurs ? C'est l'adresse de passerelle IP. Pour cet exemple l'adresse IP est 14.66.1.1.

    3. tftp-server ? C'est l'adresse du serveur TFTP. Pour cet exemple l'adresse est 14.66.1.1, qui est identique que l'adresse IP du serveur CNR. Notez que le répertoire par défaut pour les fichiers servis sur une plate-forme Windows est des fichiers de programme \ Network Registrar \ données \ TFTP.

    4. log-serveur ? Adresse pour se connecter les messages de serveur DHCP. Dans cet exemple c'est 14.66.1.1 (serveur CNR).

    5. serveur temporel ? Un Serveur de synchronisation externe peut être utilisation. Dans notre exemple le CMTS agit en tant que Serveur de synchronisation 14.66.1.1.

    6. décalage temporel ? C'est le temps excentré du GMT en quelques secondes. Dans cet exemple le décalage de temps est 18000.

    7. paquet-FILE-nom ? Cette option détaille le nom du fichier cm à utiliser. Dans notre exemple gold.cm est utilisé.

    ubr7100_bridging_24544_3.gif

    Figure 3

Créez une place pour les Modems câble

  1. Cliquez sur en fonction le DHCP server.Ý

  2. Cliquez sur en fonction le bouton d'ajouter la barre de gestionnaire du serveur.

    http://www.cisco.com/c/dam/en/us/support/docs/video/ubr7100-series-universal-broadband-routers/24544-ubr7100-bridging-24544-4.gif

    Figure 4

  3. Dans la case de portée d'ajouter qui s'affiche assignez un nom à la portée.

  4. De la stratégie abaissez choisi la stratégie qui a été créée pour cette portée.

  5. Entrez dans votre réseau en blanc de réseau. Pour cet exemple le network number est 14.66.1.0.

  6. Écrivez le masque de sous-réseau pour votre réseau en blanc de masque de sous-réseau. Pour cet exemple le masque de sous-réseau est 255.255.255.0.

  7. Écrivez les premières et dernières adresses IP dans l'adresse de début et finissez les cases d'adresse. Dans cet exemple la première adresse serait 14.66.1.245, et le bout serait 14.66.1.254.

ubr7100_bridging_24544_5.gif

Figure 5

Configuration CMTS

Les Routeurs de gamme uBR7100 sont livré équipé de l'construits dans l'upconverter. Un upconverter externe peut être utilisé en s'exécutant SI sorti du port DS0 à l'upconverter externe. Dans cet exemple l'upconverter interne est utilisé.

Remarque: Pour plus d'informations sur configurer le convertisseur élévateur de fréquence intégré, référez-vous à placer le convertisseur élévateur de fréquence intégré dans configurer l'interface de câble Cisco pour la documentation d'uBR7100.

Puisque cette configuration a été exécutée dans un environnement de travaux pratiques, l'installation rf était tout à fait simple. Le rf et les mesures installées sont hors de portée de ce document, et le lecteur est connecter visé et configurer la documentation de tête de réseau câblé pour l'installation appropriée et la mesure rf et selon la spécification DOCSIS (SP-RFI-IO5-991105 ou révision postérieure).

Configuration Cisco IOS

  1. Configurez une adresse Internet sur le CMTS.

  2. Configurez un mot de passe d'enable sur le CMTS.

  3. Configurez un mot de passe sur les lignes vty.

  4. Désactivez le Routage IP en n'exécutant l'aucune commande de Routage IP.

  5. Configurez une adresse IP sur l'interface Fast Ethernet 0/0.

  6. Configure jetant un pont sur sur le port Fast Ethernet avec l'ordre de passerelle-groupe.

  7. Désactivez le spanning-tree sur Fast Ethernet 0/0 avec la commande de bridge-group spanning-disabled.

  8. Sur le câble d'interface 1/0 configurez l'upconverter :

    1. Activez le convertisseur haut en n'exécutant un aucun cable downstream rf-shutdown.

    2. Placez la fréquence en aval avec la commande de cable downstream frequency. Maintenez dans l'esprit que la fréquence est dans le hertz. Vous devez utiliser une fréquence standard de canal NTSC CATV.

    3. Placez l'alimentation de canal descendant avec la commande de cable downstream rf-power.

    4. Lancez le linecard en n'exécutant un aucun arrêt.

    5. Lancez l'en amont en n'exécutant un aucun en amont de câble 0 arrêts.

    6. Placez la fréquence ascendante avec la commande de cable upstream frequency.

    7. Fixez la largeur du canal ascendant utilisant la commande de cable upstream channel-width.

  9. Configure jetant un pont sur sur le câble d'interface 1/0.

  10. Spanning-tree de débronchement sur le câble 1/0.

Nom du périphérique (routeur de Cisco 1600)
version 12.1
       no service pad
       service timestamps debug datetime msec localtime
       service timestamps log datetime
       no service password-encryption
       enable password cisco
       service udp-small-servers max-servers no-limit
       service tcp-small-servers max-servers no-limit
       !
       hostname ubr7100
       !
       cable time-server
       !
       clock timezone PST -9
       clock calendar-valid
       ip subnet-zero
       no ip routing 
!--Disable IP routing, enabled by default 

       no ip domain-lookup
       !
       interface FastEthernet0/0
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       no keepalive
       duplex half
       speed auto
       no cdp enable
       bridge-group 1
       bridge-group 1 spanning-disabled
       !
       interface FastEthernet0/1
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       shutdown 
!-- Not connected
 
       duplex auto
       speed 10
       no cdp enable
       bridge-group 1
       bridge-group 1 spanning-disabled
       !
       interface Cable1/0
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       load-interval 30
       no keepalive
       cable downstream annex B
       cable downstream modulation 256qam 
!-- for a non-lab environment 64 QAM is suggested

       cable downstream interleave-depth 32
       cable downstream frequency 525000000 
!-- This is a required line for the uBR7100

       no cable downstream rf-shutdown 
!-- This line turns on the internal upconverter.

       cable downstream rf-power 55 
!-- This line specifies the CMTS's transmit level.

       cable upstream 0 frequency 17808000 
!-- This line configures the frequency specified in the UCD

       cable upstream 0 power-level 0
       cable upstream 0 channel-width 3200000
       no cable upstream 0 shutdown 
!-- This line turns the upstream receiver on.

       bridge-group 1 
!-- This line configure bridging on the cable interface.

       bridge-group 1 subscriber-loop-control
       bridge-group 1 spanning-disabled
       !
       ip default-gateway 14.66.1.1
       ip classless
       no ip http server
       !
       no cdp run
       alias exec scm show cable modem
       !
       line con 0
       exec-timeout 0 0
       privilege level 15
       length 0
       line aux 0
       line vty 0 4
       password cisco
       no login
       !
       end

Vérifiez

Remarque: Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

le show cable modem affichera tous les Modems qui ont entré en contact avec le CMTS, et les informations concernant l'état du modem dans la procédure d'enregistrement. La sortie de cette commande est un instantané. Dans la théorie, si cette commande est exécutée en série vous pouvez voir un modem progresser de init(r1) à l'état en ligne. Dans l'exemple au-dessous du BPI est activé.

ubr7100#show cable modem
 Interface Prim Online Timing Rec QoS CPE IP address MACaddress
 Sid State Offset Power 
 Cable1/0/U0 1 online(pt) 1551 0.00 5 0  14.66.1.245 0050.7366.1e69
 Cable1/0/U0 2 online(pt) 1920 -0.75 5 0 14.66.1.252 0006.2854.72db
 Cable1/0/U0 3 online(pt) 1549 0.25 5 0  14.66.1.250 0050.7366.1e6d
 Cable1/0/U0 4 online(pt) 1548 -0.25 5 0 14.66.1.251 0050.7366.1e41

Vérification de bail au CNR

Pour confirmer que des adresses IP sont remises à un modem câble, allez à l'onglet de bail pour la portée. Confirmez que des adresses IP sont distribuées. Cette section affiche le bloc IP, et ses informations de bail. La sortie est un instantané. Pour mettre à jour les informations, frappez le bouton de liste de régénération.

ubr7100_bridging_24544_6.gif

Figure 6

Si les Modems reliés à votre CMTS ne s'enregistrent pas, référez-vous s'il vous plaît aux Modems câble d'ubr de dépannage n'étant pas livré en ligne.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 24544