IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Utilisations du bit de surcharge avec IS-IS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document introduit la commande de configuration de Protocole IS-IS (Intermediate System-to-Intermediate System) de set-overload-bit, et how and when l'utiliser avec l'attente - pour-BGP et supprimer des mots clé. Dans tout ce document, le système intermédiaire de terme (EST) et le routeur sont interchangeables.

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir une connaissance de base de :

  • Protocole BGP (Border Gateway Protocol) et protocoles de routage IS-IS.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.1(9) de Cisco IOSÝ

  • Routeurs de gammes Cisco 2500 et 3600

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Utilisation traditionnelle du bit de surcharge

Quand un routeur manque de ressources système (mémoire ou CPU), elle ne peut pas enregistrer le plus court chemin de base de données ou de passage d'état de lien d'abord (SPF). Dans cette situation, le routeur devrait alerter d'autres Routeurs dans sa zone en plaçant un bit particulier en ses paquets d'état de lien (LSP). Quand d'autres Routeurs les détectent que ce bit est placé, ils n'utiliseront pas ce routeur pour le trafic de transit mais ils l'utiliseront pour des paquets destinés aux réseaux connectés du routeur surchargé directement et aux préfixes IP.

Dans l'IS-IS, un routeur inonde immédiatement son propre LSP même avant d'envoyer des paquets du PDU contenant le numéro de séquence entier (CSNP). Le bit de surcharge est de ce fait utilisé pour informer le reste du réseau pour ne pas conduire le trafic de transit par le routeur nouvellement rechargé.

Pour chaque LSP, l'ISO/IEC 10589:1992leavingcisco.com définit un bit spécial appelé bit de surcharge de base de données LSP. L'ébauche mentionne la surcharge (dans section 7.3.19) : « En raison de la SIG-configuration de réseau, ou de certaines conditions transitoires, il est possible qu'il puisse y avoir des ressources en mémoire insuffisante disponibles pour enregistrer une État de lien reçue PDU. Quand ceci se produit, EST les besoins de prendre certaines mesures pour s'assurer que si sa base de données LSP devient contradictoire avec les autres IS, que ces IS ne se fondent pas sur des chemins de transfert par surchargés EST. »

Quand un IS-IS en cette condition, il place ce bit dans le fragment 0 du non-pseudonode LSP qu'il génère.

En outre, dans l'ébauche, la section 7.2.8.1 fait une note que d'autres IS ne devraient pas utiliser surchargé EST en tant que routeur de transit, mais peut atteindre les systèmes d'extrémité (ESs) qui sont reliés directement. Pendant les interfaces directement connectées de ce temps, aussi bien que l'IP préfixe, soyez encore accessible. Le Cisco IOS n'utilise pas la surcharge mordue pour cette fonctionnalité, bien que la capacité de placer de manière permanente le surcharge-bit ait été introduite dans l'IOS avec l'ID de bogue Cisco CSCdj18100. Dans l'implémentation de Cisco, quand le positionnement de bit de surcharge est placé, les préfixes directement connectés interfaces/IP sont accessibles.

Utilisation développée du bit de surcharge

La technique de bit de surcharge IS-IS a été développée avec l'ID de bogue Cisco CSCdp01872 (clients enregistrés seulement). Vous pouvez configurer un routeur pour annoncer son LSP avec le bit de surcharge pour une durée spécifique après une recharge. Quand le temporisateur expire, le bit de surcharge est effacé et le LSP re-est inondé.

Cette nouvelle fonctionnalité est utile aux fournisseurs d'accès Internet (ISP) qui exécutent le Protocole BGP (Border Gateway Protocol) et l'IS-IS pour éviter quelques scénarios de « trou noir ». Établissement du bit de surcharge pendant une quantité déterminée d'heure juste après qu'une recharge s'assure que le routeur ne reçoit pas le trafic de transit tandis que le protocole de routage converge toujours.

La technique pour placer ce bit pendant une certaine période après une recharge est mise en application utilisant la commande suivante. Cette commande prend une seconde plage 5 à 86400 d'heure pour que le bit de surcharge reste positionnement après recharge.

router isis
set-overload-bit [on-startup [<timeout> | wait-for-bgp] ]

Exemple :

Router(config-router)#set-overload-bit on-startup 3500 wait-for-bgp

!--- Set the overload bit for 5 minutes (default is 10 minutes).

Cette caractéristique a également permis pour configurer un routeur pour désactiver automatiquement la surcharge mordue quand le BGP a convergé. Pour plus d'informations sur attendre le BGP, voir s'il vous plaît le système intermédiaire RFC3277 à la manière d'éviter passagère de Blackhole du système intermédiaire (IS-IS)leavingcisco.com .

Selon la spécification BGP, un routeur BGP n'a pas besoin d'envoyer le Keepalives tant que elle envoie des mises à jour. Ainsi, le Keepalives sera envoyé seulement après tout à des mises à jour a été envoyé. Le BGP est considéré comme pour avoir convergé quand le Keepalives est reçu de tous les voisins BGP.

Si le Keepalives BGP n'est pas reçu de tous les voisins BGP, et l'attente-pour-BGP est configuré, l'IS-IS désactivera la surcharge mordue après 10 minutes.

Les ISP peuvent vouloir supprimer certains préfixes IP de l'publicité dans les propres LSP du routeur quand le set-overload-bit est configuré. Par exemple, il peut ne pas être desirable de permettre le niveau 1 dans la propagation de préfixe IP du niveau 2, qui ferait au routeur un noeud de transit pour le trafic IP.

L'ID de bogue Cisco CSCdr98046 (clients enregistrés seulement) donne plus de contrôle de ce qui se produit quand le le bit de surcharge est utilisé dans sa capacité développée. Cette amélioration permet un niveau 1 IS-IS - le routeur du niveau 2 (L1L2) qui redistribue des artères IP du niveau 1 dans le niveau 2 ou le niveau 2 dans le niveau 1 pour continuer à annoncer ces artères redistribuées dans son LSP quand le bit de surcharge a été placé.

Utilisant le mot clé de supprimer, vous pouvez configurer un routeur L1L2 pour redistribuer et annoncer des artères IP du niveau 1 dans le niveau 2 ou vice versa même lorsque le set-overload-bit est configuré. La syntaxe de la commande est comme suit :

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

Le mot clé d'interlevel de supprimer indique le routeur ne pas annoncer des préfixes IP appris d'un autre niveau IS-IS si le bit de surcharge est placé. Le mot clé externe de supprimer indique le routeur ne pas annoncer des préfixes IP appris d'autres protocoles si le bit de surcharge est placé. Le par défaut n'est pas de supprimer et mettre à jour le comportement de l'ID de bogue Cisco CSCdp01872 (clients enregistrés seulement).

L'option de supprimer la prend effet seulement quand votre propre bit de surcharge est placé, et pas quand elle est reçue ou configurée (par exemple, vous pourriez avoir le sur-startup de set-overload-bit et le bit n'est pas placé).

router isis
set-overload-bit on-startup 40 suppress interlevel

Dans le cas ci-dessus, le bit de surcharge n'est pas placé réellement jusqu'à ce que le routeur soit rechargé, et ainsi vous devriez continuer à couler des préfixes IP entre les niveaux. Quand vous rechargez et placez réellement le bit, vous devriez supprimer les annonces d'interlevel.

Exemple de configuration

Le schéma de réseau suivant est utilisé pour expliquer la commande de set-overload-bit et l'attente - pour-BGP et pour supprimer des options.

/image/gif/paws/24509/TOPO.gif

Voici la configuration contenant l'attente - l'option pour-BGP sur le Router2.

Configuration du Routeur 2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis
passive-interface Loopback0
net 12.0020.0200.2002.00
set-overload-bit on-startup wait-for-bgp
!

!--- Enables the IS-IS process on the router.
!--- Makes loopback interface passive 
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.
!--- Sets the overload bit on startup to wait for BGP
!--- using the default timeout of 10 minutes.

Le routeur a été fraîchement rechargé et avant que l'eBGP ait convergé vous pouvez voir que le bit de surcharge est placé sur le routeur 2's LSP dans la base de données du niveau 1 IS-IS.

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000017   0x2372        284               0/0/1

Ci-dessous, nous voyons dans la sortie de mettons au point la mise à jour d'ISIS que le BGP a convergé sur le Router2 :

*Mar 1 00:00:51.015 UTC: BGP(0): Revise route installing 1.1.1.1/32 
-> 135.8.1.1 to main IP table

Le Router2 reconstruit maintenant son niveau 1 LSP parce que le BGP a convergé et le bit de surcharge est effacé. C'est de pourquoi vous voyez les « importants champs changés » dans la sortie pour mettre au point la mise à jour d'ISIS ci-dessous.

*Mar 1 00:00:51.087 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Important fields changed
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Full SPF required

Maintenant nous pouvons voir que le Router2 s'est terminé sa session de mise à jour BGP avec le voisin :

*Mar 1 00:00:52.127 UTC: BGP: 135.8.1.1 initial update completed

Quand nous regardons le niveau 1 LSP du routeur 2's de nouveau, nous voyons que le Router2 a effacé la surcharge mordue (parce que le BGP a convergé) et que le champ numérique Seq LSP est augmenté de 1 (parce qu'un nouveau LSP a été créé) :

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000018   0xAD87        287               0/0/0

Voici la configuration de Router2 avec l'artère L1L2 coulant configurée et le bit de surcharge effacé.

Configuration du Routeur 2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis 
redistribute static ip metric 11 level-1
redistribute isis ip level-2 into level-1 distribute-list 100
passive-interface Loopback0
net 12.0020.0200.2002.00
!

!--- Enables the IS-IS process on the router.
!--- Configured L2 to L1 route leaking
!--- Makes loopback interface passive
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.

!
ip route 200.200.200.200 255.255.255.255 loopback0 

!--- Static route to 200.200.200.200 via loopback0.

access-list 100 permit ip any any

!--- Access list 100 is used to control which route
!--- gets leaked from Level 2 to Level 1.

Notez que la base de données du niveau 1 du routeur 2's prouve que le bit de surcharge est clair dans le routeur 2's L1 LSP.

IS-IS Level-1 LSP r2.00-00        
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL        
r2.00-00 * 0x0000005D   0xC252        180           0/0/0        
Area Address: 12        
NLPID: 0xCC         
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric:  0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01
Metric: 11 IP-External 200.200.200.200 255.255.255.255
Metric:138 IP-Interarea 1.1.1.1 255.255.255.255

Quand nous regardons les artères IP qui Routeur3 apprend, nous pouvons voir qu'il a appris l'adresse de bouclage 1.1.1.1 du routeur 1's de la fuite de l'artère L2L1. Notez également qui Routeur3 reçoit également l'artère statique redistribuée 200.200.200.0/32.

r3#show ip route isis
200.200.200.0/32 is subnetted, 1 subnets
i L1 200.200.200.200 [115/21] via 135.8.2.2, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
i ia 1.1.1.1 [115/148] via 135.8.2.2, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Permettez-maintenant nous configurent le set-overload-bit sur le Router2 avec l'option de supprimer. Nous supprimerons les deux routes internes et externes. La syntaxe de commande suit :

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

supprimez l'interlevel empêche le routeur des préfixes de la publicité appris du niveau 2. suppriment externe empêche la redistribution.

r2(config-router)#set-overload-bit suppress interlevel external

Examination la base de données du niveau 1 de Router2 nous pouvons voir que le bit de surcharge est maintenant placé dans le niveau 1 LSP du routeur 2's. 200.200.200.200/32 et 1.1.1.1/32 ont été supprimés. Ils ne sont pas injectés dans la base de données du niveau 1.

IS-IS Level-1 LSP r2.00-00
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r2.00-00 * 0x0000005F   0x23C6       266            0/0/1
Area Address: 12
NLPID: 0xCC 
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric: 0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01

Quand nous activons le debug isis update-packets sur le Router2, nous voyons les « importants champs changés » dans la sortie quand le niveau 1 et le niveau 2 LSP sont établis. Ceci indique que le contenu LSP a changé, en d'autres termes, nous avons reçu un LSP qui a le bit de surcharge réglé. Un nouveau LSP exige d'une pleine SPF d'être exécutée.

*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L2 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:09.035 UTC: ISIS-Upd: Sending L1 LSP 0020.0200.2002.00-00, seq 61, ht 299 on Ethernet0/0
*Mar 1 03:16:09.095 UTC: ISIS-Upd: Sending L2 LSP 0020.0200.2002.00-00, seq 65, ht 299 on Ethernet1/0

La table de routage à jour par 3's de routeur n'inclut plus les réseaux IP 200.200.200.200 et 1.1.1.1.

r3#show ip route isis
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Les informations DDTS

  • L'ID de bogue Cisco CSCdj18100 (clients enregistrés seulement) - a introduit la capacité de placer la surcharge mordue manuellement.

  • L'ID de bogue Cisco CSCdp01872 (clients enregistrés seulement) - a introduit la capacité de placer le bit de surcharge sur le startup. Attendez jusqu'à ce que le BGP ait signalé la convergence ou placez un temporisateur pour effacer le bit de surcharge.

  • ID de bogue Cisco CSCdr98046 (clients enregistrés seulement) - qu'un routeur IS-IS L1L2 qui redistribue des artères IP du niveau 1 dans le niveau 2 ou le niveau 2 dans le niveau 1 peut continuer à annoncer ces artères redistribuées dans son LSP quand le bit de surcharge a été placé.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 24509