Voix : H.323

Présentation du routage d'appel des contrôleurs d'accès Cisco IOS

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Les contrôleurs d'accès Cisco sont utilisés pour grouper des passerelles dans des zones logiques et pour effectuer le routage d'appels entre elles. Les passerelles sont responsables des décisions de routage de périphérie entre le réseau téléphonique public commuté (PSTN) et le réseau H.323. Les contrôleurs d'accès Cisco gèrent le principal routage d'appels parmi des périphériques dans le réseau H.323 et fournissent la gestion centralisée de plan de numérotation. Sans contrôleur d'accès Cisco, des adresses IP explicites pour chaque passerelle de terminaison devraient être configurées à la passerelle d'origine et être appariées à un cadran-pair de voix sur ip (VoIP). Avec un contrôleur d'accès Cisco, les passerelles envoient des requêtes au contrôleur d'accès en essayant d'établir des appels VoIP avec les passerelles VoIP distantes.

Par exemple, une fois présentée avec un appel, la passerelle détermine si l'envoyer au tronçon de téléphonie ou au tronçon IP selon les son Plan de composition. Dans le cas du tronçon IP, la passerelle questionne le garde-porte de Cisco pour sélectionner le meilleur point final. Puis, le garde-porte de Cisco détermine si le point final appelé est un périphérique dans sa zone locale ou il se trouve à une zone distante commandée par un garde-porte distant de Cisco.

Conditions préalables

Conditions requises

Cisco recommande que vous ayez la connaissance compréhension des Contrôleurs d'accès H.323.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cisco 2500, 2600, 3600, 3700, 7200, et Routeurs de gamme MC3810

  • Ce document n'est pas spécifique à aucune version de Cisco IOSÝ. Cependant, les configurations dans ce document ont été testées sur la version du logiciel Cisco IOS 12.2(19). Référez-vous au conseiller de logiciel (clients enregistrés seulement) pour confirmer l'ensemble de fonctionnalités de Cisco IOS requis pour prendre en charge la fonctionnalité de contrôleur d'accès H.323.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Messages ARQ et LRQ

La demande d'admission (ARQ) et la demande d'emplacement (LRQ) sont l'enregistrement deux H.225, admission, les messages de l'état (RAS) qui déclenchent un garde-porte pour initier le processus de décision de routage d'appels.

  • ARQ — Messages locaux de zone qui sont envoyés par H.323 des points finaux (habituellement passerelles) au garde-porte de Cisco. Les garde-portes reçoivent ARQs d'un point final si :

    • Un point final local de zone initie un appel. OU

    • Une autorisation locale de demande de point final de zone d'admettre un appel entrant.

    Les garde-portes répondent aux messages ARQ avec une admission confirment (ACF) ou un message de l'anomalie d'admission (ARJ). Si le garde-porte de Cisco est configuré pour admettre l'appel, il répond avec un message ACF (qui inclut les informations telles que l'adresse IP de passerelle de destination). Sinon, il répond avec un message ARJ.

  • LRQ — Ces messages sont permutés entre les garde-portes et sont utilisés pour des appels d'inter-zone (zone distante). Par exemple, le garde-porte A reçoit un ARQ d'une passerelle locale de zone demandant l'admission d'appel pour un périphérique distant de zone. Le garde-porte A envoie alors un message LRQ au garde-porte B. Gatekeeper B que les réponses au message LRQ avec un emplacement confirment (LCF) ou le message de l'anomalie d'emplacement (LRJ), qui dépend de s'il est configuré pour admettre ou rejeter la demande d'appel d'inter-zone et si la ressource demandée est enregistrée.

Référez-vous compréhension derrière des Contrôleurs d'accès H.323 : Garde-porte au pour en savoir plus d'écoulement d'appel de passerelles.

Messages relatifs H.225 RAS
ARQ Demande d'admission LRQ Demande d'emplacement
ACF L'admission confirment LCF L'emplacement confirment
ARJ Anomalie d'admission LRJ Anomalie d'emplacement

Importants concepts de configuration : Préfixes de zone et de technologie

Afin de comprendre le processus de décision de routage d'appels de garde-porte de Cisco, il est essentiel de comprendre des préfixes de zone et de technologie. En général (à quelques exceptions), la zone prefix détermine le routage à une zone, tandis que le préfixe de technologie détermine la passerelle dans cette zone.

Zones prefix

Une zone prefix est la pièce du numéro appelé qui identifie la zone outre derrière la à laquelle un appel saute à cloche-pied. Des zones prefix sont habituellement utilisées pour associer code postal à une zone configurée.

Le garde-porte de Cisco détermine si un appel est conduit à une zone distante ou localement traité. Par exemple, selon cet extrait de configuration, le garde-porte (GK) A en avant 214 ....... appelle à GK-B. Des appels à code postal (512) sont traités localement.

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	
!--- The IP address configured above should be the RAS 
 !--- address of the remote gatekeeper.    
 !--- and should be reachable from the local gateway. 
 !--- In order to find out the RAS address on the remote gatekeeper,
 !--- issue the 
show gatekeeper zone status
 command 
 !--- on the remote gateway.
 
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

Préfixes de technologie

Un préfixe de technologie est H.323 une caractéristique facultative de conformité aux normes, prise en charge par des passerelles Cisco et des garde-portes, qui active plus de flexibilité dans le routage d'appels dans H.323 un réseau VoIP. Le garde-porte de Cisco emploie des préfixes de technologie pour grouper des points finaux du même type ensemble. Des préfixes de technologie peuvent également être utilisés pour identifier un type, une classe, ou un groupe de passerelles.

Les préfixes de technologie d'utilisation de garde-portes de Cisco pour conduire des appels quand il n'y a aucun (par une passerelle) ce E.164 enregistré par adresses apparie le numéro appelé. En fait, c'est un scénario commun parce que la plupart des passerelles de Cisco IOS enregistrent seulement leur H.323 ID (à moins qu'elles ont le Foreign Exchange Station (FXS) met en communication configuré). Sans adresses E.164 enregistrées, le garde-porte de Cisco compte en deux options de prendre la décision de routage d'appels :

  • Avec l'option de correspondances de préfixe de technologie, le garde-porte de Cisco utilise le préfixe de technologie ajouté dans le numéro appelé pour sélectionner la passerelle ou la zone de destination.

  • Avec l'option de préfixes de technologie de par défaut, le garde-porte de Cisco assigne la passerelle par défaut pour conduire des adresses d'appel non résolues. Cette affectation est basée sur le préfixe enregistré de la technologie des passerelles.

Cette table récapitule des options de configuration disponibles :

Sur la passerelle
Interface VoIP Cette commande enregistre la passerelle Cisco avec le préfixe défini de technologie. Le formulaire d'inscription de préfixe de technologie est envoyé au garde-porte de Cisco dans le message de la demande d'enregistrement RAS (RRQ). Exemple :
GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.
Homologue de numérotation VoIP Cette commande ajoute un préfixe au début de technologie au numéro appelé apparié par le cadran-pair. Il n'est pas utilisé pour l'enregistrement, mais pour l'établissement d'appel avec le garde-porte de Cisco. Par exemple, le numéro appelé 5551010 devient 1#5551010.
GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

Remarque: Le numéro appelé modifié est également envoyé à la dernière passerelle dans l'établissement d'appel. Assurez que les cadran-pairs de réseau téléphonique public commuté de dernière passerelle (POTS) sont mis à jour pour se terminer l'appel.

Sur le garde-porte
Préfixe par défaut de technologie de garde-porte Cette commande place les passerelles enregistrées avec le préfixe spécifié de technologie en tant que par défaut pour conduire les adresses d'appel qui sont non résolues. Par exemple, si la plupart des passerelles dans votre zone conduisent le même type d'appels et elles sont inscrites au préfixe 1# de technologie, vous pouvez configurer le garde-porte de Cisco pour utiliser 1# comme préfixe par défaut de technologie. Par conséquent, il n'est plus que les passerelles d'origine ajoutent le numéro appelé au début avec 1#. Des numéros appelés sans préfixe valide de technologie sont conduits à une des passerelles inscrites à 1#.
GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology

Remarque: S'il y a plus d'une passerelle par défaut, vous pouvez affecter l'utilisation prioritaire de passerelle avec la commande de la gw-priorité <0-10> du <gk_id> <e.164_pattern> de zone prefix.

Zone de saut-Hors fonction de garde-porte Des configurations de saut-hors fonction sont utilisées pour ignorer la sélection de zone prefix et pour forcer l'appel à sauter à cloche-pied-offed à une zone spécifiée, indépendamment de la zone prefix de numéro appelé. Par exemple, avec cette configuration, tous les appels avec le préfixe 2# de technologie seront expédiés à la zone GK-A.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A
Enregistrement statique de préfixe de technologie de passerelle de garde-porte Utilisé pour enregistrer statiquement un préfixe de technologie pour une passerelle. Il accomplit les mêmes résultats sur le garde-porte que la configuration d'interface de la passerelle VoIP réalise sur la passerelle. Il est recommandé pour configurer ceci sur les passerelles si vous avez un grand nombre de passerelles. Généralement, il est plus facile de configurer chaque passerelle avec un préfixe de technologie que pour configurer le garde-porte avec tous les préfixes de technologie pour chaque passerelle.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  Gateway's call signaling IP address

L'algorithme/processus de décision de routage d'appels de garde-porte

Ces diagrammes affichent le processus de décision de routage d'appels de garde-porte après réception des messages ARQ et LRQ dans des versions du logiciel Cisco IOS avant 12.4 :

gk-call-routing-1.gif

gk-call-routing-2.gif

Routage d'appels pseudonyme Pseudonyme

Le routage d'appel de garde-porte a changé dans la version du logiciel Cisco IOS 12.4 et plus tard. H.323-ID et la correspondance basée parID est effectué avant de traiter les nombres de la destination E.164 (DNIS). Si n'importe quel point final s'avère pour avoir enregistré le H.323-ID/email-ID spécifié, alors l'ACF est envoyé. Ce diagramme explique le nouveau processus de routage d'appels pseudonyme pseudonyme :

/image/gif/paws/24462/gk-call-routing-2a.gif

Les fonctions d'infrastructure et d'application de The Voice (PAR L'INTERMÉDIAIRE DE) sont des améliorations logicielles à l'image existante de garde-porte de Cisco. Avec cette amélioration, le garde-porte de Cisco peut identifier deux tronçons d'appel sur la même plate-forme (passerelle IP-à-IP) et également équilibrer la charge le trafic à travers les plusieurs passerelles IP-à-IP, qui sont incluses (des passerelles et des garde-portes) dans des prédéfinis PAR L'INTERMÉDIAIRE de la zone. Ces garde-portes s'asseyent à la périphérie du réseau du fournisseur de service téléphonique Internet (ITSP) et sont comme un point de transfert VoIP, ou la zone de transit, où le trafic VoIP est creusé des rigoles sur le chemin vers la destination distante de zone. Les passerelles IP-à-IP dans PAR L'INTERMÉDIAIRE de la zone terminent les appels entrant et le reoriginate ils vers leurs destinations définitives. Référez-vous au réseau distant à local avec la configuration interarmées de la passerelle IP-à-IP de Cisco pour plus d'informations sur PAR L'INTERMÉDIAIRE de la zone.

/image/gif/paws/24462/gk-call-routing-2b.gif

Remarque: Si la zone spécifiée d'invia ou d'outvia n'est pas trouvée dans les configs (c.-à-d. elle n'est pas définie comme zone locale ou distante), alors un message ARJ est envoyé.

Afin de sélectionner un IP-IP gw enregistré au viazone sélectionné cet algorithme est utilisé :

  1. Si un tech-prefix est trouvé (dans apparier pseudonyme pseudonyme), regardez par la liste de passerelles dans le viazone spécifié qui ont enregistré ce tech-prefix.

  2. Si aucun tech-prefix n'est trouvé, regardez par la liste entière de passerelles enregistrées au viazone spécifié.

  3. Sélectionnez le premier IP-IP gw trouvé dans l'étape 1 ou 2 qui a des ressources disponibles.

  4. Si tous les IP-IP GWs dans la liste sont hors des ressources, sélectionnez le premier IP-IP gw qui est trouvé (quoiqu'il pourrait être hors des ressources).

  5. Si aucun IP-IP GWs n'est trouvé, renvoyez la panne.

Exemples locaux d'appel de zone

Dans les exemples fournis dans cette section, les deux passerelles s'inscrivent au garde-porte de Cisco avec leurs H.323 id respectifs. En outre, la passerelle (GWY) A2 s'inscrit à une adresse E.164. Ce diagramme est utilisé pour tous les exemples dans cette section :

gk-call-routing-3.gif

Les trois scénarios dans cette section expliquent le processus de décision pas à pas les utilisations de garde-porte de conduire des appels ont basé sur les messages ARQ.

Remarque: Seulement la sortie appropriée est affichée dans ces captures de configuration.

Scénario 1 : Aucun préfixes de technologie configurés

GK-A
!
gatekeeper
zone local GK-A abc.com
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 

!--- The IP address configured here should 
!--- be the RAS address of GK-A
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status
 
!--- command on GK-A.
 
h323-gateway voip h323-id GW-A1@abc.com 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512

!--- On outgoing calls through POTS dial-peers,
!--- all explicit digit matches are dropped, 
!--- which is the reason
!--- for adding the prefix 512. This has nothing to  
!--- do with technology prefixes.

!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras

!--- Uses RAS messages (GK) to get 
!--- call setup information.


!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718

!--- The IP address configured here  
!--- should be the RAS address of GK-A.
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status

!--- command on GK-A.
 
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0

!--- This is the FXS port.

!
gateway
!

Cette sortie capturée sur GK-A affiche les enregistrements réels. L'avis GWY-A2 enregistre également l'ID E.164 du port FXS.

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    H323-ID: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    E164-ID: 9725551010
    H323-ID: GW-A2@abc.com
Total number of active registrations = 2

Action de premier appel : L'utilisateur A1 appelle l'utilisateur A2 à 972-555-1010. Employez le diagramme ARQ pour compléter le processus de décision.

GK-A reçoit ARQ de GWY-A1.

  1. Le préfixe de technologie s'assortit-il ? Non

  2. La zone prefix s'assortit-elle ? Non

  3. La commande d'arq reject-unknown-prefix est-elle placée ? Non, cible-zone égale la zone locale.

  4. La cible-zone est-elle locale ? Oui

  5. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Non

  6. L'adresse de destination est-elle enregistrée ? Oui. Envoyez ACF.

Établissement d'appel réussi.

Remarque: GWY-A2 a l'ID de la destination E.164 enregistré (port FXS). Par conséquent, le garde-porte pouvait admettre l'appel.

Action de deuxième appel : L'utilisateur A2 compose 512-555-1212 pour appeler l'utilisateur A1.

GK-A reçoit ARQ de GWY-A2.

  1. Le préfixe de technologie s'assortit-il ? Non

  2. La zone prefix s'assortit-elle ? Non

  3. La commande d'arq reject-unknown-prefix est-elle placée ? Non, la cible-zone égale la zone locale.

  4. La cible-zone est-elle locale ? Oui

  5. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Non

  6. L'adresse de destination est-elle enregistrée ? Non

  7. Le préfixe par défaut de technologie est-il placé ? Non Envoyez ARJ.

L'établissement d'appel a manqué.

Remarque: Le scénario 2 explique comment réparer ce problème de routage d'appels avec des préfixes de technologie.

Scénario 2 : Préfixes de technologie configurés

Dans ce scénario, ces modifications de configuration sont apportées :

  • GWY-A1 — A ajouté la commande du h323-gateway voip tech-prefix 1#. GWY-A1 s'enregistre au GK-A avec le préfixe 1# de technologie.

  • GWY-A1 — A ajouté un homologue de numérotation POTS avec une commande de destination-pattern qui apparie le numéro appelé entrant de GWY-A2 avec le préfixe 1# de technologie.

  • GK-A — A ajouté la commande de la zone prefix GK-A. Définit les zones prefix locales que GK-A gère.

  • GK-A — A ajouté la commande d'arq reject-unknown-prefix. Ceci impose GK-A pour recevoir seulement des appels ARQ pour des zones prefix qu'il gère. Dans le scénario 1, ceci n'a pas été configuré. Par conséquent, la zone de cible a été placée à la zone locale en tant que par défaut.

  • GWY-A2 — A ajouté la commande du tech-prefix 1# sous la configuration d'homologue de numérotation VoIP. De cette façon, GWY-A2 ajoute les chiffres au début 1# aux appels sortants VoIP. GK-A identifie le modèle 1# pour sélectionner GWY-A1 comme passerelle de destination.

GK-A
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
arq reject-unknown-prefix
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Cette sortie capturée sur GK-A affiche les préfixes enregistrés de technologie :

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Remarque: Au lieu de configurer GW-A1 avec la commande du h323-gateway voip tech-prefix 1#, il peut être accompli la même manière en configurant manuellement ces informations dans le GK-A avec la commande.

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1

Action d'appel : L'utilisateur A2 compose 512-555-1212 pour appeler l'utilisateur A1.

GK-A reçoit ARQ de GWY-A2.

  1. Le préfixe de technologie s'assortit-il ? Oui

    Remarque: Après la correspondance de préfixe de technologie, le garde-porte l'élimine pour analyser la zone prefix. Cette bande est seulement exécutée par l'analyse de garde-porte. La passerelle d'origine l'ajoute toujours dans l'établissement d'appel à la dernière passerelle.

  2. La zone prefix s'assortit-elle ? Oui. Placez la cible-zone pour égaler la zone locale.

  3. La correspondance de pseudonyme (après tech éliminant fait-elle préfixent) avec un gw enregistré ? No (si oui, envoyez ACF).

  4. La cible-zone est-elle locale ? Oui

  5. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Oui

  6. Est-ce qu'passerelle locale avec un préfixe de technologie a été trouvée ? Oui. Envoyez ACF.

    Succès d'établissement d'appel.

Ce GK-A met au point la sortie de commande illustre le comportement ci-dessus.

Remarque: Cette commande de débogage est une utile, mais masqué, mettez au point. Par conséquent, le programme d'analyse syntaxique n'affiche pas le débogage.

GK-A#debug gatekeeper main 5
      
    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched tech-prefix 1#
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched zone prefix 512
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

Remarque: C'est une configuration alternative qui peut être plus intuitive :

  • Émettez la commande du h323-gateway voip tech-prefix 512 afin de configurer GWY-A1 pour s'inscrire au préfixe 512 de technologie.

  • De cette façon, GWY-A2 ne doit pas passer le préfixe dans le tronçon d'appel d'homologue de numérotation VoIP parce que la destination-pattern inclut déjà 512. , Sortez par conséquent la commande du tech-prefix 1# dans la configuration GWY-A2 et retirez également 1# de la destination-pattern sous le pair de cadran de pots sur GWY-A1.

Scénario 3 : Préfixes par défaut de technologie configurés

Dans ce scénario, GWY-A1 s'inscrit au préfixe 1# et GK-A de technologie est configuré pour conduire des appels sans correspondance de préfixe de technologie aux passerelles par défaut de préfixe de technologie. Par conséquent, GWY-A2 n'a pas besoin d'être configuré pour passer le préfixe de technologie de destination.

GK-A
!
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix 
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0 
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com 
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Cette sortie capturée sur GK-A affiche les préfixes enregistrés de technologie :

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#* (Default gateway-technology)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Action d'appel : L'utilisateur A2 compose 512-555-1212 pour appeler l'utilisateur A1.

GK-A reçoit ARQ de GWY-A2.

  1. Le préfixe de technologie s'assortit-il ? Non

  2. La zone prefix s'assortit-elle ? Oui. Placez la cible-zone pour égaler la zone locale.

  3. La cible-zone est-elle locale ? Oui

  4. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Non

  5. L'adresse de destination est-elle enregistrée ? Non

  6. Le préfixe par défaut de technologie est-il placé ? Oui. Sélectionnez la passerelle locale avec le préfixe de technologie (seulement un disponible).

  7. Envoyez ACF.

    Établissement d'appel réussi.

Exemples distants d'appel de zone

Dans ces exemples, il y a deux H.323 zones : un contrôlé par GK-A et des autres par GK-B.

/image/gif/paws/24462/gk-call-routing-4.gif

Les scénarios dans cette section expliquent le processus de décision pas à pas que les garde-portes les utilisent pour conduire des appels ont basé sur les messages ARQ et LRQ.

Remarque: Seulement la sortie appropriée est affichée dans ces exemples de configuration.

Scénario 1 : Garde-portes de zone configurés avec des préfixes par défaut de technologie

Dans ce scénario, GWY-A1 s'enregistre à GK-A avec le préfixe 1# et GWY-B1 de technologie s'enregistre à GK-B avec le préfixe 2# de technologie. Les deux garde-portes sont configurés avec les passerelles par défaut de préfixe de technologie.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com 172.22.1.3
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 2#* default-technology
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

Action d'appel : L'utilisateur A1 compose 214-555-1111 pour appeler l'utilisateur B1.

GK-A reçoit ARQ de GWY-A1.

  1. Le préfixe de technologie s'assortit-il ? Non

  2. La zone prefix s'assortit-elle ? Oui. Placez la cible-zone pour égaler la zone du distant GK-B (214).

  3. La cible est-elle zone local ? Non

  4. Envoyez LRQ à GK-B.

GK-B reçoit LRQ de GK-A.

  1. Le préfixe de technologie s'assortit-il ? Non

  2. La zone prefix s'assortit-elle ? Oui. Placez la cible-zone pour égaler la zone locale.

  3. La cible est-elle zone local ? Oui

  4. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Non

  5. L'adresse de destination est-elle enregistrée ? Non

  6. Le préfixe par défaut de technologie est-il placé ? Oui. Sélectionnez la passerelle locale avec le préfixe de technologie (2#).

  7. Envoyez LCF à GK-A.

    GK-A reçoit LCF de GK-B avec les informations de dernière passerelle.

    GK-A envoie ACF à GWY-A1.

    L'établissement d'appel est réussi.

Scénario 2 : Garde-portes de zone configurés sans préfixes par défaut de technologie

Dans ce scénario, GWY-A1 s'enregistre à GK-A avec le préfixe 1# et GWY-B1 de technologie s'enregistre à GK-B avec le préfixe 2# de technologie. GWY-A1 ajoute le préfixe 2# de technologie à la chaîne de numéro appelé en faisant appelle (à 214) et GWY-B1 ajoute le préfixe 1# de technologie à la chaîne de numéro appelé en faisant appelle à (512).

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
gateway
!

Action de premier appel : L'utilisateur B1 compose 512-555-1212 pour appeler l'utilisateur A1.

GK-B reçoit ARQ de GWY-B1.

  1. Le préfixe de technologie s'assortit-il ? Non

  2. La zone prefix s'assortit-elle ? Non

    Remarque: Puisque GK-B ne se rend pas compte d'un préfixe de la technologie 1#, il l'assume que ce fait partie du numéro appelé et lit comme zone prefix.

  3. La cible est-elle zone local ? Oui

    Remarque: GK-B prend aux égaux de zone de cible par défaut la zone locale parce que la commande d'arq reject-unknown-prefix n'est pas placée.

  4. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Non

  5. L'adresse de destination est-elle enregistrée ? Non

  6. Le préfixe par défaut de technologie est-il placé ? Non

  7. Envoyez ARJ à GWY-B1.

    L'établissement d'appel a manqué.

Cette sortie a été capturée dans GK-B pour illustrer plus loin ce comportement :


!--- From debug gatekeeper main 5.

      
GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Tech-prefix match failed
rassrv_get_addrinfo(1#5125551212): unresolved zone prefix, using source zone GK-B
rassrv_get_addrinfo(1#5125551212): unknown address and no default technology defined
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

!--- From debug ras.


GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) sent to 172.22.2.1

Configurez les garde-portes pour identifier les préfixes distants de technologie de zone afin de réparer ce problème.

  • Ajoutez ceci à GK-B :

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
    
  • Ajoutez ceci à GK-A :

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B
    

Notez que l'homologue de numérotation POTS dans les dernières passerelles requises pour être mis à jour pour apparier les chaînes entrantes de cadran avec les préfixes de technologie.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!
GK-B GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!

!--- This dial-peer is used for 
!--- incoming calls from the PSTN.

dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!

!--- This dial-peer is used to 
!--- terminate (512) calls coming
!--- from the VoIP network. Notice 
!--- that the technology prefix 
!--- is matched to select the dial-peer 
!--- but does not pass it to 
!--- the PSTN.
 
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
! 
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
dial-peer voice 3 pots
destination-pattern 2#214....... 
port 3/0:23
prefix 214 
! 
gateway
!

Action de deuxième appel : L'utilisateur B1 compose 512-555-1212 pour appeler l'utilisateur A1.

GK-B reçoit ARQ de GWY-B1.

  1. Le préfixe de technologie s'assortit-il ? Oui

  2. Y a-t-il un préfixe de technologie de saut-hors fonction ? Oui

  3. Envoyez LRQ à GK-A.

    Remarque: Le LRQ inclut le préfixe de technologie dans le numéro appelé pour l'analyse GK-A.

GK-A reçoit LRQ de GK-B.

  1. Le préfixe de technologie s'assortit-il ? Oui

  2. Y a-t-il un préfixe de technologie de saut-hors fonction ? Non

    Remarque: Afin de continuer l'analyse de routage d'appels, GK-A élimine le préfixe de technologie. Le préfixe de technologie demeure dans la chaîne de numéro appelé quand les passerelles installent les tronçons d'appel.

  3. La zone prefix s'assortit-elle ? Oui. Placez la cible-zone pour égaler la zone locale.

  4. La cible-zone est-elle locale ? Oui

  5. Est-ce qu'préfixe de technologie a été trouvé dans l'étape 1 ? Oui

  6. Avez-vous trouvé une passerelle locale avec un préfixe de technologie ? Oui

  7. Envoyez LCF à GK-B.

    GK-B reçoit LCF de GK-A avec les informations de dernière passerelle.

    GK-B envoie ACF à GWY-B1.

    Établissement d'appel réussi.

Cette sortie de commande a été capturée dans GK-B pour illustrer plus loin ce comportement :


!--- From debug gatekeeper main 5.


GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Matched tech-prefix 1#
rassrv_put_remote_zones_from_zone_list() zone GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#

!--- From debug ras.


RecvUDP_IPSockData successfully received message of 
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode 
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from 
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) sent to 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd 
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719 
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
76 from 172.22.2.1:51141

Vérification et commandes de dépannage

Cette section fournit une liste de commandes d'exposition et de débogage qui sont utilisées pour vérifier et dépanner des questions de routage d'appels de garde-porte et de passerelle.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • show gateway — Utilisé pour vérifier E.164 et H.323 alias inscription à la passerelle.

  • show gatekeeper endpoints — Utilisé pour vérifier l'E.164 et H.323 alias inscrit au garde-porte.

  • show gatekeeper gw-type-prefix — Utilisé pour vérifier des enregistrements du préfixe E.164 sur le garde-porte.

  • show gatekeeper zone prefix | état — Utilisé pour vérifier l'état et les paramètres de configuration de zone.

  • debug ras — Applicable pour des passerelles et des garde-portes.

  • debug h225 asn1 — Applicable pour des passerelles et des garde-portes.

  • show dial-peer voice — Utilisé pour vérifier a configuré des préfixes de technologie sous les cadran-pairs.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 24462