Voix et communications unifiées : Passerelles universelles de la gamme Cisco AS5400

Configuration Cisco AS5350 ou AS5400 pour les appels RNIS et les appels de modem sortants

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cette configuration a Cisco AS5400 avec un accès primaire (PRI) et soutien de 23 appels par modem ou d'appels RNIS, selon l'hôte composant ou dedans. Il est configuré avec quatre PRIs pour permettre async et le RNIS les connexions sortantes. Nous avons configuré les Cartes de composeur statiques du côté appelant pour le chaque RNIS ou connexion async. Nous utilisons les artères statiques IP aux deux extrémités de la connexion pour éviter le temps système inutile d'un protocole de routage dynamique. Ajouter un site distant exigerait l'ajout d'une carte de numéroteur, du nom d'utilisateur, et d'une artère statique pour la nouvelle destination du côté appelant. Tous les Noeuds distants ont des adresses IP fixes.

Remarque: Ce document ne couvre pas le modem entrant et le RNIS fait appel aux Routeurs de gamme AS5350 ou AS5400. Pour plus d'informations sur ceci, référez-vous à configurer un AS5350/AS5400 pour l'asynchrone entrant et les appels RNIS.

Conditions préalables

Conditions requises

Avant de tenter cette configuration, assurez-vous que vous répondez à ces exigences :

  • Veuillez s'assurer que les circuits de PRI RNIS provisioned par la compagnie de téléphone pour le dialout-sync et async.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • AS5400 exécutant la version de logiciel 12.2(6) de ½ du ¿  de Cisco IOSïÂ

  • Un T1 PRI d'active

  • Modems Nextport exécutant le portware 0.6.108.0

Puisque cette configuration est seulement pour l'analogue de base et le dialin RNIS, n'importe quelle version de logiciel de Cisco IOS l'a pris en charge sur l'AS5350 et l'AS5400 est suffisante. Pour exécuter des fonctionnalités supplémentaires, référez-vous à l'outil Software Advisor pour sélectionner la version IOS et l'ensemble de caractéristiques appropriés pour vos besoins.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être appliquée au serveur d'accès AS5350 ou AS5400.

Cette configuration peut être modifiée pour l'usage avec des ports PRI d'E1. Configurez le contrôleur d'E1 avec le codage de ligne, le tramage et d'autres caractéristiques physiques fournis par la compagnie de téléphone. Le configuration du canal D (interface x:15 séquentiel pour E1) est semblable à celui affiché ici.

Cette configuration est très semblable à une configuration AS5200 ou AS5300 pour l'accès de dialout. Référez-vous au document AS5300 composant pour sortir avec ISDN/Async (DDR sortant). Le seul changement majeur entre les deux est le dial-tdm-clock priority number t1_slot/port de commande utilisé pour assigner la priorité d'horloge de t1 dans l'AS5350 ou l'AS5400.

Cette configuration peut également être modifiée pour prendre en charge les deux appels entrant et sortants. Référez-vous au document configurant Dialin et Dialout sur le même pour en savoir plus de circuits PRI T1/E1

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/24141/5400out.gif

Configurations

Ce document utilise les configurations suivantes :

5400
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 5400
!
no boot startup-test
!
username remoteISDN01 password open4u
username remoteAsync01 password open4u 

!--- Usernames for remote routers and shared secret 
!--- (used for CHAP authentication).
!--- These usernames are for local authentication of the call.
!--- The client presents the username/password and the NAS 
!--- authenticates the peer.
   
!
!
resource-pool disable
!
ip subnet-zero
ip cef
no ip domain-lookup
!
isdn switch-type primary-5ess
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 7/0

!--- T1 Physical interface controller configuration. 
!--- Interfaces are addressed as controller slot/port.

framing esf

!--- Framing for this T1 is Extended Super Frame (ESF). 
!--- Obtain this information from the Telco.

linecode b8zs

!--- Linecoding for this T1. Obtain this information from the Telco.

pri-group timeslots 1-24

!--- PRI T1 with 24 DSOs provided by the Telco.
!--- The PRI signaling is configured in global configuration or the 
!--- the serial 7/X:23 interface (d-channel). The signaling defined 
!--- under the d-channel takes precedence over the PRI signaling 
!--- defined in global configuration.

!

!--- Unsed T1 configuration omitted!

interface FastEthernet0/0
  ip address 172.68.186.54 255.255.255.240
  duplex auto
  speed auto
!
interface FastEthernet0/1
  no ip address
  shutdown
  duplex auto
  speed auto
!
interface Serial0/0
  no ip address
  shutdown
  clockrate 2000000
!
interface Serial0/1
  no ip address
  shutdown
  clockrate 2000000
!
interface Serial7/0:23
  no ip address
  encapsulation ppp
  dialer rotary-group 2

!--- The D-channel is added to rotary-group 2. Interface Dialer 2 
!--- provides the logical configuration for this interface.

  dialer-group 1
  isdn switch-type primary-5ess
  isdn incoming-voice modem

!--- This allows the PRI circuits to accept and place async modem calls.

!
interface Group-Async1

!--- This group-async interface is the configuration template for all modems.
!--- Individual async interface do not have to be configured since they 
!--- can be cloned from one managed copy.

  no ip address
  dialer in-band
  dialer rotary-group 1

!--- This command links this interface to logical interface Dialer interface 1.
!--- The Dialer 1 interface serves as template for this interface.

  group-range 1/00 6/107

!--- Modems 1/00 through 6/107 belong to this group-async interface.
!--- Make sure you configure line 1/00 through 6/107 as well.
!--- This command links all the modem ranges listed to this interface.

!
interface Dialer1

!--- This interface is used for the modem DDR dialout.
!--- This dialer controls rotary-group 1 (configured under Group-Async 1).
! -- Remember that this is a rotary and not a Dialer Profile

  ip address 10.1.1.1 255.255.255.192
  encapsulation ppp
  dialer in-band

!--- Makes this interface DDR capable.
!--- If you do not configure a dialer idle-timeout, the default will be 120
!--- seconds.

  dialer idle-timeout 600

!--- Sets Idle timer to 600 seconds (10 minutes).

  dialer map ip 10.1.1.2 name remoteAsync01 broadcast 4724125

!--- Dialer map for the peer. 
!--- Note the ip address matches the one configure on the peer. 
!--- The name must also exactly match the one used to authenticate the peer.

  dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
!--- Note: The specified dialer-group number must be the same as 
!--- the dialer-list number; in this example, defined as "1".
!--- Interesting traffic specifies the packets that should reset the idle timer.
  
  ppp authentication chap
!
interface Dialer2

!--- This interface will be used for the ISDN DDR outbound calls.
!--- This dialer controls rotary-group 2 (configured under Serial 7/0:23).
! -- Remember that this is a rotary and not a Dialer Profile

  ip address 10.1.1.65 255.255.255.192
  encapsulation ppp
  dialer in-band

!--- If you do not configure a dialer idle-timeout, the default will be 120
!--- seconds.

  dialer idle-timeout 600

!--- Sets Idle timer to 600 seconds (10 minutes).

  dialer map ip 10.1.1.66 name remoteISDN01 broadcast 6665800
  dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
!--- Note: The specified dialer-group number must be the same as 
!--- the dialer-list number; in this example, defined to be "1".
!--- Interesting traffic specifies the packets that should reset the idle timer.

  ppp authentication chap
!
ip classless
ip route 10.1.200.0 255.255.255.0 10.1.1.2

!--- Static route for the 10.1.200.0/24 network.
!--- Note the next hop IP address is the peer router. 
!--- This also matches the ip address in the dialer map
!--- statement under int Dialer 1.

  ip route 10.1.201.0 255.255.255.0 10.1.1.66

!--- Static route for the 10.1.201.0/24 network.
!--- Note the next hop IP address is the peer router. 
!--- This also matches the ip address in the dialer map
!--- statement under interface Dialer 2 no ip http server.

!
dialer-list 1 protocol ip permit

!--- Specifies all IP traffic as interesting. Interesting traffic 
!--- specifies the packets that should reset the idle timer. 
!--- This is applied to interface Group-Async 1 using dialer-group 1.
!--- Note: The specified dialer-list number must be the same as the 
!--- dialer-group number; in this example, defined to be "1".

!
!
call rsvp-sync
!
voice-port 7/0:D
!
voice-port 7/1:D
!
voice-port 7/2:D
!
voice-port 7/3:D
!
!
mgcp profile default
!
!
line con 0
line aux 0
line vty 0 4
login
line 1/00 1/107

!--- These lines are linked to the modems. Note that this range includes 
!--- the group-range configured under group-async 1.

modem InOut
!--- Permit incoming and outgoing calls on the modem.
transport input all
line 6/00 6/107

!--- These lines are linked to the modems. Note that this line range is
!--- included in the group-range configured under group-async 1.

  modem InOut
  transport input all
!
scheduler allocate 10000 400
end

remoteAsync01
remoteAsync01
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteAsync01
!
enable password <deleted>
!
username 5400 password open4u

!--- Username and password for the 5400.
!--- The shared secret password must be identical on both sides.

ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
  no ip address
  no ip directed-broadcast
  shutdown
!
interface Serial1
  no ip address
  no ip directed-broadcast
  shutdown
!
interface Async1

!--- Async interface for the incoming modem call.

  ip address 10.1.1.2 255.255.255.192

!--- IP address for this interface. 
!--- Note: this ip address is the same as the one configured in the 
!--- dialer map on the 5400 Dialer 1.

  no ip directed-broadcast
  encapsulation ppp
  ppp authentication chap
 !
 no ip http server
  ip classless
  ip route 0.0.0.0 0.0.0.0 10.1.1.1

!--- Default router with next hop being the 5400's dialer 1 ip address.

!
 line con 0
  transport input none
 line 1 8

!--- Line number range includes line 1(corresponding to interface async1).

   modem InOut
   transport input all
   speed 38400
   flowcontrol hardware
 line aux 0
 line vty 0 4
!
end

remoteISDN01
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname remoteISDN01
!
enable secret <deleted>
!
username 5400 password open4u

!--- Username and password for the 5400 router.
!--- The shared secret password must be identical on both sides.

ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.1.201.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0

!--- BRI interface for incoming call.

 ip address 10.1.1.66 255.255.255.192

!--- IP address is the same as that configured on the 5400 Dialer 2 
!--- dialer map statement.
!--- A dialer map is not needed on this router. A dynamic map will be created
!--- for incoming calls. If this router is to be used for outgoing calls
!--- then a dialer map is needed.

 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1

!--- Interesting traffic definition from dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
!
no ip http server
 ip classless
 ip route 0.0.0.0 0.0.0.0 10.1.1.65

!--- Default route points to ip address of 5400 dialer 2 interface.

!
dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • état de show isdn — L'état devrait être :

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED
    

    Si la couche 1 n'est pas en activité, l'adaptateur ou le port de câblage peut être mauvais ou non branché. Si la couche 2 est dans un état de « TEI_ASSIGNED », le routeur ne parle pas au commutateur. Référez-vous au T1 PRI dépannant le pour en savoir plus de document.

  • service de show isdn — Pour vérifier le statut des canaux B. Il devrait y a un canal occupé pour chaque appel.

  • show caller — Affiche des paramètres pour l'utilisateur particulier tel que l'adresse IP assignée, le protocole de point-à-point (PPP) et les paramètres d'ensemble de PPP, et ainsi de suite. Si votre version de logiciel de Cisco IOS ne prend en charge pas cette commande, utilisez l'ordre d'utilisateur d'exposition.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

Configurez les horodateurs en configuration globale comme suit :

service timestamps debug datetime msec 
service timestamps log datetime msec 

Utilisez les commandes suivantes pour le dépannage :

  • mettez au point le numéroteur — Quand le Routage à établissement de connexion à la demande (DDR) est activé sur l'interface, cette affiche des informations de commande au sujet de la cause de tout appel (appelé la cause d'appel).

  • debug isdn q931 — Pour vérifier des connexions RNIS comme appels sortants sont initiés.

  • debug ppp negotiation — Pour voir si un client passe la négociation PPP. Un nombre élevé de négociations PPP simultanées peut accabler la CPU de routeur.

  • debug ppp authentication — Pour voir si un client passe l'authentification.

  • debug ppp error — Pour afficher des erreurs de protocole et des statistiques sur les erreurs a associé avec la négociation et l'exécution de connexion PPP.

Pour le dépannage de modem, utilisez les commandes suivantes :

  • debug modem — Pour voir si le routeur reçoit les bons signaux du modem.

  • debug modem csm — Pour activer le module de commutation d'appel de gestion de modems (CSM) mettez au point le mode.

Pour plus d'informations sur le NextPort les commandes satisfont se rapportent à gérer des services des ports sur la Passerelle universelle Cisco AS5400.

Exemple de sortie de débogage

Sont ci-dessous quelques sorties de débogage pour des appels réussis. Prêtez l'attention aux sections en gras et aux commentaires fournis dans les sorties. Comparez la sortie que vous obtenez avec le résultat affiché ci-dessous.

Appel par modem sortant

Router#show debug 
General OS: 
 Modem control/process activation debugging is on 
Dial on demand: 
  Dial on demand events debugging is on 
 CSM Modem: 
  Modem Management Call Switching Module debugging is on 
PPP: 
  PPP authentication debugging is on 
  PPP protocol errors debugging is on 
  PPP protocol negotiation debugging is on 
 ISDN: 
 ISDN events debugging is on 
 ISDN Q931 packets debugging is on 
ISDN events debug DSLs. (On/Off/No DSL:1/0/-) 
DSL  0 --> 31 
1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 
ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-) 
DSL  0 --> 31 
1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 
  
Router#ping 10.1.1.2 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds: 
*Jan  2 01:07:19.085: As1/107 DDR: rotor dialout [priority] 
*Jan  2 01:07:19.085: As1/107 DDR: Dialing cause ip (s=10.1.1.1, d=10.1.1.2) 
*Jan  2 01:07:19.085: As1/107 DDR: Attempting to dial 4724125 

!--- The DDR process has detected interesting traffic destined for a device off 
!--- dialer 1's interface and is inticating a call.

*Jan  2 01:07:19.085: CHAT1/107: Attempting async line dialer script 
*Jan  2 01:07:19.085: CHAT1/107: no matching chat script found for 4724125 
*Jan  2 01:07:19.085: CHAT1/107: Dialing using Modem script: d0efault-d0ials0cript 
& System script: none 
*Jan  2 01:07:19.085: CHAT1/107: process started 
*Jan . 2 01:07:19.085: CHAT1/107: Asserting DTR 
*Jan  2 01:07:19.085: CHAT1/107: Chat script d0efault-d0ials0cript started 
*Jan  2 01:07:20.533: CSM DSPLIB(1/107): Rcvd Dial String (4724125) 
*Jan  2 01:07:20.533: CSM_PROC_IDLE: CSM_EVENT_MODEM_OFFHOOK at slot 1, port 107 
*Jan  2 01:07:20.537: csm_get_signaling_channel csm_call_info->bchan_num 0xFFFFFFFF 
*Jan  2 01:07:20.537: csm_get_signaling_channel dchan_index=16504,next_index=0,
dchan_info=0x628C2BF0 
*Jan  2 01:07:20.537: CSM_PROC_OC3_COLLECT_ALL_DIGIT: CSM_EVENT_GET_ALL_DIGITS 
at slot 1, port 107 
*Jan  2 01:07:20.537: CSM_PROC_OC3_COLLECT_ALL_DIGIT: called party num: (4724125) 
at slot 1, port 107

!--- The Call Switch Module (CSM) is informed of the call. 
!--- The CSM allocates modem 1/107 for the outbound call.

*Jan  2 01:07:20.537: csm_get_signaling_channel csm_call_info->bchan_num 0xFFFFFFFF 
*Jan  2 01:07:20.537: csm_get_signaling_channel dchan_index=24935,next_index=0,
dchan_info=0x628C2BF0 
*Jan  2 01:07:20.537: ISDN Se7/0:23: Outgoing call id = 0x800F, dsl 0 
*Jan  2 01:07:20.537: CSM_PROC_OC3_COLLECT_ALL_DIGIT:  csm_call_info->bchan_num 
0xFFFFFFFF 
*Jan  2 01:07:20.537: ISDN Se7/0:23: VOICE_I.SDNCALL Event: call id 0x800F, 
bchan 65535, ces 0 
*Jan  2 01:07:20.537: ISDN Se7/0:23: process_pri_call(): call id 0x800F, 
number 4724125, speed 64, call type VOICE, redialed? f, csm call? t, pdata? f 
*Jan  2 01:07:20.537: trying to get callinf from isdn_info 
*Jan  2 01:07:20.537: Don't know what calling number for later redial. 
*Jan  2 01:07:20.537: ISDN: Created entry call_id 0x800F, speed 64, remote 4724125, 
calling 
*Jan  2 01:07:20.537: callED type/plan overridden by call_decode 
*Jan  2 01:07:20.537: did't copy oct3a reason: not CALLER_NUMBER_IE 
*Jan  2 01:07:20.537:  building outgoing channel id for call nfas_int is 0 len is 0 
*Jan  2 01:07:20.537: ISDN Se7/0:23: TX -> SETUP pd = 8  callref = 0x000C 
*Jan  2 01:07:20.537:         Bearer Capability i = 0x8090A2 
*Jan  2 01:07:20.537:         Channel ID i = 0xA98397 
*Jan  2 01:07:20.537:         Called Party Number i = 0xA1, '4724125', Plan:ISDN, 
Type:National

!--- Outgoing Q.931 SETUP message. Indicates an outgoing call. 
!--- For more information on Q.931 refer to the document: 
!--- Troubleshooting ISDN Layer 3 using the debug isdn q931 Command.

*Jan  2 01:07:20.617: ISDN Se7/0:23: RX <- CALL_PROC pd = 8  callref = 0x800C 
*Jan  2 01:07:20.617:         Channel. ID i = 0xA98397

!--- The Call Proceeding Message is sent through the D-channel.

*Jan  2 01:07:20.617: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_PROCEEDING 
*Jan  2 01:07:20.617: ISDN Se7/0:23: CALL_PROCEEDING id 0x800F 
*Jan  2 01:07:20.617: ISDN Se7/0:23: PRI Event: 6, bchan = 22, call type = VOICE 
*Jan  2 01:07:20.617: EVENT_FROM_ISDN: dchan_idb=0x62C31CC0, call_id=0x800F, ces=0x1 
   bchan=0x16, event=0x3, cause=0x0 
*Jan  2 01:07:20.617: EVENT_FROM_ISDN:(800F): DEV_CALL_PROC at slot 1 and port 107, 
bchan 22 on Serial7/0:23 
*Jan  2 01:07:20.617: CSM_PROC_OC4_DIALING: CSM_EVENT_ISDN_BCHAN_ASSIGNED at slot 1, 
port 107 
*Jan  2 01:07:20.617: csm_connect_pri_vdev: TS allocated at bp_stream 0, bp_Ch 9, 
vdev_common 0x624BAD88 1/107 
*Jan  2 01:07:20.617: CSM DSPLIB(1/107): np_dsplib_prepare_modem 
*Jan  2 01:07:20.625: CSM DSPLIB(1/107):DSPLIB_MODEM_INIT: 
Modem session transition to IDLE 
*Jan  2 01:07:20.717: ISDN Se7/0:23: RX <- ALERTING pd = 8  callref = 0x800C 
*Jan  2 01:07:20.717: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_PROGRESS 
*Jan  2 01:07:20.717: ISDN Se7/0:23: event CA.LL_PROGRESS dsl 0 
*Jan  2 01:07:20.797: ISDN Se7/0:23: RX <- CONNECT pd = 8  callref = 0x800C

!--- Received the Q.931 CONNECT.

*Jan  2 01:07:20.797: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_CONNECT 
*Jan  2 01:07:20.797: ISDN Se7/0:23: Event CALL_CONNECT dsl 0 
*Jan  2 01:07:20.797: EVENT_FROM_ISDN: dchan_idb=0x62C31CC0, call_id=0x800F, 
ces=0x1 bchan=0x16, event=0x4, cause=0x0 
*Jan  2 01:07:20.797: EVENT_FROM_ISDN:(800F): DEV_CONNECTED at slot 1 and port 107 
*Jan  2 01:07:20.797: CSM_PROC_OC5_WAIT_FOR_CARRIER: CSM_EVENT_ISDN_CONNECTED 
at slot 1, port 107 
*Jan  2 01:07:20.797: CSM DSPLIB(1/107): np_dsplib_call_accept 
*Jan  2 01:07:20.797: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x800F CALL_PROGRESS 
*Jan  2 01:07:20.797: ISDN Se7/0:23: event CALL_PROGRESS dsl 0 
*Jan  2 01:07:20.797: ISDN Se7/0:23: TX -> CONNECT_ACK pd = 8  callref = 0x000C

!--- D-channel transmits a CONNECT_ACK.

*Jan  2 01:07:20.801: CSM DSPLIB(1/107):DSPLIB_MODEM_WAIT_ACTIVE: 
Modem session transition to ACTIVE 
*Jan  2 01:07:20.801: CSM DSPLIB(1/107): Modem state changed to (CONNECT_STATE) 
*Jan  2 01:07:26.797: %ISDN-6-CONNECT: 
Interface Serial7/0:22 is now connected to 4724125 
*Jan  2 01:07:26.893: CSM DSPLIB(1/107): Modem state changed to (LINK_STATE) 
*Jan  2 01:07:29.837: CSM DSPLIB(1/107): Modem state changed to (TRAINUP_STATE) 
*Jan  2 01:07:37.997: CSM DSPLIB(1/107): Modem state changed to (EC_NEGOTIATING_STATE) 
*Jan  2 01:07:38.333: CSM DSPLIB(1/107): Modem state changed to (STEADY_STATE)

!--- Modems have trained up and are in a steady state.

*Jan  2 01:07:38.333: CHAT1/107: Chat script d0efault-d0ials0cript finished, 
status = Success 
*Jan  2 01:07:38.333: TTY1/107: no timer type 1 to destroy 
*Jan  2 01:07:38.333: TTY1/107: no timer type 0 to destroy 
*Jan  2 01:07:38.333: Di1 IPCP: Install route to 10.1.1.2 
*Jan  2 01:07:40.333: %LINK-3-UPDOWN: Interface Async1/107, changed state to up 
*Jan  2 01:07:40.333: As1/107 DDR: Dialer statechange to up 
*Jan  2 01:07:40.333: As1/107 DDR: Dialer call has been placed 
*Jan  2 01:07:40.333: As1/107 PPP: Treating connection as a callout 
*Jan  2 01:07:40.333: As1/107 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 1 load]

!--- LCP negotiation begins.

*Jan  2 01:07:42.469: As1/107 LCP: I CONFREQ [REQsent] id 1 len 25 
*Jan  2 01:07:42.469: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:42.469: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:42.469: As1/107 LCP:    MagicNumber 0x2862C096 (0x05062862C096) 
*Jan  2 01:07:42.469: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:42.469: As1/107 LCP:    ACFC (0x0802)

!--- Incoming LCP CONFREQ. 
!--- For more information on interpreting PPP debugs refer to the document: 
!--- Dialup Technology: Troubleshooting Techniques

*Jan  2 01:07:42.469: As1/107 LCP: O CONFACK [REQsent] id 1 len 25 
*Jan  2 01:07:42.469: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:42.469: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:42.469: As1/107 LCP:    MagicNumber 0x2862C096 (0x05062862C096) 
*Jan  2 01:07:42.469: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:42.469: As1/107 LCP:    ACFC (0x0802) 
*Jan  2 01:07:44.333: As1/107 LCP: O CONFREQ [ACKsent] id 29 len 25 
*Jan  2 01:07:44.333: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:44.333: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:44.333: As1/107 LCP:    MagicNumber 0x081D8CEC (0x0506081D8CEC) 
*Jan  2 01:07:44.333: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:44.333: As1/107 LCP:    ACFC (0x0802) 
*Jan  2 01:07:44.461: As1/107 LCP: I CONFACK [ACKsent] id 29 len 25 
*Jan  2 01:07:44.461: As1/107 LCP:    ACCM 0x000A0000 (0x0206000A0000) 
*Jan  2 01:07:44.461: As1/107 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 01:07:44.461: As1/107 LCP:    MagicNumber 0x081D8CEC (0x0506081D8CEC) 
*Jan  2 01:07:44.461: As1/107 LCP:    PFC (0x0702) 
*Jan  2 01:07:44.461: As1/107 LCP:    ACFC (0x0802) 
*Jan  2 01:07:44.461: As1/107 LCP: State is Open

! --- LCP negotiation is complete.

*Jan  2 01:07:44.461: As1/107 PPP: Phase is AUTHENTICATING, by both 
[0 sess, 1 load] 
*Jan  2 01:07:44.461: As1/107 CHAP: O CHALLENGE id 16 len 27 from "Router" 
*Jan  2 01:07:44.477: As1/107 CHAP: I CHALLENGE id 1 len 34 from "remoteAsync01" 
*Jan  2 01:07:44.477: As1/107 CHAP: O RESPONSE id 1 len 27 from "Router" 
*Jan  2 01:07:44.581: As1/107 CHAP: I RESPONSE id 16 len 34 from "remoteAsync01" 
*Jan  2 01:07:44.581: As1/107 CHAP: O SUCCESS id 16 len 4 
*Jan  2 01:07:44.601: As1/107 CHAP: I SUCCESS id 1 len 4

!--- CHAP authentication is successful. 
!--- If this fails, verify that the username and password are correct. 
!--- Refer to Dialup Technology: Troubleshooting Techniques.


*Jan  2 01:07:44.601: As1/107 PPP: Phase is UP [0 sess, 1 load] 
*Jan  2 01:07:44.601: As1/107 IPCP: O CONFREQ [Closed] id 6 len 10 
*Jan  2 01:07:44.601: As1/107 IPCP:    Address 10.1.1.1 (0x03060A010101) 
*Jan  2 01:07:44.601: As1/107 CDPCP: O CONFREQ [Closed] id 5 len 4 
*Jan  2 01:07:44.701: As1/107 IPCP: I CONFREQ [REQsent] id 1 len 10 
*Jan  2 01:07:44.701: As1/107 IPCP:    Address 10.1.1.2 (0x03060A010102) 
*Jan  2 01:07:44.701: As1/107 IPCP: O CONFACK [REQsent] id 1 len 10 
*Jan  2 01:07:44.701: As1/107 IPCP:    Address 10.1.1.2 (0x03060A010102) 
*Jan  2 01:07:44.705: As1/107 CDPCP: I CONFREQ [REQsent] id 1 len 4 
*Jan  2 01:07:44.705: As1/107 CDPCP: O CONFACK [REQsent] id 1 len 4 
*Jan  2 01:07:44.733: As1/107 IPCP: I CONFACK [ACKsent] id 6 len 10 
*Jan  2 01:07:44.733: As1/107 IPCP:    Address 10.1.1.1 (0x03060A010101) 
*Jan  2 01:07:44.733: As1/107 IPCP: State is Open 
*Jan  2 01:07:44.733: As1/107 DDR: dialer protocol up

!--- The route has been successfully negotiated and installed in the routing table.

*Jan  2 01:07:44.737: As1/107 CDPCP: I CONFACK [ACKsent] id 5 len 4 
*Jan  2 01:07:44.737: As1/107 CDPCP: State is Open 
*Jan  2 01:07:45.601: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async1/107, 
changed state to up 
*Jan  2 01:07:48.321: TTY0: timer type 1 expired 
*Jan  2 01:07:48.321: TTY0:  Exec timer (continued)

Appel RNIS sortant

Sont ci-dessous quelques sorties de débogage pour l'appel sortant réussi RNIS. Prêtez l'attention aux sections en gras et aux commentaires fournis dans les sorties. Comparez la sortie que vous obtenez avec le résultat affiché ci-dessous.

Router#show debug 
Dial on demand: 
  Dial on demand events debugging is on 
PPP: 
  PPP authentication debugging is on 
  PPP protocol errors debugging is on 
  PPP protocol negotiation debugging is on 
ISDN: 
  ISDN events debugging is on 
  ISDN Q931 packets debugging is on 
  ISDN events debug DSLs. (On/Off/No DSL:1/0/-) 
  DSL  0 --> 31 
  1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 
  ISDN Q931 packets de  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-) 
  DSL  0 --> 31 
  1 - - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - - 

Router#ping 10.1.1.66 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 10.1.1.66, timeout is 2 seconds: 
*Jan  2 02:00:59.937: Se7/0:23 DDR: rotor dialout [priority] 
*Jan  2 02:00:59.937: Se7/0:23 DDR: Dialing cause ip (s=10.1.1.65, d=10.1.1.66) 
*Jan  2 02:00:59.937: Se7/0:23 DDR: Attempting to dial 6665800

!--- The DDR process has detected interesting traffic destined for a device off 
!--- dialer 1's interface and is inticating a call.

*Jan  2 02:00:59.937: ISDN Se7/0:23: Outgoing call id = 0x8016, dsl 0 
*Jan  2 02:00:59.937: ISDN Se7/0:23: Event: Call to 4724125 at 64 Kb/s 
*Jan  2 02:00:59.937: ISDN Se7/0:23: process_pri_call(): call id 0x8016, 
number 6665800, speed 64, call type DATA, redialed? f, csm call? f, pdata? f 
*Jan  2 02:00:59.937: callED type/plan overridden by call_decode 
*Jan  2 02:00:59.937: did't copy oct3a reason: not CALLER_NUMBER_IE 
*Jan  2 02:00:59.941:  building outgoing channel id for call nfas_int is 0 len is 0 
*Jan  2 02:00:59.941: ISDN Se7/0:23: TX -> SETUP pd = 8  callref = 0x0013 
*Jan  2 02:00:59.941:         Bearer Capability i = 0x8890 
*Jan  2 02:00:59.941:         Channel ID i = 0xA98397 
*Jan  2 02:00:59.941:         Called Pa.rty Number i = 0xA1, '6665800', 
Plan:ISDN, Type:National

!--- Outgoing Q.931 SETUP message. Indicates an outgoing call. 
!--- For more information on Q.931 refer to the document. 
!--- Troubleshooting ISDN Layer 3 using the debug isdn q931 Command.

*Jan  2 02:01:00.017: ISDN Se7/0:23: RX <- CALL_PROC pd = 8  callref = 0x8013 
*Jan  2 02:01:00.017:         Channel ID i = 0xA98397

!--- The Call Proceeding Message is sent through the D-channel.

*Jan  2 02:01:00.017: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x8016 CALL_PROCEEDING 
*Jan  2 02:01:00.017: ISDN Se7/0:23: CALL_PROCEEDING id 0x8016 
*Jan  2 02:01:00.021: ISDN Se7/0:23: PRI Event: 6, bchan = 22, call type = DATA 
*Jan  2 02:01:00.093: ISDN Se7/0:23: RX <- CONNECT pd = 8  callref = 0x8013

!--- Received the Q.931 CONNECT.

*Jan  2 02:01:00.097: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x8016 CALL_CONNECT 
*Jan  2 02:01:00.097: ISDN Se7/0:23: Event CALL_CONNECT dsl 0 
*Jan  2 02:01:00.097: %LINK-3-UPDOWN: Interface Serial7/0:22, changed state to up 
*Jan  2 02:01:00.097: Se7/0:22 PPP: Treating connection as a callout 
*Jan  2 02:01:00.097: Se7/0:22 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

!--- LCP negotiation begins.

*Jan  2 02:01:00.097: Se7/0:22 LCP: O CONFREQ [Closed] id 7 len 15 
*Jan  2 02:01:00.097: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.097: Se7/0:22 LCP:    MagicNumber 0x084E600A (0x0506084E600A) 

!--- Outgoing LCP CONFREQ. 
!--- For more information on interpreting PPP debugs refer to the document 
!--- Dialup Technology: Troubleshooting Techniques.

*Jan  2 02:01:00.097: ISDN Se7/0:23: LIF_EVENT: ces/callid 1/0x8016 CALL_PROGRESS 
*Jan  2 02:01:00.097: ISDN Se7/0:23: event CALL_PROGRESS dsl 0 
*Jan  2 02:01:00.097: ISDN Se7/0:23: TX -> CONNECT_ACK pd = 8  callref = 0x0013

!--- D-channel transmits a CONNECT_ACK.

*Jan  2 02:01:00.105: Se7/0:22 LCP: I CONFREQ [REQsent] id 30 len 15 
*Jan  2 02:01:00.105: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.105: Se7/0:22 LCP:    MagicNumber 0x28938B8C (0x050628938B8C) 
*Jan  2 02:01:00.105: Se7/0:22 LCP: O CONFACK [REQsent] id 30 len 15 
*Jan  2 02:01:00.105: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.109: Se7/0:22 LCP:    MagicNumber 0x28938B8C (0x050628938B8C) 
*Jan  2 02:01:00.109: Se7/0:22 LCP: I CONFACK [ACKsent] id 7 len 15 
*Jan  2 02:01:00.109: Se7/0:22 LCP:    AuthProto CHAP (0x0305C22305) 
*Jan  2 02:01:00.109: Se7/0:22 LCP:    MagicNumber 0x084E600A (0x0506084E600A) 
*Jan  2 02:01:00.109: Se7/0:22 LCP: State is Open

! --- LCP negotiation is complete.

*Jan  2 02:01:00.109: Se7/0:22 PPP: Phase is AUTHENTICATING, by both [0 sess, 1 load] 
*Jan  2 02:01:00.109: Se7/0:22 CHAP: O CHALLENGE id 7 len 27 from "Router" 
*Jan  2 02:01:00.121: Se7/0:22 CHAP: I CHALLENGE id 25 len 33 from "remoteISDN01" 
*Jan  2 02:01:00.121: Se7/0:22 CHAP: O RESPONSE id 25 len 27 from "Router" 
*Jan  2 02:01:00.129: Se7/0:22 CHAP: I SUCCESS id 25 len 4 
*Jan  2 02:01:00.137: Se7/0:22 CHAP: I RESPONSE id 7 len 33 from "remoteISDN01" 
*Jan  2 02:01:00.137: Se7/0:22 CHAP: O SUCCESS id 7 len 4

!--- CHAP authentication is successful. 
!--- If this fails verify that the username and password are correct. 
!--- Refer to Dialup Technology: Troubleshooting Techniques.

*Jan  2 02:01:00.137: Se7/0:22 PPP: Phase is UP [0 sess, 1 load] 
*Jan  2 02:01:00.137: Se7/0:22 IPCP: O CONFREQ [Closed] id 2 len 10 
*Jan  2 02:01:00.137: Se7/0:22 IPCP:    Address 10.1.1.65 (0x03060A010141) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: I CONFREQ [REQsent] id 3 len 10 
*Jan  2 02:01:00.145: Se7/0:22 IPCP:    Address 10.1.1.66 (0x03060A010142) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: O CONFACK [REQsent] id 3 len 10 
*Jan  2 02:01:00.145: Se7/0:22 IPCP:    Address 10.1.1.66 (0x03060A010142) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: I CONFACK [ACKsent] id 2 len 10 
*Jan  2 02:01:00.145: Se7/0:22 IPCP:    Address 10.1.1.65 (0x03060A010141) 
*Jan  2 02:01:00.145: Se7/0:22 IPCP: State is Open 
*Jan  2 02:01:00.145: Se7/0:22 DDR: dialer protocol up 
*Jan  2 02:01:00.145: Di2 IPCP: Install route to 10.1.1.66

!--- The Route has been successfully negotiated and installed in the routing table.

*Jan  2 02:01:01.137: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial7/0:22,
changed state to up 
*Jan  2 02:01:06.097: %ISDN-6-CONNECT: Interface Serial7/0:22 
is now connected to 6665800 remoteISDN01

Informations connexes


Document ID: 24141