Voix : Qualité vocale

QoS voix : Signalisation des paquets ToS-CoS pour utilisation avec LLQ

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit la qualité de service (QoS) pour la voix sur IP (VoIP) dans un environnement de réseau local en mappant les paramètres de types de service (ToS) pour les classes de service (CoS).

Jusque récemment, le consensus général était que QoS ne serait jamais une question dans le côté d'entreprise dû à la nature bursty du trafic réseau et à la capacité du débordement de tampon. La raison pour QoS du côté LAN est due à bufferiser, pas manque de bande passante. Pour cette raison, des outils de QoS sont exigés pour parvenir ces mémoires tampons pour réduire la perte, le retard, et la variation de délai. Transmettez les mémoires tampons ont une tendance de remplir à la capacité dans les réseaux à haute vitesse dus à la nature bursty des réseaux de données combinés avec le grand volume de plus petits paquets de Protocole TCP (Transmission Control Protocol). Si une mémoire tampon de sortie remplit, les interfaces d'entrée ne peuvent pas placer immédiatement le nouveau trafic d'écoulement dans la mémoire tampon de sortie. Une fois que la mémoire tampon d'entrée remplit (peut se produire rapidement), les pertes de paquets se produisent. C'est où la Qualité vocale peut probablement dégrader en raison de la perte de paquets.

Le trafic VoIP est sensible aux deux paquets différés et paquets abandonnés. Le retard devrait ne jamais être un facteur, indépendamment de la taille de la mémoire tampon de file d'attente, due à la grande vitesse sur des liens de RÉSEAU LOCAL. Cependant, les baisses toujours compromettent la Qualité vocale dans tous les réseaux. L'utilisation de plusieurs files d'attente sur des interfaces de transmission est la seule manière d'éliminer le potentiel pour le trafic abandonné provoqué par les mémoires tampons qui fonctionnent à la capacité de 100%. La séparation de la Voix et du vidéo (sensible aux retards et aux baisses) dans leurs propres files d'attente peut empêcher des écoulements d'être abandonné à l'interface d'entrée, même si les flux de données remplissent données transmettent la mémoire tampon.

Dans les réseaux avec des charges de trafic élevé, il est essentiel de parvenir la livraison du trafic de contrôle à assurer une expérience utilisateur positive avec le VoIP. Ceci est facilement illustré. Par exemple, quand un téléphone IP disparaît le hors fonction-crochet, il demande au Cisco CallManager quoi faire. Le Cisco CallManager demande alors au téléphone IP pour jouer la tonalité. Si le trafic maigre de Gestion et de contrôle de Protocol de client est abandonné ou retardé, l'expérience utilisateur est compromise. Afin de fournir QoS, identifier des en-têtes de paquet par une priorité plus élevée et les tracer correctement aux en-têtes de la couche 2 pour que les Catalyst comprennent. Ceci assure l'attribution appropriée des priorités sur les paquets vocaux à travers le RÉSEAU LOCAL.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et matériel suivantes :

  • Passerelle de Voix de Cisco 3725 avec la version de logiciel 12.3(4)T de ½ du ¿  de Cisco IOSïÂ.

  • Commutateur de Catalyst 4000

  • Cisco CallManagers et Téléphones IP

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/23442/tos-cos-1.gif

Configurations

Ce document utilise les configurations suivantes.

Cette configuration affiche comment tracer le tos/les valeurs de point code de Différenciation de services (DSCP) dans une valeur CoS dans la partie en-tête 802.1p. Il y a beaucoup de manières d'implémenter ceci et les légères différences varient selon votre conception. Les deux exemples de configuration ici sont équivalents et l'un ou l'autre un peut être utilisé pour réaliser le même résultat. Soyez sûr de permettre seulement les paquets VoIP qui ont une Priorité IP de (5) essentiel dans le bit de tos. Aucun autre trafic ne devrait avoir ce bit réglé à essentiel. Ceci entraîne la superposition du trafic non désiré dans la file d'attente de Voix.

Remarque: La configuration LLQ est faite sur d'autres périphériques dans le réseau tel que le Catalyst 4000, qui n'est pas discuté dans ce document.

En cet premier exemple, seulement flots de RTP que le match ip precedence 5 sont étiquetés, et pas RTCP ou tous paquets de la signalisation H.225/245 et de la Messagerie.

Cisco 3660 (exemple 1)
!
ip cef
!

!--- The Cisco Express Forwarding (CEF) mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".

! 
class-map match-all RTP
match ip precedence 5 

!--- This command matches on all packets with the IP precedence of 5.
 
!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all packets which previously matched on class-map RTP for 
!--- having precedence of 5, the CoS bit is now set to 5.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and 
!--- carries a lower priority of delivery.

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816

!--- There must be subinterfaces for FastEthernet to enable trunking, 
!--- as well as either dot1q or isl encapsulation.

ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply the QoS to the interface that connects to the LAN
!--- via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Remarque: L'ip qos dscp de commande a été introduit dans le Logiciel Cisco IOS version 12.2(2)T. Il remplace la commande d'ip precedence (dial peer). Tous les Routeurs qui fonctionnent sur le Logiciel Cisco IOS version 12.2(2)T et plus tôt peuvent utiliser la Priorité IP dans la configuration de cadran-pair.

Le deuxième exemple a différents paramètres assortis pour des classes de policy-map. La configuration de Cisco 3660 s'assortit sur les paquets de l'établissement d'appel H.225 aussi bien que les flots de RTP. Les critères de correspondance pour le flot de RTP sont également légèrement différents. Ne regardez pas les en-têtes IP, seulement regardez la chaîne de port UDP. S'il tombe entre 16384 et 32767, étiquetez-les et envoyez-les au policy-map.

Cisco 3660 (exemple 2)
!
ip cef
!

!--- The CEF mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".
!
class-map match-all Call-Control
match access-group 101
!
class-map match-all RTP
match ip rtp 16384 16383

!--- Match on UDP port range 16384-32767 to single out 
!--- VoIP packets for policy-map.

!
access-list 101 permit tcp host 10.120.16.112 any eq 1720

!--- Match on all packets using TCP port 1720 which is 
!--- dedicated for H.225 call setup. 

!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all VoIP packets that match the  UDP port range listed above,
!--- set the CoS bit to 5.

class Call-Control
set CoS 3
set ip precedence 3

!--- For all signaling and control packets that match access-list 
!--- 101, set the CoS bit to 3 and IP precedence to 3.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and carries a 
!--- lower priority of delivery. 

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply your QoS to the interface that connects to the 
!--- LAN via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media 
no vad
!

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show policy-map interface — Les affichages apparient des compteurs pour toutes les classes d'une carte de stratégie de service indiquée.

Les Routeurs sont maintenant configurés pour tracer le tos mordus au bit de cos. Utilisez la commande de show policy-map interface de s'assurer que le trafic est marqué réellement selon la configuration.

Dans cet premier exemple de sortie, les 539 paquets VoIP apparient le class-map et chacun des 539 paquets a le bit de cos marqué à une valeur d'essentiel en conséquence. Ce type de Mise en file d'attente ne doit pas attendre l'encombrement pour être en activité. Tant que il y a du trafic vocal qui traverse le lien de FastEthernet, il marque tous les paquets en conséquence. Dans le deuxième exemple, tous les paquets VoIP ont marqué à la valeur CoS de 5 et tous les paquets de signalisation sont marqués à une valeur CoS de 3 selon la configuration.

Premier exemple de configuration du 3660 :

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816  
  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      539 packets, 42042 bytes
      5 minute offered rate 2000 bps, drop rate 0 BPS
      Match: ip precedence 5 
      QoS Set
        CoS 5
          Packets marked 539

    Class-map: class-default (match-any)
      13 packets, 1803 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 13

Deuxième exemple de configuration du 3660 :

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816 

  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      370 packets, 28860 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip rtp 16384 16383
      QoS Set
        CoS 5
          Packets marked 370

    Class-map: Call-Control (match-all)
      26 packets, 2697 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: access-group 101
      QoS Set
        ip precedence 3
          Packets marked 26
        CoS 3
          Packets marked 26

    Class-map: class-default (match-any)
      4363 packets, 515087 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 4363
vdtl-3660-16a#

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 23442