Voix et communications unifiées : Passerelles universelles de la gamme Cisco AS5300

Utilisation de Dialout/EZ avec un serveur d'accès Cisco

15 août 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (29 janvier 2008) | Commentaires


Contenu

Introduction
Conditions préalables
      Conditions requises
      Composants utilisés
      Conventions
Installation et configuration
      Installant les pilotes de modem compétents pour Dialout/EZ le port COM virtuel
      Configurer le serveur d'accès
Dépanner DialOut/EZ
Configurations de NAS d'échantillon pour l'utilitaire DialOut/EZ
      AS25xx, Nanomètre-xAM, WIC-xAM
      AS5xxx sans AAA
      AS5xxx avec l'AAA
Conversations connexes de la communauté de soutien de Cisco
Informations connexes

Introduction

Le produit DialOut/EZ du logiciel tactique permet aux utilisateurs de LAN de bureau pour partager des ports de serveur d'accès réseau (NAS) en tant que pool de modems pour les communications asynchrones sortantes. Les utilisateurs de DialOut/EZ n'ont besoin plus de modems et de lignes téléphoniques dédiés à leurs appareils de bureau, mais emploient à la place le logiciel de redirecteur de port de la transmission (COM :) pour permettre à des ports de numérotation sur les serveurs d'accès pour apparaître comme modems locaux aux applications des communications de bureau. Les utilisateurs Windows peuvent composer par un serveur central NAS/access pour accéder à des services en ligne distants et pour envoyer même des télécopies de leurs PC. L'exécution de version de logiciel de Cisco IOS® sur le NAS doit prendre en charge le protocole de contrôle de port COM (RFC 2217). Vous pouvez découvrir plus d'informations sur le DialOut/EZ du logiciel tactique du site internet de la société à : http://www.tacticalsoftware.comleavingcisco.com .

Remarque: DialOut/EZ est un remplacement pour l'utilitaire DialOut de Cisco.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Le logiciel tactique exige ce logiciel Cisco IOS Version 12.0(9) ou plus tard soit installé sur le NAS pour interopérer avec DialOut/EZ.

  • En raison de l'ID de bogue Cisco CSCds28071, Cisco recommande que vous exécutiez le logiciel Cisco IOS Version 12.1(8) ou plus tard.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Installation et configuration

Installant les pilotes de modem compétents pour Dialout/EZ le port COM virtuel

  1. Installez DialOut/EZ.

    Pour les informations complètes d'installation DialOut/EZ sur un poste de travail client, référez-vous au guide de l'utilisateur sur le site Web du logiciel tactique : DialOut/EZ.

  2. Pilotes de modem de téléchargement.

    Les ports COM virtuels DialOut/EZ n'ont aucun périphérique de modem relié à eux. L'utilisateur DialOut/EZ devrait utiliser un fichier approprié .inf pour les modems (installez un pilote de modem sur les ports COM virtuels). Les fichiers de MICA, de NextPort et de Microcom .inf sont disponibles pour le téléchargement du site Web Cisco. Pour les autres plates-formes utilisez les fichiers spécifiés .inf.

    Type de modem Plate-forme fichier .inf
    MICA 3600, AS5200,AS5300,AS5800 mdcsmica.inf
    NextPort AS5350,AS5400 AS5800, AS5850
    Microcom AS5200 mnpv90.inf
    Nanomètre-xAM 2600, 3600 Microcom DeskPorte V.34 JEÛNENT
    WIC-xAM 2600, 3600 mdmrock5.inf (ou la norme 28800 bps de fichier de modem)

    Remarque: Pour Windows XP, Cisco a fourni des fichiers .inf peut ne pas fonctionner. L'essai utilisant les fenêtres .inf intégré classent à la place.

  3. Installez les pilotes de modem.

    Pour installer un pilote de modem sur le PC Windows, utilisez la procédure suivante :

    1. Début > configurations > options de panneau de configuration > de téléphone et de modem.

    2. Sélectionnez le modem et ajoutez pour ajouter un nouveau modem.

    3. Select ne détectent pas mon modem ; Je le sélectionnerai d'une liste, puis clique sur Next.

    4. Sélectionnez le constructeur et modèle de votre modem. Sélectionner Cisco sur la fenêtre de gauche affiche le mica sur la fenêtre droite.

    5. Select ont le disque et naviguent sur l'emplacement où le fichier .inf est enregistré.

    6. Dans l'option de ports sélectionnés, utilisez le port COM sélectionné pendant l'installation EZ Dialout (par exemple, COM 5).

Configurer le serveur d'accès

La configuration logicielle d'IOS requise pour des applications de dialout de modem de caractère-mode seulement (comme avec DialOut/EZ) va sous la configuration de ligne :

line starting_line_number ending_line_number
     modem dtr-active  
     
! -- If the router is for dialin and dialout use "modem inout" instead

     transport input telnet
     
! -- Or transport input all could be used

     escape-character NONE 
     
! -- Due to Bug CSCdv12194 for the AS5350/AS5400.

     rotary 1 
     
! -- Specifies the use of TCP port 7001 in the Dialout/EZ manager 
     ! -- window to dial out rotary 1

Si des modems externes sont utilisés, alors ajoutez les paramètres de la couche RS232 physique et du tramage sous la configuration de ligne comme désirée :

speed 115200 
    
 ! --  Set to the highest speed supported by the modems

     flowcontrol hardware
     parity even 
     databits 7 
     
! -- Or databits 8

     stopbits 1 
     
! -- Recommended for best throughput

Si vous voulez contrôler l'accès aux lignes de dialout, ajoutez le suivant dans le mode de configuration de ligne :

password password

Alternativement, configurez l'Authentication, Authorization, and Accounting (AAA) et appliquez la liste à la ligne avec :

login authentication listname

Si vous souhaitez contrôler quelles jonctions sont utilisées pour les appels de dialout, utilisez la commande de modem dialout controller introduite dans la version de logiciel de Logiciel Cisco IOS 12.1(T) (en date de maintenant, pris en charge sur l'AS5300 seulement). Le pour en savoir plus, se rapportent à configurer un t1 ou une interface d'E1 pour des appels sortants d'analogue utilisant la commande de modem dialout controller.

Astuce : Parfois DialOut/EZ peut obtenir confus par le message d'OK de mot de passe du logiciel IOS. Pour éviter ce problème, configurez l'AAA (local ou basé sur un serveur) sur le routeur. Référez-vous à l'AS5xxx avec la section d'AAA de ce document pour un exemple de configuration.

Facultatif : Vous pouvez également configurer un modemcap pour réinitialiser le modem à la configuration par défaut après chaque appel. Utilisez le mica de modem autoconfigure type de commande sous la configuration de ligne. Ce modemcap (qui définit le &F) de paramètres d'usine par défaut peut être appliqué à tous les routeurs indépendamment du type de modem (MICA, NextPort, Microcom, etc.). Pour plus d'informations sur des modemcaps, référez-vous à Modemcaps recommandé pour Digital interne et modems analogiques sur des serveurs d'accès Cisco.

Le même serveur d'accès peut être utilisé pour le dialin aussi bien que le dialout (application). Pour des exemples de configuration complets référez-vous aux configurations de NAS d'échantillon de section pour l'utilitaire DialOut/EZ.

Dépanner DialOut/EZ

Suivez la méthode tracée les grandes lignes ci-dessous pour dépanner des questions connexes DialOut/EZ :

  1. Reverse Telnet au modem de NAS de l'invite EXEC de NAS. Assurez que vous pouvez se connecter au modem en émettant à la commande qui devrait renvoyer une réponse CORRECTE. Si vous pouvez se connecter au modem, essayez de composer le numéro du périphérique distant utilisant la commande de ######## d'atdt. Si la connexion est réussie, alors la configuration de routeur est correcte et le matériel fonctionne correctement.

    Remarque: Utilisez la chaîne binaire de port TCP de Telnet : rotary_number 6000+line pour utiliser une ligne donnée, ou 7000+ pour un dialout rotary.

    L'exemple ci-dessous affiche un appel réussi :

    maui-nas-03#telnet 172.22.53.150 7001
    
    ! -- Reverse Telnet to an up/up interface on the router 
    ! -- and use port 7000+rotary
    
    Trying 172.22.53.150, 7001 ... Open
    User Access Verification
    !
    Username: admin
    Password:
    at
    OK
    
    ! -- Modem is responding
    
    atdt 81560
    
    ! -- Dial number 81560 to connect to remote device. 
    ! -- This may take up to 30 seconds.
    
    CONNECT 33600 /V.42/V.42bis
    
    ! -- Call is connected to the remote device.
    
      User Access Verification
    
    ! -- Username prompt by remote device
    
      Username: cisco
      Password: maui-nas-01>

    Si le Telnet inversé n'atteint pas le modem au mode de commande, alors le NAS misconfigured. Vérifiez ce qui suit :

    1. L'interface dont l'adresse IP que vous êtes Telnetting au au devoir être up/up et pingable de l'hôte PC sur le LAN. Si vous ne pouvez pas envoyer un ping le dépannage d'interface de routeur votre LAN pour router des questions connexes.

    2. La ligne du modem devrait avoir le modem inout (pour dialin/dialout) ou le modem dtr-active (pour le dialout seulement).

    3. La ligne devrait être configurée avec le Telnet ou le transport input tous de transport input.

    Si le Telnet inversé réussit à atteindre le modem au mode de commande, mais l'appel manuel échoue, alors le problème pourrait être un problème de compagnie de téléphone ou de routeur distant. Dépannez le routeur distant, la ligne et retestez la connexion avant de poursuivre plus loin. Référez-vous à la connectivité de technologie de numérotation de dépannage - Pour en savoir plus de légende de Non-DDR.

  2. Essayez un Telnet inversé d'un hôte PC sur le LAN. Hyperterminal de fenêtres ouvertes (ou Telnet de fenêtres) et Telnet à l'adresse IP et au port du routeur que vous utilisez pour DialOut/EZ (par exemple 7001). Si vous pouvez atteindre le modem et le dialout, alors il n'y a rien mal avec le LAN (nous avions précédemment vérifié que le dialout du NAS fonctionne).

  3. Si le Telnet inversé n'atteint pas le modem au mode de commande, alors le NAS misconfigured ou le réseau IP ne fonctionne pas. Vérifiez ce qui suit :

    1. L'interface dont l'adresse IP que vous êtes Telnetting au au devoir être up/up et pingable de l'hôte PC sur le LAN. Si vous ne pouvez pas envoyer un ping le dépannage d'interface de routeur votre LAN pour router des questions connexes.

    2. Il ne devrait y avoir aucun access-class qui bloque la connexion de Telnet.

    Les captures d'écran suivantes affichent une session HyperTerminal réussie :

    hyperterm1.gif

    hyperterm2.gif

    Remarque: Si vous utilisez le client Telnet de Microsoft Windows et l'AAA est configuré sur le NAS, les fenêtres établissent une connexion Telnet la connexion peuvent échouer. Cette panne est provoqué par par des configurations d'application et est caractérisée par une incapacité d'entrer le mot de passe, ainsi la connexion échoue. Pour corriger la configuration d'application Telnet pour cette session, suivez la procédure ci-dessous sur le PC d'hôte :

    1. Le Start > Run > le Telnet de type, cliquent sur OK.

    2. Introduisez la commande annulée de crlf. (Ceci s'assure que vous envoyez des retours chariot comme <CR><NUL> de Telnet plutôt que le <CR><LF>.)

    3. <port> ouvert de <ip_address> d'utilisation à établir une connexion Telnet au modem.

    4. Vous devriez maintenant être connecté aux modems et pouvez maintenant initier la numérotation manuelle utilisant l'atdt tout comme avec les affichers d'exemple de Hyperterminal ci-dessus. La capture d'écran suivante est un exemple :

      wintelnet1.gif

  4. Le Hyperterminal d'utilisation au connecter directement aux modems de NAS par l'intermédiaire de DialOut/EZ a émulé le port COM. Référez-vous au chapitre de guide de l'utilisateur DialOut/EZ sur l'installation sur le pour en savoir plusleavingcisco.com de http://www.tacticalsoftware.com. Ceci vérifiera que le port COM émulé par DialOut/EZ fonctionne.

    Si le Hyperterminal au-dessus du port COM émulé par DialOut/EZ ne fonctionne pas, alors le problème semblerait être particulier à la transmission DialOut/EZ avec l'IOS. Recueillez les informations suivantes :

    • Ces débogages détermine si le NAS reçoit la connexion de Telnet.

      debug telnet 
      debug modem
      
    • Le journal de suivi DialOut/EZ : Sélectionner l'option de menu Fenêtre de suivi ouvre la fenêtre du port monitor 3,0 DialOut/EZ, avec l'onglet de fenêtre de suivi activé. Pour commencer le suivi, cochez la case de suivi d'enable au bas de cette fenêtre. Assurez-vous que vous sauvegardez le journal pour l'analyse approfondie. Référez-vous à la section dépannage du guide de l'utilisateur sur le pour en savoir plus du site Web du logiciel tactique.

  5. Puisque nous avons vérifié que DialOut/EZ peut se connecter aux modems, ayez ensuite l'initié d'application finale une connexion. Si les applications finales ne peuvent pas communiquer entre eux utilisant la connexion DialOut/EZ, alors le problème pourrait être particulier à l'application finale. Le journal de suivi DialOut/EZ peut être utile en dépannant ce problème. Activez également le modem log des fenêtres TAPI, et également n'importe quelle journalisation fournie par l'application. Référez-vous au site Web de Microsoftleavingcisco.com pour l'article suivant de Microsoft : Comment créer et utiliser le pour en savoir plus du fichier de Modemlog.txt (Q142730).

    Si le fonctionnement ne fonctionne pas comme désiré, recueille les débogages IOS, le journal de suivi DialOut/EZ, et (si c'est approprié) le modem log de fenêtres, et analyse toujours les résultats pour déterminer où l'application échoue.

    Référez-vous au logiciel tactique : Forums aux questionsleavingcisco.com pour information le plus d'informations.

Configurations de NAS d'échantillon pour l'utilitaire DialOut/EZ

AS25xx, Nanomètre-xAM, WIC-xAM

Être suit un fichier d'exemple de configuration pour des routeurs avec les modems analogiques externes, tels que Cisco AS2509, Cisco AS2510, Cisco AS2511, ou serveur d'accès aussi bien que routeurs de Cisco AS2512 avec des modems analogiques internes (Nanomètre-xAM et le WIC-xAM) comme le 26xx, et des routeurs de gamme 36xx.

L'exemple ci-dessous affiche le routeur capable des appels entrant et sortants. Si le routeur est pour l'usage sortant seulement, alors la configuration de ligne est toute qui est nécessaire.

interface Group-Async1
   
! -- Group-Async interface used for dialin calls
   ! -- This is not used for dialout

    ip unnumbered Ethernet0
    no ip mroute-cache
    encapsulation ppp
    no ip route-cache
    async default routing
    async dynamic address
    async mode interactive
    peer default ip address pool local
    dialer in-band
    no cdp enable
    ppp authentication chap
    group-range 1 8
    
! -- Range of lines include 1 through 8
    ! -- Modems 1 through 8 can now be used for incoming or outgoing calls

   !
   line 1 8
    
! -- Line configuration used for Dialout/EZ

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only use "modem dtr-active"

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

    rxspeed 115200
    txspeed 115200
    
! -- Speed for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM)
 
    flowcontrol hardware
    
! -- Flowcontrol for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM

AS5xxx sans AAA

Être suit un fichier d'exemple de configuration pour un serveur d'accès de gamme Cisco AS5xxx sans AAA.

Cet exemple affiche le routeur recevant des appels entrant et faisant des appels sortants :

controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 6661210
    dialer-group 1
    isdn incoming-voice modem
    
! -- Incoming analog calls will be switched to the modems

    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap
    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   line 1 48
   
! -- Line configuration for Dialout/EZ

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout if the line is used for
    ! -- dialout only use, modem dtr-active transport preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport input all
    transport input telnet
    
! -- Configure one or both of the above commands

AS5xxx avec l'AAA

Être suit un fichier d'exemple de configuration pour des serveurs d'accès de gamme Cisco AS5xxx avec l'AAA sur serveur configuré.

L'exemple suivant, affiche un serveur d'accès configuré pour des appels de dialin et de dialout :

aaa new-model
   aaa authentication login default radius
   
! -- Use the radius server for login on the default list
   ! -- for local AAA replace "radius" with "local" 
   ! -- (make sure to configure the username/password locally as well

   aaa authentication ppp ppptac radius
   
! -- Use the radius server for ppp on the list named ppptac
   ! -- This is used for incoming ppp calls and is not used for outgoing 
   ! -- Dialout/EZ calls
   !

   controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 name test 5551210
    dialer-group 1
    isdn incoming-voice modem
    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap ppptac
    ppp multilink
   !
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap ppptac
    
! -- Use list named ppptac for authentication

    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   !
   radius-server host 10.4.1.10
   radius-server timeout 20
   radius-server key nas1
   
! -- Radius server configuration

   !
   line 1 48
    
! -- Line configuration for Dialout/EZ as well as dialin calls

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only, use modem dtr-active transport 
    ! -- preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 23241