IP : Attribution et résolution d'adresse dynamique

Configuration dynamique des options de serveur DHCP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

DHCP vous permet d'affecter automatiquement des adresses IP réutilisables aux clients DHCP. Ce document fournit un exemple de configuration des options DHCP, telles que le Système de noms de domaine (DNS) et les adresses WINS (Windows Internet Name Service), pour répondre aux requêtes DHCP des clients locaux derrière l'équipement client (CPE).

Précédemment, les administrateurs réseau ont dû manuellement configurer le serveur DHCP de ½ du ¿  de Cisco IOSï sur chaque périphérique activé avec cette configuration. Une fois qu'un routeur est déployé, le fait de se rendre à chaque emplacement et d'apporter des modifications coûte cher, prend du temps et nécessite une main-d'œuvre importante.

En conséquence, le serveur DHCP Cisco IOS a été amélioré afin de permettre la mise à jour automatique des informations de configuration. Les administrateurs réseau peuvent configurer un ou plusieurs serveurs DHCP centralisés pour mettre à jour des options DHCP spécifiques dans les pools DHCP. Les serveurs distants peuvent demander ou importer ces paramètres d'option à partir des serveurs centralisés.

Conditions préalables

Conditions requises

Cisco recommande aux lecteurs de ce document qu'ils possèdent des connaissances sur les sujets suivants :

  • DHCP

  • Système de noms de domaine (DNS)

  • Service WINS (Windows Internet Name Service)

Composants utilisés

Cette configuration a été développée et testée avec les versions de logiciel et de matériel suivantes :

  • Version de logiciel 12.2(27) de ½ du ¿  de Cisco IOSïÂ

  • Deux routeurs Cisco 3660 avec NM-1E utilisés pour la connexion PC et client

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Remarque: La fonctionnalité Serveur DHCP Cisco IOS est introduite dans le logiciel Cisco IOS Version 12.0(1)T. Vous avez besoin de la version de logiciel 12.0(2)T ou ultérieures de ½ du ¿  de Cisco IOSï pour l'usage avec des Routeurs de gamme Cisco 1700. Pour plus d'informations sur les routeurs qui prennent en charge la fonctionnalité Serveur DHCP, reportez-vous à la section Plates-formes prises en charge du document Serveur DHCP Cisco IOS.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations qui vous permettront de configurer les options du serveur DHCP pour DNS et WINS. Le routeur « central » est configuré pour ces options de serveur et le routeur « distant » importe ces options. Le PC ou le client distant reçoit ces options importées du routeur « distant » au cours de la phase DHCPACK.

Remarque: Pour obtenir plus d'informations sur les commandes utilisées dans ce document, reportez-vous à Commandes DHCP ou utilisez l'Outil de recherche de commande (clients inscrits uniquement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/22920/dhcp_ser_01.gif

Configurations

Ce document utilise les configurations suivantes :

Central (3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- This range must not be assigned to DHCP clients.

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

!--- Specify the network number and mask for DHCP clients.
   
   domain-name Central

!--- Specify the domain name for the client.
   
   dns-server 10.0.0.2

!--- Specify the DNS server you want to respond to DHCP clients who


!--- need to correlate the host name to the IP address.
   
   netbios-name-server 10.0.0.2

!--- Specify the Network Basic Input/Output System (NetBIOS)


!--- WINS server (for Microsoft DHCP clients)
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

Remarque: Quand vous utilisez un routeur Cisco comme serveur DHCP, seul un domaine est autorisé par pool DHCP ; en d'autres termes, le routeur ne peut pas envoyer de baux DHCP aux clients qui incluent deux noms de domaine. Il n'est pas possible de mélanger le mappage statique dans un pool dynamique. S'il est mélangé, le message d'erreur % This command may not be used with network, origin, vrf, or relay pools apparaît.

Remote (3660)
Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- This ip address must not be assigned to DHCP clients.

!
ip dhcp pool Client   
   import all

!--- Import DHCP option parameters into the database.
   
   network 192.168.1.0 255.255.255.248

!--- Specify the network number and mask for DHCP clients.

   default-router 192.168.1.1

!--- Specify the default gateway for DHCP clients.
	
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

La commande service config est utilisée conjointement avec la commande boot host ou boot network. La commande service config est entrée pour permettre au routeur de configurer automatiquement le système à partir du fichier spécifié par la commande boot host ou boot network.

La commande service config peut également être utilisée sans la commande boot host ou boot network. Si vous ne spécifiez pas de noms de fichier de configuration d'hôte ou de réseau, le routeur utilise les fichiers de configuration par défaut. Le fichier de configuration de réseau par défaut est network-config. Le fichier de configuration d'hôte par défaut est host-config, où host est le nom d'hôte du routeur. Si le logiciel Cisco IOS ne peut pas résoudre son nom d'hôte, le fichier de configuration d'hôte par défaut est router-config.

Utilisez la commande boot host avec la commande service config. Sans la commande service config, le routeur ignore la commande boot host et utilise les informations de configuration dans NVRAM. Si les informations de configuration dans NVRAM sont non valides ou manquantes, la commande service config est activée automatiquement. Le serveur réseau essayera de charger deux fichiers de configuration à partir des hôtes distants. Le premier est le fichier de configuration de réseau contenant les commandes qui s'appliquent à tous les serveurs réseau sur un réseau. Utilisez la commande boot network pour identifier le fichier de configuration de réseau. Le deuxième est le fichier de configuration d'hôte qui contient les commandes qui s'appliquent à un serveur réseau en particulier. Utilisez la commande boot host pour identifier le fichier de configuration d'hôte.

Le client envoie une diffusion malgré le fait que l'option 150 soit configurée, sa nature par défaut étant de rechercher le serveur TFTP, et que l'option 150 soit définie côté serveur et non côté client. Outre TFTP, l'option 150 est également disponible pour les éléments suivants :

  • Etherboot 150

  • Nom de chemin de configuration GRUB 150

Les options DHCP peuvent être configurées avec la commande option code ascii chaîne nom_serveur_tftp. Si vous ne connaissez pas le nom du serveur et que le serveur est configuré uniquement avec l'adresse IP, utilisez alors la commande option code ip adresse_ip.

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip dhcp import — Affiche les paramètres d'option importés dans la base de données du serveur DHCP.

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Remarque: Avant d'émettre des commandes debug, reportez-vous aux Informations importantes sur les commandes de débogage.

La sortie extraite d'un PC ou d'un client avec un système d'exploitation Microsoft Windows avec la commande ipconfig /all donne les valeurs de configuration TCP/IP configurées par DHCP. Reportez-vous à RFC 2132 pour plus d'informations sur les options DHCP.leavingcisco.com

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Informations connexes


Document ID: 22920