Mode de transfert asynchrone (ATM) : Classe de service IP à ATM

Application des stratégies de service QoS et de CBWFQ/LLQ sur les circuits virtuels permanents (PVC) ATM à pont

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour des options de mise en file d'attente de fantaisie, telles que le Mise en file d'attente pondérée basée sur les classes (CBWFQ) et la basse latence s'alignant (LLQ), sur des interfaces ATM configurées pour recevoir les unités de données de protocole de pont RFC 1483 (PDU).

Les supports logiciels de Cisco IOSÝ trois protocoles pour conduire hors réseau (à un network number différent IP) dans le RFC 1483 ont jeté un pont sur des applications. Ces protocoles sont Routage et mise en parallèle intégrés (IRB), encapsulation d'Artère-passerelle (RBE), et circuits virtuels permanents de style jeté un pont sur (PVCs). Tous ces protocoles permettent à un PVC atmosphère pour recevoir le jeter un pont sur-format PDU. Ce document se rapporte à PVCs configuré avec un protocole de pontage tel que PVCs traversier.

Une stratégie configurée de service avec l'interface de ligne de commande de qualité de service modulaire (QoS) (CLI) (MQC) applique des mécanismes de QoS à une interface, à une sous-interface, ou à un circuit virtuel. Sur PVCs traversier, des stratégies de service qui appliquent un mécanisme de mise en file d'attente de fantaisie sont prises en charge seulement avec RBE. Des stratégies de service sur l'atmosphère VCs configuré pour exécuter IRB ne sont pas prises en charge. Sur un tel VCs, si vous définissez un class-map qui s'assortit sur une liste d'accès IP (ACL), correspondance de paquet à cette classe ne se produit pas, et tous les paquets sont classifiés à la classe par défaut.

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir la connaissance de ces thèmes : :

Remarque: La configuration IRB ne prend en charge pas le Par-circuit virtuel CBWFQ ou LLQ. La configuration doit être migrée vers RBE ou PPPoE au-dessus de configuration atmosphère avant que vous essayiez d'implémenter CBWFQ ou LLQ.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur de Cisco 2620 avec l'interface ATM NM-1A-OC3

  • Logiciel Cisco IOS Version 12.2(27)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

La stratégie de service QoS gère la profondeur de la file d'attente, les marques trafiquent, et identifient le trafic non critique sur une base de par-circuit virtuel. Spécifiquement, cette stratégie atteint ces objectifs :

  • Utilisations NBAR afin de classifier le trafic non-entreprise-essentiel, tel que Napster.

  • Emploie la fonctionnalité de réglementation basée sur classe pour marquer la valeur de priorité de la conformation, de dépasser et de violer le trafic.

  • Applique WRED basé sur classe afin de gérer la profondeur de la file d'attente.

    Remarque: Les commandes de sortie et de random-detect-group de service-stratégie sont mutuellement - exclusivité au niveau PVC. Vous ne pouvez pas appliquer un groupe WRED à un circuit virtuel pour lequel vous avez activé CBWFQ par l'application d'une stratégie de service. Cependant, vous pouvez appliquer les deux caractéristiques si vous configurez la commande de random-detect sur une classe à l'intérieur du policy-map.

  • Applique la Fonction Class-based Marking avec la commande set afin de marquer ces valeurs de Priorité IP par le type de trafic.

Valeur de priorité Type de trafic
1 Non-entreprise-essentiel, comme Napster
4 Par défaut, utilisé pour le trafic normal
5 Réservé pour le futur trafic en temps réel, tel que la voix sur ip (VoIP).
6 et 7 Réservé pour le trafic de contrôle de réseau

Les points d'encombrement potentiels sont les atmosphères VCs qui alimentent les utilisateurs DSL-connectés. Les écoulements IP arrivent au port Fast Ethernet à jusqu'aux 100 Mbits/s et sortent l'atmosphère VCs. Ceux-ci sont configurés pour la catégorie de service ATM non spécifiée de débit binaire (UBR) avec du débit de cellules maximal par défaut (PCR) de l'interface de t1 (1.544 Mbits/s). Ainsi, les marques de service-stratégie de QoS trafiquent qui arrive sur le port Fast Ethernet. Les valeurs remarquées sont alors utilisées par WRED afin de créer des classes de services basées sur la Priorité IP et fournir le service différencié par de seuls niveaux de baisse par classe.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/22820/bridging_cbwfq1.gif

Remarque: Les atmosphères VCs de la catégorie de service d'UBR ne fournissent aucune bande passante minimale par définition. Ainsi, vous ne pouvez pas appliquer CBWFQ ou LLQ et garantir la bande passante à un circuit virtuel d'UBR. Afin de faire ainsi, vous devez changer la catégorie de service ATM à quelque chose autre que l'UBR, tel que vbr-nrt ou l'ABR. Pour plus de détails sur ceci, référez-vous à comprendre la catégorie de service d'UBR pour des circuits virtuels ATM.

Configurations

Ce document utilise la configuration suivante :

Routeur Cisco 2600
class-map match-any HTTP-HACKS 

!--- Use the class-map command in global configuration mode
!--- in order to match packets to a specified class.


   match protocol http url "*.ida*"  
   
!--- In order to configure NBAR to match HTTP traffic 
!--- by URL, HOST, or Multi-purpose Internet Mail Extension (MIME)-type, use the
!--- match protocol http command in class-map configuration mode.

   match protocol http url "*cmd.exe*"  
   match protocol http url "*root.exe*"  
   match protocol http url "*Admin.dll*"  
   match protocol http url "*readme.eml*"  
class-map match-any JUNK  
   match protocol napster 
   match protocol fasttrack
class-map match-all IP-PREC-4  match ip precedence 4class-map match-all DEFAULT  
match any
! 
policy-map DSL-OUT-C

!--- Use this command
!--- in order to create or modify a policy map that can be attached to one or more 
!--- interfaces to specify a service policy.

  class IP-PREC-4
   police 32000 250000 5000000 conform-action set-prec-transmit 4 exceed-action
 set-prec-transmit 3 violate-action set-prec-transmit 2
  
!--- Use this command to mark a packet with different quality of service (QoS) 
!--- values based on conformance to the service-level agreement.

! 
policy-map LAN-IN  
  class HTTP-HACKS  
     police 8000 1000 1000 conform-action drop exceed-action
       drop  
  class JUNK  
   set ip precedence 1  
  class DEFAULT  
   set ip precedence 4  
! 
policy-map DSL-OUT  
   class class-default
    
!-- Used to make class-default a single FIFO queue 
!-- inside the WFQ system. 
 
    bandwidth percent 1 
    
    random-detect  
    random-detect exponential-weighting-constant 7  
    random-detect precedence 0   20    40    10  
    random-detect precedence 1   22    40    10 
    random-detect precedence 2   24    40    10 
    random-detect precedence 3   26    40    10 
    random-detect precedence 4   28    40    10  
    random-detect precedence 5   31    40    10  
    random-detect precedence 6   33    40    10  
    random-detect precedence 7   35    40    10  
    random-detect precedence rsvp   37    40    10 
    service-policy DSL-OUT-C
    
!--- In order to use a service policy as a QoS policy within a policy map
!--- (called a hierarchical service policy), use the service-policy command
!--- in policy-map class configuration mode.

! 
interface Loopback1  
  ip address 172.16.1.1 255.255.255.0  
!  
interface FastEthernet0/0  
  ip address 10.1.1.1 255.255.255.192  
  service-policy input LAN-IN  
  
!--- Use this command in order to attach a policy map to an input interface
!--- or virtual circuit (VC), or an output interface or VC, to be used as 
!--- the service policy for that interface or VC.

!  
interface ATM1/0  
  no ip address  
  no atm ilmi-keepalive 
!  
interface ATM1/0.4 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
  no ip mroute-cache  
  atm route-bridged ip  
  pvc 1/35  
   service-policy output DSL-OUT  
  ! 
!  
interface ATM1/0.5 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
 no ip mroute-cache  
  atm route-bridged ip 
 
!--- Use in order to configure an interface to use ATM RBE.

  pvc 1/36
   service-policy output DSL-OUT 
!
ip route 172.16.1.2 255.255.255.255 ATM1/0.4
ip route 172.16.1.3 255.255.255.255 ATM1/0.5
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • atmosphères de show queueing interface — Affiche les statistiques de queue d'un circuit virtuel spécifique sur une interface. Une valeur différente de zéro pour des « conversations » actives est affichée au cours des périodes d'encombrement quand des écoulements IP sont alignés aux files d'attente de la couche 3.

    2600# show queueing interface atm1/0.4
            Interface ATM1/0.4 VC 1/35
            Queueing strategy: weighted fair
            Total output drops per VC: 0
            Output queue: 0/512/64/0 (size/max total/threshold/drops)
               Conversations  0/1/64 (active/max active/max total)
               Reserved Conversations 1/1 (allocated/max allocated)
               Available Bandwidth 0 kilobits/sec
  • atmosphères de show policy-map interface — Utilisez cette commande de vérifier ces des statistiques quand vous surveillez votre stratégie de service :

    • L'incrémentation évalue pour les paquets qui apparient la classe. Si ceci ne fonctionne pas, assurez-vous que le CEF est activé et que les paquets suivent le chemin de commutation de CEF. Émettez le show interface stats commandent afin de visualiser si des paquets CEF-sont commutés.

    • Comparez la valeur de « paquets » à la valeur appariée des « par paquets ». Les « paquets ont apparié » des incréments de valeur pendant des périodes d'encombrement seulement. Le pour en savoir plus, se rapportent compréhension derrière des compteurs de paquet dans la sortie de show policy-map interface.

    • Corrigez le nombre de baisses aléatoires. Surveille la valeur du champ de « moyenne profondeur de la file d'attente » et détermine si ce champ atteint une valeur au-dessus du seuil minimum. WRED commence à relâcher aléatoirement des paquets quand la profondeur de la file d'attente de moyen monte au-dessus du seuil minimum pour un niveau particulier de Priorité IP.

2600# show policy-map interface atm1/0.4
ATM1/0.4: VC 1/35 -
 Service-policy output: DSL-OUT
 Class-map: class-default (match-any)
     29121 packets, 41550530 bytes
     5 minute offered rate 0 bps, drop rate 0 bps
     Match: any
     Queueing
       Output Queue: Conversation 73
       Bandwidth 1 (%)
       (pkts matched/bytes matched) 59/8894
       (depth/total drops/no-buffer drops) 0/0/0
        exponential weight: 7
        mean queue depth: 0

 class    Transmitted      Random drop   Tail drop    Minimum   Maximum   Mark
          pkts/bytes       pkts/bytes    pkts/bytes   thresh    thresh    prob
 0        15791/22456790       0/0           0/0          20        40    1/10
 1           0/0               0/0           0/0          22        40    1/10
 2         8555/13041140       0/0           0/0          24        40    1/10
 3         3417/5207580        0/0           0/0          26        40    1/10
 4         1358/845020         0/0           0/0          28        40    1/10
 5           0/0               0/0           0/0          31        40    1/10
 6           0/0               0/0           0/0          33        40    1/10
 7           0/0               0/0           0/0          35        40    1/10
 rsvp        0/0               0/0           0/0          37        40    1/10
     Service-policy : DSL-OUT-C
 Class-map: IP-PREC-4 (match-all)
   13330 packets, 19093740 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: ip precedence 4
   police:
     32000 bps, 250000 limit, 5000000 extended limit
     conformed 1358 packets, 845020 bytes; action: set-prec-transmit 4
     exceeded 3417 packets, 5207580 bytes; action: set-prec-transmit 3
     violated 8555 packets, 13041140 bytes; action: set-prec-transmit 2
     conformed 0 bps, exceed 0 bps, violate 0 bps
 Class-map: class-default (match-any)
   15791 packets, 22456790 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: any 

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 22820