Commutation LAN : EtherChannel

Configuration d'un port EtherChannel couche 2 et du mode Trunk entre les commutateurs des gammes 2900XL/3500XL/2950 et les commutateurs Catalyst qui exécutent les logiciels Cisco IOS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 octobre 2015) | Commentaires


Contenu

DTP

Introduction

Ce document fournit des configurations d'échantillon sur l'EtherChannel de jonction et de couche 2 du lien d'IEEE 802.1Q/Inter-Switch (ISL) (L2) entre Cisco Catalyst 2900 XL/3500 XL ou Commutateurs de gamme Catalyst 2950 et un commutateur du Catalyst 6500/6000 qui exécute le logiciel de ½ du ¿  de Cisco IOSïÂ. Vous pouvez également utiliser un commutateur Catalyst 4500/4000 qui exécute le logiciel Cisco IOS au lieu du Catalyst 6500/6000 pour cet exemple. Ce document discute des facteurs les plus importants à considérer quand vous configurez la jonction et l'acheminement entre les commutateurs. Le document comporte également des exemples de configuration.

Dans ce document, quatre ports Fast Ethernet de chacun des Commutateurs ont été trunked et ont empaqueté dans les Fast EtherChannels (FEC). Le protocole d'agrégation a été utilisé pour les 3500 XL ISL, et le 802.1Q a été utilisé pour l'exemple 2950.

Remarque: Le 2950 de Catalyst ne prend en charge pas la jonction ISL. Jonction de 802.1Q d'utilisation à la place.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Afin de créer les exemples dans ce document, ces Commutateurs ont été utilisés dans un environnement de travaux pratiques, avec des configurations effacées :

  • Commutateur du Catalyst 3548 XL qui exécute la version du logiciel Cisco IOS 12.0(5)WC2

  • Commutateur du Catalyst 2950-24 qui exécute la version du logiciel Cisco IOS 12.1(6)EA2c

  • Commutateur du Catalyst 6509 avec Supervisor Engine II qui exécute le Logiciel Cisco IOS version 12.1(11b)E

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

DTP

Des joncteurs réseau entre les périphériques peuvent être configurés statiquement ou avec l'utilisation du Protocole DTP (Dynamic Trunking Protocol). Le DTP permet les deux périphériques connectés pour négocier les configurations de jonction avant de former réellement la connexion de jonction. Les modes configurables de port de commutateur de logiciel de Cisco IOS (jonction) incluent : dynamique (le port négocie l'accès ou le mode de joncteur réseau), joncteur réseau (place sans réserve le port à la jonction), et accès (port d'accès de non-joncteur réseau). Les configurations de combinaison de mode les plus utilisées généralement de deux côtés (non-DTP négocié) d'un joncteur réseau statique sont joncteur réseau-joncteur réseau. Pour les joncteurs réseau (DTP-négociés) dynamiques, les configurations habituelles sont dynamique-dynamiques. D'autres combinaisons peuvent produire des résultats valides mais sont hors de portée de ce document. Une connexion de jonction entre un Protocole PAgP (Port Aggregation Protocol) - le commutateur capable et un périphérique de non-PagP exige du mode de joncteur réseau d'être allumé.

Remarque: La plupart des Routeurs de Cisco et quelques Commutateurs de Catalyst ne prennent en charge pas le DTP et exigent la configuration de jonction statique. Par exemple, la gamme du Catalyst XL, le Catalyst 2948G-L3, le Catalyst 4908G-L3, gamme Catalyst 8500, des Routeurs de Cisco de gamme 2/3/4/7xxx, etc ne prend en charge pas le DTP et exige la configuration de jonction statique.

considération indigène du 802.1Q VLAN

la jonction de 802.1Q insère un champ de balise du 802.1Q 4-byte dans les trames envoyées au-dessus du joncteur réseau, qui contiennent les informations VLAN. La balise de 802.1Q est insérée dans chaque trame transférée au-dessus du joncteur réseau excepté les trames transmises sur le VLAN indigène, qui sont envoyées à non-marqué. Dans la plupart des cas, le VLAN indigène doit s'assortir des deux côtés du joncteur réseau à moins qu'il y ait une configuration requise peu commune spécifique, qui est hors de portée de ce document. Si les VLAN indigènes ne s'assortissent pas, le commutateur se connecte des messages de Protocole CDP (Cisco Discovery Protocol) énonçant la non-concordance. Tandis que non catastrophique, cette installation cause efficacement aux deux l'indigène différent VLAN d'être fusionné dans un plus grand domaine de l'émission L2 (VLAN). La tentative ces deux VLAN de calculer une topologie commune du Protocole Spanning Tree (STP) pour tels a jeté un pont sur des VLAN indigènes, avec le risque de dépasser par la suite le diamètre STP pris en charge par maximum.

Remarque: Il y a un cas particulier quand un voisin ou un périphérique de tiers exige de tous les VLAN d'être étiquetés. Si ceci se produit, vous pouvez implémenter un contournement pour créer un VLAN factice et pour l'établir en tant que VLAN indigène. Ceci étiquettera tous autres VLAN nécessaires, et ils passeront le trafic au-dessus du joncteur réseau au voisin ou au périphérique de tiers. Dans la version du logiciel Cisco IOS 12.1.11bEX, 12.1.13E, et plus tard, le Catalyst 6500 qui exécute des supports logiciels de Cisco IOS l'option de jonction de 802.1Q qui étiquettera tout le trafic VLAN comprenant le VLAN indigène. Émettez la commande de vlan dot1q tag natif sous le mode de configuration globale. Sur le Catalyst que 4500/4000 cela exécute le logiciel de Cisco IOS, la commande de vlan dot1q tag natif a été introduit la première fois dans la version du logiciel Cisco IOS 12.2(18)EW.

PAgP

Des Gigabits EtherChannels (GECs) et les FEC entre les Commutateurs peuvent également être configurés statiquement ou dynamiquement avec l'utilisation de PAgP. PAgP permet les deux périphériques connectés pour négocier les configurations avant de former réellement le canal. Les modes de canal de PAgP incluent : desirable (le port entame activement la négociation de canal), automatique (le par défaut, dans lesquels le port n'entame pas la négociation mais répond aux tentatives de négociation commencées par l'autre côté), et sur (sans réserve place le port pour creuser des rigoles et ne permute pas des trames de PAgP). Une connexion entre un commutateur PAgP-capable et un périphérique de non-PAgP exige en fonction du mode de former un canal.

La combinaison de mode la plus utilisée généralement de deux côtés (non-PAgP négocié) d'un canal statique est sur-sur. Pour les canaux (PAgP-négociés) dynamiques, les configurations habituelles sont desirable-desirable ou desirable-automatique. Les ports connectés configurés pour le mode desirable exécutent la négociation et la vérification de canal avant de commencer l'acheminement et continuent également à vérifier le canal quand il est en fonction. En raison de la protection ajoutée offerte par PAgP, c'est habituellement l'installation recommandée si les deux commutateurs connectés prennent en charge PAgP.

Remarque: PAgP a quelques limites de configuration délibérées. Les ports pour négocier un canal doivent avoir la mêmes vitesse, duplex, encapsulation d'agrégation, et VLAN réglé. En outre, l'algorithme d'Équilibrage de charge de canal à travers des liens peut être configurable sur certaines Plateformes.

Remarque: Un EtherChannel est considéré un seul port STP dès qu'il sera. Par conséquent, pour éviter des incohérences STP en installant un canal non-négocié, opérez comme suit :

  1. Arrêtez tous les ports du canal pour configurer des deux côtés.

  2. Exécutez la configuration sur les deux extrémités.

  3. Réactivez tous les ports.

Tenter pour configurer un tel canal tandis que les ports sont peut avoir comme conséquence des incohérences provisoires et/ou des boucles STP. Les étapes s'appliquent seulement si PAgP n'est pas utilisé.

Catalyst 2900XL/3500XL

La gamme du Catalyst 2900 XL 3500 XL que les Commutateurs ne prennent en charge pas le DTP et le PAgP, et exigent donc le joncteur réseau statique et creusent des rigoles l'installation. Référez-vous à la note au-dessus du pour en savoir plus. Les Commutateurs de gamme du Catalyst 2900 XL 3500 XL prennent en charge actuellement des encapsulations d'agrégation ISL et de 802.1Q. Le pour en savoir plus, se rapportent à ce document :

L'ISL est pris en charge dans la version du logiciel Cisco IOS 11.2(8)SA4 et plus tard, et le 802.1Q est pris en charge dans la version du logiciel Cisco IOS 11.2(8)SA5 et plus tard.

Avec un Catalyst 2900 XL qui exécutent la version du logiciel Cisco IOS 11.2(8)SA1 ou 11.2(8)SA2, on te permet quatre EtherChannels (groupes de port) par commutateur avec un nombre illimité de ports par groupe. L'Équilibrage de charge à travers les liens dans le canal est toujours destination basée sur adresse. Le Fonction Switched Port Analyzer (SPAN) et les caractéristiques de Sécurité de port ne sont pas pris en charge.

Sur un Catalyst 2900 XL qui exécute la version du logiciel Cisco IOS 11.2(8)SA3 ou plus tard, un Catalyst 3500 XL qui exécute la version du logiciel Cisco IOS 11.2(8)SA6 ou plus tard, et un 2950 de Catalyst, Équilibrage de charge à travers les liens dans le canal est configurable pour être basé sur la source ou l'adresse MAC de destination. La source est le par défaut. l'expédition basé sur source permet jusqu'à huit ports dans une FEC (groupe de port). l'expédition destination Destination permet les ports illimités par groupe de port. Vous pouvez configurer jusqu'à 12 groupes de port par commutateur et pouvez avoir un mélange de groupes source-/destination-based. L'ENVERGURE et la Sécurité de port ne sont pas prises en charge.

Catalyst 2950

Les Commutateurs 2950 de Catalyst prennent en charge seulement la jonction de 802.1Q et ne prennent en charge pas la jonction ISL. Les Commutateurs 2950 de Catalyst prennent en charge la négociation DTP et de jonction dynamique et de canal de PAgP avec des versions de Logiciel Cisco IOS version 12.1 et les modes statiques seulement avec des versions de Logiciel Cisco IOS version 12.0. L’équilibrage de charge EtherChannel peut utiliser la transmission d’adresse MAC source ou de destination. Vous pouvez configurer la méthode d'Équilibrage de charge en émettant la commande de configuration globale de port-channel load-balance. Ces Commutateurs prennent en charge jusqu'à huit ports de commutateur par canal.

Catalyst 6500 qui exécute le logiciel de Cisco IOS

Commutateurs de Catalyst 6500 qui exécutent le support logiciel L2 (switchport) de Cisco IOS et la couche 3 (L3) (port conduit) des configurations d'EtherChannel. Une gamme Catalyst 6500/6000 commute prend en charge un maximum de 64 EtherChannels (256 avec le Logiciel Cisco IOS version 12.1(2)E et plus tôt). Vous pouvez former un EtherChannel avec jusqu'à huit ports compatiblement configurés réseau local sur n'importe quel module dans une gamme Catalyst 6000 commutez, excepté la carte fonctionnelle de Digital (DFC) - les modules équipés (tels que WS-X6816 etc) qui permettent actuellement un canal L2 seulement utilisant des ports sur le même module DFC. Cependant, un canal L3 peut être configuré à travers différents modules DFC-équipés. Cette limite a été enlevée dans la version du logiciel Cisco IOS 12.1(11b)EX du Catalyst 6500/6000 et plus tard. Ce document configure un EtherChannel L2.

Le Catalyst 6500/6000 cela exécute le Cisco IOS que le logiciel te permet l'Équilibrage de charge pour configurer EtherChannel pour utiliser des adresses MAC, des adresses IP, ou pose 4 les informations de port (L4) dans n'importe quelles source, destination, et combinaison de source-destination en émettant la commande de configuration globale de port-channel load-balance. Le par défaut est d'utiliser une fonction d'informations parasites entre la source et les adresses IP de destination.

Les Commutateurs du Catalyst 6500/6000 prennent en charge des encapsulations d'agrégation ISL et de 802.1Q et le DTP. Les informations détaillées sur des capacités de port sont disponibles en émettant la commande de capacités d'interface_id d'interface d'exposition.

Catalyst 4000 qui exécute le logiciel de Cisco IOS

Commutateurs de Catalyst 4000 qui exécutent le logiciel de Cisco IOS (avec le Supervisor Engine III et IV) les configurations d'EtherChannel L2 (switchport) et L3 de support (port conduit). Une gamme Catalyst 4000 commute prend en charge un maximum de 64 EtherChannels. Vous pouvez former un EtherChannel avec jusqu'à huit compatiblement interfaces Ethernet configurées sur n'importe quel module, et à travers des modules dans une gamme Catalyst 4000 commutez. Toutes les interfaces dans chaque EtherChannel doivent être la même vitesse et doivent tout être configurées que les interfaces L2 ou L3.

Le Catalyst 4000 qui exécute le logiciel de Cisco IOS te permet pour configurer l'Équilibrage de charge d'EtherChannel pour utiliser les adresses MAC, l'adresse IP, ou les informations de port L4 dans n'importe quelles source, destination, et combinaison de source-destination en émettant la commande de configuration globale de port-channel load-balance. Le par défaut est d'utiliser une fonction d'informations parasites entre la source et les adresses IP de destination.

Le Catalyst 4000 qui exécute les supports logiciels ISL de Cisco IOS et les encapsulations d'agrégation de 802.1Q et le DTP. L'ISL n'est pas disponible sur certains modules. Pour une liste complète de tels modules, référez-vous compréhension derrière la section de joncteurs réseau VLAN de configurer des interfaces Ethernet de la couche 2. Dans une future version logicielle, les informations détaillées sur des capacités de port seront disponibles en émettant la commande de show interface capabilities. Actuellement cette commande n'est pas disponible.

Configuration 1 : Jonction et EtherChannel ISL entre le Catalyst 3500 XL et le Catalyst 6500 qui exécute le logiciel de Cisco IOS

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Cette configuration utilise cette configuration réseau :

/image/gif/paws/22422/144-a.gif

Catalyst 3524XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (logiciel de Cisco IOS)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

Configuration 2 : jonction et EtherChannel de 802.1Q avec l'utilisation du DTP et le PAgP entre le 2950 de Catalyst et le Catalyst 6500 qui exécute le logiciel de Cisco IOS

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Cette configuration utilise cette configuration réseau :

/image/gif/paws/22422/144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500 (logiciel de Cisco IOS)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

Vérifiez : Jonction ISL

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Catalyst 3500XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Remarque: Si vous avez un EtherChannel de huit-port, émettre la commande récapitulative de show etherchannel peut tomber en panne le commutateur si vous exécutez une version logicielle de Cisco IOS qui est plus tôt que la version du logiciel Cisco IOS 12.0(5)WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (logiciel de Cisco IOS)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Vérifiez : jonction de 802.1Q

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Logiciel de Cisco IOS de Catalyst 6500

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Dépannez

Utilisez cette section pour dépanner votre configuration.

Le trafic ne passe pas sur un joncteur réseau de 802.1Q

Une de ces causes peut avoir comme conséquence la question :

  • Il y a une non-concordance de configuration du VLAN natif sur les ports qui sont connectés entre deux Commutateurs.

    Vérifiez la configuration du VLAN natif sur les les deux les Commutateurs. Émettez la commande de show trunk sur le commutateur de CatOS afin de voir la configuration indigène VLAN. Émettez la commande de switchport d'interface_id d'interface d'exposition sur le commutateur XL afin de voir la configuration indigène VLAN. S'il y a une erreur d'assortiment de VLAN indigène entre les deux Commutateurs, configurez les Commutateurs avec le même VLAN indigène. Émettez la commande de configuration d'interface de switchport trunk native vlan afin de changer le VLAN indigène sur le commutateur XL. Émettez la commande de set vlan afin de changer le VLAN indigène sur le commutateur de CatOS.

  • Des trames DTP ne sont pas prises en charge dans des Commutateurs XL.

    Les Commutateurs de CatOS envoient des trames DTP au-dessus de la liaison agrégée, mais les Commutateurs XL ne prennent en charge pas des trames DTP. Le DTP n'est pas pris en charge dans des Commutateurs XL. Afin d'éviter ce problème, placez l'état de port de commutateur de CatOS à l'aucun négocient. Émettez la commande du nonegotiate dot1q de set trunk mod/port afin de placer le mode de joncteur réseau au nonegotiate pour le mode de jonction dot1q.

  • Il y a une erreur de correspondance d'encapsulation sur le commutateur XL.

    Sur le commutateur XL, vérifiez que l'encapsulation de jonction est placée à dot1q. Émettez la commande de switchport d'interface_id d'interface d'exposition afin de voir la configuration actuelle. Émettez la commande de configuration d'interface de l'encapsulation de jonction dot1q de switchport afin de changer l'encapsulation à dot1q.

  • Une version tôt de CatOS ne prend en charge pas la jonction dot1q.

    La version tôt de CatOS qui a été utilisé dans les Commutateurs ne prend en charge pas la jonction dot1q. Améliorez le CatOS du commutateur à une version ultérieure qui prend en charge le joncteur réseau dot1q et le joncteur réseau ISL.


Informations connexes


Document ID: 22422