Voix : H.323

QoS (Qualité de service) VoIP pour interopérabilité Frame Relay et ATM avec LLQ, PPP LFI et cRTP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour la voix sur ip utilisant le PPP à liaisons multiples au-dessus de l'interworking atmosphère et de Relais de trames (VoIP utilisant MLPoATM/MLPoFR). Le centre central des exemples de configuration est la fourniture de Qualité de service (QoS) afin de prendre en charge correctement la Voix à travers une atmosphère/un WAN dialogué par Relais de trames. Les exemples de configuration se servent également du Protocole CRTP (Compressed Real-Time Protocol), qui a été pris en charge sur l'atmosphère depuis la version de logiciel 12.2(2)T de Ý de Cisco IOS.

Le document peut être autonome lu pour des conseils de configuration, des exemples de configuration, et des commandes de vérification afin d'être utilisé en établissant le réseau. Une certaine information générale est également donnée pour des problématiques spécifiques associées avec l'utilisation de l'interworking atmosphère/Relais de trames. Référez-vous à ces documents pour plus d'informations sur QoS pour le VoIP sur frame relay ou le PPP :

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Vous devriez être au courant de ces secteurs de technologie :

  • Listes de contrôle d'accès

  • Circuits virtuels permanents atmosphère (PVCs)

  • Circuits virtuels permanents en relais de trame (identificateur de connexion de liaison de données (DLCI))

  • Gestion de la bande passante

  • LLQ

  • LFI

  • Modèles virtuels et interfaces d'accès virtuelles

  • MLPPP

  • cRTP

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cisco 3640 en tant que routeur atmosphère

  • Cisco 2620 en tant que routeur Frame Relay

  • Logiciel Cisco IOS version 2.2(8)T (IP Plus)

Remarque:  Comme orientation, la dernière version de maintenance de mainline du Cisco IOS 12.2 est la version logicielle recommandée de Cisco IOS à l'utiliser pour MLPoATM/version du logiciel Cisco IOS 12.2T de TRAME est exigée sur le routeur atmosphère si le cRTP est utilisé.

Des caractéristiques appropriées ont été introduites dans des ces versions logicielles de Cisco IOS :

  • LFI a été introduit dans le Logiciel Cisco IOS version 11.3.

  • LLQ a été introduit dans le Logiciel Cisco IOS version 12.0(7)T.

  • LLQ au-dessus de Relais de trames et d'atmosphère par PVC a été introduit dans le Logiciel Cisco IOS version 12.1(2)T.

  • Le PPP à liaisons multiples LFI pour le Relais de trames et les circuits virtuels ATM a été introduit dans le Logiciel Cisco IOS version 12.1(5)T.

  • le cRTP au-dessus de l'atmosphère a été introduit dans le Logiciel Cisco IOS version 12.2(2)T.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Les questions clés en fournissant le retard de bout en bout et la manière d'éviter réduits de jitter pour le VoIP à travers une atmosphère/un réseau dialogué par Relais de trames sont :

  • Priorité stricte pour le trafic vocal (basse queue de latence (LLQ))

  • Fonction Link Fragmentation and Interleaving (LFI)

  • Formatage du trafic de relais de trames (FRTS) pour la Voix

  • Formatage du trafic ATM

Ces documents fournissent des sources utiles de davantage d'information générale :

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil de recherche de commande (réservé aux clients inscrits) pour plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/22383/voip-qos-fr-atm-01.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Il est important de noter que dans cette configuration, les deux Routeurs sont dos à dos connecté au-dessus d'un Relais de trames au commutateur d'interworking atmosphère. Dans la plupart des topologies cependant, les routeurs activés de Voix peuvent exister n'importe où. Habituellement, les Routeurs de Voix utilisent la Connectivité de RÉSEAU LOCAL à d'autres Routeurs, qui sont connectés au WAN ATM/Frame. Dans des ces cas, les Routeurs connectés au WAN, le Relais de trames, et les atmosphères doivent être configurés pour LLQ, LFI, et MLPPP ainsi ils peuvent fournir QoS, et pas les Passerelles voix suivant les indications de ces configurations.

Routeur connecté de Relais de trames

!--- Note: This configuration is commented and numbered 
!--- in the order that commands should be entered.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname FR
!
enable password cisco
!
username ATM password 0 cisco
voice-card 0
dspfarm
!
ip subnet-zero
!
!
!
!


!--- access-list 105 permit ip any any dscp ef specifies 
!--- that all traffic with Differentiated Services Code Point (DSCP)
!--- are set to 40 falls into this access-list.
!--- This class-map command defines a class of traffic called "voice".


access-list 105 permit ip any any dscp ef 
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice 
match access-group 105
!

!         
!

!--- This policy-map command defines a policy for LLQ called "VoIP" and 
!--- maps the "voice" class to the "VOIP" policy.
!--- "priority" defines the amount of bandwidth reserved for the priority queue.
!--- "class-default" specifies that the default class is also mapped to this policy.  
!--- "fair-queue" specifies that all other traffic is served in the WFQ.


policy-map VOIP 
  class voice 
    priority 48 
  class class-default  
   fair-queue 


!--- Note: Although it is possible to queue various types of 
!--- real-time traffic to the priority queue, 
!--- Cisco recommends that you direct only voice traffic 
!--- to it. Real-time traffic such as video or voice
!--- could introduce variations in delay. Please note voice and 
!--- video should not be combined in the same PVC.
!--- (the priority queue is a First In First Out (FIFO) 
!--- queue). Voice traffic requires that delay be 
!--- nonvariable in order to avoid jitter.

!--- Note: The sum of the values for priority and 
!--- bandwidth statements needs to be less 
!--- than or equal to 75% of the link bandwidth. 
!--- Otherwise service-policy cannot be 
!--- assigned to the link. When configuring VoIP over a 
!--- 64 Kbps link to support two 
!--- voice calls, it is common to allocate more than 75% 
!--- (48 Kbps) of the link bandwidth to 
!--- the priority queue. In such cases, you can use the  
!--- max-reserved-bandwidth <#%> command in order to raise 
!--- available bandwidth to a value more than 75%.


!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.0
!
!
interface FastEthernet0/0
 ip address 172.17.111.16 255.255.255.224
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 no ip mroute-cache
 frame-relay traffic-shaping
!

!--- Choose the frame relay interface to be 
!--- associated with the virtual interface. The
!--- virtual template could equally have been associated 
!--- with the physical interface. 
!--- The "class mlp" associates the virtual template interface 
!--- defined in "interface Virtual-Template1" with a Frame Relay DLCI.
!--- Associates a Frame Relay map class with a DLCI.


interface Serial0/0.1 point-to-point 
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 16 ppp Virtual-Template1 
  class mlp 


!--- The interface command creates a virtual 
!--- template called Virtual-Template1. 
!--- A bandwidth of 64 Kbps is assigned to this 
!--- template interface. This bandwidth is used
!--- by Cisco IOS to calculate the data fragment size as noted regarding
!--- interleaving of PPP segments.

!--- "ip rtp header-compression"—cRTP is supported in an ATM/Frame Relay Interworking 
!--- environment. It requires Cisco IOS Software Release 12.2(2)T on the 
!--- ATM router.

!--- "service-policy output VOIP"—The VoIP policy created earlier is assigned 
!--- to this interface in the outbound direction.
 
!--- PPP multilink is enabled and the 
!--- maximum delay per segment is specified. This bandwidth is   
!--- used by Cisco IOS to calculate the data fragement size as noted.

!--- Interleaving of PPP segments is enabled, which allows 
!--- voice packets to be expedited. Voice  
!--- packets need only wait behind a single segment of 
!--- a previously queued data packet (for example, 10 ms 
!--- delay) rather than wait until the end of the 
!--- entire data packet. Cisco IOS calculates the  
!--- data fragment size using the following formula: 
!--- fragment size = delay x bandwidth/8

!
interface Virtual-Template1 
 bandwidth 64 
 ip unnumbered loopback0
 ip rtp header-compression 
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP 
 ppp multilink 
 ppp multilink fragment-delay 10 
 ppp multilink interleave 
!


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
no ip http server
ip pim bidir-enable
!
!
!

!--- A map class called mlp is created.
!--- With "no frame-relay adaptive-shaping", adaptive
!--- shaping is disabled. You do not 
!--- want to exceed CIR and have voice packets
!--- possibly queued within the Frame Relay network. 
!--- Waiting for a BECN to resolve this 
!--- situation could result in poor voice quality.
!--- The frame-relay cir 64000 command forces the router to transmit 
!--- at the desired CIR rate rather than line
!--- rate for the port.
!--- "frame-relay bc 640" configures the Bc value to force the desired 
!--- Tc (shaping interval) value is 10 ms. 
!--- This formula should be used to determine 
!--- the Bc value to use: Tc = Bc/CIR. A 
!--- smaller Tc value reduces the interval a voice 
!--- packet has to wait to be sent.
!--- As in "frame-relay be 0", the Be value should be set to zero
!--- in order to avoid voice being sent as part of a burst
!--- that is not guaranteed by the Frame Relay network.


map-class frame-relay mlp

 no frame-relay adaptive-shaping
 frame-relay cir 64000  
 frame-relay bc 640 
 frame-relay be 0 


!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 123 voip
 destination-pattern 123
 session target ipv4:10.1.1.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
dial-peer voice 456 pots
 destination-pattern 456
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

Routeur connecté atmosphère

!--- Note: This configuration is commented only 
!--- where additional consideration is required from the 
!--- above configuration of the Frame Relay router.


version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname ATM
!
enable password cisco
!
username FR password 0 cisco
memory-size iomem 25
ip subnet-zero
!
!
!
access-list 105 permit ip any any dscp ef
access-list 105 permit udp any any  range 16384 32767
access-list 105 permit ip any any precedence critical
!
class-map match-all voice
 match access-group 105
!
!

!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
policy-map VOIP
  class voice
    priority 48
  class class-default
   fair-queue


!--- Note: Matching commands to the Frame Relay 
!--- router side of the network.


!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
controller T1 2/0
 framing sf
 linecode ami
!
!
!
!
interface ATM0/0
 no ip address
 ip route-cache
 no atm ilmi-keepalive
!

!--- "interface ATM0/0.1 point-to-point" chooses the ATM subinterface.
!---  The physical interface could equally have been used.
!--- "pvc 10/100" creates an ATM PVC. 
!--- "cbr 64"—A VBR PVC has been defined on this example.
!--- This exapmle uses VBR non-realtime and the sustained 
!--- cell rate (SCR) should be equal to the peak
!--- cell rate (PCR)  in order to avoid bursting. 
!--- ATM cell tax and the possibility
!--- of ATM bandwidth expansion due to poor 
!--- fragment/cell alignment, means that it  
!--- cannot be assumed that the PCR/SCR on the ATM 
!--- side should equal the CIR of the Frame Relay side.
!--- Maintain the value of CIR on the Frame-Relay side to define 
!--- our SCR, in this case, 64 kbps. This value may in some networks
!--- require some fine-tuning as the CIR on the Frame side does not
!--- exactly match the SCR on the ATM but makes for a good-enough estimation
!--- for most purposes.
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM
!--- for more information. 
!--- "encapsulation aal5snap" is required.
!--- "protocol ppp Virtual-Template1" associates the virtual 
!--- template with the ATM PVC.


interface ATM0/0.1 point-to-point
 ip route-cache
 pvc 10/100 
  cbr 64 
  encapsulation aal5snap 
  protocol ppp Virtual-Template1 


!
!
interface loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet3/0
 ip address 172.17.111.15 255.255.255.224
 half-duplex
!
interface Ethernet3/1
 no ip address
 shutdown
 half-duplex
!
interface Virtual-Template1
 bandwidth 64
 ip unnumbered loopback0
 ip rtp header-compression
 no ip route-cache
 load-interval 30
 max-reserved-bandwidth 99
 service-policy output VOIP
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave


!--- Note: The virtual template is created in 
!--- exactly the same way as for the
!--- Frame Relay router side of the network. 
!--- An additional consideration for
!--- the ATM router is that the fragment size 
!--- should be optimized to fit into
!--- an integral number of ATM cells. 
!--- Refer to Designing and Deploying
!--- Multilink PPP over Frame Relay and ATM 
!--- for more information on this issue.


!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.111.1
ip http server
ip pim bidir-enable
!
!
call rsvp-sync
!
voice-port 1/0/0
 description FXS
!
voice-port 1/0/1
!
voice-port 1/1/0
 description FXO
!
voice-port 1/1/1
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 456 voip
 destination-pattern 456
 session target ipv4:10.1.1.2
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad   
!
dial-peer voice 123 pots
 destination-pattern 123
 port 1/1/0
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
!
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Ces commandes show sont utiles dans la vérification du statut opérationnel de l'environnement d'interworking de relais ATM/Frame, qui inclut des statistiques DLCI et PVC, l'état d'examen médical et d'interface virtuelle, l'application de stratégie (QoS), et des informations de cRTP :

  • interface-nom d'interface de show ppp multilink — Vérifie si le paquet est haut/bas, que l'interface d'accès virtuel est le paquet (paquet MLPPP), et qui est des membres (lien de PPP). Cette commande vérifie également si le transporteur relâche des cellules/trames (<> perdu 0 de fragments). La seule perte acceptable de fragment est une provoquée par des erreurs de contrôle de redondance cyclique (CRC).

  • utilisateur d'exposition — Affiche le numéro associé avec l'interface d'accès virtuelle. Vous pouvez utiliser les informations de cette commande ou de la commande de show ppp multilink ainsi vous pouvez afficher des statistiques au sujet de l'interface ou effacer l'interface.

  • dlci de show frame-relay pvc — Affiche des informations telle que des paramètres de formatage du trafic, des valeurs de fragmentation, et des paquets relâchés. Cette commande affiche également si l'interface physique a été liée à l'interface virtuelle.

  • PVC de show atm pvc — Affiche tous les ATM PVC et informations routières actifs.

  • interface-nom de show policy-map interface — Affiche toute l'exécution LLQ et toutes les baisses dans le PQ. Référez-vous compréhension derrière des compteurs de paquet dans la sortie de commande de show policy-map interface pour plus d'informations sur les divers champs de cette commande.

    Remarque: La Mise en file d'attente de fantaisie est toujours appliquée à l'interface virtual-access2. L'autre mise en file d'attente FIFO d'utilisation d'interfaces.

  • show ip rtp header-compression — Affiche les statistiques de Compression d'en-tête RTP si configuré. Notez que les statistiques sont reliées à l'interface virtual-access2, qui est l'interface de paquet.

Des exemples de ces commandes sont affichés ici :

FR#show ppp multilink interface virtual-access 2
Virtual-Access2, bundle name is ATM
Bundle up for 00:22:42
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 231/255 load
0x2E5 received sequence, 0x10C31 sent sequence
Member links: 1 (max not set, min not set)
Virtual-Access1, since 00:22:42, last rcvd seq 0002E4 160 weight

Cette sortie affiche les utilisateurs d'exposition sur le routeur Frame Relay.

FR#show users
Line User Host(s) Idle Location
67 vty 1 idle 00:00:00 10.1.1.1
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (FR ) - 
Vi2 Virtual PPP (Bundle) 00:00:00 10.1.1.1
FR#

Cette sortie affiche les utilisateurs d'exposition sur le routeur atmosphère.

ATM#show users 
Line User Host(s) Idle Location
131 vty 1 idle 00:00:00 64.104.207.95
Interface User Mode Idle Peer Address
Vi1 Virtual PPP (ATM ) - 
Vi2 Virtual PPP (Bundle) 00:00:02 10.1.1.2
ATM#

Cette sortie affiche la commande de show frame-relay pvc.

FR#show frame-relay pvc 16
 PVC Statistics for interface Serial0/0 (Frame Relay DTE)
 DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1
  
     input pkts 2301 output pkts 2295 in bytes 152266 
     out bytes 151891 dropped pkts 0 in FECN pkts 0 
     in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 
     in DE pkts 0 out DE pkts 0 
     out bcast pkts 0 out bcast bytes 0 
     5 minute input rate 9000 bits/sec, 9 packets/sec
     5 minute output rate 9000 bits/sec, 9 packets/sec
     pvc create time 23:46:56, last time pvc status changed 00:22:56
     Bound to Virtual-Access1 (up, cloned from Virtual-Template1) 
     
!--- PPP link interface.

     cir 64000 bc 640 be 0 byte limit 80 interval 10 
     mincir 64000 byte increment 80 Adaptive Shaping none
     pkts 2296 bytes 152053 pkts delayed 9 bytes delayed 375
     shaping active 
     traffic shaping drops 0
     Queueing strategy: fifo
     Output queue 0/40, 0 drop, 0 dequeued
FR#

Cette sortie affiche au show atm pvc 10/100 commande sur le routeur atmosphère.

ATM#show atm pvc 10/100 
     ATM0/0.1: VCD: 1, VPI: 10, VCI: 100
     CBR, SusRate: 128
     AAL5-LLC/SNAP, etype:0x0, Flags: 0x820, VCmode: 0x0
     OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)
     OAM up retry count: 3, OAM down retry count: 5
     OAM Loopback status: OAM Disabled
     OAM VC state: Not Managed
     ILMI VC state: Not Managed
     InARP frequency: 15 minutes(s)
     Transmit priority 1
     InPkts: 729, OutPkts: 729, InBytes: 49700, OutBytes: 51158
     InPRoc: 0, OutPRoc: 729
     InFast: 729, OutFast: 0, InAS: 0, OutAS: 0
     InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)
     CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, 
     CPIErrors: 0
     OAM cells received: 0
     F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
     F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
     OAM cells sent: 0
     F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
     F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
     OAM cell drops: 0
     Status: UP
   PPP: Virtual-Access2 from Virtual-Template1 
    
!--- MLPPP bundle interface.

ATM#

C'est le show policy-map sur le routeur Frame Relay.

FR#show policy-map interface Virtual-Access2
Service-policy output: VoIP
Class-map: voice (match-all)
15483 packets, 959502 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing 
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48(kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 15536/962784
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
139 packets, 19481 bytes
30 second offered rate 1000 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0

Cette sortie affiche la commande de carte de stratégie d'exposition sur le routeur atmosphère.

ATM#show policy-map interface Virtual-Access2 
Service-policy output: VOIP
Class-map: voice (match-all)
11293 packets, 699718 bytes
30 second offered rate 24000 bps, drop rate 0 bps
Match: ip dscp 40 
Weighted Fair Queueing
Strict Priority 

!--- LLQ Strict Priority Queue for voice.

Output Queue: Conversation 24 
Bandwidth 48 (kbps) Burst 1500 (Bytes)
(pkts matched/bytes matched) 11352/703376
(total drops/bytes drops) 0/0 

!--- No drops in the voice queue.

Class-map: class-default (match-any)
63 packets, 9772 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any 
Weighted Fair Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16 
(total queued/total drops/no-buffer drops) 0/0/0
ATM#

Cette sortie affiche la commande de show ip rtp header-compression sur le routeur Frame Relay.

FR#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions

Interface Virtual-Access2:
Rcvd: 23682 total, 23681 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 327 total, 233 compressed,
8821 bytes saved, 5159 bytes sent
2.70 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 94 misses 0 collisions
71% hit ratio, five minute miss rate 0 misses/sec, 0 max

Cette sortie affiche la commande de show ip rtp header-compression sur le routeur atmosphère.

ATM#show ip rtp header-compression
RTP/UDP/IP header compression statistics:
Interface Virtual-Access1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Template1:
Rcvd: 0 total, 0 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 0 total, 0 compressed,
0 bytes saved, 0 bytes sent
Connect: 16 rx slots, 16 tx slots,
0 long searches, 0 misses 0 collisions, 0 negative cache hits

Interface Virtual-Access2:
Rcvd: 283 total, 233 compressed, 0 errors
0 dropped, 0 buffer copies, 0 buffer failures
Sent: 25341 total, 25340 compressed,
955537 bytes saved, 564463 bytes sent
2.69 efficiency improvement factor
Connect: 16 rx slots, 16 tx slots,
0 long searches, 1 misses 0 collisions, 100 negative cache hits
99% hit ratio, five minute miss rate 0 misses/sec, 0 max

Dépannez

Utilisez cette section afin de dépanner votre configuration.

Cette section fournit un certain exemple met au point destiné pour clarifier MLP LFI et pour servir d'exemples de fonctionnement pour dépanner votre configuration.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • debug ppp negotiation — Illustre le processus de copier les deux interfaces d'accès virtuel pour représenter le PPP et le paquet de PPP joint. L'interface d'accès virtuel 1 (Vi1) est le lien de PPP auquel (atmosphère ou trame) le PVC est lié. L'interface virtuelle 2 (Vi2) est le lien de paquet de PPP auquel des stratégies de Mise en file d'attente sont reliées.

  • fragment de multilink de debug ppp — Illustre le concept de plus grands paquets de données étant intercalés avec de plus petits paquets vocaux. L'interfoliage se produit sur l'interface Vi2 (le niveau MLP) puisque l'interface de paquet a la Mise en file d'attente de fantaisie assignée.

C'est la sortie de commande pour la commande de debug ppp negotiation.

FR(config-if)#no shut
FR(config-if)#^Z
FR#
FR#
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar 7 23:20:42.842: Vi1 PPP: Treating connection as 
a dedicated line 

!--- Vi1 is the PPP link to which the PVC is bound.

*Mar 7 23:20:42.842: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:42.842: Vi1 LCP: O CONFREQ [Closed] id 197 len 19
*Mar 7 23:20:42.842: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.842: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.842: Vi1 LCP: EndpointDisc 1 FR (0x1305014652) 

!--- Router FR at one end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: I CONFREQ [REQsent] id 14 len 20
*Mar 7 23:20:42.858: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.858: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.858: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D) 

!--- Router ATM at the other end of PPP discovery.

*Mar 7 23:20:42.858: Vi1 LCP: O CONFACK [REQsent] id 14 len 20

*Mar 7 23:20:42.862: Vi1 LCP: MagicNumber 0x294819D4 (0x0506294819D4)
*Mar 7 23:20:42.862: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.862: Vi1 LCP: EndpointDisc 1 ATM (0x13060141544D)
*Mar 7 23:20:42.870: Vi1 LCP: I CONFACK [ACKsent] id 197 len 19
*Mar 7 23:20:42.870: Vi1 LCP: MagicNumber 0xF44128D2 (0x0506F44128D2)
*Mar 7 23:20:42.870: Vi1 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:42.870: Vi1 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:42.870: Vi1 LCP: State is Open
*Mar 7 23:20:42.870: Vi1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 7 23:20:42.874: Vi1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 7 23:20:42.874: Vi1 PPP: Phase is VIRTUALIZED
*Mar 7 23:20:42.942: Vi2 PPP: Phase is DOWN, Setup
*Mar 7 23:20:43.222: Vi1 IPCP: Packet buffered while building MLP bundle interface
6d23h: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up 

!--- MLP level queuing.

*Mar 7 23:20:43.226: Vi2 PPP: Treating connection as a dedicated line
*Mar 7 23:20:43.226: Vi2 PPP: Phase is ESTABLISHING, Active Open
*Mar 7 23:20:43.226: Vi2 LCP: O CONFREQ [Closed] id 1 len 19
*Mar 7 23:20:43.226: Vi2 LCP: MagicNumber 0xF4412A53 (0x0506F4412A53)
*Mar 7 23:20:43.226: Vi2 LCP: MRRU 1524 (0x110405F4)
*Mar 7 23:20:43.230: Vi2 LCP: EndpointDisc 1 FR (0x1305014652)
*Mar 7 23:20:43.230: Vi2 MLP: 
Added first link Vi1 to bundle ATM 

!--- PVCs make up the bundle.

*Mar 7 23:20:43.230: Vi2 PPP: Phase is UP
*Mar 7 23:20:43.230: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.234: Vi2 PPP: Pending ncpQ size is 1
*Mar 7 23:20:43.234: Vi1 IPCP: Redirect packet to Vi1
*Mar 7 23:20:43.234: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.234: Vi2 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar 7 23:20:43.234: Vi2 IPCP: Address 10.1.1.1 (0x03060A010101)
*Mar 7 23:20:43.266: Vi2 IPCP: I CONFACK [ACKsent] id 1 len 10
*Mar 7 23:20:43.266: Vi2 IPCP: Address 10.1.1.2 (0x03060A010102)
*Mar 7 23:20:43.266: Vi2 IPCP: State is Open
*Mar 7 23:20:43.266: Vi2 IPCP: Install route to 10.1.1.1
*Mar 7 23:20:43.270: Vi2 IPCP: Add link info for cef entry 10.1.1.1

Cette sortie de commande est de la commande de fragment de multilink de debug ppp.

*Mar 7 23:16:08.034: Vi2 MLP: 
Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi2 MLP: Packet interleaved from queue 24
*Mar 7 23:16:08.038: Vi1 MLP: O ppp UNKNOWN(0x0000) (0000) size 64 
*Mar 7 23:16:08.038: Vi1 MLP: O frag 0000829B size 160 
*Mar 7 23:16:08.042: Vi1 MLP: I ppp IP (0021) size 64 direct
*Mar 7 23:16:08.046: Vi1 MLP: I ppp IP (0021) size 64 direct

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 22383