Câble haut débit : Data-over-Cable Service Interface Specifications (DOCSIS)

Utilisation de la commande max-cpe dans DOCSIS et CMTS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique les relations entre la nouvelle commande maximum-cpe n de modem câble et le paramètre MAX-CPE spécifiés dans le fichier de configuration de Data-over-Cable Service Interface Specifications (DOCSIS). Le fichier de configuration DOCSIS est chargé dans le modem câblé, et peut être codé sur les Routeurs de gamme uBR7200 exécutant la version de logiciel 12.1(2)EC1 ou ultérieures de ½ du ¿  de Cisco IOSïÂ.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Conditions préalables

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Les informations dans ce document sont basées sur le processeur du matériel uBR7246 (NPE150) de Cisco (révision B) et logiciel de Cisco IOS (UBR7200-IST-M), version 12.1(2)EC1.

  • Ce document se rapporte à des Modems câble en jetant un pont sur le mode seulement.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Informations générales

Il y a une demande des clients de câble pour le système de terminaison par modem câble (CMTS) pour laisser plus de CPEs pour se connecter au modem câble, malgré le fait que la valeur dans le fichier de configuration de Modems câble limite le nombre d'hôtes. Le changement pour laisser plus de CPEs pour se connecter au modem câblé a été introduit avec CSCdp52029 (clients enregistrés seulement) des séries de Cisco IOS du logiciel Release12.0(9.5)SC et de la version du logiciel Cisco IOS 12.1(1.0.3)EC1 d'IOS.

Cette demande était due créé au modem câble ne pouvant pas garder le compte de CPEs a alloué dans la synchronisation avec le compte CMTS. Quand le modem câble initialise, le seul cas où il peut synchroniser MAX-CPE avec le CMTS est quand il envoie le compte MAX-CPE au CMTS dans l'écoulement de demande d'enregistrement.

Si le modem câble est rechargé, il n'y a aucun écoulement au CMTS pour l'informer pour ramener le compte alloué du CPE à zéro. Le modem câble, cependant, commencera de nouveau à partir de zéro. Si un nouveau CPE derrière les demandes de modem câble d'être livré en ligne, le modem câble le permettra à car son compte MAX-CPE est maintenant zéro. Le CMTS avec un compte non zéro MAX-CPE, cependant, échouera la demande, et le message suivant apparaît sur le CMTS :

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

Ceci est intensifié par le fait que, si non spécifiée, l'entrée du par défaut MAX-CPE dans le fichier de configuration DOCSIS est placée à un.

Un exemple de ceci est quand le modem câble informe le CMTS qu'il a un compte MAX-CPE d'un dans sa demande d'enregistrement. Un client de câble veut que la fonctionnalité du cycle d'alimentation le modem câble permette l'ordinateur portable de leur installateur à retirer, et le PC de l'utilisateur final a remis sur le modem câble. Ceci échouera parce que. Après que la recharge le modem câble ait le compte MAX-CPE réglé à zéro, cependant, le CMTS se souviendra toujours l'entrée de l'ordinateur portable de l'installateur, et qui égale le compte MAX-CPE d'un.

Il y a un contournement disponible en émettant la commande du clear cable host x.x.x.x, où x.x.x.x égale l'IP ou l'adresse MAC de l'hôte à effacer sur le CMTS. Ce contournement, cependant, est impopulaire aux clients de câble.

Implémentation

Une nouvelle commande de configuration a été ajoutée au CMTS. Pour spécifier un nombre maximal d'hôtes permis par modem (ignorant la valeur MAX-CPE dans le fichier de configuration de modem câble), émettez la commande maximum-cpe n de modem câble dans le mode de configuration d'interface de câble. n égale 1 à 255.

Le CMTS active jusqu'au nombre n d'hôtes pour un modem câble. Quand le positionnement à illimité, ou à n est plus grand que la valeur MAX-CPE dans le fichier de configuration d'un modem câble, cette commande ignore la valeur de fichier de configuration. Le serveur DHCP contrôle le nombre d'adresses IP assignées aux hôtes derrière un seul modem câble.

Si le fichier de configuration du modem câble spécifie un certain nombre d'hôtes plus grands que n, le paramétrage du fichier de configuration aura la priorité. Il appartient au modem câble pour contrôler le nombre d'hôtes actifs.

En émettant la commande illimitée maximum-cpe de modem câble, le CMTS n'imposera pas une limite sur le nombre de CPEs s'est connecté à un seul modem câble. Avec cette configuration, il appartient au modem câble pour contrôler le nombre maximal de CPEs, et jusqu'au serveur DHCP pour contrôler le nombre d'adresses IP assignées à CPEs derrière un seul modem câble.

attention Attention : L'utilisation de la commande illimitée maximum-cpe de modem câble, si utilisé sans attention, peut ouvrir une faille de sécurité dans le système en activant des attaques par déni de service. Spécifiquement, il peut permettre à un utilisateur d'obtenir un grand nombre d'adresses IP, prenant de ce fait en bas du tout le réseau après tout des adresses IP que disponibles ont été réservées par ce seul utilisateur. On le recommande donc que, si la commande illimitée maximum-cpe de modem câble est activée, le nombre d'adresses IP assignées à CPEs derrière un seul modem câble soit strictement contrôlé par le serveur DHCP.

En n'émettant l'aucune commande maximum-cpe de modem câble, la valeur par défaut est activée. La valeur MAX-CPE fournie dans le fichier de configuration sera utilisée par le CMTS pour limiter le nombre de CPEs s'est connectée à un seul modem câble.

La commande de détail de show cable modem affiche la valeur MAX-CPE comme configurée dans le fichier de configuration DOCSIS pour le modem câble, et si possible, la valeur a configuré quand le maximum-cpe n de modem câble est émis.

Référez-vous au log témoin sorti ci-dessous. CMTS est configuré pour MAX-CPE égal à quatre, et MAX-CPE égal à illimité.

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

Remarque: Bien que le CMTS, laisse le nombre spécifié d'hôtes par des Modems câble, les Modems câble eux-mêmes seront encore limités pour laisser seulement le nombre de CPEs ont autorisé dans le fichier de configuration DOCSIS.


Informations connexes


Document ID: 22177