Qualité de service (QoS) : Marquage des paquets QoS

Ordre des opérations QoS (Qualité de service)

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 avril 2015) | Commentaires


Contenu


Introduction

Ce document montre la commande dans laquelle des caractéristiques de Qualité de service (QoS) sont exécutées quand d'arrivée ou sortant appliqué à une interface sur un routeur exécutant le logiciel de Cisco IOSÝ. Des stratégies QoS sont configurées avec l'interface de ligne de commande modulaire de QoS (MQC). Ce document discute également l'en-tête IP marquant, comme le DSCP et la Priorité IP, et la commande dans laquelle les composants d'une stratégie QoS sont évalués par le routeur.

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir la connaissance de :

  • Méthodologies de base de QoS

Composants utilisés

L'exemple de sortie dans la section de configurations de ce document a été saisi sur une plate-forme de gamme Cisco 7513 qui exécute le Logiciel Cisco IOS version 12.2.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Classification commune

La classification est le processus de définir les classes du trafic qui trient le trafic dans des groupes de catégories d'écoulements. La classification définit le « critère de correspondance » pour chaque classe du trafic qui doit être traité par une stratégie QoS. Plus spécifiquement, il définit le « filtre du trafic » ce des paquets sont vérifiés contre quand une service-stratégie est appliquée.

Distribué et les plates-formes non distribuées apparient des paquets à une classe simple dans un policy-map. Apparier se termine à la première classe assortie. Si deux classes dans un policy-map apparient la même Priorité IP ou plage d'adresses IP, le paquet appartient toujours à la première classe assortie. Pour cette raison, la commande de classe dans un policy-map est très importante.

Cette approche de classification s'appelle « la classification commune » et a ces avantages :

  • Comptabilité précise et la manière d'éviter des problèmes de double-comptabilité qui ont été vus avant « classification commune ».

  • Réduit l'incidence du Listes de contrôle d'accès (ACL) sur la CPU puisque l'ACL est vérifié une fois par classe, plutôt qu'une fois par caractéristique.

  • Une consultation plus rapide des en-têtes de paquet en raison de la mise en cache.

La classification commune est activée automatiquement quand vous reliez un policy-map d'entrée ou de sortie avec la commande de service-stratégie.

Cette table montre la commande de l'exécution avec la classification commune. Il est important de comprendre de la table quand la classification se produit dans le cadre des caractéristiques de QoS. Sur le chemin d'arrivée, un paquet est classifié avant qu'il soit commuté. Sur le chemin de sortie, un paquet est classifié après qu'il soit commuté.

D'arrivée Sortant
  1. Propagation de stratégie QoS par le Protocole BGP (Border Gateway Protocol) (QPPB)
  2. Classification de terrain communal d'entrée
  3. Entrée ACLs
  4. Marquage d'entrée (Fonction Class-based Marking ou Fonction Committed Access Rate (CAR))
  5. Maintien de l'ordre d'entrée (par un contrôle basé sur les classes ou un CAR)
  6. Sécurité IP (IPSec)
  7. Technologie Cisco Express Forwarding (CEF) ou commutation rapide
  1. CEF ou commutation rapide
  2. Classification de terrain communal de sortie
  3. Sortie ACLs
  4. Marquage de sortie
  5. Maintien de l'ordre de sortie (par un contrôle basé sur les classes ou un CAR)
  6. Queue (Mise en file d'attente pondérée basée sur les classes (CBWFQ) et basse queue de latence (LLQ)), et Détection précoce directe pondérée (WRED)

Remarque: Le Reconnaissance d'application fondée sur le réseau (NBAR) d'arrivée se produit après ACLs et avant le routage basé sur la politique.

D'importantes modifications ont été mises en application concernant la commande de caractéristique et l'utilisation remarquée de valeur. Ces modifications incluent le débit d'accès garanti en entrée, le MAC d'entrée, et les fonctions de traçabilité mobiles de Priorité IP pour se produire avant classification de sortie MQC :

  • Entrez la limitation de débit, ou le CAR, s'applique aux paquets suivant le chemin de commutation de processus et destinés au routeur. Précédemment, seulement les paquets commutés par le routeur utilisant le CEF ont pu être débit-limités.

  • La nouvelle valeur définie de Priorité IP par le débit d'accès garanti en entrée ou le QPPB peut être utilisée pour sélectionner un circuit virtuel (circuit virtuel) dans un paquet de circuit virtuel atmosphère.

  • La valeur définie de groupe de Priorité IP, de Differentiated Services Code Points (DSCP), et de QoS par le débit d'accès garanti en entrée ou le QPPB peut être utilisée pour la classification de paquet en sortie MQC.

Actions de repérage et autres de QoS sur le même routeur

Une application fréquente de QoS est de remarquer un paquet et puis d'appliquer une action qui considère la valeur remarquée sur la même interface ou sur le même routeur. Vous pouvez configurer le marquage et d'autres actions de QoS avec la classification commune.

Vous pouvez remarquer des paquets avec ces configurations de QoS :

  • commande set avec la Fonction Class-based Marking

  • la police commande avec le maintien de l'ordre basé sur classe

  • CAR

Cette table indique si une valeur remarquée est considérée par une action de QoS dans une service-stratégie.

Emplacement de stratégie Valeur utilisée par les actions de politique sortante
Marquez et appliquez l'action de QoS dans la même stratégie. Les actions de QoS utilisent la valeur initiale du paquet quand elle est généralement classifiée. Le paquet portera la nouvelle valeur quand il est transmis, et le prochain routeur utilise la nouvelle valeur.
Identifiez par la stratégie entrante et appliquez l'action de QoS avec la politique sortante. Les actions de QoS utilisent la valeur nouvelle ou remarquée en classifiant le trafic contre la politique sortante.

Sur le chemin de sortie, la classification commune se produit avant que toutes les caractéristiques de QoS soient appliquées. Un résultat de cette approche est que toutes les caractéristiques de QoS appliquées sur la politique sortante agissent sur la valeur prioritaire d'origine. Si vous devez agir basés sur une valeur remarquée sur le même routeur, alors vous devez marquer les paquets sur l'interface entrante et appliquer d'autres actions de QoS basées sur cette nouvelle priorité sur l'interface sortante.

Diagramme du réseau

Les configurations dans cette section utilise ce schéma de réseau :

/image/gif/paws/22141/qos_orderofop_3b.gif

Remarque: La carte de commutation multicouche (MSFC) agit en tant qu'hôte.

Configurations

Cet exemple explique comment la commande des exécutions peut affecter le marquage de paquets.

Configuration de marquage séparé et de stratégie de mise en forme
class-map match-all In_Mark
   match any 
policy-map In_Bound
  class In_Mark
    set ip precedence 5 

!--- Use Private address below:

interface FastEthernet4/0/0 
 ip address  10.20.3.2 255.255.255.0
ip route-cache distributed  
 service-policy input In_Bound

!--- Apply the input policy for class-based marking.

  
class-map match-all Out_Shaper
match ip precedence 5 
! 
policy Map Outbound_Shaper
class  Out_Shaper 
    shape average 64000 256 256 

!--- Use Private address below:

interface Serial2/0/0 
 ip address 172.16.20.1 255.255.255.252
ip route-cache distributed 
 service-policy output Outbound_Shaper

!--- Apply the output policy for class-based shaping.

Terminez-vous ces étapes pour confirmer le marquage et les stratégies de mise en forme :

  1. Utilisez la commande ping à l'adresse de destination de 172.16.20.2. Le ping apparie les critères du class-map nommé « In_Mark ».

    msfc#ping 172.16.20.2
      
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 40.1.44.2, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
  2. Utilisez le show policy-map interface jeûnent 4/0/0 commande de visualiser les compteurs de correspondance de la stratégie de Fonction Class-based Marking d'entrée. Le mécanisme de classification est avec succès apparié sur les paquets IP, et a remarqué la valeur de priorité IP à cinq.

    7513#show policy-map interface fast 4/0/0 
     FastEthernet4/0/0 
      Service-policy input: In_Bound
     
        Class-map: In_Mark (match-all) 
          5 packets, 570 bytes 
          5 minute offered rate 0 bps, drop rate 0 bps 
          Match: any 
          QoS Set 
            ip precedence 5 
              Packets marked 5
     
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any
  3. Utilisez la commande de l'interface série 2/0/0 de show policy-map interface de visualiser les compteurs de correspondance de la stratégie de mise en forme basée sur classe sortante. Le mécanisme de classification est avec succès apparié sur la valeur de priorité IP remarquée cinq dans l'en-tête de paquet, et a aligné les paquets à la classe correcte.

    7513#show policy-map interface serial 2/0/0 
     Serial2/0/0 
    
      Service-policy output: Outbound_Shaper
    
        Class-map: Out_Shaper(match-all) 
          5 packets, 520 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPSMatch: ip precedence 5 
          queue size 0, queue limit 16 
          packets output 5, packet drops 0 
          tail/random drops 0, no buffer drops 0, other drops 0 
          Shape: cir 64000,  Bc 256,  Be 256 
            output bytes 520, shape rate 0 BPS 
    
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any  (1327)

Vous pouvez voir ce qui se produit quand nous configurons une service-stratégie simple qui s'applique la formation et le repérage à une classe du trafic, comme indiqué dans cet exemple.

Configuration simple de marquage et de stratégie de mise en forme
class-map match-all prec5 
  match any 
! 
policy-map shape_five
  class prec5 
    set ip precedence 5 
    shape average 64000 256 256
int serial1/0/0
  service-policy out shape_five

La sortie de la commande de l'interface série 2/0/0 de show policy-map interface prouve que le routeur a remarqué les cinq paquets de ping, mais les paquets ont été alignés à la classe par défaut. Les mécanismes de classification QoS sur ce routeur n'ont pas considéré la valeur remarquée dans le champ de priorité IP.

7513#show policy-map interface serial 2/0/0 
 Serial2/0/0
  
  Service-policy output: shape_five
 
    Class-map: prec5 (match-all) 
      0 packets, 0 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match:  any
      queue size 0, queue limit 16 
      packets output 0, packet drops 0 
      tail/random drops 0, no buffer drops 0, other drops 0 
      QoS Set 
        ip precedence 5 
          Packets marked 5 
      Shape: cir 64000,  BC 256,  Be 256 
        output bytes 0, shape rate 0 BPS 

    Class-map: class-default (match-any) 
      5 packets, 520 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match: any

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 22141