Commutation LAN : EtherChannel

Configurer EtherChannel entre commutateurs Catalyst exécutant le logiciel système Cisco IOS et un routeur Cisco

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Cette configuration d'échantillon explique comment installer un EtherChannel de la couche 3 (L3), sans jonction VLAN, entre un routeur de Cisco et un commutateur de Cisco Catalyst 6500 exécutant le logiciel système de ½ du ¿  de Cisco IOSïÂ. EtherChannel peut être appelé Fast EtherChannel (FEC) ou Gigabit EtherChannel (GEC) ; le terme dépend de la vitesse des interfaces ou des ports que vous utilisez pour former l'EtherChannel. Dans cet exemple, deux ports Fast Ethernet d'un routeur Cisco et d'un commutateur Catalyst 6500 ont été regroupés dans un FEC. Dans tout ce document, les termes FEC, GEC, canal de port, canal et groupe de ports se rapportent tous à EtherChannel.

Ce document comporte seulement les fichiers de configuration du commutateur et du routeur, et la sortie des exemples de commande show relatifs.

Conditions préalables

Conditions requises

Assurez-vous de répondre à ces exigences avant d'essayer cette configuration :

  • Commutateurs des gammes Catalyst 6500/6000 et 4500/4000 exécutant le logiciel Cisco IOS :

    • Les commutateurs des gammes Catalyst 6500/6000 et 4500/4000 exécutant le logiciel Cisco IOS prennent en charge à la fois EtherChannel L2 et L3, avec jusqu'à huit interfaces Ethernet configurées de façon compatible sur n'importe quel module. Toutes les interfaces dans chaque EtherChannel doivent avoir la même vitesse. Toutes doivent être configurées en tant qu'interfaces L2 ou L3.

    • L'équilibrage de charge EtherChannel peut utiliser des adresses MAC, des adresses IP ou des numéros de port TCP.

      Remarque: Le mode sélectionné s'applique à tous les EtherChannel configurés sur le commutateur.

    • Logiciel Cisco IOS version 12.1E ou ultérieure Catalyst 6500/6000 et Logiciel Cisco IOS version 12.1(8a)EW ou ultérieure Catalyst 4500/4000.

  • Routeurs Cisco :

    • Le trafic IP est réparti sur l'interface de canal de port tandis que le trafic d'autres protocoles de routage est envoyé sur une liaison unique. Le trafic relié par un pont est distribué sur la base des informations L3 dans le paquet. Si les informations L3 n'existent pas dans le paquet, le trafic est envoyé sur la première liaison.

  • Une grande variété de routeurs Cisco prennent en charge EtherChannel. Pour rechercher une plate-forme ou version de code qui prend en charge EtherChannel sur un routeur Cisco, utilisez l'outil Navigateur de fonctionnalités Cisco II (clients inscrits seulement). Une liste des routeurs et des versions du logiciel Cisco IOS qui prennent en charge EtherChannel figure sous la fonctionnalité FEC.

Pour connaître la configuration matérielle et logicielle requise pour EtherChannel sur d'autres produits Cisco, reportez-vous à Configuration système requise pour implémenter EtherChannel sur les commutateurs Catalyst.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur Catalyst 6500 exécutant la version du logiciel Cisco IOS 12.1(8b)E10

  • Routeur Cisco 7500 exécutant la version du logiciel Cisco IOS 12.1(21)

Dans ce document, la configuration de commutateur s'applique à tous les commutateurs des séries Catalyst 6500/6000 et Catalyst 4500/4000 exécutant le logiciel Cisco IOS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Remarque: L'utilisation de la commande write erase a effacé les configurations sur tous les périphériques pour s'assurer qu'ils avaient une configuration par défaut. Veillez à recharger les périphériques après que vous émettez la commande write erase pour vider toutes les configurations autres que par défaut.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Remarques importantes

Si vous émettez initialement la commande channel-group sous l'interface physique, elle crée automatiquement l'interface port-channel. Si vous avez configuré l'interface port-channel avant la transmission des interfaces physiques, supprimez d'abord l'interface port-channel. C'est seulement pertinent sur des commutateurs Catalyst. L'ordre de configuration change sur le routeur 7500. Vous devez configurer l'interface de canal de port avant que vous configuriez le groupe de canaux de ½ du ¿  de theï sous l'interface physique.

L'ordre de configuration d'un canal de port dans le logiciel Cisco IOS Catalyst 6500/6000 et 4500/4000 est important. Il est conseillé d'émettre toute commande switchport avant d'émettre la commande channel-group dans une interface physique.

Quand vous émettez la commande channel-group avant la commande switchport sur une interface physique (interface Gigabit Ethernet 1/1), l'interface port-channel est créée automatiquement et devient une interface L3. Si vous émettez alors la commande switchport sous l'interface physique, l'interface physique devient une interface L2. En outre, l'interface port-channel que vous avez créée plus tôt n'a aucune interface physique associée à elle. Notez que la commande channel-group est absente de sous l'interface physique. Dans ce cas, vous devez d'abord émettre la commande switchport sous l'interface port-channel nouvellement configurée. Puis, le port physique accepte de nouveau la commande channel-group. Dans ce cas, le canal de port est passé d'une interface L3 à une interface L2.

Supposez, en revanche, que vous émettez la commande switchport d'abord sur une interface physique, puis ajoutez la commande channel-group. Dans ce cas, l'interface port-channel est automatiquement créée et hérite de toutes les commandes switchport configurées.

Sur un commutateur Catalyst 6500/6000 exécutant le logiciel Cisco IOS, tous les ports sont des ports L3 par défaut. Sur un commutateur Catalyst 4500/4000 exécutant le logiciel Cisco IOS, tous les ports sont des ports L2 par défaut.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/21066/135-a.gif

Configurations

Ce document utilise les configurations suivantes :

Remarque: Les commentaires et les explications apparaissent en italique et en bleu.

Commutateur Catalyst 6500 (sans jonction VLAN)
Building configuration...
�
Current configuration : 5869 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
enable password ww
!
redundancy
�main-cpu
� auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!

!--- In this example, you configure L3 EtherChannel.
!--- For more details, refer to this document:
!--- Configuring EtherChannels.
!--- A logical port-channel interface is automatically created�
!--- when ports are grouped into a channel group.


interface Port-channel 1
�ip address 11.1.1.2 255.255.255.0
 duplex full
 speed 100

!--- If you specify the speed and duplex setting at the port channel 
!--- level, these settings pass down to the physical ports.
!--- In other words, the physical ports inherit the same speed 
!--- and duplex settings as the port-channel interface.

 hold-queue 300 in
!
interface GigabitEthernet1/1
�no ip address
�shutdown
!
interface GigabitEthernet1/2
�no ip address
�shutdown
!
interface FastEthernet3/1
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (Port Aggregation Protocol [PAgP]), so PAgP
!--- needs to be disabled. On a Catalyst 4500/4000 switch, all ports are
!--- L2 ports by default. Convert this port from a physical L2 port to
!--- a physical L3 port with the no switchport command.

channel-group 1 mode on

interface FastEthernet3/2
�no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (PAgP), so PAgP needs to be disabled.
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default. 
!--- Convert this port from a physical L2 port to a physical L3 port 
!--- with the no switchport command.


channel-group 1 mode on


interface FastEthernet3/3
�no ip address
�switchport
�switchport mode access
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
�transport input none
line vty 0 4
!
end

Routeur Cisco 7500 (sans jonction VLAN)

!--- Output suppressed.

!
interface Port-channel1
�ip address 11.1.1.1 255.255.255.0
 full-duplex
�hold-queue 300 in
!
interface FastEthernet0/0
�no ip address
�full-duplex
 speed 100
�channel-group 1
!
interface FastEthernet0/1
�no ip address���
�full-duplex
 speed 100���������������������������� �
�channel-group 1

!--- Output suppressed.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Commandes show

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show etherchannel channel-id port-channel — Pour vérifier le canal de port dans un commutateur Cisco IOS.

  • show interfaces port-channel channel-id — Pour vérifier le canal de port dans un routeur Cisco IOS.

Exemple de sortie de la commande show

Commutateur Catalyst 6500/6000

  • show etherchannel channel-id port-channel

Router#show etherchannel 1 port-channel
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 01h:56m:20s

Logical slot/port = 10/1 Number of ports in agport = 2
GC = 0x00010001 HotStandBy port = null
Passive port list = Fa3/1 Fa3/2
Port state = Port-channel L3-Ag Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
0 55 Fa3/1
1 AA Fa3/2
Time since last port bundled: 01h:55m:44s Fa3/2
Router#

Routeur Cisco 7500

  • show interfaces port-channel channel-id

Router#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
Internet address is 11.1.1.1/24
MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
ARP type: ARPA, ARP Timeout 04:00:00
No. of members in this fechannel: 2
Member 0 : FastEthernet0/0
Member 1 : FastEthernet0/1
Last input never, output never, output hang never
Last clearing of "show interface" counters 10:51:55
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/300, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 98281000 bits/sec, 8762 packets/sec
4545 packets input, 539950 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast
0 input packets with dribble condition detected
342251216 packets output, 3093422680 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 21066