Interfaces et modules Cisco : Module de commutation de contenu Cisco

Configuration de la mise en cache transparente sur le module de commutation de contenu

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer un module de commutation satisfait (CSM) pour la mise en cache transparente, avec des Cisco Contents Engine comme caches. Le cache transparent se repose entre l'utilisateur et le serveur. Le CSM est introduit entre l'utilisateur et le cache. Le CSM est intelligent en raison de sa capacité de la couche 5 d'analyser dynamiquement le contenu et de déterminer s'il est cacheable ou pas. Ces instructions s'appliquent :

  • Si cacheable, le CSM équilibrent la charge la demande au service en fonction de cache sur le predictor configuré.

  • Sinon cacheable, le CSM l'envoie directement au serveur d'origine. Ceci évite l'impact sur les performances qui se produit quand l'objet non-cacheable va dans le cache, seulement pour faire réorienter sa demande par le cache au serveur d'origine.

Il y a plusieurs méthodes de équilibrage disponibles, qui dépendent de la façon dont vous voulez distribuer des données au-dessus des caches (par exemple, URL entier, chaîne d'URL, et ainsi de suite).

Le CSM peut être configuré avec une liste d'extensions de fichier pour envoyer dans le cache. Cette liste s'appelle une liste de qualificatif d'extension (EQL). Une fois que vous configurez la slb-stratégie CACHE-POLICY sous le vserver TRANSPARENT, seulement des demandes avec les extensions de fichier qui sont répertoriées dans la liste URL de la carte CACHEABLE sont envoyées au cache. Si des extensions de fichier n'est pas répertoriées dans la liste URL de la carte CACHEABLE, alors la demande frappera la slb-stratégie NONCACHE-POLICY.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.1(8)EX de ½ du ¿  de Cisco IOSï de superviseur du Catalyst 6000 pour l'engine 1 de superviseur avec MSFC1 (c6sup11-dsv-mz.121-8a.EX)

  • Version de logiciel 2.1(2) CSM du Catalyst 6000 (c6slb-apc.2-1-2.bin)

  • Version courante 5.1.3 de Logiciel Cisco Application and Content Networking System (ACNS) du Cisco Content Engine 565

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cette section, vous êtes présenté avec les informations pour configurer les caractéristiques qui sont décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Mise en cache transparente sur le CSM

config_transp_caching_19680.gif

Configurations

Ce document utilise les configurations suivantes :

CSM
Building configuration...
Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
ip name-server 10.107.241.185
!

!--- CSM located in slot 3. Module is running as active
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 3
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.

 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!

!--- Probe setup to check the availability of the Content
!--- Engine default probe values. Interval is 300 seconds.

 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command.
!--- CSM needs to do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND.
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the map CACHEABLE url list
!--- will use serverfarm OUTBOUND. The NAT server has no
!--- effect, as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
  priority 20
!

!--- CSM located in slot 4. Module is running as standby
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 4
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.
!--- Note: Module 3 and 4 VLAN IP addresses are different.

 vlan 200 server 
  ip address 10.107.249.253 255.255.255.248
!

!--- Probe setup to check availability of Content Engine.
!--- Default probe values. Interval 300 seconds.

!
 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command. CSM needs to
!--- do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the CACHEABLE URL list will
!--- use serverfarm OUTBOUND. The NAT server has no effect,
!--- as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!

!--- CSM client side VLAN. Uplink to the Internet.

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!

!--- Cache Engine connected to FE2/3 and FE2/4.
!--- CSM client side VLAN.

interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!

!--- CSM Server side VLAN. Connection to end users.

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!

!--- MSFC VLAN 100. Content Engine and client uses this
!--- address as the default gateway.

interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end

Engine satisfaite
device mode content-engine
!
hostname ce1
!
http proxy incoming 80

!--- Accept proxy requests on port 80.

!
http l4-switch enable


!--- Instructs the Content Engine to accept traffic that is
!--- directed to any destination IP.

!
ip domain-name cisco.com
!
!
interface Fastethernet 0/0
 ip address 10.107.249.254 255.255.255.248
 exit
!
interface Fastethernet 0/1
 exit
!
ip default-gateway 10.107.249.250
!
primary-interface Fastethernet 0/0
!
!
no auto-register enable
!
ip name-server 10.107.241.185
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

Vérifiez

Cette section présente les informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes debug, reportez-vous aux Informations importantes sur les commandes de débogage.

Le CSM mettent au point et des commandes show

  • show module

  • show arp — Fournit la liste de cache de Protocole ARP (Address Resolution Protocol) d'Équilibrage de charge de serveur (SLB).

  • shows conn — Fournit les informations de connexion SLB.

  • dfp d'exposition — Fournit des informations de gestionnaire de Protocole DFP (Dynamic Feedback Protocol) SLB.

  • exposition pi — Fournit des informations de la tolérance aux pannes SLB (pi).

    cat# show module csm 3 ft
    
    FT group 1, vlan 250
    This box is active
    priority 20, heartbeat 1, failover 3, preemption is off
    
    cat# show module csm 4 ft
    
    FT group 1, vlan 250
    This box is in standby state
    priority 10, heartbeat 1, failover 3, preemption is off
  • carte d'exposition — Fournit des informations de carte SLB.

  • show memory — Fournit des informations de mémoire SLB.

  • natpools d'exposition — Fournit des informations NAT de groupe de client SLB.

  • stratégie d'exposition — Fournit des informations de stratégie SLB.

  • sonde d'exposition — Fournit des informations de sonde SLB.

  • reals d'exposition — Fournit les vraies informations du serveur SLB.

  • serverfarms d'exposition — Fournit des informations de ferme de serveur SLB.

  • charge statique d'exposition — Fournit des informations NAT de serveur statique SLB.

  • show stats — Fournit des statistiques SLB.

  • état d'exposition — Fournit les informations d'état SLB.

  • exposition Rémanente — Fournit la base de données Rémanente SLB.

  • show tech-support — Fournit SLB technique mettent au point les informations.

  • VLAN d'exposition — Fournit des informations SLB VLAN.

  • vservers d'exposition — Fournit des informations de serveur virtuel SLB.

    show module csm 3 vservers name transparent detail
    
    TRANSPARENT, state = OPERATIONAL, v_index = 10
      virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
      idle = 3600, replicate csrp = none, vlan = ALL
      max parse len = 2000, persist rebalance = TRUE
      conns = 0, total conns = 47
      Default policy:
        server farm = CACHE
        sticky: timer = 0, subnet = 0.0.0.0, group id = 0
      Policy           Tot Conn     Client pkts  Server pkts
      ------------------------------------------------------
      CACHE-POLICY     44           249          203
      NONCACHE-POLICY  37           111          37
      (default)        0            0            0
  • module csm ? — Configure le CSM pour la mise en cache transparente. Spécifie également l'emplacement du CSM que vous configurez.

    cat(config)# module csm ?
    
    <1-6>  slot where the CSM module resides
  • proxy de vserver — Configure le serveur virtuel.

    cat(config-module-csm)# vserver proxy
    
    cat(config-slb-vserver)# ?
    
  • le vserver annoncent — Annoncez l'adresse IP virtuelle.

  • client de vserver — Place les adresses IP de client.

  • ensembles par défaut de vserver une commande à ses par défaut.

  • sortie de vserver — Quitte le sous-mode d'équilibrage de charge du serveur.

  • inactif de vserver — Les positionnements tournent au ralenti le temporisateur.

  • inservice de vserver — Les enables entretiennent pour ce serveur virtuel.

  • aucun vserver — Réalise une inversion une commande ou place ses par défaut.

  • analyser-longueur de vserver — Place la couche maximum 7 analysent la longueur.

  • vserver persistant — Enables ou persistance de connexion de débronchements.

  • réplique de vserver — Place la réplication de tolérance aux pannes de vserver.

  • serverfarm de vserver — Vraie batterie de serveur de positionnements.

  • slb-stratégie de vserver — Place la stratégie d'équilibrage de charge du serveur.

  • vserver Rémanent — Place le temporisateur Rémanent.

  • URL-informations parasites de vserver — Place la correspondance de préfixe/suffixe pour l'algorithme d'URL-informations parasites.

  • vserver virtuel — Configure un serveur virtuel.

  • cache de serverfarm — Configure la batterie de serveur.

    cat(config-module-csm)# serverfarm cache
    
    cat(config-slb-sfarm)# ?
    
  • bindid de serverfarm — ID de grippages pour DFP.

  • ensembles par défaut de serverfarm une commande à ses par défaut.

  • sortie de serverfarm — Sous-mode de ferme de serveur des sorties SLB.

  • failaction de serverfarm — Action de prendre la vraie panne de serveur.

  • serverfarm nat — Place la traduction d'adresses pour SLB.

  • aucun serverfarm — Réalise une inversion une commande ou place ses par défaut.

  • predictor de serverfarm — Place l'algorithme de prévision d'Équilibrage de charge.

  • sonde de serverfarm — Configure pour l'usage d'une sonde.

  • serverfarm vrai — Configure un vrai serveur.

  • le serverfarm réorientent-vserver — Configure un SLB réorientent le serveur virtuel.

Commandes show satisfaites d'engine

  • affichez l'épargne de HTTP de statistiques — Enregistre les statistiques de l'engine satisfaite.

    ce1# show statistics http savings
    
                           Statistics - Savings
                         Requests           Bytes
    -----------------------------------------------
    Total:               635                2764599
    Hits:                113                254517
    Miss:                505                2483555
    Savings:            17.8 %              9.2 %

    Comme vous pouvez voir, il y avait 113 hit.

Dépannez

Il n'y a actuellement aucune informations disponibles spécifique pour dépanner cette configuration.


Informations connexes


Document ID: 19680