IP : Attribution et résolution d'adresse dynamique

Utilisation d'un serveur DHCP pour les réseaux de signaux vocaux et de données

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans un réseau de téléphonie IP optimisé, les adresses IP pour les téléphones et les PC doivent être configurées dans différents segments réseau. Si le protocole DHCP est utilisé pour attribuer des adresses, alors un serveur DHCP est requis pour chaque segment de réseau. Cependant, vous pouvez utiliser un seul serveur DHCP pour attribuer les deux plages d'adresses si vous avez des routeurs capables de relayer le DHCP dans votre réseau IP. Ce document explique comment et pourquoi il est possible d'utiliser un serveur unique pour des adresses IP de voix et de données.

Remarque: Les informations dans ce document ne s'appliquent pas dans entièrement un réseau commuté ou si vous n'avez pas un périphérique capable de routage. Dans de tels scénarios, il y a seulement deux possibilités pour assigner différentes adresses IP aux téléphones et PCs.You doit avoir un serveur DHCP avec deux networks interface cards ou avoir deux serveurs DHCP.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Problème

Si vous installez un réseau de Téléphonie sur IP, alors vous devez assigner des adresses IP pour vos téléphones et PC dans différents segments de réseau. Ces affectations d'adresses exigent un serveur DHCP pour chaque segment de réseau. Cependant, vous avez seulement un serveur DHCP.

Solution

Pour pouvoir utiliser votre serveur DHCP en cours pour assigner des adresses pour les deux VLAN, vous devez avoir un périphérique de la couche 3 (L3) dans le réseau qui peut faire font le Routage inter-VLAN.

Les deux exemples dans ce document décrivent comment utiliser un serveur DHCP pour assigner des adresses IP de Voix et de données.

La configuration réseau

Il y a un réseau en cours avec Cisco Catalyst 6000 ou un Catalyst 3524-XL-PWR. Dans ce qui, VLAN 10 est configurée pour être les données VLAN utilisées par les PC et les serveurs. Dans le même VLAN il y a également un serveur DHCP qui exécute le Windows 2000 pour fournir des adresses dans la plage 10.10.10.20 à 10.10.10.200. L'adresse IP de serveur DHCP est 10.10.10.2.

dhcp-multintwk-1.gif

Pour ajouter la Téléphonie sur IP dans ce réseau, branchez un téléphone IP avec un PC dans de nouveau au port de Catalyst où le PC a été connecté.

Exemple du Catalyst 6000 avec MSFC

Dans ce scénario, il y a Cisco Catalyst 6000 avec une carte de commutation multicouche (MSFC) comme périphérique capable de routage.

/image/gif/paws/19580/dhcp-multintwk-2.gif

Pour permettre au PC et au téléphone pour être sur le même Catalyst mettez en communication, vous doivent configurer la commande d'auxiliaryVLAN avec la nouvelle Voix VLAN 110 comme affichés :

cat6k-access> (enable) set VLAN 110 name 11.1.1.0_voice
cat6k-access> (enable) set VLAN 10 5/1-48
cat6k-access> (enable) set port auxiliaryVLAN 5/1-48 110

Pour permettre le serveur DHCP en cours dans les données VLAN 10 à utiliser pour assigner des adresses IP aux téléphones, suivez ces étapes :

  1. Créez une interface sur le MSFC pour chaque VLAN, données et Voix.

  2. Configurez chaque interface avec une adresse valide dans le VLAN.

  3. Sur l'interface vlan 110, ajoutez une commande de helper-address d'IP.

    Cette commande permet des paquets de diffusion DHCP sur la Voix VLAN 110 à envoyer comme paquets monodiffusions au serveur DHCP dans les données VLAN 10.

    La configuration sur le MSFC devrait être :

    cat6k-msfc(config)#interface vlan10
    cat6k-msfc(config-if)#ip address 10.10.10.19
    cat6k-msfc(config-if)#<description of data VLAN for PCs and where the DHCP
     server is located>
    
    cat6k-msfc(config)#interface vlan110
    cat6k-msfc(config-if)#ip address 11.1.1.19
    cat6k-msfc(config-if)#ip helper-address 10.10.10.2
    cat6k-msfc(config-if)#<description VLAN for voice>
    

    La configuration de Cisco Catalyst 6000 demeure sans changement.

  4. Configurez le serveur DHCP avec une nouvelle portée des adresses pour les téléphones (11.1.1.1.X) dans la Voix VLAN 110.

    Si le serveur DHCP n'a pas une portée qui apparie l'adresse IP d'agent de relais, alors la requête DHCP échoue. Vous devez ajouter l'option 150 dans cette portée de fournir l'adresse du serveur TFTP aux téléphones. Pour des instructions pas à pas sur la configuration du serveur DHCP pour les téléphones, référez-vous à configurer le serveur DHCP de Windows 2000 pour le Cisco CallManager.

Exemple du Catalyst 3524-XL avec un routeur externe

Dans ce scénario, il y a Cisco Catalyst 3524-XL-PWR et un routeur externe comme périphérique capable de routage, avec une interface dans chaque VLAN.

/image/gif/paws/19580/dhcp-multintwk-3.gif

Pour permettre au PC et au téléphone pour être sur le même Catalyst mettez en communication, configurez la jonction avec la nouvelle Voix VLAN 110 comme affichés :

interface FastEthernet0/13
description phone and PC
switchport mode trunk
switchport trunk encapsulation dot1q
switchport voice vlan 110
switchport trunk native vlan 10

Répétez la configuration pour tous les ports sur le Catalyst où vous avez connecté un téléphone à un PC branché au téléphone.

Pour permettre le serveur DHCP en cours dans les données VLAN 10 à utiliser pour assigner des adresses IP aux téléphones, suivez ces étapes :

  1. Connectez deux interfaces de routeur à deux ports sur Cisco Catalyst 3524-XL, un dans le VLAN 10 et l'autre dans VLAN 110.

  2. Du côté routeur, assignez une adresse valide dans chaque VLAN.

    Remarque: La jonction étant configuré, vous pouvez également réaliser ceci avec un port unique connecté du Catalyst 3524-XL au routeur.

  3. Émettez la commande de helper-address d'IP sur l'interface de routeur qui est connectée pour exprimer VLAN 110.

    Ceci permet des paquets de diffusion DHCP reçus sur l'interface à envoyer comme paquets monodiffusions au serveur DHCP dans les données VLAN 10.

    La configuration sur le routeur devrait être comme affichée :

    router(config)#interface FastEthernet0/0 
    router(config-if)#ip address 10.10.10.19 255.255.255.0 
    
    router(config-if)#<description connected to catalyst port 0/10 
     data VLAN for PCs and DHCP server>
     
    router(config)#interface FastEthernet0/1
    router(config-if)#IP address 11.1.1.19 255.255.255.0 
    router(config-if)#IP helper-address 10.10.10.2 
    router(config-if)#<description connected to catalyst port 0/11 voice VLAN>
    
    

    La configuration sur Cisco Catalyst 3524-XL devrait être :

    router(config)interface FastEthernet0/10
    router(config-if)#switchport access vlan 10
    router(config-if)#<description port on data VLAN going to the router FE0/0>
    
    router(config)interface FastEthernet0/11
    router(config-if)#switchport access vlan 110
    router(config-if)#<description port on voice VLAN going to the router FE0/1>
    
  4. Configurez le serveur DHCP avec une nouvelle portée des adresses pour les téléphones (11.1.1.1.X) dans la Voix VLAN 110.

    Si le serveur DHCP n'a pas une portée qui apparie l'adresse IP d'agent de relais, la requête DHCP échoue. Vous devez ajouter l'option 150 dans cette portée de fournir l'adresse du serveur TFTP aux téléphones. Pour des instructions pas à pas sur la configuration du serveur DHCP pour les téléphones, référez-vous à configurer le serveur DHCP de Windows 2000 pour le Cisco CallManager.

Comment la solution fonctionne

Le serveur DHCP peut fournir des adresses de la portée appropriée pour les deux VLAN, basée sur l'utilisation du champ d'agent de relais dans les paquets DHCP. Un agent de relais est l'agent qui est responsable de la conversion des paquets DHCP d'émission envoyés par le téléphone dans les paquets monodiffusions qui sont envoyés au serveur DHCP. Cet agent convertit également les paquets DHCP d'unicast envoyés du serveur DHCP en paquets d'émission qui sont envoyés sur le réseau téléphonique. Dans cet exemple, l'agent de relais est l'interface VLAN 110 sur le MSFC configuré avec la commande de helper-address d'IP.

Quand le serveur DHCP reçoit le DHCP découvrez le message avec une adresse IP actuelle dans le domaine d'agent de relais, il emploie cette adresse pour apparier la portée appropriée et assigne l'adresse IP de lui. Vous pouvez voir des détails de ce protocole dans RFC 3046leavingcisco.com .

Les paquets DHCP qui sont permutés dans cet exemple seraient comme affichés :

/image/gif/paws/19580/dhcp-multintwk-4.gif

Les lignes bleues affichent les paquets DHCP qui sont envoyés à et du téléphone IP. Ce sont les seuls paquets qui apparaissent si le serveur DHCP est dans le même réseau Ethernet que les téléphones.

Les lignes noires représentent les paquets monodiffusions DHCP que l'agent de relais transmet à et du serveur DHCP.

Cette table affiche les détails des paquets pour cet exemple. Pour des informations sur le protocole et des champs DHCP, référez-vous à RFC 1541leavingcisco.com .

1 DHCP les découvrent DHCP 2 les découvrent
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255] 

DHCP Client IP Address = [0.0.0.0] 
DHCP Relay Agent = [0.0.0.0] 
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover) 
Parameter Request List:
...
    150= Unknown Option 
... 
IP Source Address = [11.1.1.19] 
IP Destination Address =[10.10.10.2]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover)
Parameter Request List:
...
    150= Unknown Option 
...
Offre DHCP 4 Offre DHCP 3
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2]
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
Requête DHCP 5 Requête DHCP 6
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [0.0.0.0]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
IP Source Address = [11.1.1.19] 
IP Destination Address = [10.10.10.2]

DHCP Client IP Address =  [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
8 DHCP ACK 7 DHCP ACK
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2] 
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 19580