Câble haut débit : Modems câble

Comment configurer un routeur Cisco derrière un modem câble non Cisco

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (21 avril 2016) | Commentaires


Contenu


Introduction

Dans certains environnements où un modem câble (CM) non-Cisco est utilisé, et que ce modem câble est seulement capable de pontage, un routeur Cisco, tel que Cisco 806, peut être connecté au modem câble par l'intermédiaire de l'interface Ethernet. Le routage est alors exécuté par le routeur, derrière le modem câble. L'étape suivante consiste à connecter le PC client ou l'Équipement sur site chez le client (CPE) au routeur. Une fois cette connexion établie, la Traduction d'adresses de réseau (NAT) est configurée sur le routeur.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur de gamme 806 exécutant la version 12.2(2)XI de ½ du ¿  de Cisco IOSïÂ

  • Routeur cm agissant en tant que passerelle

  • Windows 2000 courant PC agissant en tant que CPE

  • système de terminaison par modem câble uBR7246VXR (CMTS)

Remarque: Seulement Cisco 806 configurations de routeur sont affichés dans ce document. Pour plus d'informations sur configurer le CMTS, référez-vous aux exemples de configuration de technologie câble et aux notes en tech.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.gif

Configurations

Ce document utilise la configuration de routeur 806 :

Configuration de routeur 806
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

Vérifiez

Pour vérifier que le routeur a obtenu une adresse IP sur son E1 d'Ethernets dynamiquement, utilisez la commande brief de show ip interface.

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

Assurez-vous que votre table de routage a les entrées correctes. Par exemple, dans cet affichage, le default route est à 66.108.112.1. Ceci est installé par le processus DHCP quand le routeur reçoit l'adresse IP sur l'interface Ethernet.

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

Dépannez

Quand le routeur est connecté derrière le cm, le premier problème qui pourrait se poser n'obtient pas une adresse IP dynamiquement sur l'interface Ethernet du routeur. La plupart des ISP permettent seulement un hôte ou PC derrière le cm. Quelques ISP assignent une adresse IP au PC basé sur le nom d'hôte. Par conséquent, si vous avez un routeur derrière le cm, puis le nom d'hôte pour le routeur configuré utilisant la commande d'adresse Internet devrait être le même nom d'hôte donné par l'ISP.

Si le routeur n'obtient pas une adresse IP dynamiquement, la première chose à vérifier est si l'ip address dhcp de commande de configuration d'interface existe. Cette commande est sous l'interface Ethernet connectée au cm. La commande a été introduite dans la version de logiciel 12.1(2)T IOS.

Si la commande d'ip address dhcp existe, mais le routeur derrière le cm n'obtient toujours pas une adresse IP, connectez un PC derrière le cm pour le détecter s'il reçoit une adresse IP. Ceci vérifie que les services DHCP fonctionnent correctement. Les ISP permettent typiquement seulement un hôte derrière le cm, donc connectant un PC derrière les comptes cm comme le premier hôte. Cette entrée demeure dans la base de données ISP pendant 24 heures. En conséquence, si vous connectez le routeur derrière le cm, l'ISP pense que le routeur est un deuxième hôte et le rejette. Si ceci se produit, libérez l'adresse IP de votre PC en se terminant ces étapes sur votre PC de Windows 2000 :

  1. Dès le début le menu choisissent le passage.

  2. Le cmd de type appuient sur alors le retour chariot.

  3. À la demande, ipconfig/release de type.

  4. Après libération de l'adresse IP du PC, redémarrez votre cm et l'essayez de nouveau.

Si ceci ne fonctionne pas, vous devez appeler votre ISP et leur demander pour effacer la première entrée de hôte sur leur CMTS.

Une autre méthode est de configurer l'interface Ethernet du routeur. Ceci se connecte au cm à l'adresse MAC du PC utilisant l'IEEE-adresse de mac-address de commande.

À l'aide de la même adresse MAC sur l'interface Ethernet qui se connecte au cm comme PC, l'ISP apprend seulement environ un hôte et une adresse IP. Le PC n'obtient pas rejeté une fois connecté derrière le routeur. NAT doit être configuré sur le routeur pour recevoir des traductions d'adresse IP.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • détail de debug dhcp — Utilisez la commande de détail de debug dhcp d'afficher les informations de débogage DHCP. Ceci est utilisé pour dépanner pourquoi le routeur de Cisco n'a pas obtenu une adresse IP pour l'interface Ethernet.

  • debug ip dhcp server [événements] [liaison] [paquet] — utilisez la commande de debug ip dhcp server d'afficher l'élimination des imperfections de serveur DHCP. Ceci aide à déterminer pourquoi le PC, qui est connecté au routeur, n'a pas obtenu une adresse IP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 19268