Voix : Digital CCS

Configuration et résolution des problèmes associés à la signalisation CCS transparente

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer et dépanner le Protocole T-CCS (Transparent Common Channel Signaling).

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

  • Comment configurer le logiciel de Ý de Cisco IOS pour la fonctionnalité de Voix.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version du logiciel Cisco IOS 12.2.7a.

  • Le routeur de Cisco 3640.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

T-CCS permet la connexion de deux PBX avec les interfaces numériques qui utilisent un protocole de propriété industrielle ou sans support CCS sans besoin de traduction de la signalisation CCS pour le Traitement des appels.

Avec T-CCS, les canaux vocaux PBX peuvent être cloués vers le haut de (fait constante), et être compressés entre les sites. Le canal ou les canaux de signalisation de accompagnement peut être percé un tunnel (transmis d'une manière transparente) à travers le circuit principal IP/FR/ATM entre les PBX. Ainsi, des appels des PBX ne sont pas conduits par Cisco sur une base d'appel par appel, mais suivent une artère préconfigurée à la destination.

Il y a trois manières configurables d'appliquer la caractéristique :

  • Trame-expédition T-CCS

  • Clear-channel T-CCS

  • Croix-connectez T-CCS

Croix-connectez T-CCS est seulement possible sur Cisco 3810, et n'est pas discuté dans ce document.

Matrice de compatibilité T-CCS

Cette table affiche les caractéristiques T-CCS qui peuvent être configurées sur de diverses Plateformes.

Vox1 Cisco 3810 Cisco 26xx/36xx/72xx
VoIP2 Clear-channel :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Clear-channel :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Vofr3 Clear-channel :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Trame-expédition :
  • signaling.4 HDLC-encadré
  • Seulement 1 canal de signalisation : E1.
  • E1 = TS16.
  • SOLIDES TOTAUX 24 T1=.
TDM5 Croix-se connectent :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Clear-channel :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Trame-expédition :
  • signalisation HDLC-encadrée.
  • Canaux de signalisation = channels-group configurables par contrôleur.
VoATM6 Clear-channel :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Trame-expédition :
  • signalisation HDLC-encadrée.
  • Seulement 1 canal de signalisation.
Clear-channel :
  • Tout type de signalisation CCS.
  • Un certain nombre de canaux de signalisation.
Trame-expédition :
  • signalisation HDLC-encadrée.
  • Canaux de signalisation = channels-group configurables par contrôleur.

1. Vox = Voix au-dessus de X

2. VoIP = voix sur ip

3. Vofr = Voix au-dessus de Relais de trames

4. HDLC = contrôle de liaison de données de haut niveau

5. TDM = multiplexage temporel

6. VoATM = Voix au-dessus d'atmosphère

Trame-expédition T-CCS

le Trame-expédition T-CCS peut seulement être utilisé pour prendre en charge des protocoles propriétaire PBX où le canal ou les canaux de signalisation HDLC-sont encadrés, et la technologie désirée de Vox est vofr ou VoATM. Dans cette solution, les trames de signalisation HDLC sont encapsulées et expédiées par un groupe de canaux qui est configuré pour la signalisation sur le contrôleur, et sont traitées ainsi comme interface série. Le tramage HDLC est interprété et compris, bien que les messages de signalisation ne soient pas. Des trames de veille sont supprimées, et seulement de vraies données sont propagées à travers le canal de signalisation.

Trame-expédition T-CCS de mise en place

Mise en garde : Limite CSCdt55871

Il y a une limite en cours sur le nombre de canaux vocaux utilisables en configurant le trame-expédition TCCS sur l'E1. La limite se produit en raison d'un conflit entre ds0-group et plages numériques de channnel-groupe, comme est expliqué dans CSCdt55871 (clients enregistrés seulement).

Essayer de configurer un groupe ds0 qui est +1 précédemment du groupe de canaux d'entrée a comme conséquence la panne, comme affiché ci-dessous.

!
 controller t1 2/1 
 channel-group 0 timeslot 24 speed 64 
 ds0-group 1 timeslots 1 type ext-sig

La configuration ci-dessus a comme conséquence un message d'erreur quand le groupe ds0 est défini, réclamant que le canal 0 est déjà utilisé, comme affiché ici :

%Channel 0 already used by other group

Le contournement est de manquer le groupe contradictoire, et continue le prochain nombre de groupe dans la plage. Ceci réduit le nombre de groupes configurables d'un.

Rendez-vous compte de ces points avant de mettre en application le trame-expédition T-CCS :

  • le Trame-expédition T-CCS doit seulement être configuré quand le protocole CCS à transporter utilise un type HDLC de tramage.

  • La commande de ccs-trame-expédition de mode définit le trame-expédition CCS.

  • Le DSO-groupe et les commandes de sig ext. déterminent quels ports vocaux doivent être créée et utilisée pour le joncteur réseau avec la signalisation de source externe.

  • La commande de jonction de connexion établit les canaux vocaux permanents.

  • L'ordre de channel-group définit le créneau horaire ou les créneaux horaires de trame-expédition.

  • le Trame-expédition T-CCS n'est pas pris en charge pour le VoIP.

  • Le TS16 sur l'E1 est toujours réservé pour le signalisation CAS (Channel Associated Signaling). Si vous configurez un autre créneau horaire pour CAS (comme dans l'exemple ci-dessus), vous avez alors un moins créneau horaire pour la Voix.

Un exemple de configuration pour le vofr T-CCS de Trame-expédition

La configuration et l'essai signalés dans cette section ont été réalisés sur une version du logiciel Cisco IOS courante 12.2.7a de routeur de Cisco 3640. L'exemple présenté ici représente une situation quand la signalisation n'est pas appliquée sur le créneau horaire normal (emplacement 16). Un autre créneau horaire est utilisé ici (emplacement 6) pour afficher la souplesse de la caractéristique (pas applicable sur le routeur de Cisco 3810).

/image/gif/paws/19087/trans_channel_signal1.gif

Étapes de configuration pour le côté de Voix

Pour configurer le côté de Voix, terminez-vous ces étapes :

  1. Sur le contrôleur de t1 ou d'E1 :

    1. Ajoutez la commande de trame-expédition de mode ccs.

    2. Définissez le channel-group pour chaque canal de signalisation (pour les gammes Cisco 26xx et 36xx seulement ; le routeur de Cisco 3810 crée automatiquement le canal D).

    3. Définissez les groupes ds0 pour chaque canal vocal, utilisant le type ext.-Sig.

      GTP1
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

      GTP2
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

  2. Sur l'interface de canal (cette interface série obtient créé après que l'ordre de channel-group soit configuré ci-dessus) :

    1. Ajoutez la commande de ccs encap frf11.

    2. Indiquez la Manche un ID de canal sur l'interface WAN franc à l'aide des ccs connectent la commande séquentielle x/y DLCI CID.

      Remarque: Un ID de canal distinct doit être utilisé pour chaque Manche si plus d'un canal de signalisation est exigé. Début avec l'ID de canal 254, et travail vers l'arrière.

      GTP1
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

      GTP2
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

  3. Sur les ports vocaux :

    Ajoutez la jonction de connexion xxx à chaque port vocal. Le nombre doit apparier le modèle de destination du port vocal de terminaison (homologue de numérotation POTS) de l'autre côté. Seulement un côté de la connexion devrait spécifier la « mode réponse. »

    GTP1
    !
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 6002
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 6003
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 6030
    !

    GTP2
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 8002 answer-mode
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 8003 answer-mode
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 8030 answer-mode

  4. Sur les homologues de numérotation POTS :

    1. Ajoutez un pair de cadran de vofr qui apparie le numéro composé par jonction de connexion, et indiquez-le l'identifiant de connexion de liaison de donnée par relais de trame (DLCI).

    2. Ajoutez un homologue de numérotation POTS à chaque port vocal qui apparie le numéro composé par les déclarations de la jonction de connexion xxx de l'autre côté.

      GTP1
      !
      dial-peer voice 8002 pots
       destination-pattern 8002
       port 3/0:2
      !
      dial-peer voice 8003 pots
       destination-pattern 8003
       port 3/0:3
      ! 
      ... [channels 4-30 the same] ...
      
      dial-peer voice 6000 vofr
       destination-pattern 6...
       session target Serial0/0 105
      !

      GTP2
      !
      dial-peer voice 6002 pots
       destination-pattern 6002
       port 3/0:2
      !
      dial-peer voice 6003 pots
       destination-pattern 6003
       port 3/0:3
      
      ... [channels 4-30 the same] ... 
      !
       dial-peer voice 8000 vofr
       destination-pattern 8...
       session target Serial1/0 105
      !

Étapes de configuration pour le côté WAN

Pour configurer le côté WAN, terminez-vous ces étapes :

  1. Définissez une interface série de Relais de trames, et une sous-interface point par point avec le vofr normal.

  2. Mettez dans la Voix-bande passante basée sur le nombre de canaux et de codecs utilisés pour la Voix.

  3. Permettez la bande passante supplémentaire dans le débit de données garanti (CIR) pour le canal de signalisation et d'autres données qui partagent ce DLCI.

    GTP1
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay traffic-shaping
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.105.2 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay bc 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

    GTP2
    !
    interface Serial1/0
     no ip address
     encapsulation frame-relay
     clock rate 768000
     frame-relay traffic-shaping
     frame-relay intf-type dce
    !
    interface Serial1/0.1 point-to-point
     ip address 10.10.105.1 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay BC 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

Bande passante

La bande passante provisioned dans le circuit principal doit tenir compte de tous les canaux configurés de Voix et de signalisation. Puisque ces configurations utilisent la jonction de connexion, tous les canaux en résultant de Voix et de signalisation sont en hausse tout le temps. La détection d'activation de Voix (VAD) fournit l'épargne sur les canaux vocaux actifs (bien que pas sur la signalisation), mais VAD ne devient pas active jusqu'à ce que les canaux vocaux soient établis. Ainsi la bande passante initiale requise par canal vocal devrait prendre en considération les codecs utilisés, plus l'en-tête au-dessus. Pour le vofr, seulement la bande passante des canaux vocaux devrait être expliquée dans la bande passante de Voix et des commandes LLQ. La bande passante des canaux de Voix et de signalisation devrait être expliquée sur l'interface de Franc-à-WAN.

Dépannez et vérifiez le Trame-expédition T-CCS

Les étapes suivantes aident à vérifier que le trame-expédition T-CSS fonctionne comme il faudrait.

  1. Le contrôleur d'E1 doit être pour que les ports vocaux aillent le hors fonction-crochet et trunked.

  2. Vérifiez si l'appel est en place, et si les processeurs de signaux numériques corrects (DSP) sont alloués sur des créneaux horaires.

  3. Si les appels ne se connectent pas, vérifiez la configuration ou la Connectivité d'état du circuit virtuel permanent (PVC), et la disposition de cadran-pair.

  4. Si la commande de show voice port affiche le « inactif » et le « raccroché » pour n'importe quel créneau horaire, vérifiez si le créneau horaire relatif a la version correcte DSP assignée, et fonctionnez correctement avec la commande de show voice dsp.

  5. Debug avec la commande de debug tccs signaling en mode de logging buffered (c'est très CPU intensive).

    gtp2#show controllers e1 3/0
    E1 3/0 is up. 
      Applique type is Channelized E1 - balanced
      No alarms detected.
      alarm-trigger is not set
      Version info Firmware: 20011015, FPGA: 15
      Framing is CRC4, Line Code is HDB3, Clock Source is Line.
      Data in current interval (276 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    
    gtp2#show voice dsp
     
    DSP  DSP            DSPWARE CURR  BOOT         VOICE       PAK     TX/RX
    TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT  PACK COUNT
    ==== === == ======= ======= ===== ===== === == ====== == ===== ============
    C549 000 01 g729ar8  3.4.49 busy  idle       0 3/0:18 18     0 119229/70248
    C549 000 00 g729ar8  3.4.49 busy  idle    0  0 3/0:2  02     0  41913/45414
    C549 001 01 g729ar8  3.4.49 busy  idle       0 3/0:19 19     0 119963/70535
    C549 001 00 g729ar8  3.4.49 busy  idle    0  0 3/0:3  03     0  42865/47341
    C549 002 01 g729ar8  3.4.49 busy  idle       0 3/0:20 20     0  77746/69876
    
    
    !--- This shows DSPs are being used.
    
    
    
    gtp2#show voice call summary
    
    PORT         CODEC    VAD VTSP STATE            VPM STATE
    =========   ======== === ============        ==============
    3/0:2.2       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:3.3       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:4.4       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:5.5       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:6.31      g729ar8  y  S_CONNECT             S_TRUNKED
    
    
    !--- This shows call connected.
    
    
    gtp2#show frame-relay pvc
    
    PVC Statistics for interface Serial1/0 (Frame Relay DCE)
    
                  Active     Inactive      Deleted       Static
      Local          1            0            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 105, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, 
    INTERFACE = Serial1/0.1
    
      input pkts 1201908       output pkts 2177352      in bytes 37341051  
      out bytes 71856239       dropped pkts 0           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 167       out bcast bytes 48597     
      PVC create time 08:37:30, last time PVC status changed 02:47:05
      Service type VoFR-cisco
    
    
    !--- This shows Frame Relay is active.
    
    
    
    gtp2#show frame-relay fragment 
    interface   dlci  frag-type   frag-size  in-frag  out-frag   dropped-frag
    Serial1/0.1 105   VoFR-cisco  640        172      169        0    
    
    
    debug tccs signaling
    
    Log Buffer (8096 bytes):
    
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  282 tccs packets received from the nework.
    08:55:47: RX from Serial3/0:0:
    08:55:47: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:47: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 01 49 F3 69 00 0C 42 00 
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  283 tccs packets received from the nework.
    08:55:47: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:47: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 03 EA DF 0D 00 0C 42 00 
    08:55:50:  282 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
    08:55:50: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:50: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 03 EA DF 0D 00 62 05 00 
    08:55:50:  283 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
              08:55:50: RX from Serial3/0:0:
    08:55:50: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:50: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 01 49 F3 69 00 62 05 00 
    gtp2# wr t
    
    
    !--- This shows packet forwarding and receiving.
    
    

Codecs T-CCS de clear-channel

La Manche T-CCS est utilisée pour prendre en charge des protocoles propriétaire PBX où les canaux de signalisation sont ABCD-bit basé ou HDLC, ou où la technologie de transport de Voix est VoIP. Dans cette solution, le canal et les canaux vocaux de signalisation sont configurés comme ds0groups, et tous sont traités comme communications voix.

Les vraies communications voix sont de manière permanente les connexions de jonction connectées utilisant les codecs de Voix de votre choix. Les canaux de signalisation sont les joncteurs réseau de manière permanente connectés également utilisant le codec de clear-channel, qui est semblable à G.711 dans des longueurs de paquet d'échantillon et, mais excluent automatiquement l'annulation d'écho et le VAD. Il n'y a aucune intelligence en logiciel de savoir quels canaux sont des canaux vocaux, et ce qui sont des canaux de signalisation. Vous devez configurer les créneaux horaires que vous connaissez portez le trafic de signalisation pour apparier un pair de cadran qui assigne les codecs de clear-channel, alors que les canaux vocaux doivent apparier un pair de cadran qui encode la Voix (G.729, et d'autres).

Codecs T-CCS de clear-channel de mise en place

Rendez-vous compte de ces points avant que vous implémentiez le clear-channel T-CCS :

  • Clear-channel T-CCS un être utilisé pour tout type d'E1 numérique ou de signalisation T1 (tramage HDLC HDLC y compris).

  • Un certain nombre de canaux de signalisation peuvent être pris en charge.

  • Le clear-channel T-CCS peut être utilisé dans des environnements VoIP, de vofr ou de VoATM

  • Le codec de clear-channel est utilisé pour le canal ou les canaux de signalisation dans le clear-channel T-CCS.

  • VoIP — La bande passante de signalisation et de Voix doit être expliquée dans l'IP RTP Priority ou le Fonction Low Latency Queuing (LLQ).

  • VoIPovFR/vofr — La signalisation et la Voix peuvent être sur la même chose ou séparer des DLCI.

  • Vofr — La signalisation de la bande passante est comptée en tant qu'élément du vofr « bande passante de Voix. »

  • Avec le clear-channel T-CCS, la signalisation prend 64K de bande passante dédiée (pas comprenant le temps système de paquet).

  • L'ordre de DSO-groupe configure des canaux de Voix et de signalisation.

  • Le logiciel de Cisco IOS ne se rend pas compte du qui le canal de signalisation est en service.

  • Trente et un DSP sont exigés pour un PBX utilisant la signalisation sur le créneau horaire 16 avec 30 ports vocaux, ainsi deux joncteurs réseau sur l'E1 2MFT épuiseraient la quantité de DSP sur NMV2 (62 sont exigés).

En employant des codecs de clear-channel pour transporter le trafic de données, il est important que la synchronisation de réseau soit synchronisée. C'est parce que l'algorithme DSP relâche des paquets quand les dépassements de capacité de mémoire tampon se produisent, et utilise son algorithme d'automatique-remplissage quand les underruns de mémoire tampon se produisent (correct pour le trafic vocal, mais non bon pour le trafic de données). Chacun des deux situations sont susceptibles de faire échouer et redémarrer le canal D.

Exemple de configuration pour le clear-channel VoIP T-CCS

La configuration et l'essai du clear-channel VoIP T-CCS ont été réalisés sur une version du logiciel Cisco IOS courante 12.2.7a de routeur de Cisco 3640. Dans l'exemple présenté ici, la signalisation n'est pas appliquée sur le créneau horaire normal (16). Un autre créneau horaire est utilisé ici (créneau horaire 6) pour afficher la souplesse de la caractéristique.

/image/gif/paws/19087/trans_channel_signal2.gif

  1. Sur le contrôleur de t1 ou d'E1 :

    Définissez les groupes ds0 pour chaque canal vocal et canal de signalisation.

    GTP1
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

    GTP2
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
    
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

  2. Sur les ports vocaux :

    1. Ajoutez une commande de la jonction de connexion xxx à chaque configuration de port vocal. Le nombre doit apparier le modèle de destination du port vocal de terminaison (homologue de numérotation POTS) de l'autre côté.

    2. Ajoutez une commande de la jonction de connexion xxx à chaque configuration de port vocal de signalisation — le nombre doit apparier le modèle de destination du port vocal de terminaison (homologue de numérotation POTS) de l'autre côté.

    3. Seulement un côté de la connexion devrait spécifier la mode réponse.

      GTP1
      voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 3001
      !
      voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 6001
      ! 
      ... [channels 2-30 the same] ...
      !
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 6030

      GTP2
      !
       voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 5001 answer-mode
      !
       voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 8001 answer-mode
      !
      ... [channels 2-30 the same] ...
      
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 8030 answer-mode

  3. Sur les pairs de cadran :

    1. Ajoutez un pair de cadran VoIP qui apparie le nombre composé par jonction de connexion de canaux vocaux. Indiquez-le l'adresse IP du côté distant ; assignez (ou par défaut) les codecs désirés de Voix sur ce pair de cadran.

    2. Ajoutez un pair de cadran VoIP qui apparie le nombre composé par jonction de connexion de canaux de signalisation. Indiquez-le l'adresse IP du côté distant ; assignez les codecs de clear-channel sur ce pair de cadran.

    3. Ajoutez les homologues de numérotation POTS à chaque port vocal qui apparient le numéro composé par les déclarations de jonction de connexion de l'autre côté.

      GTP1
      dial-peer voice 8001 pots
       destination-pattern 8001
       port 3/0:1
      !
      
      
      !--- Pots dial peers 8001 --- 8030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns and ports. These are 
      !--- associated with the voice channels.
      
      
      dial-peer voice 8030 pots
       destination-pattern 8030
       port 3/0:30
      !
      dial-peer voice 5001 pots
       destination-pattern 5001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated with 
      !--- the port connected to the local PBX 
      !--- signaling channel.
      
      
      ! 
      dial-peer voice 6000 voip
       destination-pattern 6...
       session target ipv4:10.10.105.1
      !
      dial-peer voice 3001 voip
       answer-address 5001
       destination-pattern 3001
       session target ipv4:10.10.105.1
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated 
      !--- with the destination pattern that 
      !--- connects to the remote PBX signaling 
      !--- channel port.
      
      

      GTP2
      !
      dial-peer voice 6001 pots
       destination-pattern 6001
       port 3/0:1
      !
      
      
      !--- POTS dial peers 6001 --- 6030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns, and ports. 
      !--- These are associated with the 
      !--- voice channels.
      
      
      dial-peer voice 6030 pots
       destination-pattern 6030
       port 3/0:30
      ! 
      dial-peer voice 3001 pots
       destination-pattern 3001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated 
      !--- with the port connected to the local PBX 
      !--- signaling channel.
      
      
      !
      dial-peer voice 8000 voip
       destination-pattern 8...
       session target ipv4:10.10.105.2
      !
      dial-peer voice 5001 voip
       answer-address 3001
       destination-pattern 5001
       session target ipv4:10.10.105.2
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated with 
      !--- the destination pattern that connects 
      !--- to the remote PBX signaling channel port.
      
      

Étapes de configuration pour le côté WAN

Pour configurer le côté WAN, terminez-vous ces étapes :

Mettez dans une commande d'IP RTP Priority ou la bande passante LLQ basée sur ce qui suit :

  • Le nombre de canaux vocaux, et les codecs utilisés pour des signaux vocaux.

  • Le nombre de canaux de signalisation s'est multiplié par 80K (traité car vous traiteriez G.711).

GTP1
interface Multilink1
 bandwidth 512
 ip address 10.10.105.2 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!
interface Serial0/0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1

GTP2
interface Multilink1
 bandwidth 512
 ip address 10.10.105.1 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!!
interface Serial1/0
 no ip address
 encapsulation ppp
 no fair-queue
 clock rate 512000
 ppp multilink
 multilink-group 1

Dépannez et vérifiez le clear-channel T-CCS

Ces étapes aident à vérifier que le clear-channel T-CSS fonctionne comme il faudrait :

  1. Le contrôleur d'E1 doit être pour que les ports vocaux aillent le hors fonction-crochet et trunked.

  2. Assurez-vous que les appels de contrôle sont en place, et les DSP corrects sont alloués sur des créneaux horaires.

  3. Si les appels ne se connectent pas, vérifiez la configuration IP et la Connectivité, et la disposition de pair de cadran.

  4. Si l'IP est restauré après qu'une panne d'interface ou de lien, le contrôleur doive faire fermer le shut/no la commande émise sur son interface, ou le routeur doit être rechargée pour apporter des connexions de jonction sauvegardent.

  5. Si les expositions de commande de show voice port tournent au ralenti et raccroché pour n'importe quel créneau horaire, vérifiez que le créneau horaire relatif a la version correcte DSP assignée, et qu'il fonctionne correctement avec la commande de show voice dsp, comme affiché ci-dessous.

gtp#show voice dsp

DSP  DSP            DSPWARE CURR  BOOT         VOICE      PAK       TX/RX
TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT    PACK COUNT
==== === == ======= ======= ===== ===== === == ====== == =====   ============
C549 000 02 g729r8   3.4.49 busy  idle       0 3/0:25    25      0     264/2771
C549 000 01 g729r8   3.4.49 busy  idle       0 3/0:12    12      0     264/2825
C549 000 00 clear-ch 3.4.49 busy  idle    0  0 3/0:0     06      0 158036/16069


!--- The above identifies that the clear codec is used for timeslot 6.
!--- Ensure that clear codec is applied correctly against the correct timeslot.
                                                                     


gtp1#show voice port sum

PORT   CH SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
====== == ========== ===== ==== ======== ======== ==
3/0:0  6     ext     up    up   trunked  trunked  y
3/0:1  1     ext     up    up   trunked  trunked  y
3/0:2  2     ext     up    up   trunked  trunked  y
3/0:3  3     ext     up    up   trunked  trunked  y


!--- This shows that the voice port used for signaling is off-hook and trunked.
 


gtp1#show voice call sum
PORT         CODEC    VAD VTSP STATE            VPM STATE
============ ======== === ============        =============
3/0:0.6       clear-ch y  S_CONNECT             S_TRUNKED
3/0:1.1       g729r8   y  S_CONNECT             S_TRUNKED
3/0:2.2       g729r8   y  S_CONNECT             S_TRUNKED
3/0:3.3       g729r8   y  S_CONNECT             S_TRUNKED
3/0:4.4       g729r8   y  S_CONNECT             S_TRUNKED
3/0:5.5       g729r8   y  S_CONNECT             S_TRUNKED
3/0:6.31      g729r8   y  S_CONNECT             S_TRUNKED
3/0:7.7       g729r8   y  S_CONNECT             S_TRUNKED


!--- This shows a signaling call in progress.

RTP d'enable signalant sur AS5350 et AS5400

Afin d'empêcher des erreurs provoquées par des paquets de RTP de la charge utile tapez « 123" sur des Plateformes de gammes Cisco AS5350 et AS5400, traitement des signaux de RTP est désactivé par défaut. Sous quelques circonstances, les paquets de ce type peuvent entraîner une erreur d'adresse mémoire non valide dans des Plateformes de gammes AS5350 et AS5400, tombant en panne potentiellement les périphériques.

Sur ces modèles, vous pouvez activer le traitement du signal de RTP utilisant la commande de configuration masquée par enable de Voix-rtp-signalisation de Voix-fastpath. Cependant, avant que vous activiez le traitement du signal de RTP, préparez la plate-forme pour manipuler des paquets de RTP du type de charge utile « 123" en activant T-CCS.

Après que vous prépariez la plate-forme, vous pouvez employer ces commandes afin d'activer ou désactiver le traitement du signal de RTP.

  • Afin d'activer le traitement du signal de RTP, utilisez cette commande :

    Router(config)#voice-fastpath voice-rtp-signalling enable
    
  • Afin de désactiver le traitement du signal de RTP, utilisez cette commande :

    Router(config)#no voice-fastpath voice-rtp-signalling enable
    

Comment tester T-CCS (Trame-expédition et clear-channel) sans PBX

Dans certaines situations il peut être irréaliste de vérifier la configuration de T-CCS avec des PBX. Cette section décrit une méthode qui implique la substitution des PBX des Routeurs, pour tester que la signalisation peut être transportée. Puisque la structure de trame utilisée dans le PPP est semblable à cela utilisée par la signalisation message message (telle que CCS), vous pouvez utiliser des Routeurs configurés pour que le PPP teste que le canal de signalisation fonctionne. Ceci peut être utile dans les situations où le déploiement de T-CCS a manqué, et rendre résistant plus loin est nécessaire que le canal de signalisation fonctionne. (Dans le trame-expédition T-CCS là est met au point les informations disponibles affichant la transmission et la réception des trames. Dans le clear-channel T-CCS, aucun temps réel ne mettent au point les informations est disponible.)

Configurez le contrôleur d'E1 des Routeurs pour le canal de signalisation du choix. Cet exemple utilise le créneau horaire 6, à la voie de raccordement aux tests ci-dessus. Configurez le PPP sur l'interface série résultante pour représenter le trafic de signalisation.

trans_channel_signal3.gif

Routeur 1
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp

Routeur 2
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp

Sortie typique avec des paquets de debug ppp
1d00h: Se0:0 LCP: Received id 1, sent id 1, line up
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: O ECHOREP [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0x0207, datagramsize 305
1d00h: Se0:0 LCP: O ECHOREQ [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREP [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: Received id 2, sent id 2, line up

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 19087