IP : Protocole EIGPR (Enhanced Interior Gateway Routing Protocol)

Empêche les doublons d'ID de routeur EIGRP

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Les id en double de routeur de Protocole EIGPR (Enhanced Interior Gateway Routing Protocol) peuvent poser des problèmes avec la redistribution des artères externes EIGRP. Ce document explique le problème et fournit la configuration correcte pour l'empêcher.

L'ID de routeur EIGRP est normalement sélectionné de la même manière que le Protocole OSPF (Open Shortest Path First). L'adresse IP la plus élevée assignée à une interface de bouclage est sélectionnée comme ID de routeur. S'il n'y a pas aucune adresse de bouclage configurée, l'adresse IP la plus élevée assignée à n'importe quelle autre interface est choisie comme ID de routeur.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée utilisant la version de logiciel 12.2(10b) de Ý de Cisco IOS.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Problème

Le problème qui est produit avec les artères redistribuées dues à la présence des Routeurs avec des id en double de routeur EIGRP peut être compris avec l'aide de cette configuration réseau.

Diagramme du réseau

eigrp-dup-id.jpg

Configurations

Routeur 4
interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 10.10.10.10 255.255.255.0

!

interface Ethernet0

 ip address 172.16.3.4 255.255.255.0

!

router rip

 version 2

 network 10.0.0.0

 network 172.16.0.0

Routeur 3
interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0

 ip address 172.16.3.3 255.255.255.0

 ip pim sparse-dense-mode

!

interface Serial1

 ip address 172.16.13.3 255.255.255.0

 clockrate 4000000

!

router eigrp 7

 redistribute rip metric 1 1 1 1 1

 network 172.16.0.0

!

router rip

 version 2

 network 172.16.0.0

Routeur 1
interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1

 ip address 172.16.13.1 255.255.255.0

 no ip mroute-cache

!

router eigrp 7

 network 172.16.0.0

 auto-summary

 no eigrp log-neighbor-changes

Commandes show

Comme précédemment affiché, redistribue Routeur3 des artères de Protocole RIP (Routing Information Protocol) dans l'EIGRP. C'est la table de routage 3 et table de topologie EIGRP.

Router-3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
R    10.0.0.0/8 [120/1] via 172.16.3.4, 00:00:25, Ethernet0 
!--- Router 3 sees network 10.0.0.0.

     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
C       172.16.3.0 is directly connected, Ethernet0
router-3#


router-3#show ip eigrp topology 10.0.0.0 255.0.0.0
IP-EIGRP (AS 7): topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
  Routing Descriptor Blocks:
  0.0.0.0, from Redistributed, Send flag is 0x0
      Composite metric is (2560000256/0), Route is External
      Vector metric:
        Minimum bandwidth is 1 Kbit
        Total delay is 10 microseconds
        Reliability is 1/255
        Load is 1/255
        Minimum MTU is 1
        Hop count is 0
      External data:
        Originating router is 2.2.2.2 (this system)
!--- Shows that Router 3 is the originating router of the external route.

        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)
router-3#

De la sortie précédente, vous pouvez voir qui Routeur3 s'est renseigné sur le réseau 10.0.0.0 par l'intermédiaire du RIP. Par la redistribution, l'artère a été entrée dans la table de topologie EIGRP comme artère externe. Prouve Routeur3 également que c'est le routeur d'origine de l'artère externe ; son ID de routeur EIGRP est 2.2.2.2.

Puisque semble Routeur3 redistribuer l'artère externe, on s'attend à ce qu'elle la voie dans la table de routage du routeur 1. C'est l'affichage de la table de routage et de la table de topologie EIGRP pour le routeur 1.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:31:59, Serial1
router-1#


router-1# show ip eigrp topology
IP-EIGRP Topology Table for AS(7)/ID(2.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.13.0/24, 1 successors, FD is 2169856
         via Connected, Serial1
P 172.16.3.0/24, 1 successors, FD is 2195456
         via 172.16.13.3 (2195456/281600), Serial1
router-1#

De la sortie précédente vous pouvez voir que l'artère prévue de 10.0.0.0/8 n'est pas dans la table de routage ou la table de topologie EIGRP du routeur 1. La raison probable pour ceci est que les Routeurs 1 et 3 ont le même ID de routeur EIGRP. Dans le Logiciel Cisco IOS version 12.0(2) et plus tard, Cisco enregistre les id en double de routeur dans le journal d'événements EIGRP, que vous pouvez visualiser avec la commande d'événements de show ip eigrp. C'est la sortie de ceci pour le routeur 1 :

router-1 #show ip eigrp events 
Event information for AS 7:
1    18:06:15.863 Change queue emptied, entries: 1
2    18:06:15.863 Ignored route, metric: 10.0.0.0 2560512256
3    18:06:15.863 Ignored route, neighbor info: 172.16.13.3 Serial2
4    18:06:15.863 Ignored route, dup router: 2.2.2.2


!--- Output suppressed.

De la sortie précédente vous pouvez voir que l'ID de routeur en double est la raison pour laquelle le routeur 1 ne reçoit pas l'artère de Routeur3.

Solution

La solution est de changer l'ID de routeur sur un des Routeurs en changeant l'adresse IP la plus élevée sur l'interface de bouclage. Si vous Logiciel Cisco IOS version 12.1(6) d'ause ou plus tard, vous pouvez également employer la sous-commande du routeur de <router-id> d'eigrp router-id afin de changer l'ID de routeur. Dans cet exemple, nous avons changé l'ID de routeur dans le routeur 1.

router-1(config)#router eigrp 7 
router-1(config-router)#eigrp router-id 3.3.3.3

Remarque: Eigrp d'IP de question < commande clairs d'Autonomous System après que vous changiez l'ID de routeur d'Eigrp.

L'artère externe apparaît maintenant dans la table de routage comme affiché ici.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, IA - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:00:00, Serial1
D EX 10.0.0.0/8 [170/2560512256] via 172.16.13.3, 00:00:00, Serial1
router-1# 

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 18685