Qualité de service (QoS) : Réglementation QoS

Configuration du marquage de paquet sur PVC de relais de trame

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 avril 2015) | Commentaires


Contenu


Introduction

Ce document passe en revue les commandes prises en charge de configurer le marquage de paquets au-dessus des interfaces de Relais de trames.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel ou de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Marquage de paquets basé sur classe

le marquage de paquets basé sur classe utilise des commandes set et d'autres commandes de l'interface de ligne de commande de qualité de service modulaire (QoS) (CLI) de changer la valeur d'un champ dans une en-tête de paquet.

Les versions logicielles en cours de ½ du ¿  de Cisco IOSï te permettent pour faire ces actions :

  • Placez les bits de Priorité IP ou le point de code de Différenciation de services IP (DSCP) dans l'octet de type de service IP (tos).

  • Placez la valeur de Classe de service (Cos) de la couche 2.

  • Associez une valeur de groupe locale de QoS avec un paquet.

  • Changez la configuration de bit de priorité de perte cellule (CLP) dans l'en-tête ATM d'un paquet de 0 à 1.

Les deux stratégies d'entrée et sortie sont prises en charge. Quand vous configurez la Fonction Class-based Marking, notez ces restrictions :

  • Les stratégies de sortie exigent le Formatage du trafic de relais de trames (FRTS).

  • Seulement des paquets Expédition-commutés exprès de Cisco sont pris en charge.

  • Une carte de stratégie qui contient la commande de set atm-clp peut être reliée comme stratégie de sortie seulement.

C'est un exemple de la façon dont la valeur DSCP est placée :

Exemple de configuration - Fonction Class-based Marking
class-map user1
  match access-group 101
!
class-map user2
  match access-group 102
!
policy-map dscp
  class user1
    set ip dscp AF11
  class user2
    set ip dscp AF12
!
map-class frame set-dscp
  service-policy input dscp
!
int s0/0/0:0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
int s0/0/0:0.125
 frame-relay interface-dlci 125
  class set-dscp

Établissement du bit d'éligible pour suppression

Le QoS modulaire CLI prend en charge deux commandes de changer la valeur de l'éligible pour suppression (De) mordu dans une trame de Relais de trames. Ces commandes sont set fr-de avec la formation basée sur classe, et positionnement-frde-transmettent par le maintien de l'ordre basé sur classe.

Remarque: La commande de positionnement-frde-transmission n'applique pas au Relais de trames le trafic non transporté par l'intermédiaire d'aucun transport au-dessus de MPLS (atome).

Prises en charge du relais de trame un schéma de hiérarchisation à deux niveaux de paquet utilisant DE bit. Initialement, seulement les périphériques de réseau, tels que des Commutateurs de Relais de trames, ont placé DE bit pour indiquer l'importance relative d'une trame. Dans des versions logicielles récentes de Cisco IOS, les Routeurs maintenant peuvent placer DE bit.

Le prochain diagramme montre le format d'une trame de Relais de trames. DE bit est l'un de trois bits qui contrôlent les mécanismes de notification d'encombrement de Relais de trames.

/image/gif/paws/18662/config_fr_pvc.gif

Émettez ces commandes de surveiller la Fonction Class-based Marking :

  • interface-nom de show policy-map interface — Affiche la configuration et les statistiques de toutes les classes configurées pour toutes les stratégies de service sur l'interface spécifiée.

  • show frame-relay pvc [dlci-nombre] — Affiche des statistiques pour tous les composants du circuit virtuel permanent (PVC). Ceci inclut ces des statistiques :

    • FRTS et informations de stratégie de service

    • fragmentation

    • le nombre de paquets dedans et

    • le nombre de trames avec la notification d'encombrement explicite arrière (BECN), la notification explicite d'encombrement au destinataire (FECN), et le positionnement de DE bits

Exemple de configuration - Apparier sur DE Bit
class-map match-fr-de
  match fr-de

!--- Define a class-map named “match-fr-de” to match packets with the FR DE bit set.

!
policy-map set-de
  class match-fr-de
   set ip precedence 1

!--- All packets that match the class have IP precedence set to 1.

!
map-class frame-relay pvc150
   service-policy input set-DE

!--- Apply the policy map to the map class.

!
interface Serial0.1 point-to-point
   frame-relay class pvc150
   frame-relay interface-dlci 150

!--- Associate a map class to the Frame Relay data-link connection identifier (DLCI).

Router# show policy-map interface s0.1

Serial0.1

 Service-policy input: set-prec

   Class-map: match-fr-de (match-all)
     358 packets, 103820 bytes
     30 second offered rate 18000 bps, drop rate 0 BPS  Match: fr-de
     QoS Set
       ip precedence  1
         Packets marked 359

   Class-map: class-default (match-any)
     643 packets, 186470 bytes
     30 second offered rate 32000 BPS, drop rate 0 BPS
     Match: any  (1201)

Le Logiciel Cisco IOS version 12.2(2)T a introduit le support pour placer DE bit avec l'option de positionnement-frde-transmission en tant qu'élément de l'ordre de police. (Le pour en savoir plus, se rapportent à la Réglementation du trafic.) Il peut également être utile de placer DE bit une fois utilisé avec des mécanismes de limitation de débit, comme le maintien de l'ordre basé sur classe. L'objectif d'une telle stratégie QoS est de transmettre les paquets non conformes avec le Relais de trames et le positionnement de DE bit, de sorte que les Commutateurs en aval puissent potentiellement relâcher tout le trafic non conforme pendant les états d'encombrement.

Remarque: Bien que le maintien de l'ordre basé sur classe prenne en charge le marquage de paquets, il est recommandé que vous utilisez cette caractéristique seulement si vous devez marquer des paquets pour éviter de les exécuter par le mécanisme du seau à jetons du régulateur.

Le prochain exemple de configuration utilise l'ordre de police de limiter l'ensemble du trafic à 800 Kbps. Tout le trafic qui se conforme est transmis par une Priorité IP de 7, et tout le trafic non conforme a DE bit réglé.

Exemple de configuration - Établissement de DE Bit
policy-map set-DE
  class class-default
   police 800000 1000 1000 conform-action
   set-prec-transmit 7 exceed-action set-frde-transmit
   violate-action set-frde-transmit
!
map-class frame-relay pvc100
  frame-relay traffic-rate 1000000
  frame-relay mincir 1000000
  service-policy input set-DE
!
interface S0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point
  ip address 10.1.1.1 255.255.255.252
  no ip directed-broadcast
  frame-relay class pvc100
  frame-relay interface-dlci 100

router# show policy-map set-DE

 Policy Map set-DE
    Class class-default
      police 800000 1000 1000 conform-action
      set-prec-transmit 7 exceed-action
      set-frde-transmit violate-action
      set-frde-transmit

router# show frame-relay PVC 100

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1

input pkts 0       output pkts 13000    in bytes 0
out bytes 3770000  dropped pkts 0       in FECN pkts 0
in BECN pkts 0     out FECN pkts 0      out BECN pkts 0
in DE pkts 0       out DE pkts 4447
out bcast pkts 0   out bcast bytes 0
PVC create time 00:51:50, last time PVC status changed 00:51:50

service policy set-DE

  Service-policy output: set-DE (1069)

   Class-map: class-default (match-any) (1071/2)
     11519 packets, 3340510 bytes
     30 second offered rate 1140000 BPS, drop rate 0bps
      Match: ip precedence 1  (1075)
      police:
        800000 BPS, 1000 limit, 1000 extended limit
        conformed 4448 packets, 1289920 bytes; action:
        set-prec-transmit 7
        exceeded 11 packets, 3190 bytes; action:
        set-frde-transmit
        violated 8475 packets, 2457750 bytes; action:
        set-frde-transmit
        conformed 394000 BPS, exceed 1000 BPS violate
        749000 BPS
   Output queue size 20/max total 600/drops 1451

Quand vous testez votre configuration, notez ces informations :

  • La Fonction Class-based Marking exige Cisco Express Forwarding. Émettez la commande d'ip cef en mode de configuration globale, d'activer Cisco Express Forwarding, s'il n'est pas déjà activé.

  • Initialement, la Fonction Class-based Marking s'est appliquée seulement aux paquets qui étaient exprès de Cisco Expédition-commutés. Ainsi, vous ne verriez pas incrémenter les compteurs appariés de paquet si vous aviez l'habitude le ping pour générer le trafic sur le même routeur, parce que de tels paquets sont commutés par processus.

  • Le soutien de la Fonction Class-based Marking des paquets routeur-générés est introduit dans la version du logiciel Cisco IOS 12.2(6.8)T.

Choisissant où appliquer une stratégie de service

Sur la gamme Cisco 7200, la gamme Cisco 2600/3600, et d'autres Plateformes du processeur de non-artère/commutateur (RSP), une stratégie de service doit être appliquées dans un map-class ; il ne peut pas être appliqué directement au PVC de Relais de trames. Les stratégies de sortie exigent FRTS, que vous activez avec la commande de frame-relay traffic-shaping. Cette commande configure des files d'attente PVC. Ainsi, une stratégie de service généralement devrait être configurée en mode de configuration de DLCI ou dans le PVC.

Dans des versions logicielles en cours de Cisco IOS, les interfaces de Relais de trames prennent en charge l'application d'une carte de stratégie (avec la commande de service-stratégie) aux interfaces, aux sous-interfaces, et au VCs. Ce tableau présente les combinaisons prises en charge des stratégies :

Politique d'entrée Stratégie de sortie
Pris en charge sur une interface logique. Pris en charge sur les plusieurs interfaces logiques qui doivent être des pairs, tels que plusieurs PVCs.

Remarque: Une interface principale et une sous-interface ne sont pas des interfaces homologues et ne peuvent pas prendre en charge une stratégie de service en même temps.

Pris en charge sur un ou deux interfaces logiques simultanément. Combinaisons valides :
  • PVC et interface principale
  • Sous-interface et interface principale
Combinaisons non valides :
  • PVC et sous-interface
  • PVC, sous-interface, et interface principale

Initialement, la configuration d'une stratégie de service avec la commande set directement sur une interface principale n'a pas marqué le trafic de sous-interface. Ceci illustre des symptômes de ce problème :

Interface Serial5/1:1
no ip address
 encapsulation frame-relay
 no keepalive
 service-policy output set

!--- Avoid the placement of a service policy on a main interface.

 no fair-queue
 frame-relay class data-map
 frame-relay traffic-shaping
!
interface Serial5/1:1.1 point-to-point
 ip address 23.0.0.2 255.0.0.0
 frame-relay interface-dlci 300

giulia# show policy-map interface

 Serial5/1:1

  Service-policy output: set

    Class-map: prec-0 (match-all)
      100 packets, 10400 bytes

!--- Packets are classified correctly.

      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip precedence 0
      QoS Set
        ip precedence 1
          Packets marked 0

!--- No packets are marked.


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any

Comme contournement, appliquez-vous la stratégie de service à la sous-interface.

Syntaxe existante - DE Lists

Dans des versions logicielles de Cisco IOS qui ne prennent en charge pas la nouvelle syntaxe modulaire de Cisco QoS CLI, vous pouvez employer la syntaxe de Cisco legacy DE marking pour placer DE bit. La syntaxe existante utilise les listes De qui identifient les caractéristiques des paquets pour être habilitées à l'écart, et vous pouvez également spécifier DE groups pour identifier le DLCI qui est affecté.

Router(config)# frame-relay de-list list-number 
              {protocol protocol | interface typenumber} characteristic


!--- Issue this command on one line.

Vous pouvez créer des listes De basées sur le protocole ou sur l'interface, et basées sur de diverses caractéristiques telles que la fragmentation du paquet, d'un port spécifique de la Transmission Control Protocol (TPC) ou du Protocole UDP (User Datagram Protocol), un nombre de listes d'accès, ou une longueur de paquet. Référez-vous à la commande de frame-relay de-list dans la référence de commandes de réseau d'étendu de Cisco IOS pour de plus amples informations.

Pour définir DE group qui spécifie la liste De et le DLCI affectés, émettez la commande de dlci de groupe-nombre de frame-relay de-group dans le mode de configuration d'interface.


Informations connexes


Document ID: 18662