Qualité de service (QoS) : Réglementation QoS

Configuration CBWFQ sur circuits virtuels permanent (PVC) de relais de trame

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 avril 2015) | Commentaires


Contenu


Introduction

Ce document fournit des configurations d'échantillon pour configurer le Mise en file d'attente pondérée basée sur les classes (CBWFQ) sur une interface de Relais de trames. CBWFQ est activé avec la commande bandwidth, comme configuré dans un policy-map avec les commandes de la qualité de service modulaire d'interface de ligne de commande (QoS CLI).

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

CBWFQ est pris en charge en date des versions logicielles suivantes de Cisco IOSÝ selon la plate-forme :

  • Gamme Cisco 7500 avec des Versatiles Interfaces Processor (VIP) (CBWFQ distribué) - 12.1(5)T

  • Gamme Cisco 7200, gamme 2600/3600, et d'autres Plateformes de la gamme non-7500 - 12.1(2)T

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Formation et queue

S'alignant est généralement utilisé dans le cadre de la formation, qui réduit le débit sortant et induit ainsi l'encombrement. Utilisez CBWFQ avec les mécanismes de mise en forme et les commandes suivants selon votre plate-forme.

  Gamme Cisco 7500 Cisco 7200, 3600, 2600 et d'autres Plateformes de Non-VIP
Mécanismes de mise en forme pris en charge Formatage du trafic distribué (dTS) Formatage du trafic de relais de trames (TS en relais de trame)
Commande de configuration commande de forme dans un policy-map frame-relay traffic-shaping sur une interface principale, commandes de configuration de map class de spécifier des paramètres de mise en forme
Exige Cisco Express Forwarding distribué (le dCEF) Oui (vérifiez avec la commande de show cef linecard) Non

Cisco 7200, 3600, gamme 2600

Le Cisco IOS 12.1(2)T introduit le soutien de CBWFQ sur les 7200, 2600/3600, et d'autres Plateformes du processeur de commutateur de non-artère (RSP). (Le pour en savoir plus, se rapportent à la basse latence s'alignant (LLQ) au-dessus du Relais de trames.) Sur ces Plateformes, CBWFQ sur des interfaces de Relais de trames est toujours dans le cadre de TS en relais de trame. Utilisez la commande de frame-relay traffic-shaping d'activer le TS en relais de trame. Vous ne pouvez pas utiliser CBWFQ avec le Formatage du trafic générique (GTS) et la commande de forme sur ces Plateformes. Une configuration d'échantillon est fournie ci-dessous.

Configuration d'échantillon de CBWFQ sur le Cisco 7200, 3600, gamme 2600
 policy-map mypolicy 
  class voice 
   priority 16 
  class priority-data 
   bandwidth 16 

!--- Create a policy-map and apply the bandwidth 
!--- command to a class. 

! 
 int s0/0 
  encapsulation frame-relay IETF 
  load-interval 30 
  frame-relay traffic-shaping 

!--- Enable Frame Relay TS. 

! 
 interface Serial0/0.1 point-to-point 
  frame-relay interface-dlci 100 
    class frclass 

!--- Apply the map-class to the Frame Relay PVC. 

! 
 map-class frame-relay frclass 
  service-policy output mypolicy 
  frame-relay cir 64000 
  frame-relay bc 640 

!--- Apply the service policy inside the map-class.

Remarque: Si vous activez une stratégie de service directement sur une interface principale et pas dans une commande de map-class, vous ne pouvez pas également appliquer le TS en relais de trame directement à l'interface. Il est important de noter que les mécanismes de mise en file d'attente puis s'appliquent à une grande file d'attente d'interface simple plutôt qu'aux files d'attente par-virtuelles de circuit (circuit virtuel)

Dans la gamme Cisco 7200, de la version de logiciel 12.0(26)S de Cisco IOS et plus tard, il n'est pas possible de configurer une stratégie de service de sortie dans une commande de classe de mappage de relais de trame plus. Au lieu de cela la configuration de Cisco 7500 devrait être appliquée comme expliqué dans la section suivante. Un policy-map hiérarchique devrait être configuré avec la formation dans une stratégie de parent et la queue dans une stratégie enfant. La stratégie de parent devrait alors être reliée à la canalisation ou à la sous-interface. Si vous essayez de configurer une stratégie de service sortie dans la commande de map-class frame-relay, le message d'erreur suivant apparaîtra :

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Gamme Cisco 7500

En date du Cisco IOS 12.1(5)T, les stratégies QoS doivent fonctionner dans le mode distribué sur le VIP ; parce que le QoS basé sur RSP n'est plus pris en charge. Ainsi, vous devez utiliser la commande de forme et d'autres commandes du QoS modulaire CLI de mettre en application DTS pour des interfaces de Relais de trames sur des VIPs sur la gamme Cisco 7500. Cartel GTS DTS et TS en relais de trame. Une configuration d'échantillon est fournie en configurant le trafic distribué formant et ci-dessous.

Configuration d'échantillon de DTS avec une politique hiérarchique
ip cef distributed 
 !  
 class-map 1  
   match < >  

!--- Define match-on criteria.

 class-map 2  
   match < >

!--- Define match-on criteria.

 !  
 policy-map CBWFQ  
   class 1  
     bandwidth < >  
     !-- Define value in kbps or percent.  
   class 2  
     priority < > 
 
!--- Define value in kbps or percent.

 !  
 Policy-map SHAPE  
    class class-default  
     shape average    
     service-policy CBWFQ  
 !  
 int s0/0/0  
   encapsulation frame-relay  
   ip route-cache distributed  
 !  
 int s0/0/0.1 point-to-point  
   ip address a.b.c.d  
   frame-relay interface-dlci xxx  
    class cisco  
 !  
 map-class frame-relay cisco  
   service-policy output SHAPE

Choisissant où appliquer une stratégie de service

En configurant CBWFQ, vous utilisez les commandes du QoS modulaire CLI de créer un policy-map du trafic avec des plusieurs classes de trafic et un ou plusieurs configurations de QoS. Dans des versions en cours de Cisco IOS logiciel, les interfaces de Relais de trames prennent en charge appliquer un policy-map avec la commande de service-stratégie aux interfaces, aux sous-interfaces, et au VCs. Seulement les combinaisons correctes des stratégies sont maintenant prises en charge. Le tableau suivant décrit spécifiquement où vous pouvez appliquer une stratégie QoS avec la formation du trafic.

  Gamme Cisco 7500 Cisco 7200, gamme 2600/3600, et d'autres Plateformes
Interface principale Configurez une stratégie de service sur l'interface principale Pris en charge seulement si le TS en relais de trame n'est pas activé et les mécanismes de mise en file d'attente appliquent à un canal d'interface unique.
Sous-interface Configurez un servicepolicy sur la sous-interface. Configurez une stratégie de service dans une classe de mappage de relais de trame et activez le par-circuit virtuel s'alignant avec la commande de frame-relay traffic-shaping. Vous pouvez appliquer le map-class à la sous-interface.
Niveau de circuit virtuel   Configurez une service-stratégie dans une classe de mappage de relais de trame et activez le par-circuit virtuel s'alignant avec la commande de frame-relay traffic-shaping. Vous pouvez appliquer le map-class au circuit virtuel.

Problèmes identifiés

En configurant CBWFQ sur des interfaces de Relais de trames, notez les mises en garde suivantes :

  • Après qu'un routeur soit rechargé, les compteurs de correspondance de paquet d'une stratégie de service peuvent ne pas incrémenter quand la stratégie est appliquée à l'interface principale. Ce problème est résolu en s'assurant que les indicateurs de classification de la mise en file d'attente pondérée (WFQ) sont copiés de l'interface principale sur les sous-interfaces.

  • Configurer LLQ et TS en relais de trame simultanément au niveau d'interface physique n'est pas pris en charge. Le routeur enlève la stratégie de service de la configuration en cours après un routeur rechargé. La stratégie de service doit être reliée au map-class quand le TS en relais de trame est activé sur l'interface. Tenter pour configurer cette combinaison a comme conséquence le message d'erreur CBWFQ : Non pris en charge sur cette interface.

  • Quand une stratégie de service avec CBWFQ est appliquée directement à une interface principale de relais de trame (comme, non au par-circuit virtuel s'alignant), la stratégie peut être enlevée après un routeur rechargé si des instructions de bande passante sont configurées sur une sous-interface et une interface principale. Le routeur peut signaler des messages de log semblables à ce qui suit :

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps) 
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    Ce problème est résolu en changeant le comportement de CBWFQ pour ignorer les notifications quand la bande passante à la sous-interface est changée, puisque CBWFQ peut être configuré en dehors d'une classe de mappage de relais de trame seulement au niveau d'interface principale. Comme contournement, enlevez la commande bandwidth de la sous-interface. Si vous employez la bande passante sur la sous-interface pour influencer la mesure de routage, utilisez une approche alternative comme le coût, comme dans le Protocole OSPF (Open Shortest Path First) ou le retard, comme dans le Protocole EIGPR (Enhanced Interior Gateway Routing Protocol).

Notes de configuration

  • Quand les commandes de bande passante et prioritaires calculent la bande passante totale disponible sur une entité, les instructions suivantes sont appelées quand l'entité est un circuit virtuel permanent en relais de trame formé (PVC) :

    • Si un débit minimum de données garanti acceptable (minCIR) n'est pas configuré, le CIR est divisé par deux.

    • Si un minCIR est configuré, le paramétrage de minCIR est utilisé dans le calcul.

    • La bande passante complète du débit ci-dessus peut être allouée aux classes de bande passante et prioritaires. Ainsi, la commande de max-reserved-bandwidth n'est pas prise en charge sur le PVC en relais de trame, bien que vous devriez prendre le soin de s'assurer que la quantité de bande passante configurée est assez grande pour faciliter également la couche 2 (L2) supplémentaire. Le pour en savoir plus, se rapportent quels octets sont comptés par la queue de classe de service IP à ATM ?.

  • Évitez de placer le CIR ou le minCIR au débit d'accès. Autrement, vous pouvez voir des files d'attente de sortie accumulant et entraînant de grands retards dans des classes CBWFQ. La raison est que le débit de forme ne prend pas en considération les octets supplémentaires de l'indicateur et des champs de contrôle de redondance cyclique (CRC), ainsi la formation à la ligne débit réellement oversubscribing et entraînera la congestion d'interface. Il n'y a vraiment aucune raison de former au débit d'accès. Vous devriez toujours trafiquer la forme à 95 pour cent du débit d'accès ou, plus généralement, le débit formé par agrégat devrait toujours être de 95 pour cent au-dessous du débit d'accès.

  • Quand le FRF.12 est configuré, la taille de la file d'attente de sortie augmente pour faciliter le même nombre d'octets qui sont maintenant fragmentés. En d'autres termes, vous allez d'une file d'attente de paquet à une file d'attente de fragment.

  • WFQ par circuit virtuel est inclus dans la version de logiciel 12.0(7)T de Cisco IOS.

  • CBWFQ avec GTS est inclus dans la version de logiciel 12.1(2)T de Cisco IOS.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 18661