Qualité de service (QoS) : Réglementation QoS

Mise en forme du trafic de relais de trame avec QoS distribué sur Cisco 7500

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (23 avril 2015) | Commentaires


Contenu


Introduction

Ce document clarifie les différences entre l'application du trafic formant aux interfaces de Relais de trames sur le Routeurs de la gamme Cisco 7500 avec des Versatiles Interfaces Processor (VIPs) et sur d'autres Plateformes. Les autres Plateformes incluent le Cisco 7200, 3600, et des Routeurs de gamme 2600.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

En date de la version de logiciel 12.1(5)T de Cisco IOSÝ, les stratégies de Qualité de service (QoS) doivent fonctionner dans le mode distribué sur le VIP ; Le processeur de commutation routage (RSP) QoS basé sur n'est plus pris en charge. Ainsi, vous devez employer la commande de forme et d'autres commandes de l'interface de ligne de commande modulaire de QoS (MQC) afin de mettre en application le Formatage du trafic distribué (dTS) pour des interfaces de Relais de trames sur des VIPs sur la gamme Cisco 7500. DTS combine le Formatage du trafic générique (GTS) et le Formatage du trafic de relais de trames (TS en relais de trame). Référez-vous à configurer le trafic distribué formant pour une configuration d'échantillon.

Cette table clarifie comment configurer le TS en relais de trame, qui dépend de la plate-forme :

Gamme 7500 7200, 3600, 2600 et d'autres Plateformes de Non-VIP
Mécanismes de mise en forme pris en charge DTS TS en relais de trame
Commande de configuration commande de forme dans une carte de stratégie frame-relay traffic-shaping sur une interface principale ; commandes de configuration de map class de spécifier des paramètres de mise en forme
Exige le dCEF1 Oui (vérifiez avec la commande de show cef linecard.) Non

1 dCEF = Cisco Express Forwarding distribué

Remarque: Sur la gamme Cisco 7500, la capacité de configurer le TS en relais de trame par l'intermédiaire de la commande de frame-relay traffic-shaping est maintenant bloquée parce que le TS en relais de trame exécute seulement le RSP en mode nondistributed. Avec le dCEF et le TS en relais de trame, une contiguïté de « coup de volée » de CEF fait jeûner le RSP le commutateur tous les paquets, qui est suboptimal pour la représentation maximum d'expédition.

Étapes de configuration

Employez ces étapes pour configurer DTS sur les interfaces basées sur VIP de Relais de trames :

  1. DCEF d'enable avec cette commande :

    router(config)# ip cef distributed
    
  2. Assurez-vous que l'interface de Relais de trames est activée pour la commutation distribuée.

    router(config-if)# interface serial 8/0/0 
    router(config-if)# ip route-cache distributed
    
    router# show ip interface serial 8/0/0 
    Serial8/0/0 is up, line protocol is up 
      Internet address is 24.0.0.2/24 
      Broadcast address is 255.255.255.255 
     
    !--- Output suppressed.
     
      ICMP redirects are always sent 
      ICMP unreachables are always sent 
      ICMP mask replies are never sent 
      IP fast switching is enabled 
      IP fast switching on the same interface is disabled 
      IP Flow switching is disabled 
      IP CEF switching is enabled 
      IP Distributed switching is enabled 
      IP Fast switching turbo vector 
      IP CEF switching with tag imposition turbo vector 
      IP multicast fast switching is enabled 
      IP multicast distributed fast switching is disabled 
      IP route-cache flags are Fast, Distributed, CEF 
      Router Discovery is disabled 
      IP output packet accounting is disabled
  3. Créez une stratégie de service et appliquez-vous l'à la classe de carte.

    Vous pouvez implémenter une de ces stratégies :

    Remarque: Tandis que le Logiciel Cisco IOS version 12.1(2)T introduisait le soutien du bas temps d'attente s'alignant (LLQ) sur des Plateformes autres que la gamme Cisco 7500, le LLQ distribué (dLLQ) a été introduit dans le Logiciel Cisco IOS version 12.1(5)T sur le VIP. La version distribuée améliore la représentation de cette caractéristique. Vous pouvez configurer une seule stratégie de service par identificateur de connexion de liaison de données (DLCI). Vous n'avez pas besoin d'utiliser une classe de carte. Vous pouvez s'appliquer la commande de service-stratégie directement à la sous-interface ou au DLCI. Cependant, configurez le dLLQ à l'intérieur d'une classe de carte.

  4. Vérifiez la mise en oeuvre correcte de votre stratégie de service avec ces commandes :

    • show policy-map interface

    • affichez la forme d'interface

    • affichez le VIP plein-qos

    Configuration d'échantillon de DTS avec une politique hiérarchique
    ip cef distributed 
    ! 
    class-map 1 
      match <> 
      
    !--- Define match-on criteria.
     
    class-map 2 
      match <> 
      
    !--- Define match-on criteria.
     
    ! 
    policy-map CBWFQ 
      class 1 
        bandwidth <>  
        
    !--- Define the value in kbps or percent.
     
      class 2 
        priority <>  
        
    !--- Define the value in kbps or percent.
     
    ! 
    policy-map SHAPE 
       class class-default 
        shape average   
        service-policy CBWFQ 
    ! 
    int s0/0 
      encapsulation frame-relay 
      ip route-cache distributed 
    
    !--- Do not configure frame-relay traffic-shaping.
    
    ! 
    int s0/0.1 point-to-point 
      ip address a.b.c.d 
      frame-relay interface-dlci xxx 
       class cisco 
    ! 
    map-class frame-relay cisco 
      service-policy output SHAPE

FRF.12 et DTS

Le Logiciel Cisco IOS version 12.1(5)T a introduit une version distribuée de fragmentation de relais de trame, FRF.12. Quand vous vous appliquez le FRF.12 distribué à une interface de Relais de trames, vous devez définir une classe de carte et appliquer la stratégie de service sous la classe de carte. Si vous tentez de configurer une classe de carte avec la stratégie de service appliquée directement à l'interface, votre routeur signale ce message d'erreur avec le logging console activé :

Frame Relay fragmentation works with dTS only. 
Please remove traffic-shaping from the interface serial 1/0/0

La configuration dans cette section et les commandes de vérification de configuration ont été testées sur un routeur de gamme Cisco 7500 qui exécute la version du logiciel Cisco IOS 12.2(5)T sur un RSP 8.

Remarque: Référez-vous au VoIP sur frame relay avec la qualité de service (fragmentation, trafic formant, LLQ/IP RTP Priority) pour plus d'informations sur la sélection des valeurs de fragmentation.

Configuration d'échantillon de DTS et de FRF.12
interface Ethernet4/1/3 
 ip address 10.122.3.206 255.255.255.0 
! 
interface Serial5/0/0:0 
 no ip address 
 encapsulation frame-relay 
 load-interval 30 
 no fair-queue 

!--- Do not configure frame-relay traffic-shaping.

! 
interface Serial5/0/0:0.1 point-to-point 
 ip address 10.1.1.2 255.255.255.0 
 frame-relay interface-dlci 16  
 class test 
 frame-relay ip rtp header-compression 
! 
map-class frame-relay test 
 no frame-relay adaptive-shaping 
 service-policy output llq-shape 
 frame-relay fragment 120 

!--- Apply the frame-relay fragment command to the  
!--- Frame Relay map class.

 access-list 101 permit udp any range 16384 32767 any  range 16384 32767

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120  

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120 

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

Problème connu

Si vous utilisez toujours la version du logiciel Cisco IOS 12.1E, l'interface de VIP qui est configurée avec l'Encapsulation de relais de trames peut tomber en panne avec une erreur sur le bus. Ce crash se produit si vous appliquez une stratégie de service tandis que les passages d'interface trafiquent. Le contournement est d'arrêter tout le trafic de fond avant que vous mettiez à jour la stratégie de service. Ou vous pouvez améliorer à Logiciel Cisco IOS version 12.2 ou à plus tard.

Le pour en savoir plus, se rapportent à la page d'outils Cisco et de ressources.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 18660