Commutation LAN : Routage et mise en parallèle intégrés (IRB)

Présentation et configuration du routage et du pontage VLAN sur un routeur à l'aide de la fonction IRB

16 janvier 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (31 décembre 2015) | Commentaires


Contenu


Introduction

Ce document décrit la progression des VLAN pendant qu'ils sont mis en application avec un routeur, autrement dit l'IP de routage, l'IP de pontage et l'IP de pontage avec IRB (Integrated Routing and Bridging). En outre, ce document fournit un exemple de configuration de la fonctionnalité IRB sur un routeur.

Remarque: IRB a été délibérément désactivé sur les commutateurs de la gamme Catalyst 6500 et les routeurs de la gamme Cisco 7600. Pour plus d'informations, référez-vous à la section Limitations et restrictions générales sous Notes de publication relatives à Cisco IOS Version 12.1 E sur le moteur de superviseur et la MSFC Catalyst 6000 et Cisco 7600.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Informations générales

Pour qu'un VLAN s'étende sur un routeur, le routeur doit être capable de transférer des trames d'une interface à une autre, tout en maintenant l'en-tête VLAN. Si le routeur est configuré pour le routage d'un protocole de couche 3 (couche réseau), il met fin aux couches VLAN et MAC sur l'interface sur laquelle une trame arrive. L'en-tête de couche MAC peut être maintenu si le routeur effectue un pontage sur le protocole de couche réseau. Cependant, un pontage régulier met toujours fin à l'en-tête VLAN. Utilisant la caractéristique IRB dans la version 11.2 de Ý de Cisco IOS ou plus grand, un routeur peut être configuré pour conduire et jeter un pont sur le même protocole de couche réseau relatif à la même interface. Cela permet de maintenir un en-tête VLAN sur une trame pendant le transfert d'un routeur d'une interface à une autre. IRB fournit la capacité de routage entre un domaine ponté et un domaine routé avec BVI (Bridge Group Virtual Interface). BVI est une interface virtuelle dans le routeur qui agit comme une interface routée normale qui ne prend pas en charge le pontage, mais représente le groupe de pontage comparable aux interfaces routées dans le routeur. Le numéro d'interface de BVI est le numéro du groupe de pontage que l'interface virtuelle représente. Le numéro est le lien entre le BVI et le groupe de pontage.

Quand vous configurez et activez le routage sur le BVI, les paquets qui entrent sur une interface routée, qui sont destinés à un hôte sur un segment dans un groupe de pontage, sont routés vers le BVI. Du BVI, le paquet est expédié au moteur de pontage, qui le transmet par une interface pontée. Ce transfert est effectué selon l'adresse MAC de destination. De même, les paquets qui entrent sur une interface pontée, mais sont destinés à un hôte sur un réseau routé, vont d'abord au BVI. Ensuite, le BVI transfère les paquets au moteur de routage avant de les sortir de l'interface routée. Sur une interface physique simple, IRB peut être créé avec deux sous-interfaces VLAN (balisage 802.1Q) ; une sous-interface VLAN a une adresse IP qui est utilisée pour le routage et l'autre sous-interface VLAN effectue le pontage entre la sous-interface utilisée pour le routage et l'autre interface physique sur le routeur.

Puisque le BVI représente un groupe de pontage en tant qu'interface routée, il doit être configuré seulement avec des caractéristiques de la couche 3 (L3), telles que les adresses de couche réseau. De même, les interfaces configurées pour le pontage d'un protocole ne doivent pas être configurées avec des caractéristiques L3.

Concept de pontage et routage VLAN avec IRB

Dans la figure I, les PC A et B sont connectés aux VLAN qui sont à leur tour séparés par un routeur. Ceci illustre l'idée fausse commune qu'un VLAN simple peut avoir une connexion basée sur un routeur au milieu.

/image/gif/paws/17054/router_vlan1.gif

Cette figure illustre également le flux des trois couches d'en-têtes pour une trame traversant les liens du PC A au PC B.

Alors que la trame passe par le commutateur, l'en-tête VLAN est appliqué parce que la connexion est une liaison de jonction. Il peut y avoir plusieurs VLAN communiquant sur la jonction.

Le routeur met fin à la couche VLAN et la couche MAC. Il examine l'adresse IP de destination et transfère la trame en conséquence. Dans ce cas, la trame IP doit être transférée hors du port vers le PC B. C'est également une jonction VLAN et un en-tête VLAN est donc appliqué.

Bien que le VLAN qui connecte le commutateur 2 au routeur puisse être appelé au même numéro que le VLAN qui connecte le commutateur 1 au routeur, ce n'est en réalité pas le même VLAN. L'en-tête VLAN initial est retiré quand arrive la trame sur le routeur. Un nouvel en-tête peut être appliqué quand la trame quitte le routeur. Ce nouvel en-tête peut inclure le même numéro VLAN qui a été utilisé dans l'en-tête VLAN qui a été éliminé à l'arrivée de la trame. Ceci est expliqué par le fait que la trame IP s'est déplacée dans le routeur sans en-tête VLAN attaché et a été transférée selon le contenu du champ de l'adresse de destination IP, et pas selon un champ ID VLAN.

Puisque les deux jonctions VLAN se trouvent sur les côtés opposés du routeur, elles doivent être des sous-réseaux IP différents.

Pour que les deux PC aient la même adresse de sous-réseau, le routeur devra être un IP de pontage sur ses interfaces. Cependant, le fait d'avoir les périphériques sur des VLAN qui partagent un sous-réseau commun ne signifie pas qu'ils sont sur le même VLAN.

La figure II illustre l'aspect de la topologie VLAN.

/image/gif/paws/17054/router_vlan2.gif

La nécessité de réadresser des stations d'extrémité IP pendant les mouvements peut être évitée par un IP de pontage sur certaines ou toutes les interfaces dans le routeur qui se connecte aux VLAN. Cependant, ceci élimine tous les avantages de la création de réseaux basés sur un routeur pour contrôler des diffusions au niveau de la couche réseau. La figure III montre quelles modifications se produisent quand le routeur est configuré pour l'IP de pontage. La figure IV montre ce qui se produit quand le routeur est configuré pour l'IP de pontage avec IRB.

La figure III montre que le routeur est maintenant un IP de pontage. Les deux PC sont maintenant sur le même sous-réseau.

Remarque: Le routeur (pont) transfère maintenant l'en-tête de couche MAC vers l'interface liée à l'extérieur. Le routeur met toujours fin à l'en-tête VLAN et applique un nouvel en-tête avant d'envoyer la trame vers le PC B.

/image/gif/paws/17054/router_vlan3.gif

La figure IV montre ce qui se produit quand IRB est configuré. Le VLAN s'étend maintenant sur le routeur et l'en-tête VLAN est maintenu pendant que la trame transite sur le routeur.

/image/gif/paws/17054/router_vlan4.gif

Exemple de configuration IRB

Cette configuration est un exemple d'IRB. La configuration permet un IP de pontage entre deux interfaces Ethernet et un IP de routage à partir d'interfaces pontées à l'aide d'un BVI. Dans le diagramme de réseau suivant, quand PC_A essaye d'entrer en contact avec PC_B, le routeur R1 détecte que l'adresse IP de destination (PC_B) est dans le même sous-réseau et les paquets sont donc pontés par le routeur R1 entre l'interface E0 et E1. Quand PC_A ou PC_B tente d'entrer en contact avec PC_C, le routeur R1 détecte que l'adresse IP de destination (PC_C) est dans un sous-réseau différent et le paquet est routé en utilisant le BVI. De cette façon, le protocole IP est ponté aussi bien que routé sur le même routeur.

Diagramme du réseau

router_vlan5.gif

Configuration

Exemple de configuration
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
no ip domain-lookup
bridge irb

!-- This command enables the IRB feature on this router.

!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E0 is in bridge-group 1.

!
Interface Ethernet1
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E1 is in bridge-group 1.

!
Interface Serial0
ip address 10.10.20.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BVI1
ip address 10.10.10.1 255.255.255.0

!-- An ip address is assigned to the logical BVI for routing


!-- IP between bridged interfaces and routed interfaces.

no ip directed-broadcast
!
ip classless
ip route 10.10.30.0 255.255.255.0 10.10.20.2
!
bridge 1 protocol ieee

!-- This command enables the bridging on this router.

bridge 1 route ip

!-- This command enable bridging as well routing for IP protocol.

!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Sorties de la commande show

show interfaces [interface] irb

Cette commande affiche les protocoles qui peuvent être routés ou pontés pour l'interface spécifiée, comme suit :

R1#show interface e0 irb

Ethernet0

Routed protocols on Ethernet0:
ip
    
Bridged protocols on Ethernet0:
ip         ipx

!-- IP protocol is routed as well as bridged.


Software MAC address filter on Ethernet0
 Hash Len    Address      Matches  Act      Type
 0x00:  0 ffff.ffff.ffff     0     RCV  Physical broadcast
 0x2A:  0 0900.2b01.0001     0     RCV  DEC spanning tree
 0x9E:  0 0000.0c3a.5092     0     RCV  Interface MAC address
 0x9E:  1 0000.0c3a.5092     0     RCV  Bridge-group Virtual Interface
 0xC0:  0 0100.0ccc.cccc    157    RCV  CDP
 0xC2:  0 0180.c200.0000     0     RCV  IEEE spanning tree
 0xC2:  1 0180.c200.0000     0     RCV  IBM spanning tree
R1#

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 17054