Commutation LAN : Liaison inter-commutateurs (ISL)

Configuration de jonctions ISL sur les routeurs Cisco

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (11 novembre 2015) | Commentaires


Contenu


Introduction

Ce document aborde la configuration des liaisons Inter-Switch Link (ISL) sur les routeurs externes Cisco tels que 7500/7000, 3600 et 4500, ou la gamme 2500. Ce document n'aborde pas la configuration des liaisons ISL pour les commutateurs de niveau 2 et 3 (L2/L3) tels que Cisco Catalyst 6500 ou 4500.

Pour les informations sur configurer l'ISL et les joncteurs réseau de 802.1Q entre les Commutateurs L2 et L3 de Catalyst qui exécutent le SYSTÈME D'EXPLOITATION de Catalyst (CatOS) ou le logiciel de ½ du ¿  de Cisco IOSïÂ, référez-vous à l'un ou l'autre de ces derniers :

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

  • Support ISL sur des Commutateurs de Catalyst

    Le support ISL est matériel-dépendant pour des Commutateurs de Catalyst. Quand vous connectez un routeur externe à un 4500/4000 commutateur du Catalyst 6500/6000, 5500/5000 ou, utilisez une de ces commandes de déterminer le support d'encapsulation par module :

    • CatOS — show port capabilities

    • Logiciel de Cisco IOS — show interfaces capabilities

  • Support ISL sur des Routeurs de Cisco

    Dans le Logiciel Cisco IOS version 11.2 et plus tard, seulement a plus le positionnement de caractéristique est nécessaire. L'ensemble de caractéristiques plus est IP Plus ou appareil de bureau plus. N'importe quelle interface de Fast Ethernet ou de Gigabit Ethernet sur les Routeurs prend en charge la jonction d'ISL VLAN.

    Dans le Logiciel Cisco IOS version 11.3 et plus tôt, seulement IP et Internetwork Packet Exchange (IPX) avec une encapsulation d'IEEE 802.3 (Novell-Ether) ont le support au-dessus de l'ISL. Le Logiciel Cisco IOS version 11.3 a ajouté des encapsulations et des protocoles additionnels.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Un VLAN est un domaine logique d'émission. Afin de permettre à des données pour traverser entre deux VLAN, ou pour annoncer des domaines, vous devez utiliser un périphérique L3 pour conduire entre les VLAN. Le modèle ouvert de System Interconnection de sept-couche (OSI) définit cette règle. L'un de ces périphériques peuvent accomplir ce routage :

  • Un routeur externe, tel que les 2500, les 4000, ou les 7000

  • Un routeur interne, tel qu'une carte de commutation multicouche (MSFC)

  • Un périphérique externe avec le logiciel de routage, comme un hôte UNIX qui fonctionne conduit ou déclenché

La méthode d'origine était de connecter un port physique différent sur le routeur à chaque VLAN individuel. Cette méthode devient très chère à mesure que le nombre de VLAN augmente. Mais il y a une meilleure méthode. Les administrateurs réseau peuvent décider d'utiliser la jonction VLAN pour assigner des VLAN multiples à une interface conduite simple à la place. Seulement les Routeurs avec 100 Mo ou les ports Ethernet plus rapides peuvent faire la jonction VLAN.

La jonction VLAN permet à 100 Mo Fast Ethernet ou à 1000 interfaces de Gigabit Ethernet de Mo pour placer une balise sur le paquet qui identifie le VLAN auquel le paquet appartient. Quand l'autre extrémité du joncteur réseau ISL reçoit ce paquet balisé, le joncteur réseau ISL place le paquet dans le VLAN correct. La balise ISL est une en-tête 30-byte qui est ajoutée autour de la trame de Fast Ethernet. Par conséquent, l'ISL est une technologie point par point et fonctionne seulement entre deux Commutateurs de Cisco ou Routeurs qui prennent en charge l'ISL sur les 100 Mo Fast Ethernet ou 1000 interfaces de Gigabit Ethernet de Mo.

Cette figure fournit une description visuelle des joncteurs réseau ISL :

/image/gif/paws/17051/24a.gif

Configurations

Procédez comme suit :

  1. Connectez le routeur au commutateur aux ports ISL-capables à l'utilisation des câbles appropriés.

    Utilisez la catégorie directe 5 ou les câbles à fibre optique.

  2. Assurez-vous que vous avez créé les VLAN du côté de commutateur de Catalyst et que vous avez configuré le port de commutateur pour être un port de joncteur réseau ISL.

    Remarque: Souvenez-vous que les Routeurs de Cisco ne peuvent pas négocier le Protocole DTP (Dynamic Trunking Protocol) ou les trames Interswitch dynamiques du protocole de communication (DISL). Par conséquent, vous devez configurer le mode de joncteur réseau pour être nonegotiate du côté de commutateur. Référez-vous le ½ du ¿  de toï le document configurant l'ISL et la jonction de 802.1Q entre un commutateur de CatOS et un routeur externe (routage d'InterVLAN) ou la section Informations connexes de ce document.

  3. Commencez à définir les VLAN sur le routeur.

    Assurez-vous que vous savez quelles informations L2 et L3 à configurer pour chaque VLAN. Ceci inclut l'adresse IP, le numéro de réseau IPX, et d'autres informations.

version 11.3
no service password-encryption
!
hostname lt-4500-static
!
enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.
!
no ip domain-lookup
appletalk routing
ipx routing 0000.0c0b.f2f5
!
!
interface FastEthernet0              

!--- Only Layer 1 is configured here.

 no ip address
 full-duplex             
!
interface FastEthernet0.1            

!--- All L2 and L3 are on subinterfaces.

 encapsulation isl 1                 

!--- This defines ISL encapsulation and the VLAN number.

 ip address 10.6.1.220 255.255.255.0
 no ip redirects           
 appletalk cable-range 100-100 100.149
 appletalk zone cisco
 ipx network ABC encapsulation SAP
!
interface FastEthernet0.2
 encapsulation isl 2
 ip address 10.7.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 200-200 200.135
 appletalk zone cisco1
 ipx network DEADBEEF encapsulation ARPA
!
interface FastEthernet0.3
 encapsulation isl 3
 ip address 10.8.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 300-300 300.69
 appletalk zone cisco2
 ipx network 1234 encapsulation SNAP
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Vous devez configurer la commande de vlan# d'encapsulation isl avant que vous configuriez n'importe quelles autres informations L2 ou L3. La sous-interface ne doit pas apparier le nombre d'ID DE VLAN. Cependant, une correspondance fait la gestion et la dépanne des questions VLAN plus faciles.

Vous devez employer des sous-interfaces pour éviter une violation de la règle de division de horizon. La règle fendue d'horizon interdit la publicité d'une artère par un routeur par une interface que le routeur lui-même utilise pour atteindre la destination. Cette approche est très semblable pour l'utiliser des sous-interfaces point par point avec le Relais de trames dans un environnement WAN.

Débuggez et dépannez

Une fois que vous avez vérifié que votre configuration, logiciel de Cisco IOS, et plate-forme matérielle sont corrects, vous devez vérifier que les choses fonctionnent correctement. Utilisez les commandes dans cette section de vérifier l'exécution et de dépanner des problèmes.

Remarque: Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • VLAN d'exposition — Cette commande t'indique quelles informations L2 ou L3 sont configurées pour chaque VLAN.

    lt-4500-static# show vlan
    Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.1       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.6.1.220                   0                   0
           IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
             AppleTalk           100.149                    0                  22
    Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.2       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.7.1.220                   0                   0
        IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
             AppleTalk           200.135                    0                  22
    Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.3       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.8.1.220                   0                   0
           IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
             AppleTalk           300.69                     0                  23
    
  • interface d'exposition — Cette commande indique te l'état de l'interface et des sous-interfaces, aussi bien qu'à la couleur VLAN des sous-interfaces. La couleur VLAN est identique que le nombre VLAN.

    lt-4500-static# show interface
    FastEthernet0 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:03, output hang never
      Last clearing of "show interface" counters 00:04:25
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         415 packets input, 25392 bytes, 0 no buffer
         Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         137 packets output, 12378 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    FastEthernet0.1 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.6.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.2 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.7.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.3 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.8.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 3.
      ARP type: ARPA, ARP Timeout 04:00:00
    
  • affichez {IP | IPX | artère d'AppleTalk} — cette commande t'indique que la sous-interface correcte ISL est apprenante ou envoyante les informations de routage.

    lt-4500-static# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route, o - ODR
    Gateway of last resort is not set
          10.0.0.0/24 is subnetted, 3 subnets
    C       10.8.1.0 is directly connected, FastEthernet0.3
    C       10.7.1.0 is directly connected, FastEthernet0.2
    C       10.6.1.0 is directly connected, FastEthernet0.1
    
    lt-4500-static# show appletalk route
    Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
           S - static  P - proxy 
    3 routes in internet
    The first zone listed for each entry is its default (primary) zone.
    C Net 100-100 directly connected, Fa0.1, zone cisco
    C Net 200-200 directly connected, Fa0.2, zone cisco1
    C Net 300-300 directly connected, Fa0.3, zone cisco2
    
    lt-4500-static# show ipx route
    Codes: C - Connected primary network,    c - Connected secondary network
           S - Static, F - Floating static, L - Local (internal), W - IPXWAN
           R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
           s - seconds, u - uses, U - Per-user static
    3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    No default route known.
    C        ABC (ISL vLAN),      Fa0.1
    C       1234 (ISL vLAN),      Fa0.3
    C   DEADBEEF (ISL vLAN),      Fa0.2
    
  • debug vlan packet — Cette commande t'indique s'il y a une mauvaise configuration des paquets sur le joncteur réseau ISL ou si la sous-interface fausse ISL est envoyante ou recevante les paquets.

    attention Attention : Faites attention toujours quand vous utilisez n'importe quelle commande de débogage. Les commandes de débogage peuvent entraîner les problèmes de performance graves sur le routeur. Pour désactiver l'élimination des imperfections, émettez la commande undebug all.

    lt-4500-static# debug vlan packet
    Virtual LAN packet information debugging is on
    lt-4500-static#
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
          on interface FastEthernet0.3 which is not configured to
          route or bridge this packet type.
    vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
          which has no subinterface configured to route or bridge ID 4.
    vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
          which has no subinterface configured to route or bridge ID 5.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.

Informations connexes


Document ID: 17051