Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Authentification et rappel RNIS avec ID d'appelant

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

L'authentification basée sur l'Identification de l'appelant fournit la sécurité accrue en authentifiant des clients distants basés non seulement sur l'user-id et le mot de passe, mais également sur l'emplacement de composition.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Ce document explique d'abord les différentes significations pour l'ordre de dialer caller (hormis son utilisation pour le rappel) une fois utilisé sur une interface de profil du numéroteur plutôt qu'une interface de groupe rotatif de routeurs d'appels.

Dans ce dernier cas, c'est une commande de filtrage analogue à l'appelant RNIS sur une interface RNIS. Dans le premier cas, c'est une commande qui fournit un mécanisme pour lier des appels entrant au profil du numéroteur correct basé sur le numéro de l'appelant qui est présenté dans le message de configuration Q.931 entrant. Le manque d'apparier la présentation du numéro avec un numéro de l'appelant sur un profil du numéroteur ne cause pas nécessairement l'appel d'être rejeté comme unbindable si l'interface physique est configurée pour l'authentification de PPP. Vous pouvez également apparier le nom d'hôte présenté avec la valeur configurée de dialer remote-name pour lier sur cette base. C'est parce que lier sur la base de la présentation du numéro n'est pas le seul critère possible pour un grippage réussi. Référez-vous en configurant et dépannage des Profils de composeur pour plus d'informations sur lier et Profils de composeur.

De la version de logiciel 12.0(7)T et ultérieures de ½ du ¿  de Cisco IOSïÂ, enlevez l'authentification de PPP de l'interface physique pour pouvoir examiner des appels seulement basés sur le numéro de l'appelant. En pareil cas, les appels pour laquelle le routeur ne peuvent pas trouver une valeur assortie de dialer caller sont rejetés comme unbindable. Vous pouvez utiliser le PAP ou le CHAP pour configurer l'authentification de PPP sur l'interface de numérotation si vous voulez authentifier correctement ces appels.

L'appel initial est rejeté (non répondu) avec l'option de rappel ajoutée à l'authentification de l'identification de l'appelant. Cependant, le rappel est initié au numéro d'appel pour établir le rapport. Vous pouvez utiliser le rappel pour :

  • Fusion et centralisation de la facturation téléphonique

  • Économie de coûts sur des appels interurbains

  • Contrôle d'accès

Cette configuration d'échantillon illustre l'utilisation de la commande de numéro de l'appelant [rappel] de configurer le filtrage d'Identification de l'appelant et d'activer sur option le Rappel d'identification de l'appelant ISDN pour le profil du numéroteur DDR. Vous pouvez également utiliser cette commande pour le DDR hérité. Cette commande configure le logiciel de Cisco IOS pour recevoir ou rejeter l'appel RNIS basé sur le nombre PSTN de l'appelant. Par exemple, la commande du dialer caller 1234 permet au routeur pour recevoir l'appel RNIS avec l'appel le numéro 1234.

Remarque: Cette configuration exige que les informations d'identification de l'appelant de passage de compagnie de téléphone au routeur ou au serveur d'accès. Aucun appel n'est reçu si vous activez le filtrage d'Identification de l'appelant mais n'a pas les informations d'identification de l'appelant étant passées au routeur.

Référez-vous à configurer le Rappel d'identification de l'appelant ISDN pour plus d'informations sur des conditions préalables et d'autres fonctionnalités facultatives disponibles avec l'authentification et le rappel d'ID d'appelant RNIS.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Remarque: Ces configurations sont tronquées pour afficher seulement les informations pertinentes.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/15925/ISDN_3Rt.gif

Configurations

Ce document utilise les configurations suivantes :

Dans ce scénario, les routeur 2 et 3 chacun des deux initient des appels DDR au routeur 1. que le routeur 1 authentifie les deux routeur 2 et 3 seulement basés sur le routeur 1 identification d'appelant est configurés pour appeler de retour le Router2, mais pour ne pas appeler de retour Routeur3.

Conseil : Choisissez les sections appropriées de la configuration pour configurer le filtrage d'Identification de l'appelant ou la caractéristique de rappel de l'identification de l'appelant, mais pas chacun des deux. Par exemple, le diagramme prouve que le rappel a besoin de configuration de routeur 2 et de routeur 1. Cependant, choisissez seulement la configuration de l'interface du numéroteur associée avec le Router2 (il est clairement marqué dans l'interface dialer 1) puisque le routeur 1 effectue les deux tâches.

Routeur 1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
isdn switch-type basic-net3
!
interface Loopback0
ip address 10.0.0.1 255.255.255.0
!
interface BRI0
no ip address
dialer pool-member 1

!--- BRI 0 is a member of dialer pool 1 which is defined 
!--- under interface Dialer 1.

isdn switch-type basic-net3
!
interface Dialer1

!---  DDR dialer interface to call Router 2.

description for Router2
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer enable-timeout 2

!--- The time (in seconds) to wait before initiating callback.

dialer string 6121  

!--- This number is used to call back Router 2.

dialer caller 6121 callback

!--- Permits calls from 6121 and initiates callback 
!--- to the same number.
 
dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
interface Dialer2

!--- This interface is used to authenticate calls from Router 3.
!--- (Callback is NOT initiated to Router 3.)

description for Router3
ip unnumbered Loopback0
encapsulation ppp
dialer pool 1

!--- Interface BRI 0 is a member of dialer pool 1.

dialer caller 6101

!--- Permit calls from number 6101.

dialer-group 1

!--- Use dialer-list 1 to define interesting traffic.

!
dialer-list 1 protocol ip permit

!--- Define IP as interesting traffic.

Routeur 2
version 12.1
service timestamps debug datetime msec
service timestamps log datetime ms
!
hostname Router2
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 6122

!--- The number to dial for Router 1 
!--- (which initiates a callback).

dialer caller 6122

!--- Accept calls from 6122 (Router 1).

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Routeur 3
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router3
!
isdn switch-type basic-net3
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
!
interface Dialer1
ip address 10.0.0.3 255.255.255.0
dialer pool 1
encapsulation ppp
dialer string 6122

!--- The number to dial for Router 1.

dialer-group 1
no cdp enable
!
dialer-list 1 protocol ip permit

Remarque: Le routeur client compose le serveur de rappel dans la plupart des scénarios de rappel. Les deux Routeurs négocient alors des paramètres de rappel. Le serveur déconnecte l'appel et initie le rappel. Le côté appelant pourrait placer peu d'appels sortants consécutifs au serveur tout en attendant le serveur pour appeler de retour pendant l'intervalle entre le débranchement d'appel initial et le rappel. C'est comportement normal DDR parce que le client détecte que l'appel initial a manqué et ne sait pas qu'un rappel est en cours.

Émettez la commande de dialer redial du côté appelant afin d'empêcher le client de composer constamment le serveur de rappel. Ceci supprime des appels sortants supplémentaires au serveur tout en attendant le rappel. Les appels sont supprimés jusqu'à ce que le temporisateur de prédéfinis expire. Par exemple, le client attend 15 secondes avant d'initier un rappel si la valeur de l'intervalle de renumérotation du routeur d'appels est de 15 secondes. Le rappel est terminé et le client ne doit pas composer de nouveau dans ce temps.

Référez-vous à configurer des temporisateurs de rappel après des tentatives de numérotation de rappel défaillante pour plus d'informations sur mettre en application le dialer redial.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Commandes show

Certaines commandes show sont prises en charge par l'OIT, qui te permet pour visualiser une analyse de sortie de commande show.

  • active de show isdn — L'affiche des informations sur des appels en cours et fournit des informations sur des appels entrants et sortants du courant le RNIS.

  • utilisateurs d'exposition — Affiche des informations au sujet des lignes actives sur le routeur. Vous pouvez également utiliser l'ordre de show caller si votre version de Cisco IOS le prend en charge.

  • show dialer — Affiche les informations générales de diagnostic pour des interfaces configurées pour le DDR.

Exemple de sortie avec show

Router1#show isdn active

---------------------------------------------------------------------------
ISDN ACTIVE CALLS
---------------------------------------------------------------------------
Call  Calling   Called    Remote  Seconds Seconds Seconds Charges
Type  Number    Number    Name    Used    Left    Idle    Units/Currency
---------------------------------------------------------------------------
Out              6121     6121       24      96      23      0
In       6101             6101        7     113       6
---------------------------------------------------------------------------

Notez qu'un entrant et un appel sortant est en cours. L'appel sortant est de numéro 6121, qui correspond au Router2. L'appel entrant est de 6101, qui correspond à Routeur3. Notez également qu'un nombre identifie les Routeurs distants dans la zone d'identification distante plutôt qu'un nom puisque l'authentification de PPP n'est pas configurée.

Router1#show user

Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
BR0:1                   Sync PPP             00:00:33   PPP: 10.0.0.2
BR0:2                   Sync PPP             00:00:15   PPP: 10.0.0.3
Interface  User      Mode                     Idle Peer Address

Notez qu'un canal B est utilisé pour se connecter au Router2 tandis que l'autre canal B se connecte au routeur 3. vérifient que les adresses IP apparient ceux configurés sur des routeur 2 et 3.

Dépannez

Utilisez cette section pour dépanner votre configuration.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • mettez au point le numéroteur [événements | paquets]

  • debug isdn event

  • debug isdn q931

  • debug ppp negotiation — Affiche des informations sur le trafic PPP et des échanges tout en négociant les composants de PPP comprenant le Link Control Protocol (LCP), l'authentification, et le protocole de contrôle de réseau (NCP). Une négociation PPP réussie d'abord ouvre l'état LCP, puis authentifie, et négocie finalement le NCP.

Référez-vous utilisant la commande d'état de show isdn pour le dépannage BRI si vous rencontrez des questions de couche inférieure RNIS.

Exemple de sortie de débogage

Router1#show debug
     Dial on demand: Dial on demand events debugging is on 
     PPP: PPP protocol negotiation debugging is on 
     ISDN: ISDN Q931 packets debugging is on

Cette section affiche la sortie de débogage du routeur 1 et affiche que le Router2 appelle le routeur 1. routeur 1 initie alors un rappel au Router2 et établit une connexion.

Remarque: Certaines de ces lignes de sortie de débogage sont divisées en plusieurs lignes pour des raisons d'impression.

*Mar  1 04:50:34.782: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0B
*Mar  1 04:50:34.790:         Bearer Capability i = 0x8890
*Mar  1 04:50:34.798:         Channel ID i = 0x89
*Mar  1 04:50:34.802:         Calling Party Number i = 0xA1, '6121
',Plan:ISDN, Type:National

!--- Calling party information is provided by the switch.

*Mar  1 04:50:34.818:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party information is provided by the switch.

*Mar  1 04:50:34.838: ISDN BR0: Event: Received a DATA call from 6121 on
   B1at 64 Kb/s
*Mar  1 04:50:34.842: BR0:1 DDR: Caller id 6121 matched to profile  

!--- The ISDN call (from Router 2) is authenticated.

*Mar  1 04:50:34.842: Di1 DDR: Caller id Callback server starting to  6121

!--- Initiates callback to 6121.
 
*Mar  1 04:50:34.866: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8B
*Mar  1 04:50:34.870:         Cause i = 0x8095 - Call rejected
*Mar  1 04:50:36.778: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0C
*Mar  1 04:50:36.786:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.794:         Channel ID i = 0x89
*Mar  1 04:50:36.798:         Calling Party Number i = 0xA1, '6121',Plan:ISDN,
   Type:National
*Mar  1 04:50:36.814:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)
*Mar  1 04:50:36.834: ISDN BR0: Event: Received a DATA call from 6121 on B1at
   64 Kb/s
*Mar  1 04:50:36.838: BR0:1 DDR: Caller id 6121 matched to profile
*Mar  1 04:50:36.838: Di1 DDR: callback to 6121 already started
*Mar  1 04:50:36.862: ISDN BR0: TX ->  RELEASE_COMP pd = 8  callref = 0x8C
*Mar  1 04:50:36.866:         Cause i = 0x8095 - Call rejected

!--- Reject call (then initiate callback).

*Mar  1 04:50:36.878: DDR: Callback timer expired

!--- The timer is configured with the dialer enable-timeout command.

*Mar  1 04:50:36.878: Di1 DDR: beginning callback to  6121
*Mar  1 04:50:36.882: BR0 DDR: rotor dialout [priority]
*Mar  1 04:50:36.882: BR0 DDR: Dialing cause Callback return call

!--- The dialing cause is callback.

*Mar  1 04:50:36.886: BR0 DDR: Attempting to dial 6121

!--- Dialing 6121 (Router 2).

*Mar  1 04:50:36.902: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0E
*Mar  1 04:50:36.906:         Bearer Capability i = 0x8890
*Mar  1 04:50:36.914:         Channel ID i = 0x83
*Mar  1 04:50:36.922:         Called Party Number i = 0x80, '6121',Plan:Unknown,
   Type:Unknown
*Mar  1 04:50:36.998: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8E
*Mar  1 04:50:37.002:         Channel ID i = 0x89
*Mar  1 04:50:37.402: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8E
*Mar  1 04:50:37.418: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0E
*Mar  1 04:50:37.426: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

!--- The interface is up.

*Mar  1 04:50:37.446: DDR: Freeing callback to  6121
*Mar  1 04:50:37.446: BRI0:1: interface must be fifo queue, force FIFO
*Mar  1 04:50:37.450: BR0:1 PPP: Phase is DOWN, Setup
*Mar  1 04:50:37.454: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.454: BR0:1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 04:50:37.462: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 04:50:37.462: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.466: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 04:50:37.478: BR0:1 PPP: Treating connection as a callout
*Mar  1 04:50:37.486: BR0:1 LCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.490: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.494: BR0:1 LCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.498: BR0:1 LCP:    MagicNumber 0x000F4499 (0x0506000F4499)
*Mar  1 04:50:37.502: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.506: BR0:1 LCP:    MagicNumber 0xE1288054 (0x0506E1288054)
*Mar  1 04:50:37.506: BR0:1 LCP: State is Open

!--- The LCP negotiation is complete.

*Mar  1 04:50:37.510: BR0:1 PPP: Phase is UP
*Mar  1 04:50:37.514: BR0:1 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:37.518: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:37.522: BR0:1 IPCP: I CONFREQ [REQsent] id 2 Len 10
*Mar  1 04:50:37.526: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.530: BR0:1 IPCP: O CONFACK [REQsent] id 2 Len 10
*Mar  1 04:50:37.534: BR0:1 IPCP:    Address 10.0.0.2 (0x03060A000002)
*Mar  1 04:50:37.550: BR0:1 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:37.550: BR0:1 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation.

*Mar  1 04:50:37.554: BR0:1 IPCP: State is Open
*Mar  1 04:50:37.562: BR0:1 DDR: dialer protocol up
*Mar  1 04:50:37.570: Di1 IPCP: Install route to 10.0.0.2

!--- Route to Router 2 is installed.

*Mar  1 04:50:38.510: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:1,
   changed state to up

Dans cette section, les affichages de la sortie de débogage Routeur3 appelle le routeur 1. Routeur3 est alors authentifiés basés sur les informations d'identification de l'appelant et est connectés au routeur 1 sans rappel.

*Mar  1 04:50:54.230: ISDN BR0: RX <-  SETUP pd = 8  callref = 0x0D

!--- Receive a call setup.

*Mar  1 04:50:54.238:         Bearer Capability i = 0x8890
*Mar  1 04:50:54.242:         Channel ID i = 0x8A
*Mar  1 04:50:54.250:         Calling Party Number i = 0xA1, '6101',Plan:ISDN,
   Type:National

!--- Calling party (Router 3) information is provided by the switch.

*Mar  1 04:50:54.266:         Called Party Number i = 0xC1, '6122',Plan:ISDN,
   Type:Subscriber(local)

!--- Called party (Router 1) information is provided by the switch.

*Mar  1 04:50:54.286: ISDN BR0: Event: Received a DATA call from 6101 on B2at
   64 Kb/s
*Mar  1 04:50:54.290: BR0:2 DDR: Caller id 6101 matched to profile 

!--- The ISDN call (from Router 3) is authenticated.

*Mar  1 04:50:54.290: BRI0:2: interface must be FIFO queue, force FIFO
*Mar  1 04:50:54.294: BR0:2 PPP: Phase is DOWN, Setup
*Mar  1 04:50:54.298: %DIALER-6-BIND: Interface BR0:2 bound to profile Di2

!--- The interface is bound to interface Dialer 2.

*Mar  1 04:50:54.314: ISDN BR0: TX ->  CALL_PROC pd = 8  callref = 0x8D
*Mar  1 04:50:54.318:         Channel ID i = 0x8A
*Mar  1 04:50:54.326: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
*Mar  1 04:50:54.350: BR0:2 PPP: Treating connection as a callin
*Mar  1 04:50:54.354: BR0:2 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 04:50:54.354: BR0:2 LCP: State is Listen
*Mar  1 04:50:54.630: ISDN BR0: TX ->  CONNECT pd = 8  callref = 0x8D
*Mar  1 04:50:54.698: ISDN BR0: RX <-  CONNECT_ACK pd = 8  callref = 0x0D
*Mar  1 04:50:54.706:         Channel ID i = 0x8A
*Mar  1 04:50:54.766: BR0:2 LCP: I CONFREQ [Listen] id 31 Len 10
*Mar  1 04:50:54.770: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.774: BR0:2 LCP: O CONFREQ [Listen] id 1 Len 10
*Mar  1 04:50:54.778: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.782: BR0:2 LCP: O CONFACK [Listen] id 31 Len 10
*Mar  1 04:50:54.786: BR0:2 LCP:    MagicNumber 0x099285FD (0x0506099285FD)
*Mar  1 04:50:54.790: BR0:2 LCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.794: BR0:2 LCP:    MagicNumber 0xE128C3F7 (0x0506E128C3F7)
*Mar  1 04:50:54.798: BR0:2 LCP: State is Open

!---  LCP negotiation is complete.

*Mar  1 04:50:54.802: BR0:2 PPP: Phase is UP
*Mar  1 04:50:54.806: BR0:2 IPCP: O CONFREQ [Closed] id 1 Len 10
*Mar  1 04:50:54.810: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)
*Mar  1 04:50:54.814: BR0:2 IPCP: I CONFREQ [REQsent] id 17 Len 10
*Mar  1 04:50:54.818: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.822: BR0:2 IPCP: O CONFACK [REQsent] id 17 Len 10
*Mar  1 04:50:54.826: BR0:2 IPCP:    Address 10.0.0.3 (0x03060A000003)
*Mar  1 04:50:54.830: BR0:2 IPCP: I CONFACK [ACKsent] id 1 Len 10
*Mar  1 04:50:54.834: BR0:2 IPCP:    Address 10.0.0.1 (0x03060A000001)

!--- IPCP address negotiation is complete.

*Mar  1 04:50:54.834: BR0:2 IPCP: State is Open
*Mar  1 04:50:54.842: BR0:2 DDR: dialer protocol up
*Mar  1 04:50:54.850: Di2 IPCP: Install route to 10.0.0.3

!--- Route to Router 3 is installed.

*Mar  1 04:50:55.802: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceBRI0:2,
   changed state to up

Informations connexes


Document ID: 15925