Voix : H.323

Configuration du relais Hookflash sur les ports vocaux FXS/FXO

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Lorsque vous intégrez des technologies de voix sur IP (VoIP) à un autocommutateur privé (PBX) ou à un réseau téléphonique public commuté (PSTN) existant, il est parfois nécessaire de passer un signal crochet commutateur (hookflash). Un signal crochet commutateur est une brève interruption dans le courant de boucle du circuit à déclenchement par boucle que le système n'interprète pas comme une déconnexion d'appel.

Une fois que le PBX ou le PSTN sent le hookflash, il met généralement le courant invitent l'attente et fournissent une tonalité ou un accès secondaire à d'autres caractéristiques telles que le transfert ou l'accès de mise en attente.

Un hookflash est fait en enfonçant momentanément le support à un téléphone. Quelques combinés téléphoniques de téléphone font « se rappeler » un bouton appelé 'flash'ou qu'envoie « une rupture chronométrée de boucle », ou « l'éclair calibré » qui est un hookflash qui a une synchronisation précise.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cisco 1750 Routeurs

  • Version de logiciel 12.2.5a de ½ du ¿  de Cisco IOSïÂ

  • H.323 le support logiciel de version 2 est une condition préalable. C'a été disponible depuis la version du logiciel Cisco IOS 12.05T et plus tard. La détection/génération de Hookflash est prise en charge sur les ports vocaux analogiques du Foreign Exchange Station (FXS) et du Foreign Exchange Office (FXO). Ce sont disponibles sur ces plates-formes matérielles Cisco :

    • 1750/51/60

    • 2600

    • 3600

    • 3700

    • MC3810

    • Catalyst 4000 avec le module de passerelle d'accès (AGM)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

Beaucoup de clients emploient une combinaison des ports FXS et FXO pour étendre des combinés téléphoniques de téléphone à travers des réseaux IP. Ils veulent préserver des caractéristiques du PBX existant, telles que l'appel en avant, le pas de réponse à la messagerie vocale, et le transfert/attente sur les extensions distantes. Un logiciel plus tôt de Cisco VoIP n'a pas fourni le plein contrôle pour permettre l'intégration transparente. Cependant, avec la version du Support H.323 version 2 dans la version du logiciel Cisco IOS 12.0.5T et plus tard, il est maintenant possible de détecter et passer la signalisation de hookflash à travers des réseaux IP.

Quand le port FXS est configuré pour un long « hookflash en » valeur de temporisateur (plus considérablement que 500 millisecondes), les utilisateurs peuvent se plaindre que quand ils arrêtent et prennent immédiatement le combiné téléphonique, l'appel n'a pas effacé. Si la valeur est placée si basse, le hookflash peut être interprété comme arrêt imprévu, mais une valeur supérieure signifie que le combiné téléphonique doit être laissé accroché pendant une plus longue période pour effacer l'appel. Dans certains cas, le rebond de support peut poser des problèmes aussi bien. Car le combiné téléphonique est accroché, la tension de ressort sur le bouton de crochet entraîne de plusieurs petites pauses sur la ligne connue sous le nom de rebond de support. L'accord soigneux du hookflash en valeur de synchronisation peut être nécessaire pour les meilleurs résultats. Une possibilité est en pareil cas d'utiliser des combinés téléphoniques avec un bouton instantané qui envoie un hookflash d'une période spécifique. Le port FXO peut être placé pour apparier cette valeur et le port FXO puis génère le hookflash sortant. Beaucoup PBXes ont une option de Classe de service (Cos) appelée « éclair calibré » ou « la rupture chronométrée de boucle » qui leur permet pour identifier des hookflashes de la durée spécifique et pour ignorer d'autres ruptures plus courtes ou plus longues de boucle. De telles configurations sont utiles en éliminant les débranchements et la génération faux des signaux non valides de hookflash au PBX.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Configurez PLAR OPX et relais hookflash

Employez cette procédure pour configurer la ligne privée, l'extension hors-lieu automatique du ringdown (PLAR) (OPX), et le relais hookflash.

  1. Configurez le port FXO sur le routeur de MainSite comme plar-opx de connexion.

    Le mode OPX permet à des utilisateurs distants sur des ports FXS pour apparaître à un PBX central comme extension directement connectée. Quand le port FXO détecte un signal de sonnerie du PBX, le routeur envoie un établissement d'appel VoIP au port FXS distant mais il ne prend pas le hors fonction-crochet de port FXO. En conséquence, le PBX voit seulement le signal de réponse d'appel quand le port FXS de routeur de RemoteSide est pris. Après que le PBX atteigne le délai d'attente de pas de réponse (sonneries d'appel), puis il peut finir l'appel, transfère l'appel vers la messagerie vocale, ou sonne une extension/groupe d'anneau différents. Sans mode OPX, le port FXO va immédiatement le hors fonction-crochet après qu'il sente la sonnerie et le PBX ne peut pas alors exécuter un appel en avant, le pas de réponse, ou roule plus d'à la messagerie vocale.

  2. Le routeur de RemoteSite doit être configuré pour sentir et puis passer le signal de hookflash sur le port FXS.

    Puisque le hookflash est une rupture momentanée dans le courant de boucle sur le port FXS et ne peut pas être envoyé comme signal audio, le routeur passe le signal de hookflash par l'intermédiaire du relais multifréquence de double tonalité (DTMF) en tant que « ! » caractère. Le routeur avec le port FXO envoie alors une rupture courte de boucle que le périphérique externe voit comme hookflash. Pour passer correctement le signal de hookflash, les pairs de cadran VoIP doivent être configurés pour le dtmf-relay h245-signal.

  3. Les temporisateurs de port physique doivent être ajustés pour adapter aux caractéristiques du combiné téléphonique sur le port FXS et la durée de la boucle de hookflash éclatent du port FXO comme affiché ici :

    • Le port vocal FXS (routeur de RemoteSite) utilise la synchronisation hookflash-dans la commande milliseconde où la milliseconde est la valeur maximale d'une rupture de boucle (en quelques millisecondes) du combiné téléphonique de téléphone qui est interprété comme hookflash. Une rupture de boucle plus grande que la valeur configurée est considérée pendant qu'un débranchement et l'appel est abandonné. N'importe quel intervalle sous cette valeur fait envoyer le routeur « ! » caractère par l'intermédiaire du relais de DTMF H.245-signal.

    • Le port de voix FXO (routeur de MainSite) utilise la commande milliseconde de hookflash-out de synchronisation où la milliseconde est la durée de la rupture sortante de boucle en quelques millisecondes. Quand le routeur reçoit un signal de relais de DTMF H.245-signal, le port FXO génère une rupture de boucle pour l'intervalle configuré.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/15405/pbx_across_ip.gif

Configurations

Ce document utilise les configurations indiquées ici.

MainSite
MainSite#show run 
Building configuration...

Current configuration : 1121 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainSite
!
memory-size iomem 20
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback1
 ip address 205.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.1 255.255.255.252
 no fair-queue
 clockrate 1300000
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 205.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
voice-port 1/0
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec. 

 connection plar opx 200
 
!--- Use PLAR OPX option on the FXO port. 

!
voice-port 1/1
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec.

 connection plar opx 201
 
!--- Use PLAR OPX option on the FXO port.

!
dial-peer voice 100 pots
 destination-pattern 100
 port 1/0
!
dial-peer voice 101 pots
 destination-pattern 101
 port 1/1
!
dial-peer voice 200 voip
 incoming called-number .
 destination-pattern 20.
 session target ipv4:200.1.1.1
 dtmf-relay h245-signal
 
!--- H.245-signal to pass hookflash.

 ip precedence 5
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Site distant
RemoteSite#show run 
Building configuration...

Current configuration : 1096 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RemoteSite
!
memory-size iomem 25
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback0
 ip address 200.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.2 255.255.255.252
 no fair-queue
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 200.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
!
voice-port 1/0 
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.   
  
 connection plar 100
 
!--- PLAR provides dial tone from remote PBX. 

!
voice-port 1/1
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.    
 
 connection plar 101
 
!--- PLAR provides dial tone from the remote PBX.

!
dial-peer voice 100 voip
 incoming called-number .
 destination-pattern 10.
 session target ipv4:205.1.1.1
 dtmf-relay h245-signal
 
!--- Use H.245-signal to pass hookflash.

 ip precedence 5
!
dial-peer voice 200 pots
 destination-pattern 200
 port 1/0
!
dial-peer voice 201 pots
 destination-pattern 201
 port 1/1
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Vérifiez et dépannez

Cette section fournit des informations que vous pouvez employer pour vérifier et dépanner votre configuration.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • debug h225 {asn1 | événements} - les informations complémentaires d'affichages au sujet du contenu réel des messages de l'enregistrement H.225, de l'admission, et de l'état (RAS).

    asn1 Indique que seulement le contenu ASN.1 de n'importe quel message H.225 envoyé ou reçu est affiché.
    événements Indique que les événements de la clé Q.931 qui se produisent en plaçant H.323 un appel d'une passerelle à l'autre sont affichés.

Le hookflash est passé car un message H.245 par l'intermédiaire de TCP ainsi de lui est possible pour surveiller la signalisation à l'aide du debug h245 asn1 pour afficher les paquets H.245.

Ce sont deux mettent au point des suivis. Le premier affiche la réception du '5' de chiffre (la signalisation d'appel H.245 passe le chiffre et la durée). Le deuxième suivi affiche un hookflash (affiché en tant que « ! "). Il n'y a aucune durée pour un hookflash. Le signal est envoyé le port FXO basé sur la valeur de synchronisation configurée milliseconde de hookflash-out.

MainSite#
MainSite#debug h245 asn1 
H.245 ASN1 Messages debugging is on
MainSite#
00:52:17: H245 MSC INCOMING ENCODE BUFFER::= 6D 810B66A0 0F9F58AD AF684A00 00
00:52:17: 
00:52:17: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "5"
      
!--- Digit relayed is 5. 

      duration 4000
      rtp 
      {
        timestamp 2913953866
        logicalChannelNumber 1
      }
    }

00:52:18: H245 MSC INCOMING ENCODE BUFFER::= 6D 82064001 26000000 
00:52:18: 
00:52:18: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signalUpdate :
 
    {
      duration 295
      
!--- Digit duration was 295 msec. 

      rtp 
      {
        logicalChannelNumber 1
      }
    }

MainSite#


!--- This trace from the destination router shows 
!--- the hookflash passed as the character '!'. 

MainSite#
00:52:36: H245 MSC INCOMING ENCODE BUFFER::= 6D 81020420 
00:52:36: 
00:52:36: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "!"
     
 !--- Hookflash is passed as '!'. 

    }

MainSite#

Informations connexes


Document ID: 15405