Composition et accès : Routage à établissement de connexion à la demande (DDR)

Routage DDR (Dial-on-demand Routing) avec Easy IP et serveur DHCP

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique l'utilisation de la caractéristique d'Easy IP de logiciel de½ du¿Â du Cisco IOSï qui est utile dans les cas où un site entier se connecte à l'Internet par l'intermédiaire d'un fournisseur de services Internet (ISP) qui assigne seulement une adresse IP pour le site distant entier. Le routeur d'Easy IP compose le serveur d'accès à distance (NAS) au fournisseur de services et négocie sa propre adresse IP BLÊME. Le routeur emploie alors le Traduction d'adresses de réseau (NAT) par cette adresse négociée avec la translation d'adresses d'adresse du port (PAT) pour fournir l'accès extérieur pour les clients intérieurs. Une autre fonction facultative du routeur d'Easy IP est d'agir en tant que serveur du protocole DHCP (DHCP) au RÉSEAU LOCAL à l'intérieur des clients. Le petit bureau de Cisco, routeur du bureau à domicile (SOHO) est utilisé généralement dans ce type de configuration.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur d'Easy IP - Un Cisco 3620 avec quatre Ethernets et huit Logiciel Cisco IOS version 12.0(7) courants XK2 d'interface BRI.

  • Serveur d'accès - Cisco AS5300 avec un Ethernet, un Fast Ethernet et quatre a canalisé des ports T1/PRI exécutant le Logiciel Cisco IOS version 12.1(7).

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Informations générales

Composants d'Easy IP

Comment Easy IP fonctionne le pas à pas

  1. Si le routeur d'Easy IP est configuré comme serveur DHCP, le RÉSEAU LOCAL à l'intérieur des clients reçoivent une adresse IP privée de lui lors de l'alimentation. S'il n'est pas configuré en soi, les clients doivent avoir une adresse IP assignée à eux d'une autre manière.

  2. Quand un RÉSEAU LOCAL à l'intérieur de client génère le trafic « intéressant » (comme défini par des listes de contrôle d'accès) pour la numérotation, le routeur d'Easy IP compose et demande une adresse IP enregistrée simple du serveur d'accès du lieu d'exploitation principal par l'intermédiaire de PPP/IPCP. Une fois que ce rapport est établi, l'autre RÉSEAU LOCAL à l'intérieur des clients peuvent utiliser ce circuit comme expliqué dans l'étape 4.

  3. Les réponses de serveur d'accès du site central avec une adresse globale dynamique d'un groupe d'adresse IP locale qui est assigné à l'interface WAN du routeur d'Easy IP.

  4. Les utilisations PAT de routeur d'Easy IP de créer automatiquement une traduction qui associe l'adresse IP enregistrée de l'interface WAN avec l'adresse IP privée du RÉSEAU LOCAL à l'intérieur du client et d'une connexion au serveur d'accès du site central est faites.

Pour une compréhension plus détaillée d'Easy IP, référez-vous à Livre Blanc - des Services Cisco IOS Easy IP.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/15364/ddreasyip.gif

Configurations

Ce document utilise la configuration suivante :

Routeur d'Easy IP
EasyIP#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname EasyIP
!
username ISP-AS password 0 ipnegotiate

! --- Username for remote router (ISP-AS) and shared secret.
! --- Shared secret(used for CHAP) must be the same on both sides.

ip subnet-zero
no ip domain-lookup
no ip dhcp conflict logging

! --- Disable the recording of DHCP address conflicts on the DHCP server.

ip dhcp excluded-address 10.0.0.1

! --- Specifies a IP address that the DHCP server should not assign to clients.

ip dhcp pool soho

! --- Configure the DHCP address pool name and enter DHCP pool configuration mode.

 network 10.0.0.0 255.0.0.0

 ! --- Specifies the subnet network number and mask of the DHCP address pool.

 default-router 10.0.0.1

 ! --- Specifies the IP address of the default router for a DHCP clients.
 
 lease infinite

 ! --- Specifies the duration of the lease.

!
isdn switch-type basic-5ess
isdn voice-call-failure 0
!
interface Ethernet0/0
 ip address 10.0.0.1 255.0.0.0

 ! --- IP address for the Ethernet interface. 

 no ip directed-broadcast
 ip nat inside

! --- Defines the interface as internal for network address translation.

!

! Unused ethernet interfaces omitted for brevity

!
interface BRI1/0
 ip address negotiated

! --- Enables PPP/IPCP negotiation for this interface.

 no ip directed-broadcast
 ip nat outside

! --- Defines the interface as external for network address translation.

 encapsulation ppp
 dialer idle-timeout 60

! --- Idle timeout(in seconds)for this BRI interface.

 dialer string 97771200

! --- Specifies the telephone number required to reach the central access server.

 dialer-group 1

! --- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
!

!-- Unused BRI interfaces omitted for brevity.

!
ip nat inside source list 100 interface BRI1/0 overload 

! --- Establishes dynamic source translation (with PAT) for addresses which are 
! --- identified by the access list 100.

ip classless
ip route 0.0.0.0 0.0.0.0 BRI1/0 permanent

! --- Default route is via BRI1/0.

no ip http server
!
access-list 100 permit ip 10.0.0.0 0.255.255.255 any

! --- Defines an access list permitting those addresses that are to be translated.

dialer-list 1 protocol ip permit

! --- Interesting traffic is defined by dialer-list1.
! --- This is applied to BRI1/0 using dialer-group 1.

line con 0
 transport input none
line aux 0
line vty 0 4
 login
!         
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Commandes show

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • le show ip interface donnent des instructions - Affiche l'état d'interface et l'adresse IP configurés sur l'interface.

  • interfaces d'exposition - Fournit des informations de haut niveau au sujet du staus d'interface pour une interface spécifique.

  • show ip nat statistics - Statistiques de Traduction d'adresses de réseau (NAT) d'affichages.

  • show ip nat translations - Affiche des traductions d'adresses réseau actives.

  • état de show isdn - Affiche le statut de chaque couche RNIS. Vérifie que la couche RNIS 1 et 2 fonctionnent. Voyez le document utilisant la commande d'état de show isdn pour le dépannage BRI pour davantage d'information de dépannage.

  • show dialer - Affiche les informations de numéroteur.

Exemple de sortie avec show

Les sorties de commande show suivantes, qui sont prises avant que le routeur d'Easy IP initiant la connexion d'accès par réseau commuté au serveur d'accès du site central affiche l'interface BRI1/0 est en hausse et n'a aucune adresse IP mais l'adresse IP sera négociée utilisant IPCP.

EasyIP#show ip interface brief
Interface                  IP-Address      OK? Method Status                Prol
Ethernet0/0                10.0.0.1        YES manual up                    up  
Ethernet0/1                unassigned      YES manual administratively down dow 
Ethernet0/2                unassigned      YES manual administratively down dow 
Ethernet0/3                unassigned      YES manual administratively down dow 
BRI1/0                     unassigned      YES IPCP   up                    up

! -- Interface is Up, but no IP Address is assigned since it is not connected

BRI1/0:1                   unassigned      YES unset  down                  dow 
BRI1/0:2                   unassigned      YES unset  down                  dow 

! -- Both B-channels are down

BRI1/1                     unassigned      YES manual administratively down dow 
BRI1/1:1                   unassigned      YES unset  administratively down dow 
BRI1/1:2                   unassigned      YES unset  administratively down dow

EasyIP#show interfaces bri1/0
BRI1/0 is up, line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
   .
   .
EasyIP#

Les sorties de commande show suivantes, qui sont prises après le routeur d'Easy IP ont initié la connexion d'accès par réseau commuté avec le serveur d'accès du site central affiche que l'interface BRI1/0 a reçu son adresse IP 200.1.0.3 du serveur d'accès du site central par l'intermédiaire de PPP/IPCP.

EasyIP#show ip interface brief 
Interface                  IP-Address      OK? Method Status                Prorocol
Ethernet0/0                10.0.0.1        YES manual up                    up  
Ethernet0/1                unassigned      YES manual administratively down dow 
Ethernet0/2                unassigned      YES manual administratively down dow 
Ethernet0/3                unassigned      YES manual administratively down dow 
BRI1/0                     200.1.0.3       YES IPCP   up                    up  

! -- Int BRI1/0 has a registers IP address assigned after connection is up

BRI1/0:1                   unassigned      YES unset  up                    up  
BRI1/0:2                   unassigned      YES unset  down                  dow 

! -- 1st B-channel (BRI1/0:1) is UP

BRI1/1                     unassigned      YES manual administratively down dow 
BRI1/1:1                   unassigned      YES unset  administratively down dow 
BRI1/1:2                   unassigned      YES unset  administratively down dow
EasyIP#show interfaces bri1/0
BRI1/0 is up, line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
Internet address is 200.1.0.3/32
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
  .
  . 
  EasyIP#

Nous devons vérifier si les hôtes réseau privés d'intérieur peuvent se connecter au serveur d'accès du site central ou pas et la caractéristique NAT fonctionne correctement ou pas. Ceci peut faire à l'aide de l'utilitaire étendu de ping. Sur le routeur d'EasyIP, cinglez l'interface d'Ethernets du serveur d'accès du site central et spécifiez la source de ping comme adresse (privée) de RÉSEAU LOCAL du routeur d'EasyIP. Ceci s'assure que le paquet est traité par PAT et que les clients sur le RÉSEAU LOCAL peuvent communiquer avec le réseau de lieu d'exploitation principal.

EasyIP#ping
Protocol [ip]: 
Target IP address: 192.168.16.1

! -- Ethernet interface IP address of the Central Site Access Server.

Repeat count [5]: 10
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.0.0.1

! --Ethernet interface IP address (private) of the Easy IP router.

Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 192.168.16.1, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 32/34/36 ms

La sortie ci-dessus affiche que le taux de réussite est de 100 pour cent ce qui signifie que la caractéristique NAT fonctionne bien et les hôtes SOHO peut communiquer avec le serveur d'accès du site central. Nous pouvons obtenir plus d'informations détaillées au sujet des traductions NAT de la sortie suivante de commandes show.

EasyIP#show ip nat statistics 
Total active translations: 10 (0 static, 10 dynamic; 10 extended)
Outside interfaces:
  BRI1/0, BRI1/0:1, BRI1/0:2
Inside interfaces: 
  Ethernet0/0
Hits: 169  Misses: 185
Expired translations: 175
Dynamic mappings:
-- Inside Source
access-list 100 interface BRI1/0 refcount 10
EasyIP#show ip nat translations 
Pro Inside global      Inside local       Outside local      Outside global
icmp 200.1.0.3:32      10.0.0.1:32        192.168.16.1:32    192.168.16.1:32
icmp 200.1.0.3:33      10.0.0.1:33        192.168.16.1:33    192.168.16.1:33
icmp 200.1.0.3:34      10.0.0.1:34        192.168.16.1:34    192.168.16.1:34
icmp 200.1.0.3:35      10.0.0.1:35        192.168.16.1:35    192.168.16.1:35
icmp 200.1.0.3:36      10.0.0.1:36        192.168.16.1:36    192.168.16.1:36
icmp 200.1.0.3:37      10.0.0.1:37        192.168.16.1:37    192.168.16.1:37
icmp 200.1.0.3:38      10.0.0.1:38        192.168.16.1:38    192.168.16.1:38
icmp 200.1.0.3:39      10.0.0.1:39        192.168.16.1:39    192.168.16.1:39
icmp 200.1.0.3:40      10.0.0.1:40        192.168.16.1:40    192.168.16.1:40
icmp 200.1.0.3:41      10.0.0.1:41        192.168.16.1:41    192.168.16.1:41
EasyIP#

La sortie de commande suivante d'état de show isdn affiche le statut de chaque couche RNIS. Vérifiez cette couche 1 et 2 sont suivant les indications de l'exemple

EasyIP#show isdn status 
Global ISDN Switchtype = basic-5ess
ISDN BRI1/0 interface
        dsl 8, interface ISDN Switchtype = basic-5ess
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        1 Active Layer 3 Call(s)
    Activated dsl 8 CCBs = 1
        CCB:callid=8098, sapi=0, ces=1, B-chan=1, calltype=DATA
    The Free Channel Mask:  0x80000002

Voyez le document utilisant la commande d'état de show isdn pour le dépannage BRI pour davantage d'information de dépannage.

La sortie suivante de show dialer prouve que composant est initié par l'adresse IP de réseau privé d'intérieur (pour example,10.0.0.1).

EasyIP#show dialer 

BRI1/0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
97771200                23          0    00:02:02       successful   Default
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI1/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=10.0.0.1, d=192.168.16.1)
Time until disconnect 36 secs
Current call connected 00:02:03
Connected to 97771200 (ISP-AS)

BRI1/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Dépannez

commandes de débogage

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • la négociation de debug ppp fournit des informations au sujet de procédé de négociation de protocole PPP. debug ip nat - Fournit des informations

  • mettez au point l'IP national fournit des informations au sujet des paquets IP traduits par la caractéristique (NAT) de traduction d'adresse de réseau IP.

  • mettez au point le RNIS q921- fournit l'élimination des imperfections de couche liaison de données des messages q.921.

  • debug isdn q931 - Fournit l'élimination des imperfections de réseau-couche des messages q.931.

  • mettez au point le numéroteur - Fournit les informations DDR pour l'appel sortant.

Exemple de sortie de débogage

La sortie suivante de debug ppp negotiation affiche le procédé de négociation de protocole PPP/IPCP.

EasyIP#debug ppp negotiation 
PPP protocol negotiation debugging is on
.
.

2d07h: BR1/0:1 IPCP: O CONFREQ [Closed] id 223 len 10
2d07h: BR1/0:1 IPCP:    Address 0.0.0.0 (0x030600000000)
2d07h: BR1/0:1 CDPCP: O CONFREQ [Closed] id 63 len 4
2d07h: BR1/0:1 IPCP: I CONFREQ [REQsent] id 47 len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.1 (0x0306C8010001)
2d07h: BR1/0:1 IPCP: O CONFACK [REQsent] id 47 len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.1 (0x0306C8010001)
2d07h: BR1/0:1 CDPCP: I CONFREQ [REQsent] id 41 Len 4
2d07h: BR1/0:1 CDPCP: O CONFACK [REQsent] id 41 Len 4
2d07h: BR1/0:1 IPCP: I CONFNAK [ACKsent] id 223 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 IPCP: O CONFREQ [ACKsent] id 224 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 CDPCP: I CONFACK [ACKsent] id 63 Len 4
2d07h: BR1/0:1 CDPCP: State is Open
2d07h: BR1/0:1 IPCP: I CONFACK [ACKsent] id 224 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 IPCP: State is Open
2d07h: BR1/0 IPCP: Install negotiated IP interface address 200.1.0.3

! -- The EasyIP router will install the negotiated WAN IP address.

2d07h: BR1/0 IPCP: Install route to 200.1.0.1

! -- A route to the Central Site Access Server is installed.

2d07h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state Up
2d07h: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 97771200 ISP-AS
EasyIP#

La sortie de debug ip nat affiche les informations sur des paquets IP traduits par la caractéristique (NAT) de traduction d'adresse de réseau IP.

EasyIP#debug ip nat detailed 
IP NAT detailed debugging is on
.
.
2d00h: NAT: o: icmp (10.0.0.1, 2015) -> (192.168.16.1, 2015) [909]
2d00h: NAT: i: icmp (10.0.0.1, 2015) -> (192.168.16.1, 2015) [909]
2d00h: NAT: ipnat_allocate_port: wanted 2015 got 2015
2d00h: NAT*: o: icmp (192.168.16.1, 2015) -> (200.1.0.3, 2015) [909]
2d00h: NAT: o: icmp (10.0.0.1, 2016) -> (192.168.16.1, 2016) [910]
2d00h: NAT: i: icmp (10.0.0.1, 2016) -> (192.168.16.1, 2016) [910]
2d00h: NAT: ipnat_allocate_port: wanted 2016 got 2016
2d00h: NAT*: o: icmp (192.168.16.1, 2016) -> (200.1.0.3, 2016) [910]
2d00h: NAT: o: icmp (10.0.0.1, 2017) -> (192.168.16.1, 2017) [911]
2d00h: NAT: i: icmp (10.0.0.1, 2017) -> (192.168.16.1, 2017) [911]
2d00h: NAT: ipnat_allocate_port: wanted 2017 got 2017
2d00h: NAT*: o: icmp (192.168.16.1, 2017) -> (200.1.0.3, 2017) [911]
2d00h: NAT: o: icmp (10.0.0.1, 2018) -> (192.168.16.1, 2018) [912]
2d00h: NAT: i: icmp (10.0.0.1, 2018) -> (192.168.16.1, 2018) [912]
.
.

EasyIP#undebug all 
All possible debugging has been turned off

Informations connexes


Document ID: 15364