Services de mise en réseau d'applications : Cisco LocalDirector de la gamme 400

Configuration de basculement standard et avec état dans LocalDirector

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Cisco a annoncé l' interruption de vente pour Cisco LocalDirector. Le pour en savoir plus, se rapportent aux notices de fin de vie et de fin de commercialisation de gamme 400 de LocalDirector et à des bulletins de produit.


Contenu


Introduction

Les informations dans cette note en tech s'appliquent à tous les matériel et versions de logiciel du Cisco LocalDirector dans une configuration de Basculement.

Deux types de Basculement peuvent être mis en application dans LocalDirector : Basculement standard et Basculement de statefull. Dans le Basculement standard (de non-statefull), toutes les informations de connexion existante sont perdues lors du Basculement ; cependant, le Basculement de statefull met à jour les informations de session, aussi bien que les informations de session Rémanentes.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document s'applique à tous les matériel et versions de logiciel du Cisco LocalDirector dans une configuration de Basculement.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Commandes de Basculement

  • ip_address d'IP address de Basculement — Place l'adresse IP de Basculement. L'argument d'ip_address indique l'adresse IP utilisée par l'équipement de réserve pour communiquer avec l'unité d'active. Utilisez cette adresse IP avec la commande ping de vérifier le statut de l'équipement de réserve. Cette adresse doit être sur le même réseau que l'adresse IP de système. Par exemple, si l'adresse IP de système est 192.168.1.1, placez l'adresse IP de Basculement à 192.168.1.2.

  • Basculement [actif] — Active l'accès à la caractéristique facultative de Basculement. L'argument actif facultatif fait à un LocalDirector l'unité d'active.

  • interface_number replié d'interface — Active le Basculement de statefull, et spécifie une interface pour envoyer des données de réplication. L'argument d'interface_number indique le nombre par lequel l'unité de LocalDirector d'active envoie des données de réplication de connexion à l'équipement de réserve. Le par défaut est l'interface 0.

  • ip_address d'IP address de Basculement alias — Assigne une adresse IP de Basculement alias. L'adresse IP est utilisée par l'équipement de réserve pour communiquer avec l'unité d'active.

  • Basculement remis à l'état initial — Prend une unité hors de l'état défaillant.

  • Basculement d'exposition — État de Basculement de LocalDirector d'expositions, état du câble, état primaire et secondaire d'hôte, et descriptions d'interface.

  • Ethernets d'arrêt | interface_number FDDI — Désactive une interface.

Le pour en savoir plus, se rapportent à la référence de commandes de LocalDirector.

Configurations

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

LocalDirector dans le Basculement standard

C'est une configuration de base de LocalDirector dans le Basculement standard :

LocalDirector dans le Basculement standard
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 auto 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp 
: end 
[OK] 
localdirector(config)#

LocalDirector dans le Basculement de Statefull

Est ci-dessous une configuration d'échantillon de LocalDirector dans le Basculement de statefull. Les unités de Basculement de Statefull partagent les informations de connexion pour des connexions actives et sont configurables sur une base par-virtuelle. Chaque fois que l'état de la connexion de Protocole TCP (Transmission Control Protocol) change, les données sont envoyées au LocalDirector de réserve par l'intermédiaire du protocole de LocalDirector-statefull. Ceci permet l'état actuel de toutes les sessions TCP à refléter au LocalDirector de réserve.

Le protocole de LocalDirector-statefull emploie des paquets de Protocole UDP (User Datagram Protocol) pour envoyer les modifications d'état au LocalDirector de réserve au-dessus de l'interface Ethernet. Employez une interface Ethernet distincte pour envoyer des messages de Basculement de statefull. Avec le Basculement de statefull, il n'y a aucune interruption de service au client. Il est idéal pour des applications stratégiques et tient compte de la Haute disponibilité.

Remarque: Cet exemple utilise l'Ethernet 2 d'interface, qui a un croisé entre les deux LocalDirectors pour transférer les informations d'état. Cet exemple utilise également ces commandes repliées :

replicate interface 2 
replicate 10.1.1.5:0:0:tcp

Ces commandes indiquent LocalDirector répliquer l'état de connexion d'actif vers les équipements de réserve à travers les Ethernets 2 et répliquer également toutes les informations d'état de 10.1.1.5 virtuel vers l'équipement de réserve.

LocalDirector dans le Basculement de Statefull
: Saved 
: LocalDirector 420 Version 4.1.2 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
no shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 100full 
interface ethernet 2 100full 
interface ethernet 3 auto 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure  0 
no secure  1 
no secure  2 
no secure  3 
ping-allow 0 
ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 10.1.1.1 255.0.0.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 10.1.1.2 
failover 
failover hellotime 30 
password cisco 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
no dns-boomerang enable 
virtual 10.1.1.5:0:0:tcp is 
real 10.1.1.4:0:0:tcp is 
real 10.1.1.3:0:0:tcp is 
replicate interface 2 
replicate 10.1.1.5:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.3:0:0:tcp 
bind 10.1.1.5:0:0:tcp 10.1.1.4:0:0:tcp

Remarque: Toutes les interfaces sont au commencement en attendant le mode, signifiant que la Surveillance de réseau n'a pas commencé. Après que les interfaces réseau entrent dans le mode normal, la Surveillance de réseau commence. Ceci se produit quand LocalDirector-BONJOUR les messages commencent envoyant toutes les cinq secondes.

Si un intervalle 30-second passe sans LocalDirector-BONJOUR des messages étant reçus, les unités entrent dans le mode de test pour déterminer quelle unité a manqué. Si le câble série est tiré, les unités mettront à jour leur rôle en cours. Si l'unité ne passe pas un test, elle deviendra manquée et l'autre unité deviendra active. Chaque fois que ? état ? des modifications de connexion TCP, des données sont envoyées au LocalDirector de réserve par l'intermédiaire du protocole de LocalDirector-statefull. L'état de toutes les sessions TCP est reflété au LocalDirector de réserve. Si un virtuel est changé pour prendre en charge le Basculement de statefull puis les informations d'état pour seulement les nouvelles connexions sont envoyées au LocalDirector de réserve. Le protocole de statefull de LocalDirector ne copie pas l'état de sessions TCP existantes.

Vérifier l'état de Basculement

La commande de Basculement d'exposition peut être utilisée pour afficher le statut en cours de Basculement des unités et de leurs interfaces, suivant les indications de cet exemple :

Failover Off 
Cable status: My side not connected 
        This host: Secondary - Active 
                Active time: 1 weeks, 3 days, 1 hours, 2 minutes, 5 seconds 
                Interface 5 (10.86.16.225): Normal (Waiting) 
                Interface 4 (10.86.16.225): Normal (Waiting) 
                Interface 3 (10.86.16.225): Normal (Administratively down) 
                Interface 2 (10.86.16.225): Normal (Administratively down) 
                Interface 1 (10.86.16.225): Normal (Waiting) 
                Interface 0 (10.86.16.225): Normal (Waiting) 
        Other host: Secondary - Standby 
                Interface 5 (0.0.0.0): Normal (Waiting) 
                Interface 4 (0.0.0.0): Normal (Waiting) 
                Interface 3 (0.0.0.0): Normal (Administratively down) 
                Interface 2 (0.0.0.0): Normal (Administratively down) 
                Interface 1 (0.0.0.0): Normal (Waiting) 
                Interface 0 (0.0.0.0): Normal (Waiting)

Ceci prouve que bonjour des paquets sont passés dans les deux sens entre les deux unités et que deux des interfaces sur le LDs ont été arrêtés.


Informations connexes


Document ID: 15060