Interfaces et modules Cisco : Module de commutation de contenu Cisco

Configuration de l'équilibrage de charge de serveur IOS à l'aide de sondes HTTP en mode distribué

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 septembre 2015) | Commentaires


Contenu


Introduction

La caractéristique d'Équilibrage de charge de serveur (SLB) de ½ du ¿  de Cisco IOSï est une solution basée sur IOS de Cisco qui fournit l'équilibrage de charge du serveur. Cette caractéristique te permet pour définir un serveur virtuel qui représente une batterie de vrais serveurs, connu sous le nom de batterie de serveur. Quand un client initie une connexion au serveur virtuel, l'IOS SLB équilibrent la charge la connexion à un vrai serveur choisi, selon configuré équilibrez la charge l'algorithme ou le predictor.

IOS SLB peut être configuré pour fonctionner en deux modes suivants.

  • mode acheminé — En ce mode, l'adresse de serveur virtuel est connue aux vrais serveurs. Vous devez configurer chacun des vrais serveurs avec des adresses de bouclage pour leur seule interface de bouclage. C'est nécessaire pour donner à chaque ordinateur dans la batterie de serveur la même adresse IP que le serveur virtuel réel. On permettra au le vrai serveur de destination alors pour répondre directement aux clients utilisant l'adresse de bouclage, juste comme elle pour sa propre adresse IP. IOS SLB réorientent des paquets au vrai serveur à la couche 2 à la couche de Contrôle d'accès au support (MAC). Puisque l'adresse IP de serveur virtuel n'est pas modifiée en mode acheminé, les vrais serveurs doivent être la couche 2-adjacent à IOS SLB, ou les Routeurs intervenants ne pourraient pas pouvoir conduire au vrai serveur choisi.

  • mode dirigé — En ce mode, le serveur virtuel peut être assigné à une adresse IP qui est inconnue aux vrais serveurs. IOS SLB traduit des paquets permutés entre un client et un vrai serveur, traduisant l'adresse IP de serveur virtuel à une vraie adresse du serveur par le Traduction d'adresses de réseau (NAT). Pour utiliser le mode dirigé, ajoutez l'ordre nat de serveur à la batterie de serveur.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Release 12.1(6)E IOS de Supervisor de la famille du Catalyst 6000 pour l'engine 1 de superviseur avec MSFC1 (c6sup11-jsv-mz.121-6.E1)

  • Serveurs Web de Microsoft Windows 2000/IIS

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Sondes de HTTP

IOS SLB prend en charge des sondes de Protocole HTTP (Hypertext Transfer Protocol), des sondes de ping, et des sondes de Protocole WSP (Wireless Session Protocol). Vous pouvez employer la méthode de sonde de HTTP pour vérifier la Connectivité et pour surveiller les vrais serveurs étant chargement équilibré. Les sondes déterminent l'état de chaque vrai serveur dans la batterie de serveur. Dans cet exemple, des sondes de HTTP sont configurées utilisant le port TCP 80. Les sondes de HTTP sont configurées pour connecter toutes les huit secondes et pour demander une méthode obtenez la commande, recherchant un code de 200 réponses du serveur. Ces configurations sont toutes les valeurs par défaut.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/15055/ios_slb-01.gif

Configurations

Configuration IOS SLB utilisant le Catalyst 6509
Current configuration:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cat6

!

boot buffersize 126968

boot system flash slot0:c6sup11-jsv-mz.121-6.E1.bin

!

redundancy

 main-cpu

  auto-sync standard

ip subnet-zero

!

no ip finger

no ip domain-lookup

!

ip slb probe KEEPALIVE http

!

ip slb serverfarm SERVERS

 probe KEEPALIVE

 !

 real 10.1.1.3

  inservice

 !

 real 10.1.1.5

  inservice

!

ip slb vserver WEBSITE

 virtual 172.17.63.215 tcp www

 serverfarm SERVERS

 inservice

!

cns event-service server

!

interface GigabitEthernet1/1

 no ip address

 shutdown

!

interface GigabitEthernet1/2

 no ip address

 shutdown

!

interface FastEthernet2/1

 no ip address

 switchport

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet2/2

 no ip address

 shutdown

!

interface FastEthernet2/3

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/4

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/5

 no ip address

 shutdown

!

interface FastEthernet2/48

 no ip address

 shutdown

!         

interface Vlan1

 no ip address

 shutdown

!

interface Vlan100

 ip address 172.17.63.211 255.255.255.192

!

interface Vlan200

 ip address 10.1.1.250 255.255.255.0

!

ip default-gateway 172.17.63.193

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.63.193

no ip http server

!

line con 0

 transport input none

line vty 0 4

 password cisco

 login

!

end

commandes show et résumé de commande

commande de mode de slb de show ip

La commande de mode de slb de show ip affiche le statut du mode SLB.

cat6#show ip slb mode 
     SLB forwarding mode = rp (default) 
     SLB configured mode = rp (default) 

Pour exécuter le logiciel du Cisco IOS SLB, vous devez configurer le mode utilisant le mode de slb de show ip [csm | commande RP] avant toute configuration. Dans la commande de mode de slb de show ip, l'argument RP est par défaut. Vous pouvez seulement configurer l'argument csm si vous avez le module de commutation de contenu (CSM). Le CSM fournit les connexions performantes entre les batteries de serveur de périphériques de réseau basées sur des brochures d'information de la couche 4 à 7. Vous pouvez représenter un groupe de vrais serveurs (batterie de serveur) comme exemple de serveur unique (serveur virtuel), équilibrer le trafic à la batterie de serveur en sélectionnant un des vrais serveurs (équilibrage de charge du serveur), et le trafic de limite à différents serveurs (connexions adhérentes) et à batteries de serveur (stratégies). Le pour en savoir plus, voient configurer le mode sécurisé (de routeur) sur le module de commutation de contenu.

commande de vserver de slb de show ip

La commande de vserver de slb de show ip affiche les informations de serveur virtuel. Au-dessous de vous voyez également l'état du serveur virtuel et combien de connexions là sont :

cat6#show ip slb vserver 

slb vserver      protocol      virtual              state      conns 
------------------------------------------------------------------------ 
WEBSITE         TCP       172.16.63.215/32:80      OPERATIONAL   0 

commande de show ip slb reals

L'affiche des informations de commande de show ip slb reals pour chaque vrai serveur, tel que la batterie de serveur où chaque serveur réside, les états des serveurs, les seuils, et les connexions.

cat6#show ip slb reals 

real             server farm      weight     state        conns 
------------------------------------------------------------------- 
10.1.1.5         SERVERS           8        OPERATIONAL     0 
10.1.1.3         SERVERS           8        OPERATIONAL     0 

commande de show ip slb serverfarms

La commande de show ip slb serverfarms affiche les informations de ferme de serveur. Cette commande montre le predictor utilisé pour l'Équilibrage de charge. Dans cette recherche séquentielle d'exemple, qui est par défaut, est utilisé. Vous n'en verrez « aucun » sous NAT parce que le périphérique est en mode acheminé.

cat6#show ip slb serverfarm 

server farm      predictor    nat        reals    redirect    bind id 
-------------------------------------------------------------------------- 
SERVERS       roundrobin     none         2          0             0 

commande de show ip slb conns

Le show ip slb conns [virtual_server-name de vserver | adresse IP du client | la commande de firewallfarm-nom de Pare-feu] [détail] affiche les connexions actives.

  • vserver - Affichages seulement que ces connexions ont connectés à un serveur virtuel particulier.

  • Virtual Server-nom - Nom du serveur virtuel.

  • client - Affiche des connexions avec une adresse IP de client particulier.

  • IP address - Adresse IP du client.

  • détail - Les informations de connexion détaillées d'affichages.

Si aucune option n'est spécifiée, la commande de show ip slb conns affiche la sortie pour toutes les connexions actives IOS SLB.

cat6#show ip slb conns 

vserver         prot    client             real                state            nat 
----------------------------------------------------------------------- --------------- 
WEBSITE         TCP  10.21.188.123:2187    10.1.1.5            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2190    10.1.1.5            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2192    10.1.1.3            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2197    10.1.1.3            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2200    10.1.1.5            SYNCLIENT        none 
WEBSITE         TCP  10.21.188.123:2201    10.1.1.5            SYNCLIENT        none 

cat6#show ip slb conns detail 

WEBSITE, client = 10.21.188.123:2187 state = ESTAB, real = 10.1.1.5, 
nat = none  v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 1, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2205 state = CLOSING, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 3, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2206 state = ESTAB, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 2, sticky = FALSE, flows attached = 0 

commande de show ip slb probe

L'affiche des informations de commande de show ip slb probe au sujet d'un IOS SLB.

Il y a trois états opérationnels de la sonde :

  • MANQUÉ - La sonde a actuellement manqué.

  • OPÉRATIONNEL - La sonde fonctionne normalement.

  • TEST - La sonde n'a jamais réussi, en raison d'aucune réponse. IOS SLB ne garde aucun compteur ou temporisateur pour cet état.

L'autre information affichée est la suivante :

  • Pannes - Le nombre d'intervalles entre les sondes réussies.

  • Courant - Le temps puisque le dernier succès de sonde. C'est-à-dire, la durée (jusqu'ici) de la panne en cours.

  • Cumulatif - Le temps total le vrai serveur a été au test de sonde et a manqué. Cette valeur est la somme du temps en cours plus le temps total de toutes les pannes précédentes.

cat6#show ip slb probe 

Server:Port          	State        Outages  	Current    Cumulative 
----------------------------------------------------------------------- 
10.1.1.3:80             OPERATIONAL    1        never         00:05:22 
10.1.1.5:80             OPERATIONAL    0        never         00:00:00 

Bouclage acheminé de mode

Après que vous ayez configuré la caractéristique SLB sur le Catalyst 6500, vous devez configurer chaque vrai serveur avec un périphérique/interface de bouclage. Configurez l'adresse IP du serveur virtuel comme adresse IP de bouclage, avec un netmask de 255.0.0.0.

Route Table 
======================================================================= ==== 
Interface List 
0x1 ........................... MS TCP Loopback interface 
0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
======================================================================= ==== 
Active Routes: 
Network	        Destination         Netmask         Gateway     Interface   Metric 
0.0.0.0         0.0.0.0             10.1.1.250      10.1.1.3        1 
10.1.1.0        255.255.255.0       10.1.1.3        10.1.1.3        1 
10.1.1.3        255.255.255.255     127.0.0.1       127.0.0.1       1 
10.255.255.255  255.255.255.255     10.1.1.3        10.1.1.3        1 
127.0.0.0       255.0.0.0           127.0.0.1       127.0.0.1       1 
172.17.63.215   255.255.255.255     127.0.0.1       127.0.0.1       1 
224.0.0.0       224.0.0.0           10.1.1.3        10.1.1.3        1 
224.0.0.0       224.0.0.0           172.17.63.215   172.17.63.215   1 
255.255.255.255 255.255.255.255     10.1.1.3        10.1.1.3        1 
======================================================================= ==== 

Examinez l'adresse réseau dans chaque ligne de la table, où vous voyez que l'adresse de bouclage apparaît. Pour que les serveurs communiquent correctement, vous avez besoin d'une référence à une adresse réseau connue multicast. C'est dans le huitième ligne de l'exemple, ainsi vous devez supprimer le default-route supplémentaire. C'est celui dont l'adresse réseau commence par le même premier chiffre que l'adresse de batterie, et est suivi par trois zéros. Dans l'exemple ci-dessus, l'artère supplémentaire est dans la deuxième ligne.

Ce qui suit sont des adresses réseau connues multicasts :

224.0.0.0      224.0.0.0    172.17.63.215      172.17.63.215       1 

Ce qui suit sont des default route automatique-installés retirés de la table ci-dessus :

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.215       1

Vous devez supprimer l'artère supplémentaire pour permettre la bonne communication avec le serveur virtuel SLB.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 15055