Câble haut débit : Modems câble

Incapacité du CPE à se connecter

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document discute certaines des raisons les plus communes pour lesquelles la CPE (CPE) — comme le Windows 2000 courant PC ou un système d'exploitation semblable derrière un modem câble — ne peut pas obtenir une adresse IP ou ne peut pas se connecter à l'Internet. Le document emploie une approche d'organigramme pour vous mener par une gamme d'étapes dépanner le réseau du côté CPE ou du côté de Headend.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Comment CPEs obtiennent-ils une adresse IP ?

Après qu'un modem câble soit livré en ligne, le CPE derrière les essais de modem câble pour obtenir une adresse IP utilisant le processus du protocole DHCP (DHCP). Le client envoie typiquement une demande de protocole bootstrap (Protocole BOOTP) avec le positionnement d'option DHCP au DHCP LES DÉCOUVRENT, une adresse IP source de 0.0.0.0, et une adresse IP de destination de 255.255.255.255. Ce paquet est alors transmis par relais au serveur DHCP par le système de terminaison par modem câble (CMTS). Le paquet transmis par relais a l'adresse IP source de l'adresse IP secondaire configurée sur l'interface de câble, et a l'adresse IP de destination du serveur DHCP, comme spécifié par l'IP address de cable helper-address de commande (voyez la configuration d'échantillon ci-dessous).

Le serveur DHCP répond avec une OFFRE DHCP avec un certain nombre d'options, y compris « l'adresse IP serveur-assignée par client ». Ceci est transmis par relais de nouveau au CPE par le CMTS. Le CPE pourrait alors envoyer une REQUÊTE DHCP pour l'adresse IP assignée. La réponse est un DHCP ACK du serveur et du CPE utilisant l'adresse IP étant assignée. Pour observer cet échange, émettez les paquets de debug ip dhcp server commandent de recevoir la sortie semblable à cela qui est affichée ci-dessous.

CPE mac address: 0010.a4e6.d04d 
CPE assigned IP address: 192.168.50.3 
DHCP Server IP address: 172.17.110.137 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 
5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP DISCOVER.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP OFFER.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 

5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP REQUEST.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP ACK.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 

attention Attention : La commande de paquets de debug ip dhcp server peut entraîner la grave dégradation des performances si exécuté sur un CMTS occupé. Par conséquent, son utilisation est seulement recommandée dans un environnement de travaux pratiques.

Le processus ci-dessus ne pourrait pas fonctionner en tant qu'en raison désiré d'un certain nombre de facteurs, certains dont sont répertoriés ci-dessous.

  • PC incorrectement configuré

  • serveur DHCP incorrectement configuré

  • questions de modem câble

  • Paramètres de fichier de configuration de Data-over-Cable Service Interface Specifications (DOCSIS)

L'organigramme dans la section suivante met en valeur certains des facteurs les plus importants affectant la capacité du CPE de saisir des adresses IP. Il fournit également des étapes pour dépannage des essais ratés par CPE de saisir des adresses IP.

Dépannage de l'organigramme

Vous pouvez cliquer sur en fonction les cases vertes l'unes des pour aller la section correspondante.

cpe_no_connect_sm_1.gif

État de contrôle sur CMTS

Vous devez d'abord déterminer si le CPE a obtenu une adresse IP (voyez la section de configuration CPE de contrôle de ce document). Si une adresse IP n'a pas été assignée au CPE, confirmez que le modem câble est en ligne. Le CPE ne peut pas obtenir une adresse IP si le modem câble n'a pas été livré en ligne l'onlinecome.

Pour vérifier l'état sur CMTS, émettez la commande de show cable modem du CMTS. La sortie témoin de cette commande est affichée ci-dessous.

Sniper# show cable modem 
Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 1    offline    2291    0.00  2   0   10.50.50.4      0050.7366.2223
Cable2/0/U0 2    online     2814    0.25  5   0   10.50.50.5      0001.9659.4449
Cable2/0/U0 3    online     2813    0.50  5   0   10.50.50.2      0001.9659.4477

La colonne d'état en ligne ci-dessus affiche l'état du modem câble. Pour que le CPE obtienne avec succès une adresse IP et pour établit la Connectivité, le modem câble doit être dans un des états suivants :

  • En ligne

  • En ligne (pinte)

N'importe quel état autre que les deux indique ci-dessus que le modem câble ne s'est pas inscrit au CMTS et, en conséquence, le CPE ne peut pas obtenir une adresse IP.

Pour des informations exhaustives sur dépanner les états du modem câble possibles, référez-vous aux Modems câble d'ubr de dépannage n'étant pas livré en ligne.

Configuration CPE de contrôle

Windows 95 courant PC, 98, NT, ou les 2000 besoins d'avoir une pile TCP/IP qui est correctement installée et configurée afin d'obtenir une adresse IP.

Les copies d'écran témoin dans ce document affichent à un client le Windows 2000 courant. D'autres systèmes d'exploitation Windows ont les configurations semblables, cependant l'apparence des boîtes de dialogue et la commande émise pour accéder à la fenêtre de configuration IP peut différer.

Remarque: Cette section suppose que le PC client a un adaptateur Ethernet qui est correctement installé et configuré. Sinon, référez-vous à votre documentation du produit ou demandez au fournisseur de votre adaptateur l'assistance.

Pour vérifier l'adresse IP assignée au PC, utilisez la procédure suivante :

  1. Cliquez sur en fonction le Start > Run.

  2. Dans la fenêtre de passage, winipcfg de type.

    /image/gif/paws/15036/cpe_no_connect2.gif

  3. Cliquez sur OK

    La fenêtre de configuration IP apparaît.

    /image/gif/paws/15036/cpe_no_connect3.gif

    Remarque: S'il y a plus d'un adaptateur Ethernet installé dans le PC client, sélectionnez l'adaptateur connecté au modem câble utilisant la flèche déroulante de nom d'adaptateur.

    Du côté CMTS, vous pouvez vérifier que le CPE repose derrière quel modem câble et vérifiez l'adresse IP assignée au CPE en émettant la commande du modem z du câble d'interfaces d'exposition x/y. Les arguments de cette commande sont déterminés comme suit :

    • X est le nombre de linecard.

    • y est le numéro de port en aval.

    • z est l'indentifiant de service (SID) du modem câble.

      Vous pouvez placer z à 0 pour visualiser des détails au sujet de tous les Modems câble et le CPE sur une interface en aval particulière. Voyez la sortie de commande de show interface cable à la fin de la section de configuration d'échantillon de ce document.

    Si l'adresse IP est 0.0.0.0, alors le CPE n'a pas obtenu une adresse IP. Avant que vous poursuiviez à l'étape suivante, cliquez sur le bouton de renouveler pour essayer d'obtenir une adresse IP. Si le CPE ne peut pas obtenir une adresse IP, vous recevrez un IpReneweAddress avez manqué avec le message de l'erreur 2 dans le Windows 2000.

    Remarque: Dans le Windows 98, le CPE est parfois assigné une adresse IP commençant 169.254.n.n. Ce type d'adresse est une adresse IP « factice » que Windows assigne, et il indique qu'une adresse IP fonctionnante n'a pas été obtenue.

  4. Vérifiez que le CPE a une pile TCP/IP qui est correctement installée et configurée, comme affiché ci-dessous.

    1. Choisissez le Start > Settings > Network and Dial-up Connections > la connexion au réseau local.

    2. Dans l'écran de connexion au réseau local, clic Properties.

      La fenêtre de propriétés de la connexion locale apparaît.

      /image/gif/paws/15036/cpe_no_connect4.gif

    3. Assurez-vous que l'Internet Protocol (TCP/IP) est répertorié et sélectionné.

      Sinon, vous devez l'installer.

  5. Après s'être assuré qu'une pile TCP/IP est installée, vérifiez qu'il est correctement configuré, comme affiché ci-dessous.

    1. Dans la fenêtre de propriétés de la connexion locale, choisissez l'Internet Protocol (TCP/IP).

    2. Cliquez sur Properties.

      La fenêtre de Properties de l'Internet Protocol (TCP/IP) apparaît.

      /image/gif/paws/15036/cpe_no_connect5.gif

    3. Assurez-vous que l'obtenir une adresse IP automatiquement et obtenez les cases d'option d'adresse de serveur de DNS automatiquement sont sélectionnés.

      Remarque:  Pour vérifier la configuration TCP/IP sur d'autres types de clients — par exemple, CPE exécutant des systèmes d'exploitation UNIX — consultez votre documentation du produit.

MAX-CPE

En jetant un pont sur le mode, l'entrée du par défaut MAX-CPE dans le fichier de configuration DOCSIS est 1. Ainsi, seulement un CPE peut être connecté derrière le modem câble. Une nouvelle commande de configuration permet à CMTS pour spécifier un nombre maximal d'hôtes permis par modem (ignorant la valeur MAX-CPE dans le fichier de configuration DOCSIS). Cette commande est maximum-cpe de modem câble [n | illimité]. La plage valide pour n est de 1 à 254.

Pour plus d'informations sur cette commande et ses relations au MAX-CPE dans le fichier de configuration DOCSIS, référez-vous utilisant la commande maximum-cpe dans le DOCSIS et le CMTS.

Si le paramètre MAX-CPE dans le fichier de configuration DOCSIS est 0 et l'aucune commande maximum-cpe de modem câble n'est configurée sur le CMTS (par défaut) alors qu'aucun CPE peut obtenir des adresses IP.

Cisco Network Registrar

Vérifiez le suivant dans le Cisco Network Registrar (le CNR) :

  • Stratégies correctement configurées pour chaque CPE.

  • Portées à s'associer avec ces stratégies CPE.

  • L'espace d'adresse IP suffisant pour rendre service à tous les clients, au cas où tous les clients seraient livré en ligne en même temps.

  • Le serveur DHCP n'est pas surchargé.

  • Il y a une artère de retour du serveur DHCP à l'adresse réseau du CPE.

Pour plus d'informations sur configurer le CNR, référez-vous à la configuration de Cisco Network Registrar.

Pas utilisant le CNR

Si vous utilisez un serveur DHCP le non-CNR, assurez-vous qu'il est installé correctement selon la documentation de produit. Il devrait être configuré d'une manière dont est semblable à la section de Cisco Network Registrar ci-dessus.

Contrôle avec votre ISP

Si vous ne contrôlez pas l'affectation d'adresse IP — indépendamment de s'assurer que le modem câble est en ligne — vous devez vérifier avec votre ISP pour dépanner des problèmes de connexion CPE. Votre ISP a le contrôle de l'affectation d'adresse IP, et vous pourriez devoir leur fournir les adresses MAC utilisées par votre CPE.

Remarque: Si vous avez accès au CMTS puis vous pouvez visualiser et dépanner, que le modem soit en ligne ou pas. Référez-vous aux Modems câble d'ubr de dépannage n'étant pas livré en ligne. Autrement vérifiez l'état DEL sur votre Routeurs d'accès par câble de la gamme Cisco uBR900.

Adresse IP non assignée par ISP

Des adresses IP doivent être assignées par l'ISP par un serveur DHCP. Si votre adresse IP est assignée suivre une différente méthode — par exemple, configuration statique — vous devez vérifier la validité de l'adresse IP assignée avec votre ISP. Le manque de faire ainsi pourrait entraîner des interruptions du réseau à d'autres utilisateurs et manques d'établir la Connectivité.

Connectivité IP de contrôle

Si votre CPE est assigné une adresse IP valide par votre ISP mais vous ne pouvez pas encore établir la Connectivité, il y a une manière de vérifier la connectivité IP. D'abord, cinglez l'adresse IP du PC. Puis, cinglez chaque saut dans le réseau un par un, pour voir à quelle distance par le réseau vous pouvez accéder. Si les pings au reste des systèmes sur le réseau chronomètrent, vous devez contacter votre personnel de support ISP pour l'assistance.

Exemple de configuration

Cette configuration est basée sur la version de logiciel 12.1(5)T de Cisco IOSÝ.

write terminal

Sniper# write terminal

Building configuration...


Current configuration : 2472 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname Sniper
!
boot system flash slot0:ubr7200-ik1st-mz.121-5.T.bin
logging rate-limit console 10 except errors
enable password cisco
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
ip subnet-zero
no ip finger
no ip domain-lookup
!         
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.148 255.255.255.224
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Cable2/0
 ip address 192.168.50.1 255.255.255.0 secondary
 ip address 10.50.50.1 255.255.255.0
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 555000000
 cable upstream 0 frequency 30000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy
 cable helper-address 172.17.110.137
!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 no login
line vty 1 4
 exec-timeout 0 0
 no login
!
end

Sniper# 

affichez le câble d'interfaces

Sniper# show interfaces cable 2/0 modem 0
SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.50.50.5    dhcp      0001.9659.4449
8     00         host      unknown   192.168.50.3  dhcp      0010.a4e6.d04d
8     00         modem     up        10.50.50.2    dhcp      0001.9659.4477
9     00         modem     up        10.50.50.4    dhcp      0050.7366.2223

Sniper#

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes

État de contrôle sur CMTS Adresse IP non assignée par ISP Connectivité IP de contrôle CPE maximum Configuration CPE de contrôle Contrôle avec votre ISP Cisco Network Registrar Pas utilisant le CNR


Document ID: 15036