Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration du mode Données sur Voix (DoV) avec isdn incoming-voice data et dialer voice-call

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour configurer des données au-dessus de Voix (DoV) utilisant les données d'isdn incoming-voice et les commandes de dialer voice-call.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Version de logiciel 11.3 ou ultérieures de Cisco IOSÝ.

  • Vous pouvez utiliser n'importe quel routeur avec une interface RNIS. Cependant vous devez s'assurer que la compagnie de téléphone prend en charge DOV, et que là aucune corruption des données

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Les données au-dessus de la Voix (DOV) te permettent pour envoyer des données au-dessus d'une communication voix utilisant une ligne RNIS. Une ligne RNIS peut prendre en charge des appels et des communications voix de données. Deux Routeurs qui interconnectent avec des lignes RNIS typiquement utilisent des appels de données (des 64 Kbits/s ou 56 Kbps). On s'attend à ce que des communications voix soient générées par un téléphone ou une télécopie. Des communications voix peuvent également être générées par un périphérique connecté à un modem analogique (par exemple, un PC composant vers le haut d'utiliser une ligne de réseau téléphonique public commuté [POTS]).

Dans certaines circonstances, un utilisateur peut être intéressé à connecter deux Routeurs aux communications voix utilisant des lignes RNIS, particulièrement quand vu la différence de prix entre des données appelez et une communication voix. Les lignes RNIS ont généralement des frais de par-appel pour tous les appels (gens du pays, longue distance, et international).

Parfois la tarification des communications voix est inférieure à la tarification des appels de données. Pour que les Routeurs puissent communiquer utilisant des communications voix entre deux lignes RNIS, la configuration soigneuse est nécessaire pour mettre au courant les Routeurs que les appels doivent être initiés comme communications voix et que des communications voix entrantes devraient être traitées comme données appelle. Du côté (appelant) sortant, utilisez l'option de map-class de définir des appels comme communications voix :

nom de map-class dialer

dialer voice-call

Ce map-class définit un comportement et doit être appliqué aux interfaces RNIS où ce comportement est nécessaire. Voici un exemple du comportement de map-class sur la carte de numéroteur ou les commandes de chaîne de numéroteur.

numéro de téléphone de nom d'hôte de nom de classe de carte de classe d'adresses de dialer map protocol [émission]

classe de class map de numéro de téléphone de chaîne de numéroteur

Voyez la documentation du logiciel de Cisco IOS pour la syntaxe complète de ces deux commandes.

Du côté (appelé) d'arrivée, ajoutez la commande data d'isdn incoming-voice sous l'interface physique. Souvenez-vous que toutes les communications voix entrantes seront traitées comme appels de données. Si vous utilisez une plate-forme qui prend en charge des appels par modem sur BRIs, vous ne pouvez pas configurer une interface spécifique pour prendre en charge l'un ou l'autre de caractéristique. Une interface spécifique a pu manipuler des communications voix comme appels par modem ou des communications voix comme appels DOV, mais pas chacun des deux.

Remarque: Il est possible de configurer une interface spécifique pour traiter des communications voix car des appels par modem ou des communications voix comme appels DOV. Cependant, ceci exige de vous de configurer la Fonction Resource Pool Management (RPM). Pour plus d'informations sur le RPM, référez-vous au document suivant : Fonction Resource Pool Management.

Il est important de comprendre que DOV a limité la fiabilité. On s'attend à ce qu'un appel entre deux lignes RNIS fournisse un chemin numérique de bout en bout. Le matériel, les lignes, et d'autres ressources que l'opérateur téléphonique l'utilise pour installer des données et des communications voix sont habituellement identique. Cependant, ils peuvent être différents. Le transport de la voix numérique est plus flexible que le transport des données. Pour des appels de données RNIS, le réseau téléphonique garantit le transport de bit le long de l'les 64 Kbits/s ou le chemin numérique de 56 Kbps. Pour des communications voix, le réseau téléphonique peut conduire et manipuler le flux de bits dans différentes manières sans affecter la Qualité vocale, mais toutes les données sont corrompues une fois envoyées de cette façon. Par conséquent, DOV ne fonctionne pas avec quelques lignes RNIS. Vérifiez que votre compagnie de téléphone peut traiter des appels DOV avant que vous configuriez cette caractéristique, autrement l'établissement d'appel peut succeeed mais des données de tht seront corrompues.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/14964/briipun.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

Routeur 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.10.186.133 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5556700 class DOV

! --- The router will use the map-class DOV when dialing this number
! --- The map-class named DOV is defined below

 dialer load-threshold 5 outbound
 dialer-group 1
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
map-class dialer DOV

! --- map class named DOV is applied to the dialer string under 
! --- the physical interface

 dialer voice-call

! --- Outgoing call is treated as a voice call

!
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Routeur 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 isdn incoming-voice data

! --- Incoming voice calls will be treated as data calls
! --- An interface cannot accept modem calls and DOV calls without RPM

 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.186.129
ip route 10.10.186.128 255.255.255.240 BRI0
no ip http server

dialer-list 1 protocol ip permit

line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • état de show isdn - L'état devrait être :

    layer 1 = active 
    layer 2 = MULTIPLE_FRAMES_ESTABLISHED

    Si la couche 1 n'est pas en activité, alors l'adaptateur ou le port de câblage peut être mauvais ou non branché. Si la couche 2 est dans un état de TEI_Assign, alors le routeur ne parle pas au commutateur. Référez-vous utilisant la commande d'état de show isdn pour le dépannage BRI pour plus d'informations sur des connexions RNIS de dépannage

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • mettez au point le numéroteur - Pour afficher les informations au sujet de la cause de tout appel. Ceci primarilty serait utilisé pour déterminer si le routeur initiait l'appel.

  • debug isdn q931 - Pour vérifier des connexions RNIS comme utilisateurs connectez-vous pour voir ce qui se produit avec l'appel RNIS (par exemple, si la connexion est abandonnée). Vous pouvez également vérifier la capacité du support (qui indique si l'appel est numérique ou Voix) de cette sortie de débogage.

  • nego de debug ppp - Pour voir si les détails de la négociation PPP.

  • debug ppp chap - Pour vérifier l'authentification.

Sortie de débogage

La sortie suivante de debug isdn q931 affiche l'appel se connectant utilisant DOV. maui-soho-01 (le client) compose maui-nas-08 (le serveur). Notez la capacité du support des appels pour indiquer qu'ils sont des communications voix, comme prévu. maui-nas-08 est configuré pour traiter des communications voix entrantes comme des données appelle (par opposition aux appels par modem) et l'appel est connecté.

maui-soho-01#ping 10.8.186.134 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.8.186.134, timeout is 2 seconds:
Aug 17 15:48:12.523: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x03

! --- Setup message for outgoing call

Aug 17 15:48:12.531:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.543:         Channel ID i = 0x83
Aug 17 15:48:12.550:         Keypad Facility i = '5556700'
Aug 17 15:48:12.908: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x83

Aug 17 15:48:12.916:         Channel ID i = 0x89

Aug 17 15:48:12.927:         Locking Shift to Codeset 5
Aug 17 15:48:12.931:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098001, '<'
Aug 17 15:48:13.130: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x83

! --- maui-nas-08 has accepted the call and responded with the 
! --- CONNECT message

Aug 17 15:48:13.142:         Locking Shift to Codeset 5
Aug 17 15:48:13.150:         Codeset 5 IE 0x2A  i = 0x808001038308, 
'555-6700', 0x8001098909, 'Connected', 0x80010B8001, '('
Aug 17 15:48:13.217: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up.
Aug 17 15:48:13.249: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x03
Aug 17 15:48:14.372: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up
Aug 17 15:48:19.185: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5556700

Ce qui suit met au point est obtenu du maui-nas-08 (serveur). Notez que la capacité du support indique que le l'appel est une communication voix. Le NAS a été configuré pour traiter des communications voix entrantes pendant que les données font appel à cette interface.

maui-nas-08#
Aug 17 15:48:12.765: ISDN BR2/0: RX <-  SETUP pd = 8  callref = 0x13

! --- Setup message for incoming call

Aug 17 15:48:12.765:         Bearer Capability i = 0x8090A2

! --- Bearer Cap indicates that the call is a Voice call(u-law)
! --- An ISDN digital call would be indicated with 0x8890 (for 64k) 
! --- or 0x8890218F (for 56k)

Aug 17 15:48:12.765:         Channel ID i = 0x89
Aug 17 15:48:12.765:         Signal i = 0x40 - Alerting on - pattern 0 
Aug 17 15:48:12.765:         Called Party Number i = 0xC1, '5556700', 
Plan:ISDN, Type:Subscriber(local)
Aug 17 15:48:12.765:         Locking Shift to Codeset 5
Aug 17 15:48:12.765:         Codeset 5 IE 0x2A  i = 0x808001038001118001, '<'

Aug 17 15:48:12.769: ISDN BR2/0: Event: Received a DATA call from  
on B1 at 64 Kb/s

! --- The incoming voice call (on int bri 2/0) is treated as a data call
! --- This is configured (in interface config mode) using 
! --- isdn incoming-voice data

Aug 17 15:48:12.769: ISDN BR2/0: TX ->  CALL_PROC pd = 8  callref = 0x93
Aug 17 15:48:12.773:         Channel ID i = 0x89
Aug 17 15:48:12.773: %LINK-3-UPDOWN: Interface BRI2/0:1, changed state to up
Aug 17 15:48:12.773: BR2/0:1 PPP: Treating connection as a callin
Aug 17 15:48:12.773: BR2/0:1 PPP: Phase is ESTABLISHING, Passive Open
Aug 17 15:48:12.773: BR2/0:1 LCP: State is Listen
Aug 17 15:48:13.073: ISDN BR2/0: TX ->  CONNECT pd = 8  callref = 0x93

! --- The call is accepted and nas-08 responds with the CONNECT message

Aug 17 15:48:13.073:         Channel ID i = 0x89
Aug 17 15:48:13.121: ISDN BR2/0: RX <-  CONNECT_ACK pd = 8  callref = 0x13


! ---Output omitted

...

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14964