Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Connexion BRI-PRI en mode données sur voix

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour TData au-dessus de la Voix (DOV), qui permet des données à envoyer au-dessus d'une communication voix avec une ligne RNIS.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Version de logiciel 12.0 de Cisco IOS

  • Cisco 5300 avec quatre accès primaires (PRIs)

  • Cisco 2503 avec un accès de base (BRI)

  • L'adresse Internet de chaque côté

  • Un mot de passe pour l'authentification de PPP

  • Numéros de téléphone des lignes RNIS

  • Les adresses IP des interfaces Ethernet des deux côtés

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

DOV permet des données à envoyer au-dessus d'une communication voix avec une ligne RNIS. Une ligne RNIS peut prendre en charge des appels et des communications voix de données. Deux Routeurs qui interconnectent avec des lignes RNIS typiquement utilisent des appels de données (64 kpbs ou 56 Kbps). On s'attend à ce que des communications voix soient générées par un téléphone ou une télécopie. Des communications voix peuvent également être générées par un périphérique connecté à un modem analogique, par exemple, un PC ce des appels avec une ligne de réseau téléphonique public commuté (POTS).

Dans certaines circonstances, un utilisateur peut connecter deux Routeurs aux communications voix avec des lignes RNIS, particulièrement quand la différence de prix entre des données appellent et une communication voix est considérée. Les lignes RNIS ont généralement des frais de par-appel pour tous les appels : gens du pays, longue distance, et international. Parfois, le coût de communications voix est inférieur au coût d'appels de données.

Pour que les Routeurs communiquent avec des communications voix entre deux lignes RNIS, la configuration soigneuse est nécessaire pour mettre au courant les Routeurs que les appels doivent être initiés comme communications voix et que des communications voix d'arrivée doivent être traitées comme données appelle. Du côté (appelant) sortant, utilisez l'option de map-class de définir des appels comme communications voix :

nom de map-class dialer

dialer voice-call

Ce map-class définit un comportement et doit être appliqué aux interfaces RNIS où ce comportement est nécessaire. Voici un exemple du comportement de map-class sur la carte de numéroteur et les commandes de chaîne de numéroteur :

numéro de téléphone de nom d'hôte de nom de classe de carte de classe d'adresses de dialer map protocol [émission]

classe de class map de numéro de téléphone de chaîne de numéroteur

Référez-vous à la documentation du logiciel de Ý de Cisco IOS pour la syntaxe complète de ces deux commandes.

Du côté (appelé) d'arrivée, ajoutez la commande data d'isdn incoming-voice sous l'interface Serial<n>:23. Souvenez-vous que toutes les communications voix d'arrivée sont traitées pendant que les données appellent. Si vous voulez également prendre en charge des appels par modem sur la même ligne RNIS, utilisez la caractéristique du Resource Pool Manager (RPM) ; autrement, vous pouvez séparer ces deux services dans deux lignes RNIS différentes avec différents numéros de téléphone. Les problèmes se posent si les deux lignes ont le même nombre ; ils font partie d'un groupe de recherche. Une interface spécifique peut manipuler des communications voix comme appels par modem ou des communications voix comme appels de donnée-au-dessus-Voix, mais pas chacun des deux.

Il est important de comprendre que DOV a limité la fiabilité. On s'attend à ce qu'un appel entre deux lignes RNIS fournisse un chemin numérique de bout en bout. Le matériel, les lignes, et d'autres ressources que l'opérateur téléphonique l'utilise pour installer des données et des communications voix sont habituellement identiques, mais eux peut être différent. Le transport de la voix numérique est plus flexible que le transport des données. Pour des appels de données RNIS, le réseau téléphonique garantit le transport de bit le long de l'les 64 Kbits/s ou le chemin numérique de 56 Kbps. Pour des communications voix, le réseau téléphonique peut conduire et manipuler le flux de bits dans différentes manières pourtant pas Qualité vocale d'affect. Puisque toutes les données sont corrompues une fois envoyées de cette façon, DOV ne fonctionne pas avec quelques lignes RNIS.

Configurez

Cette configuration emploie Cisco 5300 avec quatre accès primaires (PRIs) pour terminer les appels et Cisco 2503 avec un accès de base (BRI) pour initier les appels. Cisco 5300 fournit le support pour 48 appels DOV, 48 appels par modem, et 96 appels de données. Les deux premiers PRIs sont configurés pour traiter des communications voix comme données, et les deux derniers sont configurés pour traiter des communications voix comme appels par modem. Un nom d'utilisateur et mot de passe doit être configuré pour chaque utilisateur qui se connecte. Cette configuration n'utilise pas le Terminal Access Controller Access Control System (TACACS+) ou le Service RADIUS (Remote Authentication Dial-In User Service).

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14962/britopri_dov.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur 1
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
aaa new-model
AAA authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default if-needed local
enable password somethingSecret
!
username santiago password 0 letmein
username Router2 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type primary-5ess
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 3
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Ethernet0
 ip address 10.10.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial0:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial1:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice data
!
interface Serial2:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface Serial3:23
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer rotary-group 2
 dialer-group 1
 isdn switch-type primary-5ess
 isdn incoming-voice modem
!
interface FastEthernet0
 ip address 10.10.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Group-Async1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 async mode interactive
 ip tcp header-compression passive
 peer default ip address pool IPaddressPool
 no cdp enable
 ppp authentication chap
 group-range 1 48
 !
interface Dialer1
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool IPaddressPool
 ppp authentication chap
!
ip local pool IPaddressPool 10.10.10.1 10.10.10.254
ip classless
ip route 10.8.186.128 255.255.255.240
no ip http server
!
line con 0
 login authentication CONSOLE
 transport input none
line 1 48
 autoselect during-login
 autoselect ppp
 modem Dialin
line aux 0
line vty 0 4
!
end

Routeur 2
!
version 12.0
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router2
!
aaa new-model
aaa authentication login default local
aaa authentication login CONSOLE none
aaa authentication ppp default local
enable password somethingSecret
!
username Router1 password 0 open4me2
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 10.8.186.134 255.255.255.240
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 ip unnumbered Ethernet0
 no ip directed-broadcast
 encapsulation ppp
 dialer string 5555700 class DOV
 dialer load-threshold 5 outbound
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
!
!
map-class dialer DOV
 dialer voice-call
dialer-list 1 protocol ip permit
!
line con 0
 login authentication CONSOLE
 transport input none
line aux 0
line vty 0 4
!
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Utilisez cette section pour dépanner votre configuration.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • mettez au point le numéroteur — Affiche des informations qui concerne la cause de n'importe quel appel

  • debug isdn q931 — Les connexions RNIS de contrôles comme utilisateurs se connectent pour voir ce qui se produit avec l'appel RNIS, par exemple, si la connexion est abandonnée

  • nego de debug ppp — Voit les détails de la négociation PPP

  • debug ppp chap — Vérifie l'authentification

  • état de show isdn — L'état doit être ceci :

    layer 1 = active 
        layer 2 = MULTIPLE_FRAMES_ESTABLISHED 

    Si la couche 1 n'est pas en activité, l'adaptateur ou le port de câblage peut être mauvais ou non branché. Si la couche 2 est dans un état de TEI_Assign, le routeur ne parle pas au commutateur.

  • utilisateur d'exposition — Affiche des utilisateurs d'asynchrone/synchrone actuellement connectés

  • show dialer map — Après qu'une connexion RNIS soit établie, elle voit si un profil d'appel dynamique était créé. Sans carte de numéroteur, vous ne pouvez pas conduire des paquets.

Dépannage de modem

  • debug modem — Voit si le routeur reçoit les bons signaux du modem interne

  • debug modem csm — Active la gestion de modems que le module de commutation d'appel (CSM) mettent au point le mode

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14962