Optique : Commutation de protection automatique (APS )

Configuration de la redondance pour POS/APS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document discute la caractéristique de Fonction Automatic Protection Switching (APS) et fournit un exemple de la façon configurer des aps pour la Redondance de Paquet sur SONET (POS).

Ce document te permet de comprendre comment les aps fonctionne, et vous aide à configurer et mettre à jour des aps sur des Routeurs de Cisco. La topologie de réseau dans la figure 1 est la base de ce document :

Figure 1 ? Topologie de réseau

pos-aps_14680-a.gif

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Réseau optique synchrone (SONET) et Technologies de POS.

  • Fondements de configuration de routeur Cisco.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.0(10)S de Cisco IOSÝ.

  • Plates-formes matérielles de gamme Cisco 12000.

Le soutien de la caractéristique aps est disponible sur les plates-formes matérielles de gammes Cisco 7500 et 12000, et sur le Logiciel Cisco IOS version 12.2(5) et plus tard.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Commutation automatique de protection

La caractéristique aps fournit la Redondance et tient compte d'un basculement des circuits de POS en cas de la panne de circuit. L'implémentation des aps te permet pour configurer une paire de lignes SONET pour la ligne Redondance. Quand l'interface du fonctionnement (w) échoue, l'interface de la protection (p) assume rapidement la charge de la circulation. En cas d'une coupe de fibre, la ligne active commute automatiquement à la ligne de réserve à moins de 60 basculement de millisecondes (initiation de 10 millisecondes et 50 millisecondes). SONET aps exécute des basculements à la couche 1 (L1). Par conséquent, le basculement est sensiblement plus rapide qu'à la couche 2 (L2) ou à la couche 3 (L3).

Le mécanisme de protection que cette caractéristique utilise a l'architecture 1+1, comme décrit dans la publication TR-TSY-000253 de Bellcore, des systèmes de transport SONET, des critères génériques communs, la section 5.3. SONET aps est conforme à GR-253 et à ITU-T G.783. Par conséquent, SONET aps permet à des Routeurs de Cisco pour intégrer sans faille avec des Multiplexeurs d'ajout/d'extraction SONET (ADMs). Cette caractéristique permet la configuration de la commutation bidirectionnelle ou unidirectionnelle, mais la commutation non-de retour bidirectionnelle est le par défaut.

En architecture aps 1+1, chaque paire de lignes redondant se compose d'une interface W et d'une interface P. Les interfaces W et P sont connectées à un SONET ADM, qui envoie la même charge utile de signal aux interfaces W et P. Les circuits W et P peuvent se terminer en deux ports du même adaptateur, linecard, ou dans des deux Routeurs différents. Quand un état de l'échouer de signal (SF) ou un état de la dégradation de signal (écart-type) se produit, le matériel commute de la ligne W à la ligne P. Il y a une option de retour. À la découverte d'un état SF, le matériel commute de nouveau à la ligne W automatiquement après que la réparation de la ligne W, et au passage d'une période configurée. L'intrabande protègent le groupe que Protocol (PGP) réalise la coordination entre la ligne W et la ligne P. Dans l'option non-de retour, si un état SF se produit, les Commutateurs de matériel à la ligne P et ne retournent pas automatiquement à la ligne W.

Sur le circuit P, les octets K1/K2 de la ligne le temps système (LOH) de la trame SONET indiquent l'état actuel de la connexion aps, et donnent toutes les demandes d'action. Les deux extrémités de la connexion utilisent ce canal de signalisation pour mettre à jour la synchronisation. W et le P se fait le tour, chez le routeur ou les Routeurs en lesquels ils se terminent, sont synchronisés au-dessus d'une voie de transmission indépendante (utilisant le PGP aps), d'isolement dans les circuits W et P. Ce canal indépendant peut être une connexion différente SONET, Ethernet, ou une connexion de bas-bande passante. Dans un routeur configuré pour des aps, la configuration pour l'interface P inclut l'adresse IP du routeur (normalement et recommandé d'être l'adresse de bouclage) qui a l'interface W.

Le PGP aps, qui fonctionne sur le Protocole UDP (User Datagram Protocol), fournit la transmission entre le processus qui contrôle l'interface W et le processus qui contrôle l'interface P. Le processus qui contrôle le circuit P emploie ce protocole pour diriger le processus qui contient le circuit W, en fonction si lancer ou désactiver le circuit W, dans le cas de la dégradation, de la perte de signal de canal, ou de l'intervention manuelle. Si les deux processus perdent la transmission les uns avec les autres, le routeur W assume le plein contrôle du circuit W comme si aucun circuit P n'a existé.

Aps et commandes relatives

Voici les déclencheurs aps classés par catégorie hiérarchiquement (de la priorité la plus basse à plus prioritaire) :

  • Demande de commutateur manuel.

  • État écart-type (taux d'erreurs sur les bits (JUJUBE) dépassant le seuil écart-type).

  • État SF (perte de trame (LOF), perte de signal (visibilité directe), Signal-Line d'indication d'alarme (AIS-L), et une ligne JUJUBE qui dépasse l'utilisateur-provisionable 10-3/or).

  • Demande obligatoire de commutateur.

Voici les options IOS de configurer des aps :

GSR(config-if)# aps ?
authentication  Authentication string 
force           Force channel 
group           Group association 
lockout         Lockout protection channel 
manual          Manually switch channel 
protect         Protect specified circuit 
reflector       Configure for reflector mode APS 
revert          Specify revert operation and interval 
signaling      Specify SONET/SDH K1K2 signaling 
timers          APS timers 
unidirectional  Configure for unidirectional mode 
working         Working channel number 

En plus des nouvelles commandes IOS pour la caractéristique aps, les commandes de configuration d'interface de POS pos threshold et le pos report ont été ajoutés pour prendre en charge la configuration utilisateur des seuils de JUJUBES et de l'enregistrement des alarmes SONET. Voici un exemple de sortie :

GSR(config-if)# POS threshold ? 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  sd-ber  set Signal Degrade BER threshold 
  sf-ber  set Signal Fail BER threshold 

GSR(config-if)# POS report ?
  all     all Alarms/Signals 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  lais    Line Alarm Indication Signal 
  lrdi    Line Remote Defect Indication 
  pais    Path Alarm Indication Signal 
  plop    Path Loss of Pointer 
  prdi    Path Remote Defect Indication 
  rdool   Receive Data Out Of Lock 
  sd-ber  LBIP BER in excess of SD threshold 
  sf-ber  LBIP BER in excess of SF threshold 
  slof    Section Loss of Frame 
  slos    Section Loss of Signal 

Modes de changement

En mode bidirectionnel, la réception (Rx) et transmettent des canaux (de Tx) sont commutées comme paire. En mode unidirectionnel, les canaux de Tx et de Rx sont commutés indépendamment. Par exemple, en mode bidirectionnel, si le canal de Rx sur l'interface W a une perte de signal de canal, les canaux de Rx et de Tx sont commutés.

(recommandé) bidirectionnel de mode

Le routeur W identifie la panne et informe le routeur P (par le PGP local d'interconnexion). Le routeur P instruit le routeur W désélectionner l'interface W (par le PGP local d'interconnexion). Le routeur P invite l'ADM pour commuter Tx et Rx à P (par octets K1/K2 sur l'interface P qui vont à l'ADM). Le routeur P sélectionne l'interface P et l'ADM est conforme à la demande de commutateur et signale la conformité (par octets K1/K2 sur ADM à la fibre d'interface P).

Mode unidirectionnel

Quand il y a une alarme LOS/LOF (panne) sur W Rx, le routeur W identifie la panne et informe le routeur P (par le PGP local d'interconnexion). Le routeur P instruit le routeur W désélectionner l'interface W (par le PGP local d'interconnexion). Le routeur W affirme une ligne le signal d'indication d'alarme (LAIS) pour tant que l'interface W est désélectionnée pour forcer l'ADM pour commuter le Rx à l'interface P. Le routeur P invite l'ADM pour commuter à l'interface P (par octets K1/K2 sur l'interface P à la fibre ADM). Le routeur P sélectionne l'interface P et l'ADM est conforme à la demande de commutateur.

En mode unidirectionnel, le routeur contraint l'ADM pour commuter. Afin de faire ainsi, le routeur affirme LAIS (constamment, si sur W ; momentanément, si sur P). Par conséquent, l'unidirectionnel que vous voyez est tout à fait vrai, parce que le mode unidirectionnel est conforme à GR-253. Cependant, ce que l'unidirectionnel fait également est, pour forcer un deuxième commutateur unidirectionnel, qui fait le commutateur sembler être bidirectionnel. C'est le résultat des contraintes qui sont profondément incluses dans les mécanismes de routage (IP), qui supposent à chaque niveau que le trafic doit avoir Rx et Tx sur la même interface. En résumé, le routeur se conforme aux protocoles unidirectionnels dans GR-253, mais force la commutation dans un modèle qui prend en charge l'IP. Par conséquent, le routeur ne prend en charge pas Tx et Rx sur différentes paires de fibre.

Remarque: Une déviation importante de la gamme Cisco 12000 de GR-253 est que la gamme Cisco 12000 ne jette pas un pont sur transmet à W et à P, mais garde un active d'interface à la fois.

Scénarios de base

Fonctionnant l'interface à la fibre ADM échoue

L'ADM voit la panne de fibre et envoie la DEMANDE de COMMUTATEUR SF au routeur P (par des octets K1/ K2 sur la fibre d'interface P), et demande un commutateur à l'interface P. Le routeur P instruit le routeur W désélectionner (désactiver) l'interface W (par l'interconnexion locale). Le routeur P sélectionne (lance) l'interface P. Le routeur P informe l'ADM de la conformité à la demande de commutateur (par des octets K1/ K2 sur la fibre d'interface ADM P).

ADM à fonctionner la fibre d'interface échoue (le mode bidirectionnel)

Le routeur W identifie la panne et informe le routeur P (par l'interconnexion locale). Le routeur P instruit le routeur W désélectionner l'interface W (par l'interconnexion locale). Le routeur P invite ADM pour commuter Tx et Rx à P (par octets K1/K2 sur l'interface P à la fibre ADM). Le routeur P sélectionne l'interface P et ADM est conforme aux demandes de commutateur et signale la conformité (par octets K1/K2 sur ADM à la fibre d'interface P).

ADM à fonctionner la fibre d'interface échoue (le mode unidirectionnel)

Le routeur W identifie la panne et informe le routeur P (par l'interconnexion locale). Le routeur P instruit le routeur W désélectionner l'interface W (par l'interconnexion locale). Le routeur W affirme un LAIS pour 100 ms pour forcer l'ADM pour commuter le Rx à l'interface P. Le routeur P invite ADM pour commuter à l'interface P (par octets K1/K2 sur l'interface P à la fibre ADM). Le routeur P sélectionne l'interface P et l'ADM est conforme à la demande de commutateur.

Fibres de Tx et de Rx entre fonctionner l'échouer d'interface et de liens ADM

Les deux ordres commencent. Si le routeur P initie d'abord le commutateur à P, ou l'ADM initie le commutateur n'importe pas, parce que le résultat est identique.

les Routeurs POS-équipés de Cisco agissent en tant que matériel de terminal (TE) pour la section de la hiérarchie SONET/Synchronous Digital (SDH), la ligne, et les segments de chemin d'un lien, et peuvent détecter et signaler ces erreurs et alarmes SONET/SDH :

  • Section : Visibilité directe, LOF, et alarmes de croisement de seuil (ACIDE TRICHLORACÉTIQUE) (B1)

  • Ligne : AIS (ligne et chemin), indication distante de défaut (RDI) (ligne et chemin), indication d'erreur distante (REI), ACIDE TRICHLORACÉTIQUE (B2)

  • Chemin : AIS, RDI, REI, (B3), nouveaux événements de pointeur (NEWPTR), événement de bourrage positif (PSE), événement de bourrage négatif (NSE)

D'autres informations signalées incluent :

  • SF-jujubes

  • Écart-type-jujubes

  • C2 - étiquette de signal (construction de charge utile)

  • J1 - octet de suivi de chemin

B1, B2, et B3 sont classés par catégorie comme paramètres de contrôle de la performance, alors que d'autres tel que la chute visibilité directe, LOF, et LAIS sous des alarmes. La supervision des performances concerne pour avancer des alertes, alors que les alarmes indiquent des pannes. L'état de l'octet K1/K2 est également signalé pour le chemin de commutation interarmées SONET aps ou SDH (FSG).

Octets K1/K2

Quand vous discutez des aps, vous le premier besoin de comprendre comment le SONET utilise les octets K1/K2 dans le LOH.

Chaque transport synchrone Signal-1 (STS-1) se compose de 810 octets, qui inclut 27 octets pour les octets supplémentaires (TOH) et 783 de transport pour l'enveloppe synchrone de charge utile (SPE). Le tableau 1 montre le format d'une trame STS-1 et les 9 lignes par 90 colonnes.

Tableau 1 ? Format d'une trame STS-1

Chemin supplémentaire
Section supplémentaire Tramage A1 Tramage A2 Tramage A3 Suivi J1
B1 BIP-8 Circuit de service d'E1 Utilisateur d'E1 B3 BIP-8
COM des données D1 COM des données D2 COM des données D3 Étiquette du signal C2
Ligne aérienne Pointeur H1 Pointeur H2 Action du pointeur H3 État du chemin G1
B2 BIP-8 K1 K2 La Manche de l'utilisateur F2
COM des données D4 D5 Data Com COM des données D6 Indicateur H4
COM des données D7 COM des données D8 COM des données D9 Croissance Z3
COM des données D10 COM des données D11 COM des données D12 Croissance Z4
État/croissance du sync S1/Z1 M0 ou croissance M1/Z2 REI-L Circuit de service E2 Connexion en tandem Z5

Les octets K1/K2 forment un champ de 16 bits. Le tableau 2 répertorie l'utilisation de chaque bit.

Tableau 2 ? Descriptions du bit K1

Bits (hexa) Description
K1 bits 12345678
Bits 5 à 8
NNNN Numéro de canal associé avec le code opération.
Bits 1 à 4
1111 (0xF) Verrouillage de demande de protection.
1110 (0xE) Demande obligatoire de commutateur.
1101 (0xD) SF - demande prioritaire.
1100 (0xC) SF - demande de faible priorité.
1011 (0xB) Écart-type - demande prioritaire.
1010 (0xA) Écart-type - demande de faible priorité.
1001 (0x9) Non utilisé.
1000 (0x8) Demande de commutateur manuel.
0111 (0x7) Non utilisé.
0110 (0x6) Attente pour restaurer la demande.
0101 (0x5) Non utilisé.
0100 (0x4) Demande d'exercice.
0011 (0x3) Non utilisé.
0010 (0x2) Renversez la demande.
0001 (0x1) Ne retournez pas la demande.
0000 (0x0) Aucune demande.

Remarque: 1 mordu est le bit de poids faible.

Tableau 3 ? Descriptions des bits K2

Bits Description
K2 bits 12345678  
Bits 1 à 4  
NNNN Numéro de canal associé avec le code opération.
5 mordus  
1 Un à l'architecture n (1:n).
0 Un plus une (1+1) architectures.
Bits 6 à 8  
111 Ligne AIS.
110 Ligne RDI.
101 Mode de fonctionnement bidirectionnel.
100 Mode de fonctionnement unidirectionnel.
Autre Réservé.

Remarque: Dans K2 (12345678) :

  • K2[1-4] ? Numéro de canal actuellement traversier.

  • K2[5] ? Architecture (toujours 0 pour 1+1).

  • K2[6-8] ? Mode de fonctionnement Provisioned (4 = unidir ; 5 = bidir).

  • K2[6-8] ? Porte également le code 6=LRDI et 7=LAIS d'alarme.

Remarque: Dans le SDH, K2[6-8] porte seulement les codes d'alarme. Le mode de fonctionnement n'est pas envoyé.

Remarque: Par exemple, quelles sont les valeurs pour K1 et K2 correspondant sur W si le routeur reçoit un SF ? Du côté P ?

Remarque:  Réponse : Seulement le P transmet et lit K1/K2, jamais le W. En mode bidirectionnel, si W reçoit un SF, et aucune demande plus élevée l'acquiert, le code de P à l'ADM est :

K1= 0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x05 (protect bridged [working bridge is incomplete];bidirectional)

Remarque: Après les réponses ADM :

K1 = 0x21 (Reverse request, channel 1) 
K2 = 0x15 (Working bridged; bidirectional)

Remarque: Le txk1k2 du routeur de protection sera :

K1=0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x15 (working bridged; bidirectional) 

Remarque: En ce moment, le commutateur est complet.

Configurez les aps

La figure 2 affiche une configuration de base aps 1+1 d'un GSR à un ADM (ONS 15454) dans le mode bidirectionnel, non-de retour (par défaut sur la gamme Cisco 12000). Les aps est commuté Linéaire, et est faits sur niveau à corde (entre la gamme Cisco 12000 et l'ADM contre le chemin ou de bout en bout).

Remarque: Cet exemple n'a pas un canal indépendant pour le PGP parce que les interfaces W et P sont sur le même routeur.

Figure 2 ? Une configuration de base aps 1+1

pos-aps_14680-a.gif

gsrA# show running-config
! 
interface Loopback0 
ip address 100.1.1.1 255.255.255.0 
no ip directed-broadcast 
! 
interface POS1/0 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS1/1 
ip address 10.1.1.3 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 100.1.1.1
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 100.1.1.0 0.0.0.255 area 0 

gsrB#show running-config 
! 
interface Loopback0 
ip address 200.1.1.1 255.255.255.0 
! 
interface POS3/0
ip address 10.1.1.2 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS3/1 
ip address 10.1.1.4 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 200.1.1.1 
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 200.1.1.0 0.0.0.255 area 0 
! 

Surveillez et mettez à jour les aps

Afin de fournir des informations au sujet des processus de système, le logiciel IOS inclut une liste étendue de commandes EXEC qui commencent par l'exposition de mot. Quand vous exécutez ces commandes show, les tableaux détaillés des informations système apparaissent. Voici une liste de certaines des commandes show communes pour la caractéristique aps, avec des sorties témoin :

  • show aps

  • show controllers pos

  • affichez l'interface pos

! 
gsrA# show aps
POS1/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x20 0x05 
Reverse Request (protect) 
Transmitted K1K2: 0xE0 0x05 
Forced Switch (protect) 
Working channel 1 at 100.1.1.1 (Enabled) 
Pending local request(s): 
0x0E (No Request, channel(s) 0 1) 
Remote APS configuration: working 
POS1/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 100.1.1.1 
Remote APS configuration: working 

gsrA# show controllers POS 1/0
POS1/0 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active) 

!--- Ensure that the working channel is active.

COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00    
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show controllers POS 1/1 
POS1/1 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 20/05 Tx(K1/K2): E0/05    
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show interface p1/0 
POS1/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrA# show interface p1/1 
POS1/1 is up, line protocol is down  (APS protect - inactive) 

! 
gsrB# show aps
POS3/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x00 0x05 
No Request (Null) 
Transmitted K1K2: 0x00 0x05 
No Request (Null) 
Working channel 1 at 200.1.1.1 (Enabled) 
Remote APS configuration: working 
POS3/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 200.1.1.1 
Remote APS configuration: working 
! 
gsrB# show controllers p 3/0
POS3/0 
SECTION 
LOF = 11         LOS    = 11                           BIP(B1) = 
46701837 
LINE 
AIS = 10         RDI    = 11         FEBE = 1873       BIP(B2) = 8662 
PATH 
AIS = 14         RDI    = 27         FEBE = 460909     BIP(B3) = 
516875 
LOP = 0          NEWPTR = 11637      PSE  = 2          NSE     = 16818 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active)

!--- Verify whether the working channel is active.

COAPS = 103        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 11 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB# show controllers p 3/1 
POS3/1 
SECTION 
LOF = 10         LOS    = 10                           BIP(B1) = 
250005115 
LINE 
AIS = 11         RDI    = 8          FEBE = 517        BIP(B2) = 5016 
PATH 
AIS = 14         RDI    = 25         FEBE = 3663       BIP(B3) = 7164 
LOP = 0          NEWPTR = 184        PSE  = 1          NSE     = 247 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 538        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/05 Tx(K1/K2): 00/05 
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 10 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB#show interface p3/0 
POS3/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrB#show interface p3/1 
POS3/1 is up, line protocol is down  (APS protect - inactive) 
! 

Dépannez les aps

Afin de dépanner des problèmes avec des aps, collectez la sortie des ces des commandes d'exposition et de débogage :

  • affichez le ver

  • affichez le passage

  • show ip international b

  • affichez le POS de contr

  • mettez au point les aps

  • show aps

Exécutez les actions nécessaires de recréer le problème. Émettez ces commandes de collecter la sortie finale et d'arrêter le débogage :

  • show aps

  • aucun mettez au point les aps

Remarque: Le dans des conditions normales, la commande du débogage aps ne produit aucune sortie. Quand une anomalie se produit, des états de cette commande l'état.

Remarque: Si les fibres W et P sont dans différents Routeurs (pendant qu'elles sont habituellement), vous devez collecter les sorties de commande sur les deux Routeurs.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14680