Composition et accès : Routage à établissement de connexion à la demande (DDR)

Configuration d'un routeur de sorte qu'il compose le numéro de plusieurs sites à l'aide de BRI RNIS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans certaines situations, vous devriez configurer un routeur pour composer des plusieurs sites. Par exemple, vous pouvez devez composez un routeur pour se connecter à une partie de votre réseau d'entreprise, et composez le routeur de fournisseur de services Internet (ISP) pour se connecter à l'Internet.

Ce document présente un exemple de configuration dans lequel un routeur central accède à l'Internet, et un bureau distant utilise Integrated Services Digital Network (le RNIS). Le bureau distant peut également accéder au routeur central et l'Internet par le routeur central.

Conditions préalables

Conditions requises

Avant que vous poursuiviez cette configuration, assurez-vous que vous :

  • Vérifiez que la couche RNIS 1 et 2 sont en hausse. Le pour en savoir plus, voient utilisant la commande d'état de show isdn pour le dépannage BRI.

  • Obtenez les informations nécessaires de l'ISP, tel que la méthode d'authentification, qui pourrait être protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) ou Password Authentication Protocol (PAP), le nom d'utilisateur et mot de passe, le nombre à composer, et l'adresse IP pour l'interface de numérotation (à moins que l'interface utilise une adresse négociée). En outre, découvrez si NAT est nécessaire pour connecter de plusieurs hôtes à l'ISP.

  • Du routeur distant, obtenez les informations sur la méthode d'authentification, le nom d'utilisateur et mot de passe, le nombre pour composer, et l'adresse IP.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur de Cisco 803 avec l'IP de version de logiciel 12.1(11) de½ du¿Â du Cisco IOSï plus.

    Remarque: Si vous devez configurer NAT, assurez-vous que vous avez ensemble de caractéristiques d'IP Plus (il a le « est » dans le nom du fichier IOS).

  • Routeur Cisco 2501, qui est le bureau à distance qui exécute le Logiciel Cisco IOS version 12.2(5).

Remarque: La configuration pour le routeur de l'ISP n'est pas incluse. Référez-vous à la page de support technologique de Composition et accès pour quelques exemples de configuration.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Produits connexes

Cette configuration peut être utilisée avec n'importe quel routeur avec une interface d'accès de base (BRI). Ceci inclut des Routeurs avec les interfaces intégrées BRI, telles que le Cisco 800 (par exemple, 801, 802, 803, 804) et le Cisco 1600 (par exemple, 1603-R et 1604-R) routeurs de la gamme. Il inclut également les Routeurs qui reçoivent les cartes d'interface WAN BRI (WIC) ou les modules réseau, comme les 1600, 1700, des gammes 2600 et 3600. Pour plus d'informations sur BRI WIC ou module réseau, se rapportent carte d'interface WAN) (WIC/tableau de compatibilité du matériel des plates-formes pour 1600, 1700, routeurs de la gamme 2600 et 3600.

Remarque: Utilisez la commande de show version de vérifier si votre routeur a une interface BRI.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14562/isdn800_14562.gif

Configurations

Dans cette configuration, le routeur central est nommé « central » et l'entreprise distante est nommée « distant ».

Sur le central, l'interface de numérotation 1 est configurée pour accéder à l'Internet. L'adresse IP est dynamiquement assignée par l'ISP. NAT est utilisé pour permettre aux réseaux IP du RÉSEAU LOCAL central, du RÉSEAU LOCAL distant, et du WAN de central-distant pour accéder à l'Internet avec l'aide d'un dynamique-assigné l'adresse IP. Entrez en contact avec votre ISP pour vérifier si vous avez besoin de NAT.

Remarque: Nous avons configuré le PAP et le CHAP, parce que ceci dépend de ce que l'ISP a configuré (cependant, seulement l'une d'entre elles est utilisée).

central
 version 12.1 
  no parser cache 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname central 
  ! 
  username remote password 0 remote
 
 !--- Username and shared secret password for the router (remote)
  !--- (used for CHAP authentication).
  !--- Shared secret password must be the same on both sides.

  ! 
  isdn switch-type basic-net3
  !  
  ! 
  interface Ethernet0 
   ip address 10.1.0.1 255.255.255.0 
   ip nat inside 

   !--- Ethernet 0 is an inside NAT interface.
   !--- All traffic from this network will be translated.

   no cdp enable 
  ! 
  interface BRI0

   !--- If you have additional BRIs, copy this BRI 0 configuration to the other BRIs.

   no ip address 
   encapsulation ppp 
   dialer pool-member 1

   !--- Assign BRI0 as member of dialer pool 1.
   !--- Dialer pool 1 is specified in interface Dialer 1.

   dialer pool-member 2 

   !--- Assign BRI0 as member of dialer pool 2.
   !--- Dialer pool 2 is specified in interface Dialer 2.

   isdn switch-type basic-net3     

   !--- This depends on the country. 

   no cdp enable 
   ppp authentication chap pap callin

   !--- Permit one-way CHAP and PAP authentication.
   !--- Configure authentication on both the physical and dialer interface.

  ! 
  interface Dialer1 

  !--- Create a dialer interface for every device to which you need to connect.

   description CONNECTION TO INTERNET 
   ip address negotiated 
   
!--- This IP address is obtained from the ISP. If the ISP permits a static
   !--- address, configure that address instead.

   ip nat outside 

   !--- The Outside NAT interface. Because this interface only has one IP address,
   !--- all traffic from the inside network will be Port Address Translated (PAT).

   encapsulation ppp 
   dialer pool 1 

   !--- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.

   dialer remote-name ISP  
   dialer idle-timeout 180 
   dialer string 6122 

   !--- The number used to dial the ISP.

   dialer-group 1 
   
!--- Apply interesting traffic definition from dialer-list 1.

   no cdp enable 
   ppp authentication chap pap callin 
   ppp chap hostname XXXXX   

   !--- XXXXX is the username the ISP expects in order to authenticate this router.
   !--- For more information, refer to the document on ppp chap hostname.

   ppp chap password YYYYY    
  
 !--- YYYYY is the password the ISP expects in order to authenticate this router.

   ppp pap sent-username XXXXX password YYYYY 

   !--- PAP username and password. 
   !--- This is required only if the ISP does not support CHAP.

  ! 
  interface Dialer2 
   description CONNECTION TO REMOTE OFFICE 
   ip address 192.168.17.2 255.255.255.252

   !--- IP address for the connection to the remote office.
   !--- The remote office BRI interface is in the same subnet.

   ip nat inside

   !--- Dialer 2 is an inside NAT interface.
   !--- With this configuration, traffic from remote office is translated
   !--- before it is sent to the ISP.

   encapsulation ppp 
   dialer pool 2 

   !--- Dialer profile 2. Remember that interface BRI 0 is a member of this profile.

   dialer remote-name remote 

   !--- Specifies the remote router name (remote).
   !--- This name must match that used by the remote router to authenticate itself.
   !--- Remember that we configured the router username and password earlier.

   dialer idle-timeout 180 
   dialer string 6121 

   !--- Number used to dial the remote office router.

   dialer-group 1 

   !--- Apply interesting traffic definition from dialer-list 1.

   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip nat inside source list 101 interface Dialer1 overload 

  !--- Establishes dynamic source translation (with PAT) for addresses that are
  !--- identified by the access list 101.

  no ip http server 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- Default route. Such traffic will use dialer 1 to the ISP.

  ip route 10.2.0.0 255.255.255.0 Dialer2 

  !--- Route to remote router network. Traffic for 10.2.0.0/24 uses Dialer2.

  ! 
  access-list 101 permit ip 10.1.0.0 0.0.0.255 any 
  access-list 101 permit ip 10.2.0.0 0.0.0.255 any 
  access-list 101 permit ip 192.168.17.0 0.0.0.3 any 
  
!--- Defines an access list that permits the addresses to be translated.
  !--- Note that the Ethernet 0 network, the remote router network and the
  !--- BRI network (between this router and the remote one) will be translated.

  dialer-list 1 protocol ip permit 

  !--- Interesting traffic definition.
  !--- This definition is applied to both connections.
  !--- If you need to define different interesting traffic for each connection,
  !--- create two dialer-lists and apply one to each dialer profile with dialer-group.

  no cdp run 
  ! 
  line con 0 
   exec-timeout 3 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  !  
  end

distant
version 12.2 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname remote 
  ! 
  username central password 0 remote 

  !--- Username and shared secret password for the router (central)
  !--- (used for CHAP authentication).
  !--- Shared secret must be the same on both sides. 

  ! 
  isdn switch-type basic-net3
  ! 
  interface Ethernet0 
   ip address 10.2.0.1 255.255.255.0 

   !--- Remember that this network is included in the NAT statements on central.

   no cdp enable 
  ! 
  interface BRI0 
    no ip address 
   encapsulation ppp 
   dialer pool-member 1 

   !--- Assign BRI0 as member of dialer pool 1.
   !--- Dialer pool 1 is specified in interface Dialer 1.

   isdn switch-type basic-net3 
   no cdp enable 
   ppp authentication chap 
  ! 
  interface Dialer1 
   ip address 192.168.17.1 255.255.255.252 
   encapsulation ppp 
   dialer pool 1 

   !--- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.  

   dialer remote-name central 

   !--- Specifies the name of the other router (central).
   !--- This name must match that used by the remote router to authenticate itself.
   !--- Remember that we configured the router username and password earlier.

   dialer string 6131

   !--- The number used to dial the central router. 

   dialer-group 1 
   
!--- Apply interesting traffic definition from dialer-list 1.

   pulse-time 0 
   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- Default route. Such traffic will use dialer 1 to the central router.

  no ip http server 
  ! 
  dialer-list 1 protocol ip permit

  !--- All IP traffic is interesting. 

  ! 
  line con 0 
   exec-timeout 3 0 
  line aux 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • active de show isdn — affiche l'isdn number que vous placiez l'appel, et indique si l'appel est d'arrivée ou sortant.

  • IP de show caller — affiche une récapitulation d'informations sur l'appelant pour l'adresse IP que vous fournissez.

  • numéroteur 1 de show ip interface | incluez l'Internet — répertorie un résumé des informations IP et de l'état d'une interface de numérotation.

  • show dialer [nombre de type d'interface] — les informations générales de diagnostic d'affichages pour des interfaces configurées pour le Routage à établissement de connexion à la demande (DDR). Si le numéroteur montait correctement, ce message apparaît :

    Dialer state is data link layer up

    Si la couche physique haute apparaît, elle implique que la ligne protocole a été soulevée, mais le protocole de contrôle de réseau (NCP) n'a pas fait. La source et les adresses de destination du paquet qui a initié la composition sont affichées dans la ligne raison d'appel. Cette commande show affiche également la configuration du temporisateur, et le temps avant les temps de connexion.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • mettez au point le numéroteur — les informations de débogage d'affichages au sujet des paquets ou des événements sur une interface de numérotation.

  • debug isdn q931 — affiche des informations au sujet de l'établissement d'appel et du démontage de la connexion réseau RNIS (couche 3) entre le routeur local (côté utilisateur) et le réseau.

  • le debug ppp negotiation — affiche des informations sur le trafic de Protocole point à point (PPP) et échanges pendant la négociation des composants de PPP, et inclut les informations sur le Link Control Protocol (LCP), l'authentification, et le NCP. Une négociation PPP réussie ouvre tout d'abord l'état LCP, puis procède à l'authentification, pour terminer par la négociation de NCP.

  • debug ppp authentication — entraîne la commande de debug ppp d'afficher des messages du protocole d'authentification, y compris des échanges de paquet de CHAP et des échanges PAP.

  • mettez au point le pair d'IP — contient les informations sur le pair.

Sortie de débogage

Pour dépanner la configuration, utilisez ces derniers met au point :

   central#debug isdn q931 
   ISDN Q931 packets debugging is on 
   
   central#debug dialer 
   Dial on demand events debugging is on 
   
   central#debug ppp negotiation 
   PPP protocol negotiation debugging is on 
   
   central#debug ppp authentication 
   PPP authentication debugging is on 
   
   central#debug ip peer 
   IP peer address activity debugging is on 

Le routeur a appelé le central initie un appel à l'Internet : 198.133.219.25 est une adresse IP sur l'Internet.

   central#ping 198.133.219.25

   :.!!!! 
   Success rate is 80 percent (4/5), round-trip min/avg/max = 40/41/44 ms 

   *Mar 1 00:06:12.984: BR0 DDR: rotor dialout [priority] 
   *Mar 1 00:06:12.988: BR0 DDR: Dialing cause ip (s=172.17.243.115, 
    d=198.133.219.25)    
   *Mar 1 00:06:12.988: BR0 DDR: Attempting to dial 6122 
   *Mar 1 00:06:12.996: ISDN BR0: TX -> SETUP pd = 8 callref = 0x01 

   !--- central initiates the call to ISDN number 6122. 

   *Mar 1 00:06:13.000: Bearer Capability i = 0x8890 
   *Mar 1 00:06:13.008: Channel ID i = 0x83 
   *Mar 1 00:06:13.008: Called Party Number i = 0x80, '6122', Plan:Unknown,
   Type:Unknown 
   *Mar 1 00:06:13.088: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x81 
   *Mar 1 00:06:13.092: Channel ID i = 0x89 
   *Mar 1 00:06:13.244: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x81 

   !--- central receives a connect message : the ISDN B channel is established. 

   *Mar 1 00:06:13.252: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x01 
   *Mar 1 00:06:13.260: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 1 00:06:13.268: BR0:1: interface must be fifo queue, force FIFO 
   *Mar 1 00:06:13.272: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1 
   *Mar 1 00:06:13.280: BR0:1 PPP: Treating connection as a callout 
   *Mar 1 00:06:13.280: BR0:1 PPP: Phase is ESTABLISHING, Active Open 
   *Mar 1 00:06:13.284: BR0:1 PPP: No remote authentication for call-out 
   *Mar 1 00:06:13.284: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10 
   *Mar 1 00:06:13.284: BR0:1 LCP: MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.300: BR0:1 LCP: I CONFREQ [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.300: BR0:1 LCP: AuthProto CHAP (0x0305C22305) 

   !--- The ISP wants to use CHAP authentication. 

   *Mar 1 00:06:13.304: BR0:1 LCP: MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.304: BR0:1 LCP: O CONFACK [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.308: BR0:1 LCP: AuthProto CHAP (0x0305C22305) 
   *Mar 1 00:06:13.308: BR0:1 LCP: MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.308: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.312: BR0:1 LCP: MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.312: BR0:1 LCP: State is Open 
   *Mar 1 00:06:13.320: BR0:1 PPP: Phase is AUTHENTICATING, by the peer 
   *Mar 1 00:06:13.328: BR0:1 AUTH: Started process 0 pid 22 
   *Mar 1 00:06:13.328: BR0:1 CHAP: I CHALLENGE id 118 Len 27 from "posets"    
   *Mar 1 00:06:13.332: BR0:1 CHAP: Using alternate hostname XXXXX 
   *Mar 1 00:06:13.332: BR0:1 CHAP: Username posets not found 
   *Mar 1 00:06:13.336: BR0:1 CHAP: Using default password 
   *Mar 1 00:06:13.336: BR0:1 CHAP: O RESPONSE id 118 Len 26 from "XXXXX"    
   *Mar 1 00:06:13.360: BR0:1 CHAP: I SUCCESS id 118 Len 4 
   
!--- central receives a CHAP SUCCESS from ISP. 

   *Mar 1 00:06:13.360: BR0:1 PPP: Phase is UP 
   *Mar 1 00:06:13.364: BR0:1 IPCP: O CONFREQ [Not negotiated] id 1 Len 10 
   *Mar 1 00:06:13.364: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000) 
   *Mar 1 00:06:13.368: BR0:1 IPCP: I CONFREQ [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.368: BR0:1 IPCP: Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.368: BR0:1: IPPOOL: validate address = 194.183.201.1 
   *Mar 1 00:06:13.372: BR0:1 set_ip_peer(3): new address 194.183.201.1 
   *Mar 1 00:06:13.372: BR0:1 IPCP: O CONFACK [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.376: BR0:1 IPCP: Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.380: BR0:1 IPCP: I CONFNAK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.380: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 

   !--- 194.183.201.3 is assigned by ISP to dialer 1 of central. 

   *Mar 1 00:06:13.384: BR0:1 IPCP: O CONFREQ [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.384: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.396: BR0:1 IPCP: I CONFACK [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.400: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.400: BR0:1 IPCP: State is Open 
   *Mar 1 00:06:13.400: Di1 IPCP: Install negotiated IP interface address
   194.183.201.3 
   *Mar 1 00:06:13.412: BR0:1 DDR: dialer protocol up 
   *Mar 1 00:06:13.416: Di1 IPCP: Install route to 194.183.201.1 
   *Mar 1 00:06:14.360: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
   *Mar 1 00:06:19.276: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 6122
   unknown

Informations connexes


Document ID: 14562