Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Configuration d'une interface asynchrone en tant que solution de secours pour une ligne série

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Il est commun pour fournir aux chemins redondants pour des connexions WAN, telles que séquentiel, bail-line ou Relais de trames, des circuits de routage à établissement de connexion à la demande (DDR). Les modems asynchrones et les lignes avec commutation à circuit de réseau téléphonique public commuté (POTS) sont les interfaces WAN de sauvegarde utilisées. La planification rigoureuse est nécessaire en concevant des scénarios d'Accès direct secouru. Considérez les facteurs tels que le trafic sur les liaisons de sauvegarde, le nombre de liens susceptibles du manque, et la planification de capacité de port de prendre en charge les circuits de sauvegarde.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Une plate-forme de routeur de Cisco 2500.

  • Version de logiciel 12.1(2)T de ½ du ¿  de Cisco IOSï sur le gaugin de routeur.

  • Logiciel Cisco IOS version 12.0(7)T sur le sphinx de routeur.

  • Les Modems externes se sont connectés au port série sur les Routeurs.

Remarque: Ce document peut être modifié pour l'usage sur n'importe quel routeur avec des interfaces asynchrones (ou des modems internes). La configuration de l'Interface de sauvegarde (interface série 2 d'interface, dans cet exemple) serait incluse sous le « interface async x ».

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Informations générales

Trois méthodes classiques disponibles pour fournir la sauvegarde pour un lien WAN sont :

  • Interfaces de sauvegarde - Une Interface de sauvegarde demeure dans le mode standby jusqu'à ce que la liaison principale descende. La liaison de sauvegarde est alors lancée, rétablissant la connexion entre les deux sites.

  • Fonctions Dialer Watch - Une Fonction Dialer Watch fournit la Connectivité fiable sans compter seulement sur définir le trafic intéressant pour déclencher des appels sortants au routeur central. Artères de particularité de moniteurs de Fonction Dialer Watch les certaines et, si ces réseaux sont inaccessibles, la Fonction Dialer Watch évoque le lien secondaire.

  • Routes statiques flottantes - Les Routes statiques flottantes sont des artères statiques qui ont une distance administrative plus grande que la distance administrative des artères dynamiques. Des distances administratives peuvent être configurées sur une artère statique de sorte que l'artère statique soit moins desirable qu'une artère dynamique ; par conséquent, l'artère statique n'est pas utilisée quand l'artère dynamique est disponible. Cependant, si l'artère dynamique est perdue, l'artère statique peut succéder et le trafic peut être envoyé par cette artère alternative.

Ce scénario emploie l'Interface de sauvegarde pour exécuter la sauvegarde. Pour plus d'informations sur les utilisations de l'Interface de sauvegarde référez-vous derrière les Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch de document évaluation pour la sauvegarde DDR.

Pour plus d'informations sur configurer la sauvegarde référez-vous s'il vous plaît au document configurant et dépannant la sauvegarde DDR. Le document fournit des informations sur déterminer quelle méthode de sauvegarde devrait être utilisée et d'autres informations de configuration.

Lisez et veuillez comprenez les deux documents ci-dessus avant de commencer avec cette configuration.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/14281/async_backup_14281.gif

Configurations

Dans cette configuration nous utilisons deux Routeurs de Cisco (gaugin et sphinx) qui sont connectés au-dessus d'une ligne louée par leurs interfaces de l'interface série 0. Les interfaces de l'interface série 2 sont connectées par des modems asynchrones au-dessus d'une ligne du réseau téléphonique public commuté (PSTN), et utilisées comme sauvegarde pour la ligne louée.

Remarque: Par défaut, ces interfaces fonctionnent en mode de sync, vous doivent manuellement les configurer (utilisant la commande async de couche physique) pour fonctionner dans le mode asynchrone.

À l'aide de la commande de show version, vous pouvez découvrir si ces interfaces peuvent fonctionner dans le mode asynchrone aussi. Les informations pertinentes affichées par la commande de show version sont affichées ci-dessous :

2 Low-speed serial(sync/async) network interfaces

! --- This means it can work in sync or async mode.

Il est recommandé que vous vous terminez la configuration et la vérifiez que la connexion modem peut être faite. Vous pouvez faire ceci telnetting inverse aux Modems, et en faisant un appel au nombre du modem distant.

Remarque: Il est également obligatoire d'utiliser une capacité de modem (modemcap) selon le type de modem. Pour plus d'informations sur ceci, référez-vous au Guide de connexion modem-routeur

gaugin (Cisco 2500) - J'appelle le routeur
gaugin#show running-config
 Building configuration...

 Current configuration:
 hostname gaugin

 username sphinx password 0 cisco

 !---Username and shared secret for CHAP authentication.

 !
 chat-script CALLOUT "" "atdt\T" TIMEOUT 60 CONNECT \c

 !--- Chat script used for dialout.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W;

 !--- Modemcap for the external modem.
 !--- Refer to Modem-Router Connection Guide for more information.

 interface Loopback1
 ip address 1.1.1.1 255.255.255.255
 !
 interface Serial0
 
!--- Primary link.

  ip address 3.3.3.1 255.255.255.0

 !--- Remote peer serial interface is in same subnet.

  backup interface serial 2

 !--- Designate interface serial 2 as the backup interface.

 !
 interface Serial2

 !--- Backup interface. This interface will be in "Standby" mode until the
 !--- line protocol on interface Serial 0 (the primary) goes down.

  physical-layer async
 
!--- Permit async mode.

  ip unnumbered Loopback1
  encapsulation ppp
  dialer in-band
  dialer map ip 2.2.2.1 name sphinx modem-script CALLOUT 8029

 !--- Dialer map for the peer. 
!--- Note the ip address, the name (which matches the
!--- authenticated username, the chat script used and the number to dial.

  dialer-group 1

 !--- Interesting traffic definition for dialout.

  async mode dedicated
  no peer default ip address

 !--- Do not provide the peer with an IP address. 
!--- It must have one configured.

  no fair-queue
  ppp authentication chap callin

 !--- Use one-way chap authentication.

 !
 ip route 2.2.2.1 255.255.255.255 Serial0
 ip route 2.2.2.1 255.255.255.255 Serial2

 ! -- Identical routes for the peer. 
!--- Note the IP address matches the dialer map ip.
 !--- When the primary is up, the backup in in Standby hence the route using
 !--- Serial 2 will not be used. When the backup is brought out of standby
 !--- it will get used and the serial 0 route is removed (since the link is down/down)
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 2.2.2.1.



 dialer-list 1 protocol ip permit

 !--- Interesting traffic definition. 
!--- Once the backup link is brought out of standby
!--- dialout is ONLY initiaited after the router receives interesting traffic.


 line 2

 !--- Line configuration for the modem on interface Serial 2. 

 script dialer CALLOUT

 !--- Use script CALLOUT.

 modem InOut
 modem autoconfigure type usr

 !--- Use modemcap named "usr" configured earlier.

 transport input all
 speed 115200

 !--- DTE-DCE speed.

 flowcontrol hardware

sphinx (Cisco 2500) - Router appelé
sphinx#show running-config
 Building configuration...

 Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname sphinx
 username gaugin password 0 cisco

 !--- Username and shared secret for CHAP authentication.

 modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W; !
 interface Loopback1
 ip address 2.2.2.1 255.255.255.255
 no ip directed-broadcast
 !
 interface Serial0

 !--- Primary interface
 !--- Note that this router does not initiate the backup when the primary fails
 !--- it will rely on the peer to initiate the connection.

 ip address 3.3.3.2 255.255.255.0
 !
 interface Serial2

 !--- Interface providing backup.
 !--- There is no dialer map/dialer string since it is only accepting the call.
 !--- This interface will be in Up/Up(Spoofing) mode when the primary interface is up.
 !--- Later, configure a floating static route to prevent packet loss.

 physical-layer async
 ip unnumbered Loopback1
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer-group 1
 async mode dedicated
 no peer default ip address
 no fair-queue
 no cdp enable
 ppp authentication chap

 ip route 1.1.1.1 255.255.255.255 Serial0
 ip route 1.1.1.1 255.255.255.255 Serial2 2 

 !--- The 2 makes the route a floating static route.
 !--- This is important since the async interface will be in spoofing mode 
 !--- (not in standby mode) when the primary interface is up.
 !--- If we do not use the 2 here, we lose half of the packets in the return path
 !--- since the router will attempt to load balance
 !--- across the 2 links (eventhough the backup is down).
 !--- To create a route for other networks use 
!--- ip route <network> <mask> 1.1.1.1.


 line 2
  modem InOut
  modem autoconfigure type usr
  transport input all
  speed 115200
  flowcontrol hardware

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • affichez l'interface série d'interface - Affiche des informations au sujet d'une interface série.

  • show ip route - Affiche l'état actuel de la table de routage.

  • show line - Affiche des paramètres d'une ligne de terminal.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Pour plus d'informations sur l'Interface de sauvegarde de dépannage référez-vous s'il vous plaît au document configurant et dépannant la sauvegarde DDR

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • show dialer - Affiche des informations au sujet d'une interface de numérotation.

  • Connectivité de tests de ping.

  • debug modem - Observe l'activité de ligne du modem sur un serveur d'accès.

  • debug ppp negotiation - Affiche des informations sur le trafic PPP et des échanges tout en négociant les composants de PPP comprenant le Link Control Protocol (LCP), l'authentification, et le protocole de contrôle de réseau (NCP). Une négociation PPP réussie ouvre tout d'abord l'état LCP, puis procède à l'authentification, pour terminer par la négociation de NCP.

  • debug ppp authentication - Affiche les messages du protocole d'authentification de PPP, y compris des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP). Si vous observez une panne, vérifiez que le nom d'utilisateur et mot de passe de CHAP sont configurés correctement.

  • mettez au point la conversation - Affiche l'activité de script de conversation.

  • mettez au point le numéroteur - Les informations de débogage de DDR d'affichages au sujet des paquets reçus sur une interface de numérotation.

Dans la sortie témoin ci-dessous, nous pouvons voir que la connexion série principale (interface série 0) sur le gaugin (le routeur appelant) a un problème et des arrêters la connexion. L'Interface de sauvegarde (débuts d'interface série 2) établissant la connexion de sauvegarde. Pour cet exemple, nous avons déconnecté le câble pour tester la liaison de sauvegarde.

Remarque: Émettre la commande shutdown sur l'interface principale ne fera pas composer la sauvegarde. Si vous émettez une commande shutdown de réduire la connexion principale, le logiciel de Cisco IOS n'évoquera pas automatiquement une connexion de sauvegarde. Vous devez physiquement réduire la connexion principale en débranchant des câbles ou une certaine méthode équivalente afin d'évoquer les Interfaces de sauvegarde.

   gaugin#
   *Mar 1 00:57:25.127: %LINK-3-UPDOWN: Interface Serial0, changed state to down
   *Mar 1 00:57:26.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
    changed state to down

    !--- Primary Link is brought down. 
    !--- This will cause the backup link (int Serial 2) to be taken out of standby.

   *Mar 1 00:57:37.143: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   
!--- The Backup link is changes from Standby to Down.

   *Mar 1 00:57:37.147: Se2 LCP: State is Closed..
   *Mar 1 00:57:40.019: TTY2: restoring DTR
   *Mar 1 00:57:41.019: TTY2: autoconfigure probe started
   *Mar 1 00:57:52.147: Se2 DDR: re-enable timeout.
   *Mar 1 00:57:55.067: Se2 DDR: Dialing cause ip (s=1.1.1.1, d=2.2.2.1)
   
!--- Interesting traffic for the peer causes the dialout.

   *Mar 1 00:57:55.071: Se2 DDR: Attempting to dial 8029
   *Mar 1 00:57:55.071: CHAT2: Attempting async line dialer script
   *Mar 1 00:57:55.075: CHAT2: Dialing using Modem script: CALLOUT 
   & System script: none
   
!--- Chat-script named CALLOUT is used.

   *Mar 1 00:57:55.083: CHAT2: process started
   *Mar 1 00:57:55.083: CHAT2: Asserting DTR
   *Mar 1 00:57:55.087: CHAT2: Chat script CALLOUT started
   *Mar 1 00:57:55.087: CHAT2: Sending string: atdt\T<8029>
   *Mar 1 00:57:55.091: CHAT2: Expecting string: CONNECT.........
   *Mar 1 00:58:12.859: CHAT2: Completed match for expect: CONNECT
   *Mar 1 00:58:12.859: CHAT2: Sending string: \c
   *Mar 1 00:58:12.863: CHAT2: Chat script CALLOUT finished, status = Success
   *Mar 1 00:58:12.867: TTY2: no timer type 1 to destroy
   *Mar 1 00:58:12.867: TTY2: no timer type 0 to destroy
   *Mar 1 00:58:12.875: Se2 IPCP: Install route to 2.2.2.1.
   *Mar 1 00:58:14.871: %LINK-3-UPDOWN: Interface Serial2, changed state to up
       Dialer state change to up Serial2 Dialer call has been placed Serial2
   *Mar 1 00:58:14.891: Se2 PPP: Treating connection as a callout

    !--- PPP LCP negotiation begins.

   *Mar 1 00:58:14.891: Se2 PPP: Phase is ESTABLISHING, Active Open
   *Mar 1 00:58:14.895: Se2 PPP: No remote authentication for call-out
   *Mar 1 00:58:14.899: Se2 LCP: O CONFREQ [Closed] id 10 len 20
   *Mar 1 00:58:14.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:14.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:14.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:14.907: Se2 LCP: ACFC (0x0802).
   *Mar 1 00:58:16.895: Se2 LCP: TIMEout: State REQsent
   *Mar 1 00:58:16.899: Se2 LCP: O CONFREQ [REQsent] id 11 len 20
   *Mar 1 00:58:16.899: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:16.903: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:16.907: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:16.907: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.063: Se2 LCP: I CONFACK [REQsent] id 11 len 20
   *Mar 1 00:58:17.067: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.067: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   *Mar 1 00:58:17.071: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.075: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.083: Se2 LCP: I CONFREQ [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.083: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.087: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.091: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.095: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.095: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.099: Se2 LCP: O CONFACK [ACKrcvd] id 32 len 25
   *Mar 1 00:58:17.103: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   *Mar 1 00:58:17.103: Se2 LCP: AuthProto CHAP (0x0305C22305)
   *Mar 1 00:58:17.107: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   *Mar 1 00:58:17.111: Se2 LCP: PFC (0x0702)
   *Mar 1 00:58:17.111: Se2 LCP: ACFC (0x0802)
   *Mar 1 00:58:17.115: Se2 LCP: State is Open
    
!--- LCP negotiation is complete.

   *Mar 1 00:58:17.115: Se2 PPP: Phase is AUTHENTICATING, by the peer
   *Mar 1 00:58:17.263: Se2 CHAP: I CHALLENGE id 4 len 27 from "sphinx"
   *Mar 1 00:58:17.271: Se2 CHAP: O RESPONSE id 4 len 27 from "gaugin"
   *Mar 1 00:58:17.391: Se2 CHAP: I SUCCESS id 4 len 4
   *Mar 1 00:58:17.395: Se2 PPP: Phase is UP
   *Mar 1 00:58:17.399: Se2 IPCP: O CONFREQ [Closed] id 4 len 10
   *Mar 1 00:58:17.399: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.407: Se2 CDPCP: O CONFREQ [Closed] id 4 len 4
   *Mar 1 00:58:17.411: Se2 IPCP: I CONFREQ [REQsent] id 5 len 10
   *Mar 1.00:58:17.415: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.419: Se2 IPCP: O CONFACK [REQsent] id 5 len 10
   *Mar 1 00:58:17.423: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   *Mar 1 00:58:17.527: Se2 IPCP: I CONFACK [ACKsent] id 4 len 10
   *Mar 1 00:58:17.531: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   *Mar 1 00:58:17.535: Se2 IPCP: State is Open
   *Mar 1 00:58:17.543: Se2 LCP: I PROTREJ [Open] id 33 len 10 protocol 
   CDPCP (0x820701040004)
   *Mar 1 00:58:17.547: Se2 CDPCP: State is Closed
   *Mar 1 00:58:17.547: Se2 DDR: dialer protocol up
   *Mar 1 00:58:18.075: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2,
    changed state to up

   !--- Connection is successful. Backup link is now active.


   gaugin#show ip route 2.2.2.1
   Routing entry for 2.2.2.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The route for the peer uses the backup link.
   !--- Note the static route for primary link is removed
   !--- (since the link is down/down).

   Route metric is 0, traffic share count is 1

   gaugin#show dialer
   Se2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Dial reason: ip (s=1.1.1.1, d=2.2.2.1)
   Time until disconnect 108 secs
   Connected to 8029
   
   Dial String Successes Failures Last     DNIS  Last status
   8029        4           0      00:01:00       successful
   
   gaugin#show interface serial 2
   Serial2 is up, line protocol is up 

   !--- Backup link is verified to be up.

   Hardware is CD2430 in async mode
   Interface is unnumbered. Using address of Loopback1 (1.1.1.1)
   MTU 1500 bytes, BW 115 Kbit, DLY 100000 usec,    ...   ...

   gaugin#ping 2.2.2.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 128/132/136 ms

Voici le même appel de la perspective du sphinx qui a reçu l'appel :

sphinx#
   00:57:29: TTY2: DSR came up

   !--- Modem DSR is first changed to up, indicating an incoming call.

   00:57:29: TTY2: destroy timer type 1
   00:57:29: TTY2: destroy timer type 0
   00:57:29: tty2: Modem: IDLE->(unknown)
   00:57:31: Se2 LCP: I CONFREQ [Closed] id 10 len 20
   
!--- Begin LCP negotiation
.
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: Lower layer not up, Fast Starting
   00:57:31: Se2 PPP: Treating connection as a callin
   00:57:31: Se2 PPP: Phase is ESTABLISHING, Passive Open
   00:57:31: Se2 LCP: State is Listen
   00:57:31: Se2 LCP: O CONFREQ [Listen] id 31 len 25
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:31: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: Se2 LCP: O CONFACK [Listen] id 10 len 20
   00:57:31: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:31: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:31: Se2 LCP: PFC (0x0702)
   00:57:31: Se2 LCP: ACFC (0x0802)
   00:57:31: %LINK-3-UPDOWN: Interface Serial2, 
   changed state to upDialer statechange 
   to up Serial2
   00:57:31: Serial2 DDR: Dialer received incoming call from <unknown>
   00:57:33: Se2 LCP: I CONFREQ [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: O CONFACK [ACKsent] id 11 len 20
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: MagicNumber 0x0041E7ED (0x05060041E7ED)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: TIMEout: State ACKsent
   00:57:33: Se2 LCP: O CONFREQ [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   00:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: I CONFACK [ACKsent] id 32 len 25
   00:57:33: Se2 LCP: ACCM 0x000A0000 (0x0206000A0000)
   00:57:33: Se2 LCP: AuthProto CHAP (0x0305C22305)
   00:57:33: Se2 LCP: MagicNumber 0xE05307CD (0x0506E05307CD)
   00:57:33: Se2 LCP: PFC (0x0702)
   0:57:33: Se2 LCP: ACFC (0x0802)
   00:57:33: Se2 LCP: State is Open
   
!--- LCP negotiation is complete.

   00:57:33: Se2 PPP: Phase is AUTHENTICATING, by this end
   00:57:33: Se2 CHAP: O CHALLENGE id 4 len 27 from "sphinx"
   00:57:33: Se2 CHAP: I RESPONSE id 4 len 27 from "gaugin"
   00:57:33: Se2 CHAP: O SUCCESS id 4 len 4

   !--- CHAP authentication is successful.

   00:57:33: Serial2 DDR:
   Authenticated host gaugin with no matching dialer map
   00:57:33: Se2 PPP: Phase is UP
   00:57:33: Se2 IPCP: O CONFREQ [Closed] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: I CONFREQ [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 IPCP: O CONFACK [REQsent] id 4 len 10
   00:57:33: Se2 IPCP: Address 1.1.1.1 (0x030601010101)
   00:57:33: Se2 CDPCP: I CONFREQ [Not negotiated] id 4 len 4
   00:57:33: Se2 LCP: O PROTREJ [Open] id 33 len 10 protocol CDPCP
   (0x820701040004)
   00:57:33: Se2 IPCP: I CONFACK [ACKsent] id 5 len 10
   00:57:33: Se2 IPCP: Address 2.2.2.1 (0x030602020201)
   00:57:33: Se2 IPCP: State is Open
   00:57:33: Serial2 DDR: dialer protocol up
   00:57:33: Se2 IPCP: Install route to 1.1.1.1

   !--- A route to the peer is installed.

   00:57:34: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial2, changed state to up
   
!--- Backup link is up.


   sphinx#ping 1.1.1.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 132/142/152 ms

   sphinx#show ip route 1.1.1.1
   Routing entry for 1.1.1.1/32
   Known via "connected", distance 0, metric 0 (connected, via interface)
   Routing Descriptor Blocks:
   * directly connected, via Serial2

   !--- The floating static route is now installed.

   Route metric is 0, traffic share count is 1

   sphinx#show dialer

   Serial2 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (120 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 119 secs (gaugin)

Maintenant rebranchons le câble pour la liaison principale. La liaison principale sera mouvement d'énoncer Up/Up et la liaison de sauvegarde (l'interface série 2) sera transformée en état de réserve sur le gaugin (puisqu'elle a la commande de l'interface série 2 d'Interface de sauvegarde). Ceci fera mourir la liaison par modem et l'interface série 2 d'interface sur le sphinx à descendre aussi bien.

Ce qui suit met au point sur le gaugin affiche ce processus :

   gaugin#
   *Mar 1 00:59:38.859: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   *Mar 1 00:59:39.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
   changed state to up
   
!--- Primary link is re-established.

   *Mar 1 00:59:59.315: TTY2: Async Int reset: Dropping DTR
   *Mar 1 01:00:00.875: TTY2: DSR was dropped
   *Mar 1 01:00:00.875: tty2: Modem: READY->(unknown)
   *Mar 1 01:00:01.315: %LINK-5-CHANGED: Interface Serial2, 
    changed state to standby mode

   !--- the backup link is returned to standby mode. 
   !--- The modem connection is terminated

   *Mar 1 01:00:01.331: Se2 IPCP: State is Closed
   *Mar 1 01:00:01.335: Se2 PPP: Phase is TERMINATING
   *Mar 1 01:00:01.335: Se2 LCP: State is Closed
   *Mar 1 01:00:01.339: Se2 PPP: Phase is DOWN
   *Mar 1 01:00:01.343: Se2 IPCP: Remove route to 2.2.2.1
   *Mar 1 01:00:01.883: TTY2: dropping DTR, hanging up
   *Mar 1 01:00:01.883: tty2: Modem: HANGUP->(unknown)
   *Mar 1 01:00:02.315: %LINEPROTO-5-UPDOWN: 
   Line protocol on Interface Serial2, changed state to down
   *Mar 1 01:00:02.899: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:03.927: TTY2: cleanup pending. Delaying DTR
   *Mar 1 01:00:04.323: TTY2: no timer type 0 to destroy
   *Mar 1 01:00:04.323: TTY2: no timer type 1 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 3 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 4 to destroy
   *Mar 1 01:00:04.327: TTY2: no timer type 2 to destroy
   *Mar 1 01:00:04.331: Serial2: allowing modem_process to continue hangup!

Ce qui suit met au point des expositions la même transaction du point de vue sur le sphinx.

   sphinx#
   00:58:54: %LINK-3-UPDOWN: Interface Serial0, changed state to up
   00:58:55: %LINEPROTO-5-UPDOWN: Line protocol on 
   Interface Serial0, changed state 
to up
   
!--- Primary link is brought up.

   00:59:16: TTY2: DSR was dropped

   !--- Modem connection is terminated by the peer.

   00:59:16: tty2: Modem: READY->(unknown)
   00:59:17: TTY2: dropping DTR, hanging up
   00:59:17: TTY2: Async Int reset: Dropping DTR
   00:59:17: tty2: Modem: HANGUP->(unknown)
   00:59:18: TTY2: cleanup pending. Delaying DTR
   00:59:19: %LINK-5-CHANGED: Interface Serial2, changed state to reset
   
!--- The Backup Interface (serial 2)is reset.

   00:59:19: Se2 IPCP: State is Closed
   00:59:19: Se2 PPP: Phase is TERMINATING
   00:59:19: Se2 LCP: State is Closed
   00:59:19: Se2 PPP: Phase is DOWN
   00:59:19: TTY2: cleanup pending. Delaying DTR
   00:59:19: Se2 IPCP: Remove route to 1.1.1.1
   
!--- The route to 1.1.1.1 using Serial 2 is removed since 
   !--- it is has a higher administrative distance of 2.

   00:59:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2, 
   changed state to down
   00:59:20: TTY2: cleanup pending. Delaying DTR
   00:59:21: TTY2: cleanup pending. Delaying DTR
   00:59:22: TTY2: destroy timer type 0
   00:59:22: TTY2: destroy timer type 1
   00:59:22: TTY2: destroy timer type 3
   00:59:22: TTY2: destroy timer type 4
   00:59:22: TTY2: destroy timer type 2
   00:59:22: Serial2: allowing modem_process to continue hangup
   00:59:22: TTY2: restoring DTR
   00:59:22: TTY2: autoconfigure probe started
   00:59:24: %LINK-3-UPDOWN: Interface Serial2, changed state to down
   00:59:24: Se2 LCP: State is Closed
   sphinx(config-if)#

Informations connexes


Document ID: 14281