Composition et accès : "Réseaux numériques à intégration de services (RNIS), canal de signalisation associé (CAS)"

Exemple de configuration RNIS - IP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à une configuration d'échantillon pour le RNIS l'utilisation de l'IP.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14222/40.gif

Configurations

Ce document utilise les configurations suivantes :

C2503
C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

!--- See the username explanation in the 
!--- Explanation of the C2503 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C4000
C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

!--- See the username explanation in the 
!--- Explanation of the C4000 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 192.168.24.65 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.2 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
ppp authentication chap
!
router igrp 1
network 172.16.0.0
network 192.168.24.0
!
ip route 172.16.10.0 255.255.255.0 172.16.20.1
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

Explication de la configuration C2503

C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

Le nom d'utilisateur C4000 est le nom d'hôte du routeur distant. La commande de carte de numéroteur, que cette section explique, utilise ce nom d'utilisateur. Le nom d'utilisateur ne distingue pas les majuscules et minuscules pendant l'authentification. Cependant, le nom que vous configurez avec la commande de carte de numéroteur distingue les majuscules et minuscules. Vous devez exactement apparier le nom d'hôte du routeur distant, qui a "C4000" ans.

Remarque: Dans le routeur C2503, le nom que vous configurez avec la commande de nom d'utilisateur doit exactement apparier le nom que vous configurez avec la commande de carte de numéroteur. Vous émettez la commande de nom d'utilisateur en mode de configuration globale.

La procédure d'authentification de protocole d'authentification CHAP (Challenge Handshake Authentication Protocol) utilise le mot de passe. Le mot de passe distingue les majuscules et minuscules et doit apparier le mot de passe de routeur distant exactement.

Remarque: Afin d'éviter la confusion, cet exemple de configuration utilise la forme non chiffrée du mot de passe cisco. Dans la configuration réelle, le mot de passe apparaît sous sa forme chiffrée : 7 13061E010803. Dans ce mot de passe, 7 dénote le type de cryptage et 13061E010803 est la forme chiffrée du mot de passe cisco. Quand vous fournissez ou apportez des modifications à la commande de nom d'utilisateur, toujours entrez le mot de passe sous sa forme non chiffrée et n'écrivez pas le type de cryptage (7). Le type de cryptage est placé automatiquement.

  • commutateur-type basic-dms100 RNIS — Le type de commutateur RNIS doit apparier le matériel de votre transporteur. Si vous changez le type de commutateur, vous devez recharger le routeur pour que le nouveau type de commutateur le prenne effet.

    interface Ethernet0
    ip address 172.16.10.1 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.1 255.255.255.0
  • encapsulation ppp — Employez l'encapsulation PPP au lieu du High-Level Data Link Control (HDLC) afin de permettre l'utilisation de l'authentification CHAP.

  • bande passante 56 — La configuration de bande passante par défaut pour une interface BRI est des 64 Kbits/s. Si vous configurez vos instructions de mappage de numéroteur avec l'option de la vitesse 56, incluez l'instruction de bande passante.

    Remarque: Cette commande ne contrôle pas la vitesse de votre ligne RNIS. La commande place le point de référence correct pour :

    • La statistique d'interface d'exposition de port BRI

    • La commande de dialer load-threshold

    • Mesures de routage du Protocole IGRP (Interior Gateway Routing Protocol) /Enhanced IGRP (EIGRP)

  • dialer idle-timeout 300 — Cette commande place le nombre de secondes qui la connexion RNIS demeure ouverte si aucun trafic intéressant n'est conduit. Le temporisateur est remis à l'état initial chaque fois qu'un paquet intéressant est expédié.

  • émission 14155551234 de la vitesse 56 du nom C4000 de 172.16.20.2 d'IP de carte de numéroteur

    émission 14155556789 de la vitesse 56 du nom C4000 de 172.16.20.2 d'IP de carte de numéroteur

    Employez la commande de carte de numéroteur avec l'authentification CHAP afin de placer l'appel initial au routeur distant quand le trafic intéressant est expédié à l'interface BRI. Quand la connexion devient active, la commande de dialer idle-timeout détermine la durée pour que la connexion demeure active. Une instruction de mappage de numéroteur est nécessaire pour chaque numéro de téléphone RNIS qui s'appellera. Cependant, rendez-vous compte que deux instructions de mappage de numéroteur que le point au même emplacement peut lancer les deux canaux B quand vous pouvez seulement vouloir utiliser un canal.

    Les paramètres de commande pour cet exemple sont :

    • 172.16.20.2 — L'adresse IP de l'interface du routeur distant BRI

      Afin de déterminer cette adresse, émettez l'interface bri d'exposition 0 commandes à la demande distante de console du routeur.

    • nom C4000 — Le nom d'hôte du routeur distant

      Le nom distingue les majuscules et minuscules et doit apparier le nom que vous configurez pour la commande de nom d'utilisateur.

    • vitesse 56 — Fixe la vitesse de numérotation à 56 Kbps pour les circuits RNIS qui ne sont pas des 64 Kbits/s de bout en bout

      Incluez ce paramètre dans les instructions de mappage de numéroteur des deux Routeurs. La plupart des installations en Amérique du Nord doivent être configurées pour 56 Kbps.

    • émission — Permet l'expédition des paquets d'émission

      À moins que la commande de dialer-list spécifie des paquets d'émission comme paquets intéressants, les paquets sont seulement expédiés quand la liaison RNIS est en activité.

    • 14155551234 et 14155556789 — Les numéros de téléphone du routeur distant le RNIS

  • dialer hold-queue 5 — Cette commande permet des paquets intéressants à aligner jusqu'à l'établissement de la connexion RNIS. Dans cet exemple, cinq paquets intéressants doivent être alignés.

  • dialer load-threshold 100 — Cette commande configure le à la demande de bande passante. La commande place le chargement maximum avant le numéroteur place un autre appel par le deuxième canal B. Le chargement est la valeur de charge calculée de moyenne pondérée pour l'interface, où 1 est déchargé et 255 chargement complet. La valeur de charge réelle à configurer dépend des caractéristiques de votre réseau particulier. Dans cet exemple, le deuxième canal B est lancé quand le chargement atteint 39 pour cent d'utilisation maximale, qui est 100 divisés par 255.

  • dialer-group 1 — La liste d'appels 1 de commandes enables du dialer-group 1 sur l'interface BRI, qui détermine quels paquets sont intéressants et lanceront la connexion RNIS.

  • le RNIS spid1 408555432101 5554321

    le RNIS spid2 408555987601 5559876

    Utilisez les commandes de spid RNIS si votre transporteur assigne les identifiants de service profile (SPID) à vos lignes RNIS.

  • CHAP d'authentification de ppp — Cette authentification CHAP de commandes enables.

    router igrp 1 
    network 172.16.0.0
  • artère 192.168.24.0 255.255.255.0 172.16.20.2 d'IP — Cette commande d'artère d'IP crée une artère statique au réseau de routeurs distant par l'intermédiaire de l'interface du routeur distant BRI. C'est une condition requise parce que des artères dynamiques sont perdues quand la liaison RNIS est en baisse.

    Les paramètres de commande pour cet exemple sont :

    • 192.168.24.0 — Le réseau de destination

    • 255.255.255.0 — Le masque de réseau de destination

      Des 255 en position d'octet spécifie qu'un précis - appariez pour cet octet est nécessaire. Un 0 en position d'octet spécifie que n'importe quelle valeur s'assortit.

    • 172.16.20.2 — L'adresse du prochain saut qui peut être utilisé pour atteindre le réseau de destination

  • la liste d'accès 100 refusent l'IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 d'autorisation de la liste d'accès 100 — cette commande access-list détermine quels paquets IP sont intéressants et lanceront la liaison RNIS. La liste d'accès à créer dépend de votre conception de réseau particulière.

    la liste d'accès 100 refusent l'IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 — cette commande access-list définit tous les paquets d'émission comme inintéressants.

    IP 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255 d'autorisation de la liste d'accès 100 — cette commande access-list définit tous autres paquets IP comme intéressants.

  • liste 100 du dialer-list 1 — Cette commande indique la liste d'accès 100, qui détermine quels paquets IP sont intéressants.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Explication de la configuration C4000

C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

Le nom d'utilisateur C2503 est le nom d'hôte du routeur distant. La commande de carte de numéroteur, que cette section explique, utilise ce nom d'utilisateur. Le nom d'utilisateur ne distingue pas les majuscules et minuscules pendant l'authentification. Cependant, le nom que vous configurez avec la commande de carte de numéroteur distingue les majuscules et minuscules. Vous devez exactement apparier le nom d'hôte du routeur distant, qui a "C2503" ans.

Remarque: Dans le routeur C4000, le nom que vous configurez avec le nom d'utilisateur doit exactement apparier le nom que vous configurez avec la commande de carte de numéroteur. Vous émettez la commande de nom d'utilisateur en mode de configuration globale.

Le procédé d'authentification CHAP utilise le mot de passe. Le mot de passe distingue les majuscules et minuscules et doit apparier le mot de passe de routeur distant exactement.

Remarque: Afin d'éviter la confusion, cet exemple de configuration utilise la forme non chiffrée du mot de passe cisco. Dans la configuration réelle, le mot de passe apparaît sous sa forme chiffrée : 7 13061E010803. Dans ce mot de passe, 7 dénote le type de cryptage et 13061E010803 est la forme chiffrée du mot de passe cisco. Quand vous fournissez ou apportez des modifications à la commande de nom d'utilisateur, toujours entrez le mot de passe sous sa forme non chiffrée et n'écrivez pas le type de cryptage (7). Le type de cryptage est placé automatiquement.

  • commutateur-type basic-dms100 RNIS — Le type de commutateur RNIS doit apparier le matériel de votre transporteur. Si vous changez le type de commutateur, vous devez recharger le routeur pour que le nouveau type de commutateur le prenne effet.

    interface Ethernet0
    ip address 192.168.24.65 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.2 255.255.255.0
    
    encapsulation ppp
  • encapsulation ppp — Employez l'encapsulation PPP au lieu du HDLC afin de permettre l'utilisation de l'authentification CHAP.

  • bande passante 56 — La configuration de bande passante par défaut pour une interface BRI est des 64 Kbits/s. Si vous configurez vos instructions de mappage de numéroteur avec l'option de la vitesse 56, incluez l'instruction de bande passante.

    Remarque: Cette commande ne contrôle pas la vitesse de votre ligne RNIS. La commande place le point de référence correct pour :

    • La statistique d'interface d'exposition de port BRI

    • La commande de dialer load-threshold

    • Mesures de routage IGRP/EIGRP

  • dialer idle-timeout 300 — Cette commande place le nombre de secondes qui la connexion RNIS demeure ouverte si aucun trafic intéressant n'est conduit. Le temporisateur est remis à l'état initial chaque fois qu'un paquet intéressant est expédié.

    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 

    Employez la commande de carte de numéroteur avec l'authentification CHAP afin de placer l'appel initial au routeur distant quand le trafic intéressant est expédié à l'interface BRI. Quand la connexion devient active, la commande de dialer idle-timeout détermine la durée pour que la connexion demeure active. Une instruction de mappage de numéroteur est nécessaire pour chaque numéro de téléphone RNIS qui s'appellera. Cependant, rendez-vous compte que deux instructions de mappage de numéroteur que le point au même emplacement peut lancer les deux canaux B quand vous pouvez seulement vouloir utiliser un canal.

    Les paramètres de commande pour cet exemple sont :

    • 172.16.20.1 — L'adresse IP de l'interface du routeur distant BRI

      Afin de déterminer cette adresse, émettez l'interface bri d'exposition 0 commandes à la demande distante de console du routeur.

    • nom C2503 — Le nom d'hôte du routeur distant

      Le nom distingue les majuscules et minuscules et doit apparier le nom que vous configurez pour la commande de nom d'utilisateur.

    • vitesse 56 — Fixe la vitesse de numérotation à 56 Kbps pour les circuits RNIS qui ne sont pas des 64 Kbits/s de bout en bout

      Incluez ce paramètre dans les instructions de mappage de numéroteur des deux Routeurs. La plupart des installations en Amérique du Nord doivent être configurées pour 56 Kbps.

    • émission — Permet l'expédition des paquets d'émission

      À moins que la commande de dialer-list spécifie des paquets d'émission comme paquets intéressants, les paquets sont seulement expédiés quand la liaison RNIS est en activité.

    • 14085554321 et 14085559876 — Les numéros de téléphone du routeur distant le RNIS

  • dialer hold-queue 5 — Cette commande permet des paquets intéressants à aligner jusqu'à l'établissement de la connexion RNIS. Dans cet exemple, cinq paquets intéressants doivent être alignés.

  • dialer load-threshold 100 — Cette commande configure le à la demande de bande passante. La commande place le chargement maximum avant le numéroteur place un autre appel par le deuxième canal B. Le chargement est la valeur de charge calculée de moyenne pondérée pour l'interface, où 1 est déchargé et 255 chargement complet. La valeur de charge réelle à configurer dépend des caractéristiques de votre réseau particulier. Dans cet exemple, le deuxième canal B est lancé quand le chargement atteint 39 pour cent d'utilisation maximale, qui est 100 divisés par 255.

  • dialer-group 1 — Les commandes enables du dialer-group 1 la liste d'appels 1 sur l'interface BRI, qui détermine quels paquets sont intéressants et lanceront la connexion RNIS.

  • le RNIS spid1 415555123401 5551234

    le RNIS spid2 415555678901 5556789

    Utilisez les commandes de spid RNIS si votre transporteur assigne des SPID à vos lignes RNIS.

  • CHAP d'authentification de ppp — Cette authentification CHAP de commandes enables.

    router igrp 1
    network 172.16.0.0
    network 192.168.24.0
  • artère 172.16.10.0 255.255.255.0 172.16.20.1 d'IP — Cette commande d'artère d'IP crée une artère statique au réseau de routeurs distant par l'intermédiaire de l'interface du routeur distant BRI. C'est une condition requise parce que des artères dynamiques sont perdues quand la liaison RNIS est en baisse.

    Les paramètres de commande pour cet exemple sont :

    • 172.16.0.0 — Le réseau de destination

    • 255.255.0.0 — Le masque de réseau de destination

      Des 255 en position d'octet spécifie qu'un précis - appariez pour cet octet est nécessaire. Un 0 en position d'octet spécifie que n'importe quelle valeur s'assortit.

    • 172.16.20.1 — L'adresse du prochain saut qui peut être utilisé pour atteindre le réseau de destination

  • la liste d'accès 100 refusent l'IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 d'autorisation de la liste d'accès 100 — cette commande access-list détermine quels paquets IP sont intéressants et lanceront la liaison RNIS. La liste d'accès à créer dépend de votre conception de réseau particulière.

    la liste d'accès 100 refusent l'IP 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0 — cette commande access-list définit tous les paquets d'émission comme inintéressants.

    IP 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 d'autorisation de la liste d'accès 100 — cette commande access-list définit tous autres paquets IP comme intéressants.

  • liste 100 du dialer-list 1 — Cette commande indique la liste d'accès 100, qui détermine quels paquets IP sont intéressants.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14222